- fix license according to advice from legal
- clean unused patches
This commit is contained in:
parent
2851e615b1
commit
75aad87998
@ -1,330 +0,0 @@
|
||||
diff -up perl-5.10.0/lib/File/Fetch.pm.BAD perl-5.10.0/lib/File/Fetch.pm
|
||||
--- perl-5.10.0.orig/lib/File/Fetch.pm 2009-03-11 14:21:00.000000000 +0100
|
||||
+++ perl-5.10.0/lib/File/Fetch.pm 2009-03-11 14:23:26.000000000 +0100
|
||||
@@ -35,7 +35,7 @@ $WARN = 1;
|
||||
|
||||
### methods available to fetch the file depending on the scheme
|
||||
$METHODS = {
|
||||
- http => [ qw|lwp wget curl lftp lynx| ],
|
||||
+ http => [ qw|lwp wget curl lftp links| ],
|
||||
ftp => [ qw|lwp netftp wget curl lftp ncftp ftp| ],
|
||||
file => [ qw|lwp lftp file| ],
|
||||
rsync => [ qw|rsync| ]
|
||||
@@ -772,9 +772,9 @@ sub _ftp_fetch {
|
||||
}
|
||||
}
|
||||
|
||||
-### lynx is stupid - it decompresses any .gz file it finds to be text
|
||||
-### use /bin/lynx to fetch files
|
||||
-sub _lynx_fetch {
|
||||
+### links is stupid - it decompresses any .gz file it finds to be text
|
||||
+### use /bin/links to fetch files
|
||||
+sub _links_fetch {
|
||||
my $self = shift;
|
||||
my %hash = @_;
|
||||
|
||||
@@ -784,21 +784,21 @@ sub _lynx_fetch {
|
||||
};
|
||||
check( $tmpl, \%hash ) or return;
|
||||
|
||||
- ### see if we have a lynx binary ###
|
||||
- if( my $lynx = can_run('lynx') ) {
|
||||
+ ### see if we have a links binary ###
|
||||
+ if( my $links = can_run('links') ) {
|
||||
|
||||
unless( IPC::Cmd->can_capture_buffer ) {
|
||||
- $METHOD_FAIL->{'lynx'} = 1;
|
||||
+ $METHOD_FAIL->{'links'} = 1;
|
||||
|
||||
return $self->_error(loc(
|
||||
"Can not capture buffers. Can not use '%1' to fetch files",
|
||||
- 'lynx' ));
|
||||
+ 'links' ));
|
||||
}
|
||||
|
||||
### check if the HTTP resource exists ###
|
||||
if ($self->uri =~ /^https?:\/\//i) {
|
||||
my $cmd = [
|
||||
- $lynx,
|
||||
+ $links,
|
||||
'-head',
|
||||
'-source',
|
||||
"-auth=anonymous:$FROM_EMAIL",
|
||||
@@ -822,14 +822,14 @@ sub _lynx_fetch {
|
||||
}
|
||||
}
|
||||
|
||||
- ### write to the output file ourselves, since lynx ass_u_mes to much
|
||||
+ ### write to the output file ourselves, since links ass_u_mes to much
|
||||
my $local = FileHandle->new(">$to")
|
||||
or return $self->_error(loc(
|
||||
"Could not open '%1' for writing: %2",$to,$!));
|
||||
|
||||
### dump to stdout ###
|
||||
my $cmd = [
|
||||
- $lynx,
|
||||
+ $links,
|
||||
'-source',
|
||||
"-auth=anonymous:$FROM_EMAIL",
|
||||
];
|
||||
@@ -860,7 +860,7 @@ sub _lynx_fetch {
|
||||
### XXX on a 404 with a special error page, $captured will actually
|
||||
### hold the contents of that page, and make it *appear* like the
|
||||
### request was a success, when really it wasn't :(
|
||||
- ### there doesn't seem to be an option for lynx to change the exit
|
||||
+ ### there doesn't seem to be an option for links to change the exit
|
||||
### code based on a 4XX status or so.
|
||||
### the closest we can come is using --error_file and parsing that,
|
||||
### which is very unreliable ;(
|
||||
@@ -870,7 +870,7 @@ sub _lynx_fetch {
|
||||
return $to;
|
||||
|
||||
} else {
|
||||
- $METHOD_FAIL->{'lynx'} = 1;
|
||||
+ $METHOD_FAIL->{'links'} = 1;
|
||||
return;
|
||||
}
|
||||
}
|
||||
@@ -1150,7 +1150,7 @@ Below is a mapping of what utilities wil
|
||||
for what schemes, if available:
|
||||
|
||||
file => LWP, lftp, file
|
||||
- http => LWP, wget, curl, lftp, lynx
|
||||
+ http => LWP, wget, curl, lftp, links
|
||||
ftp => LWP, Net::FTP, wget, curl, lftp, ncftp, ftp
|
||||
rsync => rsync
|
||||
|
||||
@@ -1262,7 +1262,7 @@ the $BLACKLIST, $METHOD_FAIL and other i
|
||||
LWP => lwp
|
||||
Net::FTP => netftp
|
||||
wget => wget
|
||||
- lynx => lynx
|
||||
+ links => links
|
||||
ncftp => ncftp
|
||||
ftp => ftp
|
||||
curl => curl
|
||||
@@ -1281,17 +1281,17 @@ example, to use an ftp proxy:
|
||||
|
||||
Refer to the LWP::UserAgent manpage for more details.
|
||||
|
||||
-=head2 I used 'lynx' to fetch a file, but its contents is all wrong!
|
||||
+=head2 I used 'links' to fetch a file, but its contents is all wrong!
|
||||
|
||||
-C<lynx> can only fetch remote files by dumping its contents to C<STDOUT>,
|
||||
+C<links> can only fetch remote files by dumping its contents to C<STDOUT>,
|
||||
which we in turn capture. If that content is a 'custom' error file
|
||||
(like, say, a C<404 handler>), you will get that contents instead.
|
||||
|
||||
-Sadly, C<lynx> doesn't support any options to return a different exit
|
||||
+Sadly, C<links> doesn't support any options to return a different exit
|
||||
code on non-C<200 OK> status, giving us no way to tell the difference
|
||||
between a 'successfull' fetch and a custom error page.
|
||||
|
||||
-Therefor, we recommend to only use C<lynx> as a last resort. This is
|
||||
+Therefor, we recommend to only use C<links> as a last resort. This is
|
||||
why it is at the back of our list of methods to try as well.
|
||||
|
||||
=head2 Files I'm trying to fetch have reserved characters or non-ASCII characters in them. What do I do?
|
||||
diff -up perl-5.10.0/lib/File/Fetch/t/01_File-Fetch.t.BAD perl-5.10.0/lib/File/Fetch/t/01_File-Fetch.t
|
||||
--- perl-5.10.0.orig/lib/File/Fetch/t/01_File-Fetch.t 2009-03-11 14:21:00.000000000 +0100
|
||||
+++ perl-5.10.0/lib/File/Fetch/t/01_File-Fetch.t 2009-03-11 14:22:10.000000000 +0100
|
||||
@@ -177,7 +177,7 @@ for my $entry (@map) {
|
||||
'http://www.cpan.org/index.html?q=1',
|
||||
'http://www.cpan.org/index.html?q=1&y=2',
|
||||
) {
|
||||
- for (qw[lwp wget curl lftp lynx]) {
|
||||
+ for (qw[lwp wget curl lftp links]) {
|
||||
_fetch_uri( http => $uri, $_ );
|
||||
}
|
||||
}
|
||||
diff -up perl-5.10.0/lib/CPAN.pm.BAD perl-5.10.0/lib/CPAN.pm
|
||||
--- perl-5.10.0.orig/lib/CPAN.pm 2007-12-18 11:47:07.000000000 +0100
|
||||
+++ perl-5.10.0/lib/CPAN.pm 2009-03-11 14:21:21.000000000 +0100
|
||||
@@ -4318,7 +4318,7 @@ sub hostdlhard {
|
||||
|
||||
# Try the most capable first and leave ncftp* for last as it only
|
||||
# does FTP.
|
||||
- DLPRG: for my $f (qw(curl wget lynx ncftpget ncftp)) {
|
||||
+ DLPRG: for my $f (qw(curl wget links ncftpget ncftp)) {
|
||||
my $funkyftp = CPAN::HandleConfig->safe_quote($CPAN::Config->{$f});
|
||||
next unless defined $funkyftp;
|
||||
next if $funkyftp =~ /^\s*$/;
|
||||
@@ -4330,7 +4330,7 @@ sub hostdlhard {
|
||||
my($src_switch) = "";
|
||||
my($chdir) = "";
|
||||
my($stdout_redir) = " > $asl_ungz";
|
||||
- if ($f eq "lynx") {
|
||||
+ if ($f eq "links") {
|
||||
$src_switch = " -source";
|
||||
} elsif ($f eq "ncftp") {
|
||||
$src_switch = " -c";
|
||||
@@ -4354,8 +4354,8 @@ Trying with "$funkyftp$src_switch" to ge
|
||||
"$chdir$funkyftp$src_switch \"$url\" $devnull$stdout_redir";
|
||||
$self->debug("system[$system]") if $CPAN::DEBUG;
|
||||
my($wstatus) = system($system);
|
||||
- if ($f eq "lynx") {
|
||||
- # lynx returns 0 when it fails somewhere
|
||||
+ if ($f eq "links") {
|
||||
+ # links returns 0 when it fails somewhere
|
||||
if (-s $asl_ungz) {
|
||||
my $content = do { local *FH;
|
||||
open FH, $asl_ungz or die;
|
||||
@@ -4363,7 +4363,7 @@ Trying with "$funkyftp$src_switch" to ge
|
||||
<FH> };
|
||||
if ($content =~ /^<.*(<title>[45]|Error [45])/si) {
|
||||
$CPAN::Frontend->mywarn(qq{
|
||||
-No success, the file that lynx has downloaded looks like an error message:
|
||||
+No success, the file that links has downloaded looks like an error message:
|
||||
$content
|
||||
});
|
||||
$CPAN::Frontend->mysleep(1);
|
||||
@@ -4371,7 +4371,7 @@ $content
|
||||
}
|
||||
} else {
|
||||
$CPAN::Frontend->myprint(qq{
|
||||
-No success, the file that lynx has downloaded is an empty file.
|
||||
+No success, the file that links has downloaded is an empty file.
|
||||
});
|
||||
next DLPRG;
|
||||
}
|
||||
@@ -9081,14 +9081,14 @@ sub _display_url {
|
||||
# should we define it in the config instead?
|
||||
my $html_converter = "html2text.pl";
|
||||
|
||||
- my $web_browser = $CPAN::Config->{'lynx'} || undef;
|
||||
+ my $web_browser = $CPAN::Config->{'links'} || undef;
|
||||
my $web_browser_out = $web_browser
|
||||
? CPAN::Distribution->_check_binary($self,$web_browser)
|
||||
: undef;
|
||||
|
||||
if ($web_browser_out) {
|
||||
# web browser found, run the action
|
||||
- my $browser = CPAN::HandleConfig->safe_quote($CPAN::Config->{'lynx'});
|
||||
+ my $browser = CPAN::HandleConfig->safe_quote($CPAN::Config->{'links'});
|
||||
$CPAN::Frontend->myprint(qq{system[$browser $url]})
|
||||
if $CPAN::DEBUG;
|
||||
$CPAN::Frontend->myprint(qq{
|
||||
@@ -9163,7 +9163,7 @@ with pager "$pager"
|
||||
} else {
|
||||
# coldn't find the web browser or html converter
|
||||
$CPAN::Frontend->myprint(qq{
|
||||
-You need to install lynx or $html_converter to use this feature.});
|
||||
+You need to install links or $html_converter to use this feature.});
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -10837,7 +10837,7 @@ defined:
|
||||
keep_source_where directory in which to keep the source (if we do)
|
||||
load_module_verbosity
|
||||
report loading of optional modules used by CPAN.pm
|
||||
- lynx path to external prg
|
||||
+ links path to external prg
|
||||
make location of external make program
|
||||
make_arg arguments that should always be passed to 'make'
|
||||
make_install_make_command
|
||||
@@ -11666,7 +11666,7 @@ Makefile.PL> or C<perl Build.PL> and C<m
|
||||
|
||||
Downloads the pod documentation of the file associated with a
|
||||
distribution (in html format) and runs it through the external
|
||||
-command lynx specified in C<$CPAN::Config->{lynx}>. If lynx
|
||||
+command links specified in C<$CPAN::Config->{links}>. If links
|
||||
isn't available, it converts it to plain text with external
|
||||
command html2text and runs it through the pager specified
|
||||
in C<$CPAN::Config->{pager}>
|
||||
@@ -11975,7 +11975,7 @@ required for non-UNIX systems or if your
|
||||
associated with a URL that is not C<ftp:>.
|
||||
|
||||
If you have neither Net::FTP nor LWP, there is a fallback mechanism
|
||||
-implemented for an external ftp command or for an external lynx
|
||||
+implemented for an external ftp command or for an external links
|
||||
command.
|
||||
|
||||
=head1 UTILITIES
|
||||
@@ -12247,16 +12247,16 @@ ftp_passive to a true value.
|
||||
|
||||
=back
|
||||
|
||||
-=head2 Configuring lynx or ncftp for going through a firewall
|
||||
+=head2 Configuring links or ncftp for going through a firewall
|
||||
|
||||
-If you can go through your firewall with e.g. lynx, presumably with a
|
||||
+If you can go through your firewall with e.g. links, presumably with a
|
||||
command such as
|
||||
|
||||
- /usr/local/bin/lynx -pscott:tiger
|
||||
+ /usr/local/bin/links -pscott:tiger
|
||||
|
||||
then you would configure CPAN.pm with the command
|
||||
|
||||
- o conf lynx "/usr/local/bin/lynx -pscott:tiger"
|
||||
+ o conf links "/usr/local/bin/links -pscott:tiger"
|
||||
|
||||
That's all. Similarly for ncftp or ftp, you would configure something
|
||||
like
|
||||
diff -up perl-5.10.0/lib/CPAN/HandleConfig.pm.BAD perl-5.10.0/lib/CPAN/HandleConfig.pm
|
||||
--- perl-5.10.0.orig/lib/CPAN/HandleConfig.pm 2007-12-18 11:47:07.000000000 +0100
|
||||
+++ perl-5.10.0/lib/CPAN/HandleConfig.pm 2009-03-11 14:21:21.000000000 +0100
|
||||
@@ -49,7 +49,7 @@ $VERSION = sprintf "%.6f", substr(q$Rev:
|
||||
"inhibit_startup_message",
|
||||
"keep_source_where",
|
||||
"load_module_verbosity",
|
||||
- "lynx",
|
||||
+ "links",
|
||||
"make",
|
||||
"make_arg",
|
||||
"make_install_arg",
|
||||
diff -up perl-5.10.0/lib/CPAN/FirstTime.pm.BAD perl-5.10.0/lib/CPAN/FirstTime.pm
|
||||
--- perl-5.10.0.orig/lib/CPAN/FirstTime.pm 2007-12-18 11:47:07.000000000 +0100
|
||||
+++ perl-5.10.0/lib/CPAN/FirstTime.pm 2009-03-11 14:21:21.000000000 +0100
|
||||
@@ -813,7 +813,7 @@ Shall we use it as the general CPAN buil
|
||||
|
||||
make
|
||||
|
||||
- curl lynx wget ncftpget ncftp ftp
|
||||
+ curl links wget ncftpget ncftp ftp
|
||||
|
||||
gpg
|
||||
|
||||
diff -up perl-5.10.0/pod/perltoc.pod.BAD perl-5.10.0/pod/perltoc.pod
|
||||
--- perl-5.10.0.orig/pod/perltoc.pod 2007-12-18 11:47:08.000000000 +0100
|
||||
+++ perl-5.10.0/pod/perltoc.pod 2009-03-11 14:21:21.000000000 +0100
|
||||
@@ -14682,7 +14682,7 @@ has_inst($module), has_usable($module),
|
||||
|
||||
http firewall, ftp firewall, One way visibility, SOCKS, IP Masquerade
|
||||
|
||||
-=item Configuring lynx or ncftp for going through a firewall
|
||||
+=item Configuring links or ncftp for going through a firewall
|
||||
|
||||
=back
|
||||
|
||||
@@ -20857,7 +20857,7 @@ $ff->output_file
|
||||
|
||||
=item So how do I use a proxy with File::Fetch?
|
||||
|
||||
-=item I used 'lynx' to fetch a file, but its contents is all wrong!
|
||||
+=item I used 'links' to fetch a file, but its contents is all wrong!
|
||||
|
||||
=item Files I'm trying to fetch have reserved characters or non-ASCII
|
||||
characters in them. What do I do?
|
||||
diff -up perl-5.10.0/pod/perlfaq9.pod.BAD perl-5.10.0/pod/perlfaq9.pod
|
||||
--- perl-5.10.0.orig/pod/perlfaq9.pod 2007-12-18 11:47:08.000000000 +0100
|
||||
+++ perl-5.10.0/pod/perlfaq9.pod 2009-03-11 14:21:21.000000000 +0100
|
||||
@@ -212,14 +212,14 @@ examples.
|
||||
|
||||
=head2 How do I fetch an HTML file?
|
||||
|
||||
-One approach, if you have the lynx text-based HTML browser installed
|
||||
+One approach, if you have the links text-based HTML browser installed
|
||||
on your system, is this:
|
||||
|
||||
- $html_code = `lynx -source $url`;
|
||||
- $text_data = `lynx -dump $url`;
|
||||
+ $html_code = `links -source $url`;
|
||||
+ $text_data = `links -dump $url`;
|
||||
|
||||
The libwww-perl (LWP) modules from CPAN provide a more powerful way
|
||||
-to do this. They don't require lynx, but like lynx, can still work
|
||||
+to do this. They don't require links, but like links, can still work
|
||||
through proxies:
|
||||
|
||||
# simplest version
|
153
perl.spec
153
perl.spec
@ -7,13 +7,17 @@
|
||||
|
||||
Name: perl
|
||||
Version: %{perl_version}
|
||||
Release: 111%{?dist}
|
||||
Release: 112%{?dist}
|
||||
Epoch: %{perl_epoch}
|
||||
Summary: Practical Extraction and Report Language
|
||||
Group: Development/Languages
|
||||
# Modules Tie::File and Getopt::Long are licenced under "GPLv2+ or Artistic,"
|
||||
# we have to reflect that in the sub-package containing them.
|
||||
License: (GPL+ or Artistic) and (GPLv2+ or Artistic)
|
||||
# under UCD are unicode tables
|
||||
# Public domain: ext/SDBM_File/sdbm/*, ext/Compress-Raw-Bzip2/bzip2-src/dlltest.c
|
||||
# MIT: ext/MIME-Base64/Base64.xs
|
||||
# Copyright Only: for example ext/Text-Soundex/Soundex.xs
|
||||
License: (GPL+ or Artistic) and (GPLv2+ or Artistic) and Copyright Only and MIT and Public Domain and UCD
|
||||
Url: http://www.perl.org/
|
||||
Source0: http://www.cpan.org/src/5.0/perl-%{perl_version}.tar.bz2
|
||||
Source11: filter-requires.sh
|
||||
@ -29,44 +33,44 @@ Patch2: perl-perlbug-tag.patch
|
||||
# work around annoying rpath issue
|
||||
# This is only relevant for Fedora, as it is unlikely
|
||||
# that upstream will assume the existence of a libperl.so
|
||||
Patch4: perl-5.8.8-rpath-make.patch
|
||||
Patch3: perl-5.8.8-rpath-make.patch
|
||||
|
||||
# Fedora/RHEL only (64bit only)
|
||||
Patch5: perl-5.8.0-libdir64.patch
|
||||
Patch4: perl-5.8.0-libdir64.patch
|
||||
|
||||
# Fedora/RHEL specific (use libresolv instead of libbind)
|
||||
Patch6: perl-5.10.0-libresolv.patch
|
||||
Patch5: perl-5.10.0-libresolv.patch
|
||||
|
||||
# FIXME: May need the "Fedora" references removed before upstreaming
|
||||
# patches ExtUtils-MakeMaker
|
||||
Patch7: perl-USE_MM_LD_RUN_PATH.patch
|
||||
Patch6: perl-USE_MM_LD_RUN_PATH.patch
|
||||
|
||||
# Skip hostname tests, since hostname lookup isn't available in Fedora
|
||||
# buildroots by design.
|
||||
# patches Net::Config from libnet
|
||||
Patch8: perl-5.10.0-disable_test_hosts.patch
|
||||
Patch7: perl-5.10.0-disable_test_hosts.patch
|
||||
|
||||
# The Fedora builders started randomly failing this futime test
|
||||
# only on x86_64, so we just don't run it. Works fine on normal
|
||||
# systems.
|
||||
Patch10: perl-5.10.0-x86_64-io-test-failure.patch
|
||||
Patch8: perl-5.10.0-x86_64-io-test-failure.patch
|
||||
|
||||
# Reorder @INC: Based on: http://github.com/rafl/perl/commit/b9ba2fadb18b54e35e5de54f945111a56cbcb249
|
||||
Patch35: perl-5.10.0-reorderINC.patch
|
||||
Patch9: perl-5.10.0-reorderINC.patch
|
||||
|
||||
# http://rt.perl.org/rt3/Ticket/Display.html?id=39060 (#221113)
|
||||
Patch58: perl-perlio-incorrect-errno.patch
|
||||
Patch10: perl-perlio-incorrect-errno.patch
|
||||
|
||||
# much better swap logic to support reentrancy and fix assert failure
|
||||
# http://perl5.git.perl.org/perl.git/commitdiff/e9105d30edfbaa7f444bc7984c9bafc8e991ad12
|
||||
# RT #60508
|
||||
Patch61: perl-much-better-swap-logic.patch
|
||||
Patch11: perl-much-better-swap-logic.patch
|
||||
|
||||
# temporarily export debug symbols even though DEBUGGING is not set:
|
||||
Patch62: perl-add-symbols.patch
|
||||
Patch12: perl-add-symbols.patch
|
||||
|
||||
# CVE_2009_3626 rhbz#547656
|
||||
Patch63: perl-5.10.1-CVE_2009_3626.patch
|
||||
Patch13: perl-5.10.1-CVE_2009_3626.patch
|
||||
|
||||
# version macros for some of the modules:
|
||||
%define Archive_Extract_version 0.34
|
||||
@ -86,22 +90,24 @@ Patch63: perl-5.10.1-CVE_2009_3626.patch
|
||||
# Update some of the bundled modules
|
||||
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
|
||||
|
||||
Patch104: perl-update-ExtUtils-CBuilder.patch
|
||||
Patch201: perl-update-ExtUtils-CBuilder.patch
|
||||
%define ExtUtils_CBuilder_version 0.27
|
||||
Patch106: perl-update-File-Path.patch
|
||||
Patch202: perl-update-File-Path.patch
|
||||
%define File_Path_version 2.08
|
||||
Patch109: perl-update-Module-Build.patch
|
||||
Patch203: perl-update-Module-Build.patch
|
||||
%define Module_Build_real_version 0.35
|
||||
# For Module-Build-0.x, the second component has to have four digits.
|
||||
%define Module_Build_rpm_version 0.3500
|
||||
Patch204: perl-update-Parse-CPAN-Meta.patch
|
||||
%define Parse_CPAN_Meta_version 1.40
|
||||
|
||||
#---
|
||||
# FIXME; is 2.18->2.21, should be 2.20->2.21
|
||||
# - was 2.21 previously; but it is not a subpackage, can wait
|
||||
Patch123: perl-update-Storable.patch
|
||||
Patch99: perl-update-Storable.patch
|
||||
%define Storable_version 2.20
|
||||
|
||||
#---
|
||||
# This patches are now unused:
|
||||
#could be 1.19
|
||||
Patch100: perl-update-constant.patch
|
||||
%define constant_version 1.17
|
||||
@ -153,8 +159,6 @@ Patch124: perl-update-IO-Compress-Base.patch
|
||||
Patch125: perl-update-IO-Compress-Zlib.patch
|
||||
%define IO_Compress_Zlib_version 2.020
|
||||
#... also update version number of Compress::Zlib
|
||||
Patch126: perl-update-Parse-CPAN-Meta.patch
|
||||
%define Parse_CPAN_Meta_version 1.40
|
||||
|
||||
# FIXME: Compress-Raw-Zlib also contains Compress-Raw-Bzip2
|
||||
# and IO-Compress-Zlib contains IO-Compress-Bzip2
|
||||
@ -868,7 +872,7 @@ Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
# Epoch bump for clean upgrade over old standalone package
|
||||
Epoch: 3
|
||||
Version: 0.77
|
||||
Version: 0.80
|
||||
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
|
||||
|
||||
%description version
|
||||
@ -914,48 +918,26 @@ upstream tarball from perl.org.
|
||||
# This patch breaks sparc64 compilation
|
||||
# We should probably consider removing it for all arches.
|
||||
%ifnarch sparc64
|
||||
%patch4 -p1
|
||||
%patch3 -p1
|
||||
%endif
|
||||
%ifarch %{multilib_64_archs}
|
||||
%patch5 -p1
|
||||
%patch4 -p1
|
||||
%endif
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
|
||||
%patch10 -p1
|
||||
%patch35 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
|
||||
%patch58 -p1
|
||||
%patch61 -p1
|
||||
%patch62 -p1
|
||||
%patch63 -p1
|
||||
|
||||
#patch100 -p1
|
||||
#patch101 -p1
|
||||
#patch102 -p1
|
||||
#patch103 -p1
|
||||
%patch104 -p1
|
||||
#patch105 -p1
|
||||
%patch106 -p1
|
||||
#patch107 -p1
|
||||
#patch108 -p1
|
||||
%patch109 -p1
|
||||
#patch110 -p1
|
||||
#patch111 -p1
|
||||
#patch112 -p1
|
||||
#patch113 -p1
|
||||
#patch114 -p1
|
||||
#patch115 -p1
|
||||
#patch116 -p1
|
||||
#patch117 -p1
|
||||
#patch118 -p1
|
||||
#patch119 -p1
|
||||
#patch120 -p1
|
||||
#patch121 -p1
|
||||
#patch122 -p1
|
||||
#patch123 -p1
|
||||
#patch124 -p1
|
||||
%patch126 -p1
|
||||
%patch201 -p1
|
||||
%patch202 -p1
|
||||
%patch203 -p1
|
||||
%patch204 -p1
|
||||
|
||||
#
|
||||
# Candidates for doc recoding (need case by case review):
|
||||
@ -1168,51 +1150,24 @@ pushd %{build_archlib}/CORE/
|
||||
'Fedora Patch1: Permit suidperl to install as nonroot' \
|
||||
'Fedora Patch2: Removes date check, Fedora/RHEL specific' \
|
||||
%ifnarch sparc64 \
|
||||
'Fedora Patch4: Work around annoying rpath issue' \
|
||||
'Fedora Patch3: Work around annoying rpath issue' \
|
||||
%endif \
|
||||
%ifarch %{multilib_64_archs} \
|
||||
'Fedora Patch5: support for libdir64' \
|
||||
'Fedora Patch4: support for libdir64' \
|
||||
%endif \
|
||||
'Fedora Patch6: use libresolv instead of libbind' \
|
||||
'Fedora Patch7: USE_MM_LD_RUN_PATH' \
|
||||
'Fedora Patch8: Skip hostname tests, due to builders not being network capable' \
|
||||
'Fedora Patch10: Dont run one io test due to random builder failures' \
|
||||
'Fedora Patch35: Reorder @INC, based on b9ba2fadb18b54e35e5de54f945111a56cbcb249' \
|
||||
'Fedora Patch58: fix RT 39060, errno incorrectly set in perlio' \
|
||||
'Fedora Patch61: much better swap logic to support reentrancy and fix assert failure' \
|
||||
'Fedora Patch62: backward compatibility for the trasition' \
|
||||
'Fedora Patch104: Update ExtUtils::CBuilder to %{ExtUtils_CBuilder_version}' \
|
||||
'Fedora Patch106: Update File::Path to %{File_Path_version}' \
|
||||
'Fedora Patch109: Update Module::Build to %{Module_Build_version}' \
|
||||
|
||||
: \
|
||||
'Fedora Patch100: Update module constant to %{constant_version}' \
|
||||
'Fedora Patch101: Update Archive::Extract to %{Archive_Extract_version}' \
|
||||
'Fedora Patch102: Update Archive::Tar to %{Archive_Tar_version}' \
|
||||
'Fedora Patch103: Update CGI to %{CGI_version}' \
|
||||
'Fedora Patch104: Update ExtUtils::CBuilder to %{ExtUtils_CBuilder_version}' \
|
||||
'Fedora Patch105: Update File::Fetch to %{File_Fetch_version}' \
|
||||
'Fedora Patch106: Update File::Path to %{File_Path_version}' \
|
||||
'Fedora Patch107: Update File::Temp to %{File_Temp_version}' \
|
||||
'Fedora Patch108: Update IPC::Cmd to %{IPC_Cmd_version}' \
|
||||
'Fedora Patch109: Update Module::Build to %{Module_Build_version}' \
|
||||
'Fedora Patch110: Update Module::CoreList to %{Module_CoreList_version}' \
|
||||
'Fedora Patch111: Update Module::Load::Conditional to %{Module_Load_Conditional_version}' \
|
||||
'Fedora Patch112: Update Pod::Simple to %{Pod_Simple_version}' \
|
||||
'Fedora Patch113: Update Sys::Syslog to %{Sys_Syslog_version}' \
|
||||
'Fedora Patch114: Update Test::Harness to %{Test_Harness_version}' \
|
||||
'Fedora Patch115: Update Test::Simple to %{Test_Simple_version}' \
|
||||
'Fedora Patch116: Update Time::HiRes to %{Time_HiRes_version}' \
|
||||
'Fedora Patch117: Update Digest::SHA to %{Digest_SHA_version}' \
|
||||
'Fedora Patch117: Update module autodie to %{autodie_version}' \
|
||||
'Fedora Patch119: Update File::Spec to %{File_Spec_version}' \
|
||||
'Fedora Patch120: Update Compress::Raw::Zlib to %{Compress_Raw_Zlib_version}' \
|
||||
'Fedora Patch121: Update Scalar-List-Utils to %{Scalar_List_Utils}' \
|
||||
'Fedora Patch122: Update Module-Pluggable to %{Module_Pluggable_version}' \
|
||||
'Fedora Patch123: Update Storable to %{Storable_version}' \
|
||||
'Fedora Patch124: Update IO::Compress::Base to %{IO_Compress_Base_version}' \
|
||||
'Fedora Patch125: Update IO::Compress::Zlib to %{IO_Compress_Zlib_version}' \
|
||||
'Fedora Patch126: Update Parse::CPAN::Meta::version to %{Parse_CPAN_Meta_version}'
|
||||
'Fedora Patch5: use libresolv instead of libbind' \
|
||||
'Fedora Patch6: USE_MM_LD_RUN_PATH' \
|
||||
'Fedora Patch7: Skip hostname tests, due to builders not being network capable' \
|
||||
'Fedora Patch8: Dont run one io test due to random builder failures' \
|
||||
'Fedora Patch9: Reorder @INC, based on b9ba2fadb18b54e35e5de54f945111a56cbcb249' \
|
||||
'Fedora Patch10: fix RT 39060, errno incorrectly set in perlio' \
|
||||
'Fedora Patch11: much better swap logic to support reentrancy and fix assert failure' \
|
||||
'Fedora Patch12: backward compatibility for the trasition' \
|
||||
'Fedora Patch13: CVE_2009_3626' \
|
||||
'Fedora Patch201: Update ExtUtils::CBuilder to %{ExtUtils_CBuilder_version}' \
|
||||
'Fedora Patch202: Update File::Path to %{File_Path_version}' \
|
||||
'Fedora Patch203: Update Module::Build to %{Module_Build_version}' \
|
||||
'Fedora Patch204: Update Parse::CPAN::Meta::version to %{Parse_CPAN_Meta_version}'
|
||||
%{nil}
|
||||
|
||||
rm patchlevel.bak
|
||||
@ -1870,6 +1825,10 @@ make test
|
||||
|
||||
# Old changelog entries are preserved in CVS.
|
||||
%changelog
|
||||
* Fri Mar 5 2010 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.10.1-112
|
||||
- fix license according to advice from legal
|
||||
- clean unused patches
|
||||
|
||||
* Wed Feb 24 2010 Chris Weyl <cweyl@alumni.drew.edu> - 4:5.10.1-111
|
||||
- update subpackage tests macros to handle packages with an epoch properly
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user