Do not use a C compiler reserved identifiers
This commit is contained in:
parent
c71b2ee08f
commit
5250f9777a
32
perl-5.33.0-MUTABLE_PTR-Rmv-non-standard-syntax.patch
Normal file
32
perl-5.33.0-MUTABLE_PTR-Rmv-non-standard-syntax.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 6c2255e0e80e0dc00c7fd96e073f1f524bbaa3e0 Mon Sep 17 00:00:00 2001
|
||||
From: Karl Williamson <khw@cpan.org>
|
||||
Date: Mon, 29 Jun 2020 09:21:24 -0600
|
||||
Subject: [PATCH] MUTABLE_PTR() Rmv non-standard syntax
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Variables in C are beginning with an underscore are reserved for use by
|
||||
the C implementation. Change this non-conformant usage.
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
handy.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/handy.h b/handy.h
|
||||
index 287e2e206d..890b2b11a2 100644
|
||||
--- a/handy.h
|
||||
+++ b/handy.h
|
||||
@@ -54,7 +54,7 @@ Null SV pointer. (No longer available when C<PERL_CORE> is defined.)
|
||||
*/
|
||||
|
||||
#if defined(__GNUC__) && !defined(PERL_GCC_BRACE_GROUPS_FORBIDDEN)
|
||||
-# define MUTABLE_PTR(p) ({ void *_p = (p); _p; })
|
||||
+# define MUTABLE_PTR(p) ({ void *p_ = (p); p_; })
|
||||
#else
|
||||
# define MUTABLE_PTR(p) ((void *) (p))
|
||||
#endif
|
||||
--
|
||||
2.25.4
|
||||
|
10
perl.spec
10
perl.spec
@ -100,7 +100,7 @@ License: GPL+ or Artistic
|
||||
Epoch: %{perl_epoch}
|
||||
Version: %{perl_version}
|
||||
# release number must be even higher, because dual-lived modules will be broken otherwise
|
||||
Release: 458%{?dist}
|
||||
Release: 459%{?dist}
|
||||
Summary: Practical Extraction and Report Language
|
||||
Url: https://www.perl.org/
|
||||
Source0: https://www.cpan.org/src/5.0/perl-%{perl_version}.tar.xz
|
||||
@ -164,6 +164,9 @@ Patch12: perl-5.27.8-hints-linux-Add-lphtread-to-lddlflags.patch
|
||||
# Pass the correct CFLAGS to dtrace
|
||||
Patch13: perl-5.28.0-Pass-CFLAGS-to-dtrace.patch
|
||||
|
||||
# Do not use a C compiler reserved identifiers, in upstream after 5.33.0
|
||||
Patch14: perl-5.33.0-MUTABLE_PTR-Rmv-non-standard-syntax.patch
|
||||
|
||||
# Link XS modules to libperl.so with EU::CBuilder on Linux, bug #960048
|
||||
Patch200: perl-5.16.3-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
|
||||
|
||||
@ -4163,6 +4166,7 @@ you're not running VMS, this module does nothing.
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch14 -p1
|
||||
%patch200 -p1
|
||||
%patch201 -p1
|
||||
|
||||
@ -4183,6 +4187,7 @@ perl -x patchlevel.h \
|
||||
'Fedora Patch11: Replace EU::MakeMaker dependency with EU::MM::Utils in IPC::Cmd (bug #1129443)' \
|
||||
'Fedora Patch12: Link XS modules to pthread library to fix linking with -z defs' \
|
||||
'Fedora Patch13: Pass the correct CFLAGS to dtrace' \
|
||||
'Fedora Patch14: Do not use a C compiler reserved identifiers' \
|
||||
'Fedora Patch200: Link XS modules to libperl.so with EU::CBuilder on Linux' \
|
||||
'Fedora Patch201: Link XS modules to libperl.so with EU::MM on Linux' \
|
||||
%{nil}
|
||||
@ -6900,6 +6905,9 @@ popd
|
||||
|
||||
# Old changelog entries are preserved in CVS.
|
||||
%changelog
|
||||
* Wed Aug 05 2020 Petr Pisar <ppisar@redhat.com> - 4:5.32.0-459
|
||||
- Do not use a C compiler reserved identifiers
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4:5.32.0-458
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user