Protect locale tests from LANGUAGE environment variable
This commit is contained in:
parent
316f16da49
commit
4f72402355
@ -0,0 +1,32 @@
|
|||||||
|
From a2f57b06b018b254bee93e1a1265cfc09833366f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Karl Williamson <khw@cpan.org>
|
||||||
|
Date: Tue, 9 Feb 2021 11:32:15 -0700
|
||||||
|
Subject: [PATCH] t/run/locale.t: Rmv LANGUAGE from environment
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
This could cause interference with our tests on some platforms that have
|
||||||
|
this environment variable.
|
||||||
|
|
||||||
|
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||||
|
---
|
||||||
|
t/run/locale.t | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/t/run/locale.t b/t/run/locale.t
|
||||||
|
index 8a04d1aea6..0f2a2ba457 100644
|
||||||
|
--- a/t/run/locale.t
|
||||||
|
+++ b/t/run/locale.t
|
||||||
|
@@ -38,7 +38,7 @@ if (defined $ARGV[0] && $ARGV[0] ne "") {
|
||||||
|
}
|
||||||
|
|
||||||
|
# reset the locale environment
|
||||||
|
-delete local @ENV{'LANG', (grep /^LC_[A-Z]+$/, keys %ENV)};
|
||||||
|
+delete local @ENV{'LANGUAGE', 'LANG', (grep /^LC_[A-Z]+$/, keys %ENV)};
|
||||||
|
|
||||||
|
# If user wants this to happen, they set the environment variable AND use
|
||||||
|
# 'debug'
|
||||||
|
--
|
||||||
|
2.26.2
|
||||||
|
|
11
perl.spec
11
perl.spec
@ -100,7 +100,7 @@ License: GPL+ or Artistic
|
|||||||
Epoch: %{perl_epoch}
|
Epoch: %{perl_epoch}
|
||||||
Version: %{perl_version}
|
Version: %{perl_version}
|
||||||
# release number must be even higher, because dual-lived modules will be broken otherwise
|
# release number must be even higher, because dual-lived modules will be broken otherwise
|
||||||
Release: 471%{?dist}
|
Release: 472%{?dist}
|
||||||
Summary: Practical Extraction and Report Language
|
Summary: Practical Extraction and Report Language
|
||||||
Url: https://www.perl.org/
|
Url: https://www.perl.org/
|
||||||
Source0: https://www.cpan.org/src/5.0/perl-%{perl_version}.tar.xz
|
Source0: https://www.cpan.org/src/5.0/perl-%{perl_version}.tar.xz
|
||||||
@ -261,6 +261,10 @@ Patch52: perl-5.33.5-Use-perl.h-versions-of-PERL_UNUSED_foo-in-XSUB.h.pat
|
|||||||
# Add missing entries to perldiag, GH#18276, in upstream after 5.33.6
|
# Add missing entries to perldiag, GH#18276, in upstream after 5.33.6
|
||||||
Patch53: perl-5.33.6-Add-missing-entries-to-perldiag-GH-18276.patch
|
Patch53: perl-5.33.6-Add-missing-entries-to-perldiag-GH-18276.patch
|
||||||
|
|
||||||
|
# Protect locale tests from LANGUAGE environment variable,
|
||||||
|
# in upstream after 5.33.6
|
||||||
|
Patch54: perl-5.33.6-t-run-locale.t-Rmv-LANGUAGE-from-environment.patch
|
||||||
|
|
||||||
# Link XS modules to libperl.so with EU::CBuilder on Linux, bug #960048
|
# Link XS modules to libperl.so with EU::CBuilder on Linux, bug #960048
|
||||||
Patch200: perl-5.16.3-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
|
Patch200: perl-5.16.3-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
|
||||||
|
|
||||||
@ -4315,6 +4319,7 @@ you're not running VMS, this module does nothing.
|
|||||||
%patch51 -p1
|
%patch51 -p1
|
||||||
%patch52 -p1
|
%patch52 -p1
|
||||||
%patch53 -p1
|
%patch53 -p1
|
||||||
|
%patch54 -p1
|
||||||
%patch200 -p1
|
%patch200 -p1
|
||||||
%patch201 -p1
|
%patch201 -p1
|
||||||
|
|
||||||
@ -4367,6 +4372,7 @@ perl -x patchlevel.h \
|
|||||||
'Fedora Patch51: Fix croaking on "my $_" when "use utf8" is in effect (GH#18449)' \
|
'Fedora Patch51: Fix croaking on "my $_" when "use utf8" is in effect (GH#18449)' \
|
||||||
'Fedora Patch52: Fix PERL_UNUSED_ARG() definition in XSUB.h' \
|
'Fedora Patch52: Fix PERL_UNUSED_ARG() definition in XSUB.h' \
|
||||||
'Fedora Patch53: Add missing entries to perldiag (GH#18276)' \
|
'Fedora Patch53: Add missing entries to perldiag (GH#18276)' \
|
||||||
|
'Fedora Patch54: Protect locale tests from LANGUAGE environment variable' \
|
||||||
'Fedora Patch200: Link XS modules to libperl.so with EU::CBuilder on Linux' \
|
'Fedora Patch200: Link XS modules to libperl.so with EU::CBuilder on Linux' \
|
||||||
'Fedora Patch201: Link XS modules to libperl.so with EU::MM on Linux' \
|
'Fedora Patch201: Link XS modules to libperl.so with EU::MM on Linux' \
|
||||||
%{nil}
|
%{nil}
|
||||||
@ -7094,6 +7100,9 @@ popd
|
|||||||
|
|
||||||
# Old changelog entries are preserved in CVS.
|
# Old changelog entries are preserved in CVS.
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 04 2021 Petr Pisar <ppisar@redhat.com> - 4:5.32.1-472
|
||||||
|
- Protect locale tests from LANGUAGE environment variable
|
||||||
|
|
||||||
* Tue Feb 09 2021 Petr Pisar <ppisar@redhat.com> - 4:5.32.1-471
|
* Tue Feb 09 2021 Petr Pisar <ppisar@redhat.com> - 4:5.32.1-471
|
||||||
- Make accessing environment by DynaLoader thread-safe
|
- Make accessing environment by DynaLoader thread-safe
|
||||||
- Use duplocale() if available
|
- Use duplocale() if available
|
||||||
|
Loading…
Reference in New Issue
Block a user