Merge branch 'rc'

Conflicts:
	perl.spec
This commit is contained in:
Marcela Mašláňová 2011-06-08 16:14:23 +02:00
commit 4c42f46f92
5 changed files with 93 additions and 180 deletions

3
.gitignore vendored
View File

@ -6,3 +6,6 @@ filter-requires.sh
/perl-5.12.3.tar.gz
/perl.stp
/perl-example.stp
/perl-5.14.0-RC2.tar.bz2
/perl-5.14.0.tar.bz2
/perl-5.14.0.tar.gz

View File

@ -4,6 +4,7 @@
# rpm core; but won't cause a build to fail if they're not present.
#
# Chris Weyl <cweyl@alumni.drew.edu> 2009
# Marcela Mašláňová <mmaslano@redhat.com> 2011
# This macro unsets several common vars used to control how Makefile.PL (et
# al) build and install packages. We also set a couple to help some of the
@ -27,7 +28,11 @@ export PERL_MM_USE_DEFAULT=1
# keep track of what "revision" of the filtering we're at. Each time we
# change the filter we should increment this.
%perl_default_filter_revision 2
%perl_default_filter_revision 3
# Perl provides/requeries are generated by external generators.
%global __perl_provides /usr/lib/rpm/perl.prov
%global __perl_requires /usr/lib/rpm/perl.req
# By default, for perl packages we want to filter all files in _docdir from
# req/prov scanning, as well as filtering out any provides caused by private
@ -36,13 +41,12 @@ export PERL_MM_USE_DEFAULT=1
# Note that this must be invoked in the spec file, preferably as
# "%{?perl_default_filter}", before any %description block.
%perl_default_filter %{?filter_setup: %{expand: \
%filter_provides_in %{perl_vendorarch}/.*\\.so$ \
%filter_provides_in -P %{perl_archlib}/(?!CORE/libperl).*\\.so$ \
%filter_provides_in %{_docdir} \
%filter_requires_in %{_docdir} \
%filter_setup \
}}
%perl_default_filter %{expand: \
%global __provides_exclude_from %{perl_vendorarch}/auto/.*\.so|%{perl_archlib}/.*\.so|%{_docdir}
%global __requires_exclude_from %{_docdir}
%global __provides_exclude perl\\\\(VMS|perl\\\\(Win32|perl\\\\(BSD::|perl\\\\(DB\\\\)|perl\\\\(UNIVERSAL\\\\)
%global __requires_exclude perl\\\\(VMS|perl\\\\(BSD::|perl\\\\(Win32
}
#############################################################################
# Macros to assist with generating a "-tests" subpackage in a semi-automatic

View File

@ -1,6 +1,6 @@
diff -up perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm.runpath perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm
--- perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm.runpath 2010-01-18 19:52:49.000000000 +0100
+++ perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm 2010-04-13 15:56:55.859789425 +0200
diff -up perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm.usem perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm
--- perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm.usem 2011-05-08 05:10:08.000000000 +0200
+++ perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm 2011-05-17 11:14:22.169115984 +0200
@@ -88,6 +88,11 @@ libraries. LD_RUN_PATH is a colon separ
in LDLOADLIBS. It is passed as an environment variable to the process
that links the shared library.
@ -13,10 +13,10 @@ diff -up perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist.pm.runpath per
=head2 BSLOADLIBS
List of those libraries that are needed but can be linked in
diff -up perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.runpath perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm
--- perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.runpath 2010-01-18 19:52:49.000000000 +0100
+++ perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm 2010-04-13 16:00:32.941778159 +0200
@@ -262,7 +262,7 @@ sub full_setup {
diff -up perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.usem perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm
--- perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.usem 2011-05-08 05:10:08.000000000 +0200
+++ perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm 2011-05-17 13:39:26.912586030 +0200
@@ -278,7 +278,7 @@ sub full_setup {
PERL_SRC PERM_DIR PERM_RW PERM_RWX
PL_FILES PM PM_FILTER PMLIBDIRS PMLIBPARENTDIRS POLLUTE PPM_INSTALL_EXEC
PPM_INSTALL_SCRIPT PREREQ_FATAL PREREQ_PM PREREQ_PRINT PRINT_PREREQ
@ -25,7 +25,7 @@ diff -up perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.runpath p
XS_VERSION clean depend dist dynamic_lib linkext macro realclean
tool_autosplit
@@ -406,7 +406,27 @@ sub new {
@@ -422,7 +422,27 @@ sub new {
# PRINT_PREREQ is RedHatism.
if ("@ARGV" =~ /\bPRINT_PREREQ\b/) {
$self->_PRINT_PREREQ;
@ -53,8 +53,8 @@ diff -up perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.runpath p
+ };
print STDOUT "MakeMaker (v$VERSION)\n" if $Verbose;
if (-f "MANIFEST" && ! -f "Makefile"){
@@ -2320,6 +2340,40 @@ precedence. A typemap in the current di
if (-f "MANIFEST" && ! -f "Makefile" && ! $ENV{PERL_CORE}){
@@ -2352,6 +2372,40 @@ precedence. A typemap in the current di
precedence, even if it isn't listed in TYPEMAPS. The default system
typemap has lowest precedence.
@ -95,9 +95,9 @@ diff -up perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.runpath p
=item VENDORPREFIX
Like PERLPREFIX, but only for the vendor install locations.
diff -up perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm.runpath perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
--- perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm.runpath 2010-01-18 19:52:49.000000000 +0100
+++ perl-5.12.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm 2010-04-13 15:56:10.656775285 +0200
diff -up perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm.usem perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
--- perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm.usem 2011-05-08 05:10:08.000000000 +0200
+++ perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm 2011-05-17 11:14:22.172115972 +0200
@@ -944,7 +944,7 @@ $(INST_DYNAMIC): $(OBJECT) $(MYEXTLIB) $
}

221
perl.spec
View File

@ -1,4 +1,4 @@
%global perl_version 5.12.3
%global perl_version 5.14.0
%global perl_epoch 4
%global perl_arch_stem -thread-multi
%global perl_archname %{_arch}-%{_os}%{perl_arch_stem}
@ -63,25 +63,9 @@ Patch6: perl-disable_test_hosts.patch
# systems.
Patch7: perl-5.10.0-x86_64-io-test-failure.patch
# Do not leak when destroying thread; RT #77352, RHBZ #630667
Patch8: perl-5.12.1-fix_thread_leak.patch
# h2ph produces incorrect code in preamble, based mainly on RT #74614
Patch9: perl-5.12.2-h2ph.patch
# Update some of the bundled modules
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
# Update ExtUtils::ParseXS to 2.2206
Patch10: perl-ExtUtils-ParseXS-2.2206.patch
# 692900 - lc launders tainted flag, RT #87336
Patch11: perl-87336-lc-uc-first-fail-to-taint-the-returned-st.patch
# Update some of the bundled modules
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: db4-devel, gdbm-devel, groff, tcsh, zlib-devel, systemtap-sdt-devel
# For tests
BuildRequires: procps, rsyslog
@ -89,10 +73,12 @@ BuildRequires: procps, rsyslog
# The long line of Perl provides.
# These provides are needed by the perl pkg itself with auto-generated perl.req
Provides: perl(VMS::Filespec)
Provides: perl(VMS::Stdio)
# TODO: do not add them, requires should be filtered.
#Provides: perl(VMS::Filespec)
#Provides: perl(VMS::Stdio)
# Compat provides
Provides: perl(:MODULE_COMPAT_5.14.0)
Provides: perl(:MODULE_COMPAT_5.12.3)
Provides: perl(:MODULE_COMPAT_5.12.2)
Provides: perl(:MODULE_COMPAT_5.12.1)
@ -215,7 +201,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.38
Version: 0.48
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -228,7 +214,7 @@ Summary: A module for Perl manipulation of .tar files
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 1.54
Version: 1.76
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
Requires: perl(Compress::Zlib), perl(IO::Zlib)
BuildArch: noarch
@ -241,29 +227,12 @@ IO::Zlib module installed, Archive::Tar will also support compressed or
gzipped tar files.
%package Class-ISA
Summary: Report the search path for a class's ISA tree
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 0.36
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
%description Class-ISA
Suppose you have a class (like Food::Fish::Fishstick) that is derived, via
its @ISA, from one or more superclasses (as Food::Fish::Fishstick is from
Food::Fish, Life::Fungus, and Chemicals), and some of those superclasses
may themselves each be derived, via its @ISA, from one or more superclasses
(as above).
%package CGI
Summary: Handle Common Gateway Interface requests and responses
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 3.49
Version: 3.52
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -283,7 +252,7 @@ Summary: Low-Level Interface to the zlib compression library
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 2.024
Version: 2.033
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
%description Compress-Raw-Zlib
@ -296,7 +265,7 @@ Summary: Query, download and build perl modules from CPAN sites
Group: Development/Languages
License: GPL+ or Artistic
Epoch: 0
Version: 1.9402
Version: 1.9600
# CPAN encourages Digest::SHA strongly because of integrity checks
Requires: perl(Digest::SHA)
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
@ -312,14 +281,15 @@ Summary: API & CLI access to the CPAN mirrors
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 0.90
# real version 0.9103
Version: 0.91.3
# CPANPLUS encourages Digest::SHA strongly because of integrity checks
Requires: perl(Digest::SHA)
Requires: perl(Module::Pluggable) >= 2.4
Requires: perl(Module::CoreList)
Requires: perl(DBIx::Simple)
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
Provides: perl-CPANPLUS-Dist-Build = 0.06
Provides: perl-CPANPLUS-Dist-Build = 0.54
Obsoletes: perl-CPANPLUS-Dist-Build <= 0.05
BuildArch: noarch
@ -334,7 +304,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 5.47
Version: 5.61
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
%description Digest-SHA
@ -350,7 +320,8 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.27
# real version 0.280203 https://fedoraproject.org/wiki/Perl/Tips#Dot_approach
Version: 0.28.2.3
Requires: perl-devel
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -366,7 +337,7 @@ Summary: Utilities for embedding Perl in C/C++ applications
Group: Development/Languages
License: GPL+ or Artistic
Epoch: 0
Version: 1.28
Version: 1.30
Requires: perl-devel
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -380,7 +351,7 @@ Summary: Create a module Makefile
Group: Development/Languages
License: GPL+ or Artistic
Epoch: 0
Version: 6.56
Version: 6.57.5
Requires: perl-devel
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
Requires: perl(Test::Harness)
@ -396,10 +367,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
# We must preserve 4-digit precison since 2.2002 version
%global ExtUtils_ParseXS_real_version 2.22
%global ExtUtils_ParseXS_version %{ExtUtils_ParseXS_real_version}06
Version: %{ExtUtils_ParseXS_version}
Version: 2.2210
Requires: perl-devel
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -416,7 +384,7 @@ Summary: Generic file fetching mechanism
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 0.24
Version: 0.32
Requires: perl(IPC::Cmd) >= 0.36
Requires: perl(Module::Load::Conditional) >= 0.04
Requires: perl(Params::Check) >= 0.07
@ -432,7 +400,7 @@ Summary: IO::Compress wrapper for modules
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 2.026
Version: 2.033
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
Obsoletes: perl-Compress-Zlib <= 2.020
Provides: perl(IO::Uncompress::Bunzip2)
@ -467,7 +435,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.54
Version: 0.70
Requires: perl(ExtUtils::MakeMaker)
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -498,7 +466,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.02
Version: 0.04
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
# Add a versioned provides, since we pull the unversioned one out.
Provides: perl(Log::Message::Handlers) = %{version}
@ -518,7 +486,7 @@ Summary: Simplified frontend to Log::Message
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 0.06
Version: 0.08
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -533,7 +501,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.3603
Version: 0.3800
Requires: perl(Archive::Tar) >= 1.08
Requires: perl(ExtUtils::CBuilder) >= 0.15
Requires: perl(ExtUtils::ParseXS) >= 1.02
@ -557,7 +525,7 @@ Summary: Perl core modules indexed by perl versions
Group: Development/Languages
License: GPL+ or Artistic
Epoch: 0
Version: 2.29
Version: 2.47
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
Requires: perl(version)
BuildArch: noarch
@ -574,7 +542,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.16
Version: 0.18
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -588,7 +556,7 @@ Summary: Looking up module information / loading at runtime
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 0.34
Version: 0.44
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -636,7 +604,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.36
Version: 0.38
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -663,10 +631,11 @@ for a Constants.pm file.
%package PathTools
Summary: PathTools Perl module (Cwd, File::Spec)
# PathTools aka File::Spec
Group: Development/Libraries
License: (GPL+ or Artistic) and BSD
Epoch: 0
Version: 3.31
Version: 3.33
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
%description PathTools
@ -679,7 +648,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.26
Version: 0.28
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -693,7 +662,8 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 1.40
# 1.4401
Version: 1.44.1
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
# FIXME it could be removed now?
@ -725,7 +695,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 3.13
Version: 3.16
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -739,7 +709,7 @@ Summary: A selection of general-utility scalar and list subroutines
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 1.22
Version: 1.23
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
%description Scalar-List-Utils
@ -754,7 +724,7 @@ Summary: Term::ReadLine UI made easy
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 0.20
Version: 0.26
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
Requires: perl(Log::Message::Simple)
BuildArch: noarch
@ -770,7 +740,7 @@ Summary: Run Perl standard test scripts with statistics
Group: Development/Languages
License: GPL+ or Artistic
Epoch: 0
Version: 3.17
Version: 3.23
Requires: perl-devel
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -787,7 +757,7 @@ Summary: Basic utilities for writing tests
Group: Development/Languages
License: GPL+ or Artistic
Epoch: 0
Version: 0.94
Version: 0.98
Requires: perl-devel
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -801,8 +771,8 @@ Summary: Test suite for package perl-Test-Simple
Group: Development/Debug
License: GPL+ or Artistic
Epoch: 0
Version: 0.94
Requires: perl-Test-Simple = 0:0.94-%{release}
Version: 0.98
Requires: perl-Test-Simple = 0:0.98-%{release}
Requires: /usr/bin/prove
AutoReqProv: 0
BuildArch: noarch
@ -816,7 +786,8 @@ Summary: Time objects from localtime and gmtime
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 1.15
# real 1.20_01
Version: 1.20.1
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
%description Time-Piece
@ -832,7 +803,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 1
Version: 0.223
Version: 0.225
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -855,7 +826,7 @@ Summary: Perl interpreter-based threads
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 1.75
Version: 1.83
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
%description threads
@ -876,7 +847,7 @@ Summary: Perl extension for sharing data structures between threads
Group: Development/Libraries
License: GPL+ or Artistic
Epoch: 0
Version: 1.32
Version: 1.37
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
%description threads-shared
@ -894,7 +865,7 @@ Group: Development/Libraries
License: GPL+ or Artistic
# Epoch bump for clean upgrade over old standalone package
Epoch: 3
Version: 0.82
Version: 0.88
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
BuildArch: noarch
@ -915,18 +886,18 @@ Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
Requires: perl-libs = %{perl_epoch}:%{perl_version}-%{release}
Requires: perl-devel = %{perl_epoch}:%{perl_version}-%{release}
Requires: perl-Archive-Extract, perl-Archive-Tar, perl-Class-ISA,
Requires: perl-Compress-Raw-Zlib, perl-CGI, perl-CPAN,
Requires: perl-CPANPLUS, perl-Digest-SHA, perl-ExtUtils-CBuilder,
Requires: perl-ExtUtils-Embed, perl-ExtUtils-MakeMaker, perl-ExtUtils-ParseXS,
Requires: perl-File-Fetch, perl-IO-Compress, perl-IO-Zlib,
Requires: perl-IPC-Cmd, perl-Locale-Maketext-Simple, perl-Log-Message, perl-Log-Message-Simple,
Requires: perl-Module-Build, perl-Module-CoreList, perl-Module-Load,
Requires: perl-Module-Load-Conditional, perl-Module-Loaded,
Requires: perl-Archive-Extract, perl-Archive-Tar
Requires: perl-Compress-Raw-Zlib, perl-CGI, perl-CPAN
Requires: perl-CPANPLUS, perl-Digest-SHA, perl-ExtUtils-CBuilder
Requires: perl-ExtUtils-Embed, perl-ExtUtils-MakeMaker, perl-ExtUtils-ParseXS
Requires: perl-File-Fetch, perl-IO-Compress, perl-IO-Zlib
Requires: perl-IPC-Cmd, perl-Locale-Maketext-Simple, perl-Log-Message, perl-Log-Message-Simple
Requires: perl-Module-Build, perl-Module-CoreList, perl-Module-Load
Requires: perl-Module-Load-Conditional, perl-Module-Loaded
Requires: perl-Module-Pluggable, perl-Object-Accessor, perl-Package-Constants, perl-PathTools
Requires: perl-Params-Check, perl-Pod-Escapes, perl-Pod-Simple, perl-Term-UI,
Requires: perl-Params-Check, perl-Parse-CPAN-Meta, perl-Pod-Escapes, perl-Pod-Simple, perl-Term-UI
Requires: perl-Test-Harness, perl-Test-Simple, perl-Time-Piece, perl-version
Requires: perl-threads, perl-threads-shared, perl-parent, perl-Parse-CPAN-Meta
Requires: perl-threads, perl-threads-shared, perl-parent
%description core
A metapackage which requires all of the perl bits and modules in the upstream
@ -943,10 +914,6 @@ tarball from perl.org.
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
#copy the example script
cp -a %{SOURCE5} .
@ -1081,7 +1048,6 @@ make %{?_smp_mflags}
%endif
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
%global build_archlib $RPM_BUILD_ROOT%{archlib}
@ -1154,10 +1120,6 @@ pushd %{build_archlib}/CORE/
'Fedora Patch5: USE_MM_LD_RUN_PATH' \
'Fedora Patch6: Skip hostname tests, due to builders not being network capable' \
'Fedora Patch7: Dont run one io test due to random builder failures' \
'Fedora Patch8: Do not leak when destroying thread; RT #77352' \
'Fedora Patch9: h2ph produces incorrect code in preamble, based mainly on RT #74614 ' \
'Fedora Patch10: Update ExtUtils::ParseXS to 2.2206' \
'Fedora Patch11: lc launders tainted flag RT #87336' \
%{nil}
rm patchlevel.bak
@ -1210,25 +1172,19 @@ sed \
#%%{__chmod} +x $T_FILES
#%%{_fixperms} %%{buildroot}%%{perl5_testdir}
%clean
rm -rf $RPM_BUILD_ROOT
%check
%ifnarch
%if %{parallel_tests}
JOBS=$(printf '%%s' "%{?_smp_mflags}" | sed 's/.*-j\([0-9][0-9]*\).*/\1/')
LC_ALL=C TEST_JOBS=$JOBS make test_harness
%else
LC_ALL=C make test
%endif
%endif
%post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc Artistic AUTHORS Copying README Changes
%{_mandir}/man1/*.1*
%{_mandir}/man3/*.3*
@ -1271,10 +1227,6 @@ rm -rf $RPM_BUILD_ROOT
%exclude %{_mandir}/man1/ptardiff.1*
%exclude %{_mandir}/man3/Archive::Tar*
# Class-ISA
%exclude %{privlib}/Class/ISA.pm
%exclude %{_mandir}/man3/Class::ISA.3*
# CGI
%exclude %{privlib}/CGI/
%exclude %{privlib}/CGI.pm
@ -1372,7 +1324,6 @@ rm -rf $RPM_BUILD_ROOT
# Compress::Zlib
%exclude %{privlib}/Compress/Zlib.pm
%exclude %{archlib}/auto/Compress/Zlib/
%exclude %{_mandir}/man3/Compress::Zlib*
# IO::Compress::Base
%exclude %{privlib}/File/GlobMapper.pm
@ -1573,7 +1524,6 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_prefix}/local/%{_lib}/perl5
%files devel
%defattr(-,root,root,-)
%{_bindir}/enc2xs
%{_mandir}/man1/enc2xs*
%{privlib}/Encode/
@ -1592,17 +1542,14 @@ rm -rf $RPM_BUILD_ROOT
%doc perl-example.stp
%files tests
%defattr(-,root,root,-)
%{perl5_testdir}/
%exclude %{perl5_testdir}/Test-Simple
%files Archive-Extract
%defattr(-,root,root,-)
%{privlib}/Archive/Extract.pm
%{_mandir}/man3/Archive::Extract.3*
%files Archive-Tar
%defattr(-,root,root,-)
%{_bindir}/ptar
%{_bindir}/ptardiff
%{privlib}/Archive/Tar/
@ -1611,20 +1558,13 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/ptardiff.1*
%{_mandir}/man3/Archive::Tar*
%files Class-ISA
%defattr(-,root,root,-)
%{privlib}/Class/ISA.pm
%{_mandir}/man3/Class::ISA.3*
%files CGI
%defattr(-,root,root,-)
%{privlib}/CGI/
%{privlib}/CGI.pm
%{_mandir}/man3/CGI.3*
%{_mandir}/man3/CGI::*.3*
%files Compress-Raw-Zlib
%defattr(-,root,root,-)
%dir %{archlib}/Compress
%{archlib}/Compress/Raw/
%dir %{archlib}/auto/Compress/
@ -1633,7 +1573,6 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/Compress::Raw::Zlib*
%files CPAN
%defattr(-,root,root,-)
%{_bindir}/cpan
%{privlib}/CPAN/
%{privlib}/CPAN.pm
@ -1642,7 +1581,6 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/CPAN:*
%files CPANPLUS
%defattr(-,root,root,-)
%{_bindir}/cpan2dist
%{_bindir}/cpanp
%{_bindir}/cpanp-run-perl
@ -1653,7 +1591,6 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/CPANPLUS*
%files Digest-SHA
%defattr(-,root,root,-)
%{_bindir}/shasum
%dir %{archlib}/Digest/
%{archlib}/Digest/SHA.pm
@ -1662,18 +1599,15 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/Digest::SHA.3*
%files ExtUtils-CBuilder
%defattr(-,root,root,-)
%{privlib}/ExtUtils/CBuilder/
%{privlib}/ExtUtils/CBuilder.pm
%{_mandir}/man3/ExtUtils::CBuilder*
%files ExtUtils-Embed
%defattr(-,root,root,-)
%{privlib}/ExtUtils/Embed.pm
%{_mandir}/man3/ExtUtils::Embed*
%files ExtUtils-MakeMaker
%defattr(-,root,root,-)
%{_bindir}/instmodsh
%{privlib}/ExtUtils/Command/
%{privlib}/ExtUtils/Install.pm
@ -1705,21 +1639,17 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/ExtUtils::testlib.3*
%files ExtUtils-ParseXS
%defattr(-,root,root,-)
%{privlib}/ExtUtils/ParseXS.pm
%{privlib}/ExtUtils/xsubpp
%{_mandir}/man3/ExtUtils::ParseXS.3*
%files File-Fetch
%defattr(-,root,root,-)
%{privlib}/File/Fetch.pm
%{_mandir}/man3/File::Fetch.3*
%files IO-Compress
%defattr(-,root,root,-)
# Compress-Zlib
%{privlib}/Compress/Zlib.pm
%{archlib}/auto/Compress/Zlib/
%{_mandir}/man3/Compress::Zlib*
#IO-Compress-Base
%{privlib}/File/GlobMapper.pm
@ -1733,7 +1663,6 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/IO::Uncompress::Base.*
# IO-Compress-Zlib
%defattr(-,root,root,-)
%{privlib}/IO/Compress/Adapter/
%{privlib}/IO/Compress/Deflate.pm
%{privlib}/IO/Compress/Gzip/
@ -1759,22 +1688,18 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/IO::Uncompress::Unzip*
%files IO-Zlib
%defattr(-,root,root,-)
%{privlib}/IO/Zlib.pm
%{_mandir}/man3/IO::Zlib.*
%files IPC-Cmd
%defattr(-,root,root,-)
%{privlib}/IPC/Cmd.pm
%{_mandir}/man3/IPC::Cmd.3*
%files Locale-Maketext-Simple
%defattr(-,root,root,-)
%{privlib}/Locale/Maketext/Simple.pm
%{_mandir}/man3/Locale::Maketext::Simple.*
%files Log-Message
%defattr(-,root,root,-)
%{privlib}/Log/Message.pm
%{privlib}/Log/Message/Config.pm
%{privlib}/Log/Message/Handlers.pm
@ -1785,12 +1710,10 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/Log::Message::Item.3*
%files Log-Message-Simple
%defattr(-,root,root,-)
%{privlib}/Log/Message/Simple.pm
%{_mandir}/man3/Log::Message::Simple.3*
%files Module-Build
%defattr(-,root,root,-)
%{_bindir}/config_data
%{privlib}/inc/
%{privlib}/Module/Build/
@ -1800,30 +1723,25 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/inc::latest.3*
%files Module-CoreList
%defattr(-,root,root,-)
%{_bindir}/corelist
%{privlib}/Module/CoreList.pm
%{_mandir}/man1/corelist*
%{_mandir}/man3/Module::CoreList*
%files Module-Load
%defattr(-,root,root,-)
%{privlib}/Module/Load.pm
%{_mandir}/man3/Module::Load.*
%files Module-Load-Conditional
%defattr(-,root,root,-)
%{privlib}/Module/Load/
%{_mandir}/man3/Module::Load::Conditional*
%files Module-Loaded
%defattr(-,root,root,-)
%dir %{privlib}/Module/
%{privlib}/Module/Loaded.pm
%{_mandir}/man3/Module::Loaded*
%files Module-Pluggable
%defattr(-,root,root,-)
%{privlib}/Devel/InnerPackage.pm
%{privlib}/Module/Pluggable/
%{privlib}/Module/Pluggable.pm
@ -1831,17 +1749,14 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/Module::Pluggable*
%files Object-Accessor
%defattr(-,root,root,-)
%{privlib}/Object/
%{_mandir}/man3/Object::Accessor*
%files Package-Constants
%defattr(-,root,root,-)
%{privlib}/Package/
%{_mandir}/man3/Package::Constants*
%files PathTools
%defattr(-,root,root,-)
%{archlib}/Cwd.pm
%{archlib}/File/Spec*
%{archlib}/auto/Cwd/
@ -1849,31 +1764,26 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/File::Spec*
%files Params-Check
%defattr(-,root,root,-)
%{privlib}/Params/
%{_mandir}/man3/Params::Check*
%files Parse-CPAN-Meta
%defattr(-,root,root,-)
%dir %{privlib}/Parse/
%dir %{privlib}/Parse/CPAN/
%{privlib}/Parse/CPAN/Meta.pm
%{_mandir}/man3/Parse::CPAN::Meta.3*
%files Pod-Escapes
%defattr(-,root,root,-)
%{privlib}/Pod/Escapes.pm
%{_mandir}/man3/Pod::Escapes.*
%files Pod-Simple
%defattr(-,root,root,-)
%{privlib}/Pod/Simple/
%{privlib}/Pod/Simple.pm
%{privlib}/Pod/Simple.pod
%{_mandir}/man3/Pod::Simple*
%files Scalar-List-Utils
%defattr(-,root,root,-)
%{archlib}/List/
%{archlib}/List/Util/
%{archlib}/List/Util.pm
@ -1886,13 +1796,11 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/Scalar::Util*
%files Term-UI
%defattr(-,root,root,-)
%{privlib}/Term/UI/
%{privlib}/Term/UI.pm
%{_mandir}/man3/Term::UI*
%files Test-Harness
%defattr(-,root,root,-)
%{_bindir}/prove
%{privlib}/App*
%{privlib}/TAP*
@ -1903,7 +1811,6 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/Test::Harness*
%files Test-Simple
%defattr(-,root,root,-)
%{privlib}/Test/More*
%{privlib}/Test/Builder*
%{privlib}/Test/Simple*
@ -1914,12 +1821,10 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/Test::Tutorial*
%files Test-Simple-tests
%defattr(-,root,root,-)
%dir %{perl5_testdir}
%{perl5_testdir}/Test-Simple
%files Time-Piece
%defattr(-,root,root,-)
%{archlib}/Time/Piece.pm
%{archlib}/Time/Seconds.pm
%{archlib}/auto/Time/Piece/
@ -1927,26 +1832,22 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/Time::Seconds.3*
%files parent
%defattr(-,root,root,-)
%{privlib}/parent.pm
%{_mandir}/man3/parent.3*
%files threads
%defattr(-,root,root,-)
%dir %{archlib}/auto/threads
%{archlib}/auto/threads/threads*
%{archlib}/threads.pm
%{_mandir}/man3/threads.3*
%files threads-shared
%defattr(-,root,root,-)
%{archlib}/auto/threads/shared*
%dir %{archlib}/threads
%{archlib}/threads/shared*
%{_mandir}/man3/threads::shared*
%files version
%defattr(-,root,root,-)
%{privlib}/version.pm
%{privlib}/version.pod
%{privlib}/version/
@ -1958,10 +1859,16 @@ rm -rf $RPM_BUILD_ROOT
# Old changelog entries are preserved in CVS.
%changelog
* Wed Jun 1 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.12.3-161
* Wed Jun 1 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.14.0-161
- arm can't do parallel builds
- add require EE::MM into IPC::Cmd 711486
* Mon May 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.14.0-161
- test build of released 5.14.0
- remove Class::ISA from sub-packages
- patches 8+ are part of new release
- remove vendorarch/auto/Compress/Zlib
* Wed Apr 13 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.12.3-160
- add provides UNIVERSAL and DB back into perl

View File

@ -1,6 +1,5 @@
aceea3db13a159cd5f7e5f2e3ad9534f perl-5.8.0-libdir64.patch
26be2f310eef77f206c47e380518cbd8 macros.perl
ad5d07285d6e4914384b43c9abc2bdba filter-requires.sh
29975a69dce54e47fcd6331c085c6c99 perl-5.12.3.tar.gz
1737a36154bb5bca781296794afc6791 perl.stp
df28fe2c574e8807d0a803308c545dca perl-example.stp
e688b0ddad50bca9a6223693a85c439d perl-5.14.0.tar.gz