Fix find2perl to translate ? glob properly (BZ#825701)
This commit is contained in:
parent
50ee283172
commit
4586ad9f3a
13
perl-5.14.2-find2perl-transtate-question-mark-properly.patch
Normal file
13
perl-5.14.2-find2perl-transtate-question-mark-properly.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -up a/x2p/find2perl.PL b/x2p/find2perl.PL
|
||||||
|
--- a/x2p/find2perl.PL 2010-12-30 03:07:17.000000000 +0100
|
||||||
|
+++ b/x2p/find2perl.PL 2012-05-29 10:18:11.697683643 +0200
|
||||||
|
@@ -681,7 +681,8 @@ sub tab () {
|
||||||
|
sub fileglob_to_re ($) {
|
||||||
|
my $x = shift;
|
||||||
|
$x =~ s#([./^\$()+])#\\$1#g;
|
||||||
|
- $x =~ s#([?*])#.$1#g;
|
||||||
|
+ $x =~ s#\*#.*#g;
|
||||||
|
+ $x =~ s#\?#.#g;
|
||||||
|
"^$x\\z";
|
||||||
|
}
|
||||||
|
|
14
perl.spec
14
perl.spec
@ -73,6 +73,8 @@ Patch7: perl-5.10.0-x86_64-io-test-failure.patch
|
|||||||
# switch off test, which is failing only on koji (fork)
|
# switch off test, which is failing only on koji (fork)
|
||||||
Patch8: perl-5.14.1-offtest.patch
|
Patch8: perl-5.14.1-offtest.patch
|
||||||
|
|
||||||
|
# Fix find2perl to translate ? glob properly, rhbz#825701, RT#113054
|
||||||
|
Patch9: perl-5.14.2-find2perl-transtate-question-mark-properly.patch
|
||||||
# Fix searching for Unicode::Collate::Locale data, rhbz#756118, CPANRT#72666,
|
# Fix searching for Unicode::Collate::Locale data, rhbz#756118, CPANRT#72666,
|
||||||
# fixed in Unicode-Collate-0.87.
|
# fixed in Unicode-Collate-0.87.
|
||||||
# TODO Looks like it was fixed differently?
|
# TODO Looks like it was fixed differently?
|
||||||
@ -1274,6 +1276,7 @@ tarball from perl.org.
|
|||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
|
%patch9 -p1
|
||||||
|
|
||||||
#copy the example script
|
#copy the example script
|
||||||
cp -a %{SOURCE5} .
|
cp -a %{SOURCE5} .
|
||||||
@ -1474,13 +1477,7 @@ pushd %{build_archlib}/CORE/
|
|||||||
'Fedora Patch5: USE_MM_LD_RUN_PATH' \
|
'Fedora Patch5: USE_MM_LD_RUN_PATH' \
|
||||||
'Fedora Patch6: Skip hostname tests, due to builders not being network capable' \
|
'Fedora Patch6: Skip hostname tests, due to builders not being network capable' \
|
||||||
'Fedora Patch7: Dont run one io test due to random builder failures' \
|
'Fedora Patch7: Dont run one io test due to random builder failures' \
|
||||||
'Fedora Patch9: Fix code injection in Digest->new()' \
|
'Fedora Patch9: Fix find2perl to translate ? glob properly (RT#113054)' \
|
||||||
'Fedora Patch10: Change Perl_repeatcpy() to allow count above 2^31' \
|
|
||||||
'Fedora Patch11: Fix leak with non-matching named captures' \
|
|
||||||
'Fedora Patch12: Fix interrupted reading' \
|
|
||||||
'Fedora Patch13: Fix searching for Unicode::Collate::Locale data' \
|
|
||||||
'Fedora Patch14: Run signal handlers before returning from sigsuspend' \
|
|
||||||
'Fedora Patch15: Stop !$^V from leaking' \
|
|
||||||
%{nil}
|
%{nil}
|
||||||
|
|
||||||
rm patchlevel.bak
|
rm patchlevel.bak
|
||||||
@ -2454,6 +2451,9 @@ sed \
|
|||||||
|
|
||||||
# Old changelog entries are preserved in CVS.
|
# Old changelog entries are preserved in CVS.
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 1 2012 Jitka Plesnikova <jplesnik@redhat.com> - 4:5.16.0-217
|
||||||
|
- Fix find2perl to translate ? glob properly (bug #825701)
|
||||||
|
|
||||||
* Fri May 25 2012 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.16.0-217
|
* Fri May 25 2012 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.16.0-217
|
||||||
- upload the stable 5.16.0
|
- upload the stable 5.16.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user