5.36.1 bump
This commit is contained in:
parent
19e3e78be7
commit
27c8969138
1
.gitignore
vendored
1
.gitignore
vendored
@ -39,3 +39,4 @@ perl-5.12.1.tar.gz
|
|||||||
/perl-5.34.0.tar.xz
|
/perl-5.34.0.tar.xz
|
||||||
/perl-5.34.1.tar.xz
|
/perl-5.34.1.tar.xz
|
||||||
/perl-5.36.0.tar.xz
|
/perl-5.36.0.tar.xz
|
||||||
|
/perl-5.36.1.tar.xz
|
||||||
|
@ -1,94 +0,0 @@
|
|||||||
Avoid implicit ints and implicit function declarations, for improved
|
|
||||||
compatibility with future compilers which will reject them by default.
|
|
||||||
|
|
||||||
Submitted upstream: <https://github.com/Perl/perl5/pull/20718>
|
|
||||||
|
|
||||||
diff --git a/Configure b/Configure
|
|
||||||
index 9bd6a7ad9465c2ce..75c090edc37015da 100755
|
|
||||||
--- a/Configure
|
|
||||||
+++ b/Configure
|
|
||||||
@@ -4638,7 +4638,7 @@ esac
|
|
||||||
# so we will take those off from locincpth.
|
|
||||||
case "$gccversion" in
|
|
||||||
3.*)
|
|
||||||
- echo "main(){}">try.c
|
|
||||||
+ echo "int main(){}">try.c
|
|
||||||
for incdir in $locincpth; do
|
|
||||||
warn=`$cc $ccflags -I$incdir -c try.c 2>&1 | \
|
|
||||||
grep '^c[cp]p*[01]: warning: changing search order '`
|
|
||||||
@@ -5771,6 +5771,7 @@ case "$intsize" in
|
|
||||||
#ifdef I_STDLIB
|
|
||||||
#include <stdlib.h>
|
|
||||||
#endif
|
|
||||||
+#include <stdio.h>
|
|
||||||
int main()
|
|
||||||
{
|
|
||||||
printf("intsize=%d;\n", (int)sizeof(int));
|
|
||||||
@@ -6844,6 +6845,7 @@ case "$doublesize" in
|
|
||||||
#ifdef I_STDLIB
|
|
||||||
#include <stdlib.h>
|
|
||||||
#endif
|
|
||||||
+#include <stdio.h>
|
|
||||||
int main()
|
|
||||||
{
|
|
||||||
printf("%d\n", (int)sizeof(double));
|
|
||||||
@@ -12606,7 +12608,7 @@ case "$dlsrc" in
|
|
||||||
dl_dlopen.xs)
|
|
||||||
echo "Checking whether your dlsym() needs a leading underscore ..." >&4
|
|
||||||
$cat >dyna.c <<'EOM'
|
|
||||||
-fred () { }
|
|
||||||
+void fred (void) { }
|
|
||||||
EOM
|
|
||||||
|
|
||||||
$cat >fred.c<<EOM
|
|
||||||
@@ -12625,7 +12627,7 @@ $cat >fred.c<<EOM
|
|
||||||
#include <link.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-extern int fred() ;
|
|
||||||
+extern void fred(void) ;
|
|
||||||
|
|
||||||
int main()
|
|
||||||
{
|
|
||||||
@@ -13659,6 +13661,7 @@ $cat >try.c <<EOP
|
|
||||||
#ifdef I_STDLIB
|
|
||||||
#include <stdlib.h>
|
|
||||||
#endif
|
|
||||||
+#include <string.h>
|
|
||||||
#define FILE_ptr(fp) $stdio_ptr
|
|
||||||
#define FILE_cnt(fp) $stdio_cnt
|
|
||||||
int main() {
|
|
||||||
@@ -16166,6 +16169,7 @@ echo "Checking to see if your libm supports _LIB_VERSION..." >&4
|
|
||||||
$cat >try.c <<EOCP
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <math.h>
|
|
||||||
+#include <stdio.h>
|
|
||||||
int main (int argc, char *argv[])
|
|
||||||
{
|
|
||||||
printf ("%d\n", _LIB_VERSION);
|
|
||||||
@@ -22063,13 +22067,15 @@ pager="$ans"
|
|
||||||
: see if ar generates random libraries by itself
|
|
||||||
echo " "
|
|
||||||
echo "Checking how to generate random libraries on your machine..." >&4
|
|
||||||
-echo 'int bar1() { return bar2(); }' > bar1.c
|
|
||||||
+echo 'extern int bar2(); int bar1() { return bar2(); }' > bar1.c
|
|
||||||
echo 'int bar2() { return 2; }' > bar2.c
|
|
||||||
$cat > foo.c <<EOP
|
|
||||||
#$i_stdlib I_STDLIB
|
|
||||||
#ifdef I_STDLIB
|
|
||||||
#include <stdlib.h>
|
|
||||||
#endif
|
|
||||||
+#include <stdio.h>
|
|
||||||
+extern int bar1();
|
|
||||||
int main() { printf("%d\n", bar1()); exit(0); }
|
|
||||||
EOP
|
|
||||||
$cc $ccflags -c bar1.c >/dev/null 2>&1
|
|
||||||
@@ -22295,7 +22301,7 @@ EOM
|
|
||||||
for nfd in 'int' 'size_t' 'unsigned long' 'unsigned' ; do
|
|
||||||
for tmo in 'struct timeval *' 'const struct timeval *'; do
|
|
||||||
case "$val" in
|
|
||||||
- '') try="$extern_C select _(($nfd, $xxx, $xxx, $xxx, $tmo));"
|
|
||||||
+ '') try="$extern_C int select _(($nfd, $xxx, $xxx, $xxx, $tmo));"
|
|
||||||
if ./protochk "$try" $hdrs; then
|
|
||||||
echo "Your system accepts $xxx."
|
|
||||||
val="$xxx"
|
|
49
perl.spec
49
perl.spec
@ -1,4 +1,4 @@
|
|||||||
%global perl_version 5.36.0
|
%global perl_version 5.36.1
|
||||||
%global perl_epoch 4
|
%global perl_epoch 4
|
||||||
%global perl_arch_stem -thread-multi
|
%global perl_arch_stem -thread-multi
|
||||||
%global perl_archname %{_arch}-%{_os}%{perl_arch_stem}
|
%global perl_archname %{_arch}-%{_os}%{perl_arch_stem}
|
||||||
@ -108,7 +108,7 @@ License: GPL-1.0-or-later OR Artistic-1.0-Perl
|
|||||||
Epoch: %{perl_epoch}
|
Epoch: %{perl_epoch}
|
||||||
Version: %{perl_version}
|
Version: %{perl_version}
|
||||||
# release number must be even higher, because dual-lived modules will be broken otherwise
|
# release number must be even higher, because dual-lived modules will be broken otherwise
|
||||||
Release: 495%{?dist}
|
Release: 496%{?dist}
|
||||||
Summary: Practical Extraction and Report Language
|
Summary: Practical Extraction and Report Language
|
||||||
Url: https://www.perl.org/
|
Url: https://www.perl.org/
|
||||||
Source0: https://www.cpan.org/src/5.0/perl-%{perl_version}.tar.xz
|
Source0: https://www.cpan.org/src/5.0/perl-%{perl_version}.tar.xz
|
||||||
@ -180,7 +180,6 @@ Patch201: perl-5.16.3-Link-XS-modules-to-libperl.so-with-EU-MM-on-Linux.pa
|
|||||||
|
|
||||||
# If optimizing -O is used, add the definition to .ph files, bug #2152012
|
# If optimizing -O is used, add the definition to .ph files, bug #2152012
|
||||||
Patch202: perl-5.36.0-Add-definition-of-OPTIMIZE-to-.ph-files.patch
|
Patch202: perl-5.36.0-Add-definition-of-OPTIMIZE-to-.ph-files.patch
|
||||||
Patch203: perl-configure-c99.patch
|
|
||||||
|
|
||||||
# Update some of the bundled modules
|
# Update some of the bundled modules
|
||||||
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
|
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
|
||||||
@ -233,7 +232,7 @@ BuildRequires: rsyslog
|
|||||||
|
|
||||||
|
|
||||||
# compat macro needed for rebuild
|
# compat macro needed for rebuild
|
||||||
%global perl_compat perl(:MODULE_COMPAT_5.36.0)
|
%global perl_compat perl(:MODULE_COMPAT_5.36.1)
|
||||||
|
|
||||||
Requires: %perl_compat
|
Requires: %perl_compat
|
||||||
Requires: perl-interpreter%{?_isa} = %{perl_epoch}:%{perl_version}-%{release}
|
Requires: perl-interpreter%{?_isa} = %{perl_epoch}:%{perl_version}-%{release}
|
||||||
@ -414,6 +413,7 @@ Summary: The libraries for the perl run-time
|
|||||||
License: (GPL-1.0-or-later OR Artistic-1.0-Perl) AND Martin-Birgmeier AND Spencer-86 AND MIT AND UCD AND LicenseRef-Fedora-Public-Domain
|
License: (GPL-1.0-or-later OR Artistic-1.0-Perl) AND Martin-Birgmeier AND Spencer-86 AND MIT AND UCD AND LicenseRef-Fedora-Public-Domain
|
||||||
# Compat provides
|
# Compat provides
|
||||||
Provides: %perl_compat
|
Provides: %perl_compat
|
||||||
|
Provides: perl(:MODULE_COMPAT_5.36.0)
|
||||||
# Interpreter version to fulfil required genersted from "require 5.006;"
|
# Interpreter version to fulfil required genersted from "require 5.006;"
|
||||||
Provides: perl(:VERSION) = %{perl_version}
|
Provides: perl(:VERSION) = %{perl_version}
|
||||||
# Integeres are 64-bit on all platforms
|
# Integeres are 64-bit on all platforms
|
||||||
@ -2734,7 +2734,7 @@ encoder/decoder. These encoding methods are specified in RFC 2045 - MIME
|
|||||||
Summary: What modules are shipped with versions of perl
|
Summary: What modules are shipped with versions of perl
|
||||||
License: GPL-1.0-or-later OR Artistic-1.0-Perl
|
License: GPL-1.0-or-later OR Artistic-1.0-Perl
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 5.20220520
|
Version: 5.20230423
|
||||||
Requires: %perl_compat
|
Requires: %perl_compat
|
||||||
Requires: perl(List::Util)
|
Requires: perl(List::Util)
|
||||||
Requires: perl(version) >= 0.88
|
Requires: perl(version) >= 0.88
|
||||||
@ -2752,7 +2752,7 @@ are shipped with each version of perl.
|
|||||||
Summary: Tool for listing modules shipped with perl
|
Summary: Tool for listing modules shipped with perl
|
||||||
License: GPL-1.0-or-later OR Artistic-1.0-Perl
|
License: GPL-1.0-or-later OR Artistic-1.0-Perl
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 5.20220520
|
Version: 5.20230423
|
||||||
Requires: %perl_compat
|
Requires: %perl_compat
|
||||||
Requires: perl(feature)
|
Requires: perl(feature)
|
||||||
Requires: perl(version) >= 0.88
|
Requires: perl(version) >= 0.88
|
||||||
@ -4186,25 +4186,24 @@ you're not running VMS, this module does nothing.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n perl-%{perl_version}
|
%setup -q -n perl-%{perl_version}
|
||||||
%patch1 -p1
|
%patch -P1 -p1
|
||||||
%ifarch %{multilib_64_archs}
|
%ifarch %{multilib_64_archs}
|
||||||
%patch2 -p1
|
%patch -P2 -p1
|
||||||
%endif
|
%endif
|
||||||
%patch3 -p1
|
%patch -P3 -p1
|
||||||
%patch4 -p1
|
%patch -P4 -p1
|
||||||
%patch5 -p1
|
%patch -P5 -p1
|
||||||
%patch6 -p1
|
%patch -P6 -p1
|
||||||
%patch7 -p1
|
%patch -P7 -p1
|
||||||
%patch8 -p1
|
%patch -P8 -p1
|
||||||
%patch9 -p1
|
%patch -P9 -p1
|
||||||
%patch10 -p1
|
%patch -P10 -p1
|
||||||
%patch11 -p1
|
%patch -P11 -p1
|
||||||
%patch12 -p1
|
%patch -P12 -p1
|
||||||
%patch13 -p1
|
%patch -P13 -p1
|
||||||
%patch200 -p1
|
%patch -P200 -p1
|
||||||
%patch201 -p1
|
%patch -P201 -p1
|
||||||
%patch202 -p1
|
%patch -P202 -p1
|
||||||
%patch203 -p1
|
|
||||||
|
|
||||||
%if !%{defined perl_bootstrap}
|
%if !%{defined perl_bootstrap}
|
||||||
# Local patch tracking
|
# Local patch tracking
|
||||||
@ -7009,6 +7008,10 @@ popd
|
|||||||
|
|
||||||
# Old changelog entries are preserved in CVS.
|
# Old changelog entries are preserved in CVS.
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 24 2023 Jitka Plesnikova <jplesnik@redhat.com> - 4:5.36.1-496
|
||||||
|
- 5.36.1 bump (see <https://metacpan.org/release/SHAY/perl-5.36.1/view/pod/perldelta.pod>
|
||||||
|
or release notes
|
||||||
|
|
||||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4:5.36.0-495
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4:5.36.0-495
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (perl-5.36.0.tar.xz) = 6dd6ac2a77566c173c5ab9c238cf555f2c3e592e89abb5600bc23ce1cbd0c349e0233f6417cbbf1f6d0aefc6a734ba491285af0d3dc68a605b658b65c89f1dab
|
SHA512 (perl-5.36.1.tar.xz) = 8d1ec654c59d078bfc477f11c9526233199a85e4d4f6f5a55bf9eb7802cd355189c669cc6785d2d5e741c1de4d740b7a0cfd3c0198122586a07ac7f527fb14af
|
||||||
|
Loading…
Reference in New Issue
Block a user