fix bug 172236 / upstream bug 37582
This commit is contained in:
parent
ce53b74d18
commit
1450ba310c
21
perl-5.8.7-bz172236.patch
Normal file
21
perl-5.8.7-bz172236.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- perl-5.8.7/utils/h2ph.PL.bz172236 2005-04-04 17:47:17.000000000 -0400
|
||||
+++ perl-5.8.7/utils/h2ph.PL 2005-11-01 17:42:36.000000000 -0500
|
||||
@@ -734,9 +734,15 @@
|
||||
# non-GCC?) C compilers, but gcc uses an additional include directory.
|
||||
sub inc_dirs
|
||||
{
|
||||
- my $from_gcc = `$Config{cc} -v 2>&1`;
|
||||
- $from_gcc =~ s:^Reading specs from (.*?)/specs\b.*:$1/include:s;
|
||||
-
|
||||
+ my $from_gcc = `LC_ALL=C $Config{cc} -v 2>&1`;
|
||||
+ if( !( $from_gcc =~ s:^Reading specs from (.*?)/specs\b.*:$1/include:s ) )
|
||||
+ { # gcc-4+ :
|
||||
+ $from_gcc = `LC_ALL=C $Config{cc} -print-search-dirs 2>&1`;
|
||||
+ if ( !($from_gcc =~ s/^install:\s*([^\s]+[^\s\/])([\s\/]*).*$/$1\/include/s) )
|
||||
+ {
|
||||
+ $from_gcc = '';
|
||||
+ };
|
||||
+ };
|
||||
length($from_gcc) ? ($from_gcc, $Config{usrinc}) : ($Config{usrinc});
|
||||
}
|
||||
|
10
perl.spec
10
perl.spec
@ -114,6 +114,8 @@ Patch32002: perl-5.8.0-nptlhint.patch
|
||||
|
||||
Patch32003: perl-5.8.6-libresolv.patch
|
||||
|
||||
Patch172236: perl-5.8.7-bz172236.patch
|
||||
|
||||
# module updatesd
|
||||
# Patch202: perl-5.8.0-Safe2.09.patch
|
||||
|
||||
@ -264,6 +266,8 @@ more secure running of setuid perl scripts.
|
||||
%patch32002 -p1
|
||||
%patch32003 -p1
|
||||
|
||||
%patch172236 -p1
|
||||
|
||||
# Candidates for doc recoding (need case by case review):
|
||||
# find . -name "*.pod" -o -name "README*" -o -name "*.pm" | xargs file -i | grep charset= | grep -v '\(us-ascii\|utf-8\)'
|
||||
recode()
|
||||
@ -472,7 +476,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 25 2005 Jason Vas Dias <jvdias@redhat.com> - 3.5.8.7-0.6
|
||||
* Tue Nov 01 2005 Jason Vas Dias <jvdias@redhat.com> - 3:5.8.7-0.7
|
||||
- fix bug 172236 : missing C standard headers -
|
||||
use gcc4's '-print-search-path' option in h2ph
|
||||
|
||||
* Tue Oct 25 2005 Jason Vas Dias <jvdias@redhat.com> - 3:5.8.7-0.6
|
||||
- fix bug 171111 : define ioctl length macro IOCPARM_LEN(x)
|
||||
macro to be _IOC_SIZE(x), not 256 - upstream bug #37535 raised.
|
||||
- provide 'perl_debugging' .spec file option to enable -DDEBUGGING
|
||||
|
Loading…
Reference in New Issue
Block a user