Fix find2perl to translate ? glob properly
This commit is contained in:
parent
64dad8cf20
commit
01cb6d0674
13
perl-5.14.2-find2perl-transtate-question-mark-properly.patch
Normal file
13
perl-5.14.2-find2perl-transtate-question-mark-properly.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up a/x2p/find2perl.PL b/x2p/find2perl.PL
|
||||
--- a/x2p/find2perl.PL 2010-12-30 03:07:17.000000000 +0100
|
||||
+++ b/x2p/find2perl.PL 2012-05-29 10:18:11.697683643 +0200
|
||||
@@ -681,7 +681,8 @@ sub tab () {
|
||||
sub fileglob_to_re ($) {
|
||||
my $x = shift;
|
||||
$x =~ s#([./^\$()+])#\\$1#g;
|
||||
- $x =~ s#([?*])#.$1#g;
|
||||
+ $x =~ s#\*#.*#g;
|
||||
+ $x =~ s#\?#.#g;
|
||||
"^$x\\z";
|
||||
}
|
||||
|
10
perl.spec
10
perl.spec
@ -24,7 +24,7 @@
|
||||
Name: perl
|
||||
Version: %{perl_version}
|
||||
# release number must be even higher, because dual-lived modules will be broken otherwise
|
||||
Release: 216%{?dist}
|
||||
Release: 217%{?dist}
|
||||
Epoch: %{perl_epoch}
|
||||
Summary: Practical Extraction and Report Language
|
||||
Group: Development/Languages
|
||||
@ -95,6 +95,9 @@ Patch14: perl-5.14.2-Signal-handlers-must-run-before-sigsuspend-returns.p
|
||||
# Stop !$^V from leaking, rhbz#787613, RT#109762, fixed after 5.15.7.
|
||||
Patch15: perl-5.14.2-Stop-V-from-leaking.patch
|
||||
|
||||
# Fix find2perl to translate ? glob properly, rhbz#825701, RT#113054
|
||||
Patch16: perl-5.14.2-find2perl-transtate-question-mark-properly.patch
|
||||
|
||||
# Update some of the bundled modules
|
||||
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
|
||||
|
||||
@ -1295,6 +1298,7 @@ tarball from perl.org.
|
||||
%patch13 -p1
|
||||
%patch14 -p1
|
||||
%patch15 -p1
|
||||
%patch16 -p1
|
||||
|
||||
#copy the example script
|
||||
cp -a %{SOURCE5} .
|
||||
@ -1501,6 +1505,7 @@ pushd %{build_archlib}/CORE/
|
||||
'Fedora Patch13: Fix searching for Unicode::Collate::Locale data' \
|
||||
'Fedora Patch14: Run signal handlers before returning from sigsuspend' \
|
||||
'Fedora Patch15: Stop !$^V from leaking' \
|
||||
'Fedora Patch16: Fix find2perl to translate ? glob properly (RT#113054)' \
|
||||
%{nil}
|
||||
|
||||
rm patchlevel.bak
|
||||
@ -2478,6 +2483,9 @@ sed \
|
||||
|
||||
# Old changelog entries are preserved in CVS.
|
||||
%changelog
|
||||
* Tue May 29 2012 Jitka Plesnikova <jplesnik@redhat.com> - 4:5.14.2-217
|
||||
- Fix find2perl to translate ? glob properly (bug #825701)
|
||||
|
||||
* Mon Apr 30 2012 Petr Pisar <ppisar@redhat.com> - 4:5.14.2-216
|
||||
- Enable usesitecustomize
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user