Import
This commit is contained in:
parent
14cc16e8de
commit
7a2c16199e
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
||||
/libnet-3.06.tar.gz
|
26
libnet-3.06-Normalize-Changes-encoding.patch
Normal file
26
libnet-3.06-Normalize-Changes-encoding.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 185ee11e986d5a0015ce38e7fe2df7397340dd50 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Thu, 2 Jul 2015 13:37:47 +0200
|
||||
Subject: [PATCH] Normalize Changes encoding
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Petr PÃsaÅ™ <ppisar@redhat.com>
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index 90246d6..d590a3f 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -164,7 +164,7 @@ Revision history for Perl distribution libnet
|
||||
|
||||
1.24 2014-01-06
|
||||
|
||||
- - Fix incorrect handling of CRLF in Net::FTP. [Willem Monsuwé, CPAN
|
||||
+ - Fix incorrect handling of CRLF in Net::FTP. [Willem Monsuwé, CPAN
|
||||
RT#41642/62029]
|
||||
|
||||
- POD fixes. [Dominic Hargreaves, CPAN RT#91761]
|
||||
--
|
||||
2.4.3
|
||||
|
106
perl-libnet.spec
Normal file
106
perl-libnet.spec
Normal file
@ -0,0 +1,106 @@
|
||||
Name: perl-libnet
|
||||
Version: 3.06
|
||||
Release: 1%{?dist}
|
||||
Summary: Perl clients for various network protocols
|
||||
License: GPL+ or Artistic
|
||||
Group: Development/Libraries
|
||||
URL: http://search.cpan.org/dist/libnet/
|
||||
Source0: http://www.cpan.org/authors/id/S/SH/SHAY/libnet-%{version}.tar.gz
|
||||
# Convert Changes to UTF-8
|
||||
Patch0: libnet-3.06-Normalize-Changes-encoding.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: make
|
||||
BuildRequires: perl
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.64
|
||||
BuildRequires: perl(Getopt::Std)
|
||||
BuildRequires: perl(IO::File)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(warnings)
|
||||
# Run-time:
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(constant)
|
||||
# Convert::EBCDIC not used
|
||||
# Encode not need if utf8 is available
|
||||
BuildRequires: perl(Errno)
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(Fcntl)
|
||||
# File::Basename not used at tests
|
||||
BuildRequires: perl(FileHandle)
|
||||
BuildRequires: perl(IO::Select)
|
||||
BuildRequires: perl(IO::Socket) >= 1.05
|
||||
# Prefer IO::Socket::IP over IO::Socket::INET6 and IO::Socket::INET
|
||||
# IO::Socket::INET6 not used
|
||||
BuildRequires: perl(IO::Socket::IP) >= 0.20
|
||||
BuildRequires: perl(POSIX)
|
||||
BuildRequires: perl(Socket) >= 2.016
|
||||
BuildRequires: perl(Symbol)
|
||||
BuildRequires: perl(Time::Local)
|
||||
BuildRequires: perl(utf8)
|
||||
# Optional run-time:
|
||||
# Authen::SASL not used at tests
|
||||
# Digest::MD5 not used at tests
|
||||
%if !%{defined perl_bootstrap}
|
||||
# Core modules must built without non-core dependencies
|
||||
BuildRequires: perl(IO::Socket::SSL) >= 2.007
|
||||
%endif
|
||||
# MD5 not used because we prefer Digest::MD5
|
||||
# MIME::Base64 not used at tests
|
||||
# Tests:
|
||||
BuildRequires: perl(Config)
|
||||
BuildRequires: perl(Cwd)
|
||||
BuildRequires: perl(File::Temp)
|
||||
BuildRequires: perl(Test::More)
|
||||
# Optional tests:
|
||||
%if !%{defined perl_bootstrap}
|
||||
# Core modules must built without non-core dependencies
|
||||
BuildRequires: perl(IO::Socket::SSL::Utils)
|
||||
%endif
|
||||
# Test::CPAN::Changes not used
|
||||
# Test::Perl::Critic not used
|
||||
# Test::Pod 1.00 not used
|
||||
# Test::Pod::Coverage 0.08 not used
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
Requires: perl(File::Basename)
|
||||
Requires: perl(IO::Socket) >= 1.05
|
||||
# Prefer IO::Socket::IP over IO::Socket::INET6 and IO::Socket::INET
|
||||
Requires: perl(IO::Socket::IP) >= 0.20
|
||||
Requires: perl(POSIX)
|
||||
Requires: perl(Socket) >= 2.016
|
||||
Requires: perl(utf8)
|
||||
Conflicts: perl < 4:5.22.0-347
|
||||
|
||||
# Filter under-specified dependencies
|
||||
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\((IO::Socket|Socket)\\)$
|
||||
|
||||
%description
|
||||
This is a collection of Perl modules which provides a simple and
|
||||
consistent programming interface (API) to the client side of various
|
||||
protocols used in the internet community.
|
||||
|
||||
%prep
|
||||
%setup -q -n libnet-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor </dev/null
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
||||
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%files
|
||||
%license Artistic Copying LICENCE
|
||||
%doc Changes README
|
||||
%{perl_vendorlib}/*
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Wed Jul 01 2015 Petr Pisar <ppisar@redhat.com> 3.06-1
|
||||
- Specfile autogenerated by cpanspec 1.78.
|
Loading…
Reference in New Issue
Block a user