Fix building on Perl without "." in @INC
This commit is contained in:
parent
119e741f0b
commit
92292c0f7a
@ -0,0 +1,31 @@
|
|||||||
|
From 70ca3b6f3e6b02bec419e944a937fd1b19b0decc Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||||
|
Date: Mon, 15 May 2017 14:26:38 +0200
|
||||||
|
Subject: [PATCH] Fix building on Perl without "." in @INC
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
CPAN RT#120446
|
||||||
|
|
||||||
|
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile.PL | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.PL b/Makefile.PL
|
||||||
|
index 898040d..5b25425 100644
|
||||||
|
--- a/Makefile.PL
|
||||||
|
+++ b/Makefile.PL
|
||||||
|
@@ -182,7 +182,7 @@ sub tools_other
|
||||||
|
my $fragment = $self->SUPER::tools_other (@_);
|
||||||
|
|
||||||
|
$fragment =~ s/^MOD_INSTALL\s*=\s*(.*?)-MExtUtils::Install
|
||||||
|
- /MOD_INSTALL =$1-MMyInstall/msx;
|
||||||
|
+ /MOD_INSTALL =$1-I. -MMyInstall/msx;
|
||||||
|
|
||||||
|
return $fragment;
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.9.4
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Internationalization library for Perl, compatible with gettext
|
Summary: Internationalization library for Perl, compatible with gettext
|
||||||
Name: perl-libintl-perl
|
Name: perl-libintl-perl
|
||||||
Version: 1.26
|
Version: 1.26
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
# gettext_xs/gettext_xs.pm: GPLv3+
|
# gettext_xs/gettext_xs.pm: GPLv3+
|
||||||
# gettext_xs/Makefile.PL: LGPLv2+
|
# gettext_xs/Makefile.PL: LGPLv2+
|
||||||
# lib/Locale/gettext_xs.pod: LGPLv2+
|
# lib/Locale/gettext_xs.pod: LGPLv2+
|
||||||
@ -11,6 +11,8 @@ Release: 2%{?dist}
|
|||||||
License: GPLv3+ and LGPLv2+
|
License: GPLv3+ and LGPLv2+
|
||||||
URL: http://search.cpan.org/dist/libintl-perl/
|
URL: http://search.cpan.org/dist/libintl-perl/
|
||||||
Source: http://search.cpan.org/CPAN/authors/id/G/GU/GUIDO/libintl-perl-%{version}.tar.gz
|
Source: http://search.cpan.org/CPAN/authors/id/G/GU/GUIDO/libintl-perl-%{version}.tar.gz
|
||||||
|
# Fix building on Perl without "." in @INC, CPAN RT#120446
|
||||||
|
Patch0: libintl-perl-1.26-Fix-building-on-Perl-without-.-in-INC.patch
|
||||||
# this module was renamed in the f25 dev cycle
|
# this module was renamed in the f25 dev cycle
|
||||||
Provides: perl-libintl = %{version}-%{release}
|
Provides: perl-libintl = %{version}-%{release}
|
||||||
Obsoletes: perl-libintl < 1.25
|
Obsoletes: perl-libintl < 1.25
|
||||||
@ -69,6 +71,7 @@ implemented for example in GNU gettext.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n libintl-perl-%{version}
|
%setup -q -n libintl-perl-%{version}
|
||||||
|
%patch0 -p1
|
||||||
find -type f -exec chmod -x {} \;
|
find -type f -exec chmod -x {} \;
|
||||||
find lib/Locale gettext_xs \( -name '*.pm' -o -name '*.pod' \) \
|
find lib/Locale gettext_xs \( -name '*.pm' -o -name '*.pod' \) \
|
||||||
-exec sed -i -e '/^#! \/bin\/false/d' {} \;
|
-exec sed -i -e '/^#! \/bin\/false/d' {} \;
|
||||||
@ -103,6 +106,9 @@ make test
|
|||||||
%{_mandir}/man?/*
|
%{_mandir}/man?/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 15 2017 Petr Pisar <ppisar@redhat.com> - 1.26-3
|
||||||
|
- Fix building on Perl without "." in @INC (CPAN RT#120446)
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.26-2
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.26-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user