210 lines
7.0 KiB
RPMSpec
210 lines
7.0 KiB
RPMSpec
# Tests require accessible syslog
|
|
%bcond_with test
|
|
|
|
Name: perl-Unix-Syslog
|
|
Version: 1.1
|
|
Release: 29%{?dist}
|
|
Summary: Perl interface to the UNIX syslog(3) calls
|
|
License: Artistic 2.0
|
|
Group: Development/Libraries
|
|
URL: http://search.cpan.org/dist/Unix-Syslog/
|
|
Source0: http://www.cpan.org/authors/id/M/MH/MHARNISCH/Unix-Syslog-%{version}.tar.gz
|
|
# Module Build
|
|
BuildRequires: coreutils
|
|
BuildRequires: findutils
|
|
BuildRequires: gcc
|
|
BuildRequires: make
|
|
BuildRequires: perl-interpreter
|
|
BuildRequires: perl-devel
|
|
BuildRequires: perl-generators
|
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
|
# Module Runtime
|
|
BuildRequires: perl(DynaLoader)
|
|
BuildRequires: perl(Exporter)
|
|
BuildRequires: perl(strict)
|
|
BuildRequires: perl(vars)
|
|
# Test Suite
|
|
%if %{with test}
|
|
BuildRequires: syslog
|
|
%endif
|
|
# Dependencies
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
|
Requires: syslog
|
|
|
|
# Don't "provide" private Perl libs
|
|
%{?perl_default_filter}
|
|
|
|
%description
|
|
This module provides an interface to the system logger syslogd(8) via
|
|
Perl's XSUBs. The implementation attempts to resemble the native
|
|
libc-functions of your system, so that anyone being familiar with
|
|
syslog.h should be able to use this module right away.
|
|
|
|
%prep
|
|
%setup -q -n Unix-Syslog-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
|
make %{?_smp_mflags}
|
|
|
|
%install
|
|
make pure_install DESTDIR=%{buildroot}
|
|
find %{buildroot} -type f -name .packlist -delete
|
|
find %{buildroot} -type f -name '*.bs' -a -empty -delete
|
|
%{_fixperms} %{buildroot}
|
|
|
|
%check
|
|
%if %{with test}
|
|
make test
|
|
%endif
|
|
|
|
%files
|
|
%if 0%{?_licensedir:1}
|
|
%license Artistic
|
|
%else
|
|
%doc Artistic
|
|
%endif
|
|
%doc README Changes
|
|
%{perl_vendorarch}/Unix/
|
|
%{perl_vendorarch}/auto/Unix/
|
|
%{_mandir}/man3/Unix::Syslog.3*
|
|
|
|
%changelog
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-29
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-28
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-27
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.1-26
|
|
- Perl 5.26 rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-25
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.1-24
|
|
- Perl 5.24 rebuild
|
|
|
|
* Tue Apr 19 2016 Paul Howarth <paul@city-fan.org> - 1.1-23
|
|
- Fix FTBFS due to missing buildreq perl-devel
|
|
- Simplify find commands using -empty and -delete
|
|
- Make %%files list more explicit
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-22
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-21
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.1-20
|
|
- Perl 5.22 rebuild
|
|
|
|
* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.1-19
|
|
- Perl 5.20 rebuild
|
|
|
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-18
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
|
|
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-17
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
|
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-16
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
|
|
|
* Thu Jul 18 2013 Petr Pisar <ppisar@redhat.com> - 1.1-15
|
|
- Perl 5.18 rebuild
|
|
|
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-14
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
|
|
|
* Wed Nov 07 2012 Petr Pisar <ppisar@redhat.com> - 1.1-13
|
|
- Conditionalize test dependencies
|
|
|
|
* Wed Nov 07 2012 Petr Pisar <ppisar@redhat.com> - 1.1-12
|
|
- Specify all dependencies
|
|
- Do not export private library
|
|
|
|
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-11
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
|
|
|
* Mon Jun 11 2012 Petr Pisar <ppisar@redhat.com> - 1.1-10
|
|
- Perl 5.16 rebuild
|
|
|
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
|
|
|
* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.1-8
|
|
- Perl mass rebuild
|
|
|
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
|
|
|
* Thu Dec 23 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.1-6
|
|
- 661697 rebuild for fixing problems with vendorach/lib
|
|
|
|
* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.1-5
|
|
- Mass rebuild with perl-5.12.0
|
|
|
|
* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.1-4
|
|
- rebuild against perl 5.10.1
|
|
|
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
|
|
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
|
|
|
* Fri May 30 2008 Steven Pritchard <steve@kspei.com> 1.1-1
|
|
- Update to 1.1.
|
|
|
|
* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0-3
|
|
- Rebuild for new perl
|
|
|
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0-2
|
|
- Autorebuild for GCC 4.3
|
|
|
|
* Mon Oct 15 2007 Steven Pritchard <steve@kspei.com> 1.0-1
|
|
- Update to 1.0.
|
|
- Update License.
|
|
- Reformat a little to match cpanspec output.
|
|
|
|
* Mon Apr 16 2007 Steven Pritchard <steve@kspei.com> 0.100-9
|
|
- Use fixperms macro instead of our own chmod incantation.
|
|
- BR ExtUtils::MakeMaker.
|
|
|
|
* Mon Aug 28 2006 Steven Pritchard <steve@kspei.com> 0.100-8
|
|
- Rebuild.
|
|
- Fix find option order.
|
|
- Minor cleanup to more closely match cpanspec output.
|
|
|
|
* Sat Feb 18 2006 Steven Pritchard <steve@kspei.com> 0.100-7
|
|
- Rebuild.
|
|
|
|
* Mon Sep 05 2005 Steven Pritchard <steve@kspei.com> 0.100-6
|
|
- Spec cleanup.
|
|
- Disable "make test" by default (spams console).
|
|
|
|
* Wed Apr 6 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
|
|
- rebuilt
|
|
|
|
* Mon Apr 26 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.100-0.fdr.4
|
|
- Bring up to date with current fedora.us perl spec template.
|
|
- Require perl(:MODULE_COMPAT_*).
|
|
|
|
* Thu Oct 2 2003 Michael Schwendt <rh0212ms[AT]arcor.de> 0:0.100-0.fdr.3
|
|
- Vendor install
|
|
- Removing some files instead of excluding them
|
|
- Own two additional directories to work around perl package bug
|
|
|
|
* Fri Jul 11 2003 Dams <anvil[AT]livna.org> 0:0.100-0.fdr.2
|
|
- Excluding empty Syslog.bs file
|
|
- Chmoding Syslog.so in install section to allow it to be stripped
|
|
- Changed Group tag value
|
|
- Added missing unowned directories
|
|
|
|
* Sun Jun 15 2003 Dams <anvil[AT]livna.org>
|
|
- Initial build.
|