85 lines
2.3 KiB
Diff
85 lines
2.3 KiB
Diff
From 1ca4f61657f805ac5a074b7b1ba5e2e3fa5d6747 Mon Sep 17 00:00:00 2001
|
|
From: Jitka Plesnikova <jplesnik@redhat.com>
|
|
Date: Thu, 6 May 2021 13:36:14 +0200
|
|
Subject: [PATCH] Upgrade to 1.28
|
|
|
|
---
|
|
Makefile.PL | 22 ++++++++++++----------
|
|
Normalize.pm | 2 +-
|
|
Normalize.xs | 2 +-
|
|
3 files changed, 14 insertions(+), 12 deletions(-)
|
|
|
|
diff --git a/Makefile.PL b/Makefile.PL
|
|
index 18bc2e2..a848b0d 100644
|
|
--- a/Makefile.PL
|
|
+++ b/Makefile.PL
|
|
@@ -1,4 +1,6 @@
|
|
-require 5.006001;
|
|
+use strict;
|
|
+use warnings;
|
|
+
|
|
use ExtUtils::MakeMaker;
|
|
|
|
my $clean = {};
|
|
@@ -6,7 +8,7 @@ my $clean = {};
|
|
my $mm_ver = ExtUtils::MakeMaker->VERSION;
|
|
|
|
if (-f "Normalize.xs") {
|
|
- print STDERR "Making header files for XS...\n";
|
|
+ print "Making header files for XS...\n";
|
|
|
|
do './mkheader' or die $@ || "mkheader: $!";
|
|
|
|
@@ -29,14 +31,14 @@ WriteMakefile(
|
|
'clean' => $clean,
|
|
'depend' => { 'Normalize.o' => '$(H_FILES)' },
|
|
'PREREQ_PM' => {
|
|
- Carp => 0,
|
|
- constant => 0,
|
|
- DynaLoader => 0,
|
|
- Exporter => 0,
|
|
- File::Spec => 0,
|
|
- strict => 0,
|
|
- warnings => 0,
|
|
- SelectSaver => 0,
|
|
+ 'Carp' => 0,
|
|
+ 'constant' => 0,
|
|
+ 'DynaLoader' => 0,
|
|
+ 'Exporter' => 0,
|
|
+ 'File::Spec' => 0,
|
|
+ 'strict' => 0,
|
|
+ 'warnings' => 0,
|
|
+ 'SelectSaver' => 0,
|
|
},
|
|
($mm_ver < 6.48 ? () : MIN_PERL_VERSION => 5.6.0),
|
|
($mm_ver < 6.46 ? () : (META_MERGE => {
|
|
diff --git a/Normalize.pm b/Normalize.pm
|
|
index d06fb8b..fd6f1cb 100644
|
|
--- a/Normalize.pm
|
|
+++ b/Normalize.pm
|
|
@@ -16,7 +16,7 @@ use Carp;
|
|
|
|
no warnings 'utf8';
|
|
|
|
-our $VERSION = '1.27';
|
|
+our $VERSION = '1.28';
|
|
our $PACKAGE = __PACKAGE__;
|
|
|
|
our @EXPORT = qw( NFC NFD NFKC NFKD );
|
|
diff --git a/Normalize.xs b/Normalize.xs
|
|
index 4acff7f..0c151b7 100644
|
|
--- a/Normalize.xs
|
|
+++ b/Normalize.xs
|
|
@@ -23,7 +23,7 @@
|
|
/* The generated normalization tables since v5.20 are in native character set
|
|
* terms. Prior to that, they were in Unicode terms. So we use 'uvchr' for
|
|
* later perls, and redefine that to be 'uvuni' for earlier ones */
|
|
-#if PERL_VERSION < 20
|
|
+#if PERL_VERSION_LT(5,20,0)
|
|
# undef uvchr_to_utf8
|
|
# ifdef uvuni_to_utf8
|
|
# define uvchr_to_utf8 uvuni_to_utf8
|
|
--
|
|
2.30.2
|
|
|