RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/perl-Unicode-Normalize#2b71d4af8aa55b6a0594688a435d927ab92db689
This commit is contained in:
parent
3fa7d89f57
commit
a8a71c77fd
6
.gitignore
vendored
6
.gitignore
vendored
@ -0,0 +1,6 @@
|
||||
/Unicode-Normalize-1.18.tar.gz
|
||||
/Unicode-Normalize-1.19.tar.gz
|
||||
/Unicode-Normalize-1.21.tar.gz
|
||||
/Unicode-Normalize-1.23.tar.gz
|
||||
/Unicode-Normalize-1.24.tar.gz
|
||||
/Unicode-Normalize-1.25.tar.gz
|
111
Unicode-Normalize-1.25-Upgrade-to-1.26.patch
Normal file
111
Unicode-Normalize-1.25-Upgrade-to-1.26.patch
Normal file
@ -0,0 +1,111 @@
|
||||
From 5ee924afc3aff6f8030a3a5523bb7d3f7f69fc52 Mon Sep 17 00:00:00 2001
|
||||
From: Jitka Plesnikova <jplesnik@redhat.com>
|
||||
Date: Thu, 24 May 2018 12:07:22 +0200
|
||||
Subject: [PATCH] Upgrade to 1.26
|
||||
|
||||
---
|
||||
Changes | 3 +++
|
||||
Makefile.PL | 2 +-
|
||||
Normalize.pm | 22 +++++++++++-----------
|
||||
3 files changed, 15 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index ead5b3e..22ec16e 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -1,5 +1,8 @@
|
||||
Revision history for Perl extension Unicode::Normalize.
|
||||
|
||||
+1.26 *** RELEASE DATE HERE ***
|
||||
+ - Switch to XSLoader from Dynaloader
|
||||
+
|
||||
1.25 Wed Dec 16 03:05:57 UTC 2015
|
||||
- Fix Normalize.xs to work on releases earlier than 5.8. The problem was
|
||||
introduced in this module's version 1.24
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index 44a4b8d..18bc2e2 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -8,7 +8,7 @@ my $mm_ver = ExtUtils::MakeMaker->VERSION;
|
||||
if (-f "Normalize.xs") {
|
||||
print STDERR "Making header files for XS...\n";
|
||||
|
||||
- do 'mkheader' or die $@ || "mkheader: $!";
|
||||
+ do './mkheader' or die $@ || "mkheader: $!";
|
||||
|
||||
$clean = { FILES => 'unfcan.h unfcmb.h unfcmp.h unfcpt.h unfexc.h' };
|
||||
}
|
||||
diff --git a/Normalize.pm b/Normalize.pm
|
||||
index ff6c0f0..adf3db5 100644
|
||||
--- a/Normalize.pm
|
||||
+++ b/Normalize.pm
|
||||
@@ -16,7 +16,7 @@ use Carp;
|
||||
|
||||
no warnings 'utf8';
|
||||
|
||||
-our $VERSION = '1.25';
|
||||
+our $VERSION = '1.26';
|
||||
our $PACKAGE = __PACKAGE__;
|
||||
|
||||
our @EXPORT = qw( NFC NFD NFKC NFKD );
|
||||
@@ -56,9 +56,9 @@ require Exporter;
|
||||
|
||||
##### The above part is common to XS and PP #####
|
||||
|
||||
-our @ISA = qw(Exporter DynaLoader);
|
||||
-require DynaLoader;
|
||||
-bootstrap Unicode::Normalize $VERSION;
|
||||
+our @ISA = qw(Exporter);
|
||||
+use XSLoader ();
|
||||
+XSLoader::load( 'Unicode::Normalize', $VERSION );
|
||||
|
||||
##### The below part is common to XS and PP #####
|
||||
|
||||
@@ -161,7 +161,7 @@ Unicode::Normalize - Unicode Normalization Forms
|
||||
|
||||
Parameters:
|
||||
|
||||
-C<$string> is used as a string under character semantics (see F<perlunicode>).
|
||||
+C<$string> is used as a string under character semantics (see L<perlunicode>).
|
||||
|
||||
C<$code_point> should be an unsigned integer representing a Unicode code point.
|
||||
|
||||
@@ -238,8 +238,8 @@ the decomposition is compatibility decomposition.
|
||||
|
||||
The string returned is not always in NFD/NFKD. Reordering may be required.
|
||||
|
||||
- $NFD_string = reorder(decompose($string)); # eq. to NFD()
|
||||
- $NFKD_string = reorder(decompose($string, TRUE)); # eq. to NFKD()
|
||||
+ $NFD_string = reorder(decompose($string)); # eq. to NFD()
|
||||
+ $NFKD_string = reorder(decompose($string, TRUE)); # eq. to NFKD()
|
||||
|
||||
=item C<$reordered_string = reorder($string)>
|
||||
|
||||
@@ -277,12 +277,12 @@ should be equal to the entire C<$normalized>.
|
||||
When you have a C<$normalized> string and an C<$unnormalized> string
|
||||
following it, a simple concatenation is wrong:
|
||||
|
||||
- $concat = $normalized . normalize($form, $unnormalized); # wrong!
|
||||
+ $concat = $normalized . normalize($form, $unnormalized); # wrong!
|
||||
|
||||
Instead of it, do like this:
|
||||
|
||||
- ($processed, $unprocessed) = splitOnLastStarter($normalized);
|
||||
- $concat = $processed . normalize($form, $unprocessed.$unnormalized);
|
||||
+ ($processed, $unprocessed) = splitOnLastStarter($normalized);
|
||||
+ $concat = $processed . normalize($form,$unprocessed.$unnormalized);
|
||||
|
||||
C<splitOnLastStarter()> should be called with a pre-normalized parameter
|
||||
C<$normalized>, that is in the same form as C<$form> you want.
|
||||
@@ -548,7 +548,7 @@ compiled into your perl. The following table lists the default Unicode
|
||||
version that comes with various perl versions. (It is possible to change
|
||||
the Unicode version in any perl version to be any earlier Unicode version,
|
||||
so one could cause Unicode 3.2 to be used in any perl version starting with
|
||||
-5.8.0. See C<$Config{privlib}>/F<unicore/README.perl>.
|
||||
+5.8.0. Read F<C<$Config{privlib}>/unicore/README.perl> for details.
|
||||
|
||||
perl's version implemented Unicode version
|
||||
5.6.1 3.0.1
|
||||
--
|
||||
2.14.3
|
||||
|
59
Unicode-Normalize-1.25-Upgrade-to-1.27.patch
Normal file
59
Unicode-Normalize-1.25-Upgrade-to-1.27.patch
Normal file
@ -0,0 +1,59 @@
|
||||
From 95cca0326ee38020d55382493e6d42b16ae889c9 Mon Sep 17 00:00:00 2001
|
||||
From: Jitka Plesnikova <jplesnik@redhat.com>
|
||||
Date: Tue, 21 Apr 2020 13:05:51 +0200
|
||||
Subject: [PATCH] Upgrade to 1.27
|
||||
|
||||
---
|
||||
Normalize.pm | 14 +++++++-------
|
||||
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/Normalize.pm b/Normalize.pm
|
||||
index adf3db5..d06fb8b 100644
|
||||
--- a/Normalize.pm
|
||||
+++ b/Normalize.pm
|
||||
@@ -16,7 +16,7 @@ use Carp;
|
||||
|
||||
no warnings 'utf8';
|
||||
|
||||
-our $VERSION = '1.26';
|
||||
+our $VERSION = '1.27';
|
||||
our $PACKAGE = __PACKAGE__;
|
||||
|
||||
our @EXPORT = qw( NFC NFD NFKC NFKD );
|
||||
@@ -606,27 +606,27 @@ and/or modify it under the same terms as Perl itself.
|
||||
|
||||
=over 4
|
||||
|
||||
-=item http://www.unicode.org/reports/tr15/
|
||||
+=item L<http://www.unicode.org/reports/tr15/>
|
||||
|
||||
Unicode Normalization Forms - UAX #15
|
||||
|
||||
-=item http://www.unicode.org/Public/UNIDATA/CompositionExclusions.txt
|
||||
+=item L<http://www.unicode.org/Public/UNIDATA/CompositionExclusions.txt>
|
||||
|
||||
Composition Exclusion Table
|
||||
|
||||
-=item http://www.unicode.org/Public/UNIDATA/DerivedNormalizationProps.txt
|
||||
+=item L<http://www.unicode.org/Public/UNIDATA/DerivedNormalizationProps.txt>
|
||||
|
||||
Derived Normalization Properties
|
||||
|
||||
-=item http://www.unicode.org/Public/UNIDATA/NormalizationCorrections.txt
|
||||
+=item L<http://www.unicode.org/Public/UNIDATA/NormalizationCorrections.txt>
|
||||
|
||||
Normalization Corrections
|
||||
|
||||
-=item http://www.unicode.org/review/pr-29.html
|
||||
+=item L<http://www.unicode.org/review/pr-29.html>
|
||||
|
||||
Public Review Issue #29: Normalization Issue
|
||||
|
||||
-=item http://www.unicode.org/notes/tn5/
|
||||
+=item L<http://www.unicode.org/notes/tn5/>
|
||||
|
||||
Canonical Equivalence in Applications - UTN #5
|
||||
|
||||
--
|
||||
2.21.1
|
||||
|
139
perl-Unicode-Normalize.spec
Normal file
139
perl-Unicode-Normalize.spec
Normal file
@ -0,0 +1,139 @@
|
||||
%global base_version 1.25
|
||||
Name: perl-Unicode-Normalize
|
||||
Version: 1.27
|
||||
Release: 458%{?dist}
|
||||
Summary: Unicode Normalization Forms
|
||||
License: GPL+ or Artistic
|
||||
URL: https://metacpan.org/release/Unicode-Normalize
|
||||
Source0: https://cpan.metacpan.org/authors/id/K/KH/KHW/Unicode-Normalize-%{base_version}.tar.gz
|
||||
# Unbundled from perl 5.28.0-RC1
|
||||
Patch0: Unicode-Normalize-1.25-Upgrade-to-1.26.patch
|
||||
# Unbundled from perl 5.32.0
|
||||
Patch1: Unicode-Normalize-1.25-Upgrade-to-1.27.patch
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: gcc
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl-interpreter
|
||||
# unicore/CombiningClass.pl and unicore/Decomposition.pl from perl-libs
|
||||
BuildRequires: perl-libs
|
||||
BuildRequires: perl(bytes)
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(constant)
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
|
||||
BuildRequires: perl(File::Spec)
|
||||
BuildRequires: perl(SelectSaver)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(warnings)
|
||||
# Run-time:
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(XSLoader)
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
Conflicts: perl < 4:5.22.0-347
|
||||
|
||||
%description
|
||||
This package provides Perl functions that can convert strings into various
|
||||
Unicode normalization forms as defined in Unicode Standard Annex #15.
|
||||
|
||||
%prep
|
||||
%setup -q -n Unicode-Normalize-%{base_version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1 OPTIMIZE="%{optflags}"
|
||||
%{make_build}
|
||||
|
||||
%install
|
||||
%{make_install}
|
||||
find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -delete
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%doc Changes README
|
||||
%{perl_vendorarch}/auto/*
|
||||
%{perl_vendorarch}/Unicode
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.27-458
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 21 2020 Petr Pisar <ppisar@redhat.com> - 1.27-457
|
||||
- Modernize a spec file
|
||||
- Apply a forgotten Unicode-Normalize-1.25-Upgrade-to-1.27.patch patch
|
||||
|
||||
* Mon Jun 22 2020 Jitka Plesnikova <jplesnik@redhat.com> - 1.27-456
|
||||
- Upgrade to 1.27 as provided in perl-5.32.0
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.26-440
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.26-439
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu May 30 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1.26-438
|
||||
- Increase release to favour standalone package
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.26-418
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.26-417
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Jun 27 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.26-416
|
||||
- Increase release to favour standalone package
|
||||
|
||||
* Thu May 24 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.26-1
|
||||
- Upgrade to 1.26 as provided in perl-5.28.0-RC1
|
||||
|
||||
* Wed Mar 07 2018 Petr Pisar <ppisar@redhat.com> - 1.25-397
|
||||
- Modernize spec file
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.25-396
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.25-395
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.25-394
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Jun 03 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.25-393
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Mon May 15 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.25-367
|
||||
- Fixes for removal '.' from @INC in Perl 5.26
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.25-366
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.25-365
|
||||
- Increase release to favour standalone package
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.25-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Dec 18 2015 Petr Šabata <contyk@redhat.com> - 1.25-1
|
||||
- 1.25 bump
|
||||
|
||||
* Thu Dec 03 2015 Petr Pisar <ppisar@redhat.com> - 1.24-1
|
||||
- 1.24 bump
|
||||
|
||||
* Tue Oct 27 2015 Petr Pisar <ppisar@redhat.com> - 1.23-1
|
||||
- 1.23 bump
|
||||
|
||||
* Fri Oct 09 2015 Petr Pisar <ppisar@redhat.com> - 1.21-1
|
||||
- 1.21 bump
|
||||
|
||||
* Mon Jul 13 2015 Petr Pisar <ppisar@redhat.com> - 1.19-1
|
||||
- 1.19 bump
|
||||
|
||||
* Thu Jul 02 2015 Petr Pisar <ppisar@redhat.com> 1.18-348
|
||||
- Specfile autogenerated by cpanspec 1.78.
|
Loading…
Reference in New Issue
Block a user