Upgrade to 1.28 as provided in perl-5.34.0
This commit is contained in:
parent
844f8e03fc
commit
6fc0899b3e
84
Unicode-Normalize-1.27-Upgrade-to-1.28.patch
Normal file
84
Unicode-Normalize-1.27-Upgrade-to-1.28.patch
Normal file
@ -0,0 +1,84 @@
|
||||
From 1ca4f61657f805ac5a074b7b1ba5e2e3fa5d6747 Mon Sep 17 00:00:00 2001
|
||||
From: Jitka Plesnikova <jplesnik@redhat.com>
|
||||
Date: Thu, 6 May 2021 13:36:14 +0200
|
||||
Subject: [PATCH] Upgrade to 1.28
|
||||
|
||||
---
|
||||
Makefile.PL | 22 ++++++++++++----------
|
||||
Normalize.pm | 2 +-
|
||||
Normalize.xs | 2 +-
|
||||
3 files changed, 14 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index 18bc2e2..a848b0d 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -1,4 +1,6 @@
|
||||
-require 5.006001;
|
||||
+use strict;
|
||||
+use warnings;
|
||||
+
|
||||
use ExtUtils::MakeMaker;
|
||||
|
||||
my $clean = {};
|
||||
@@ -6,7 +8,7 @@ my $clean = {};
|
||||
my $mm_ver = ExtUtils::MakeMaker->VERSION;
|
||||
|
||||
if (-f "Normalize.xs") {
|
||||
- print STDERR "Making header files for XS...\n";
|
||||
+ print "Making header files for XS...\n";
|
||||
|
||||
do './mkheader' or die $@ || "mkheader: $!";
|
||||
|
||||
@@ -29,14 +31,14 @@ WriteMakefile(
|
||||
'clean' => $clean,
|
||||
'depend' => { 'Normalize.o' => '$(H_FILES)' },
|
||||
'PREREQ_PM' => {
|
||||
- Carp => 0,
|
||||
- constant => 0,
|
||||
- DynaLoader => 0,
|
||||
- Exporter => 0,
|
||||
- File::Spec => 0,
|
||||
- strict => 0,
|
||||
- warnings => 0,
|
||||
- SelectSaver => 0,
|
||||
+ 'Carp' => 0,
|
||||
+ 'constant' => 0,
|
||||
+ 'DynaLoader' => 0,
|
||||
+ 'Exporter' => 0,
|
||||
+ 'File::Spec' => 0,
|
||||
+ 'strict' => 0,
|
||||
+ 'warnings' => 0,
|
||||
+ 'SelectSaver' => 0,
|
||||
},
|
||||
($mm_ver < 6.48 ? () : MIN_PERL_VERSION => 5.6.0),
|
||||
($mm_ver < 6.46 ? () : (META_MERGE => {
|
||||
diff --git a/Normalize.pm b/Normalize.pm
|
||||
index d06fb8b..fd6f1cb 100644
|
||||
--- a/Normalize.pm
|
||||
+++ b/Normalize.pm
|
||||
@@ -16,7 +16,7 @@ use Carp;
|
||||
|
||||
no warnings 'utf8';
|
||||
|
||||
-our $VERSION = '1.27';
|
||||
+our $VERSION = '1.28';
|
||||
our $PACKAGE = __PACKAGE__;
|
||||
|
||||
our @EXPORT = qw( NFC NFD NFKC NFKD );
|
||||
diff --git a/Normalize.xs b/Normalize.xs
|
||||
index 4acff7f..0c151b7 100644
|
||||
--- a/Normalize.xs
|
||||
+++ b/Normalize.xs
|
||||
@@ -23,7 +23,7 @@
|
||||
/* The generated normalization tables since v5.20 are in native character set
|
||||
* terms. Prior to that, they were in Unicode terms. So we use 'uvchr' for
|
||||
* later perls, and redefine that to be 'uvuni' for earlier ones */
|
||||
-#if PERL_VERSION < 20
|
||||
+#if PERL_VERSION_LT(5,20,0)
|
||||
# undef uvchr_to_utf8
|
||||
# ifdef uvuni_to_utf8
|
||||
# define uvchr_to_utf8 uvuni_to_utf8
|
||||
--
|
||||
2.30.2
|
||||
|
@ -1,7 +1,7 @@
|
||||
%global base_version 1.25
|
||||
Name: perl-Unicode-Normalize
|
||||
Version: 1.27
|
||||
Release: 459%{?dist}
|
||||
Version: 1.28
|
||||
Release: 477%{?dist}
|
||||
Summary: Unicode Normalization Forms
|
||||
License: GPL+ or Artistic
|
||||
URL: https://metacpan.org/release/Unicode-Normalize
|
||||
@ -10,6 +10,8 @@ Source0: https://cpan.metacpan.org/authors/id/K/KH/KHW/Unicode-Normalize-
|
||||
Patch0: Unicode-Normalize-1.25-Upgrade-to-1.26.patch
|
||||
# Unbundled from perl 5.32.0
|
||||
Patch1: Unicode-Normalize-1.25-Upgrade-to-1.27.patch
|
||||
# Unbundled from perl 5.34.0
|
||||
Patch2: Unicode-Normalize-1.27-Upgrade-to-1.28.patch
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: gcc
|
||||
@ -41,6 +43,7 @@ Unicode normalization forms as defined in Unicode Standard Annex #15.
|
||||
%setup -q -n Unicode-Normalize-%{base_version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1 OPTIMIZE="%{optflags}"
|
||||
@ -62,6 +65,9 @@ make test
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Fri May 21 2021 Jitka Plesnikova <jplesnik@redhat.com> - 1.28-477
|
||||
- Upgrade to 1.28 as provided in perl-5.34.0
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.27-459
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user