Upgrade to 1.32 as provided in perl-5.37.11
This commit is contained in:
parent
3c60841d16
commit
5d0b48cfb2
@ -1,111 +0,0 @@
|
||||
From 5ee924afc3aff6f8030a3a5523bb7d3f7f69fc52 Mon Sep 17 00:00:00 2001
|
||||
From: Jitka Plesnikova <jplesnik@redhat.com>
|
||||
Date: Thu, 24 May 2018 12:07:22 +0200
|
||||
Subject: [PATCH] Upgrade to 1.26
|
||||
|
||||
---
|
||||
Changes | 3 +++
|
||||
Makefile.PL | 2 +-
|
||||
Normalize.pm | 22 +++++++++++-----------
|
||||
3 files changed, 15 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index ead5b3e..22ec16e 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -1,5 +1,8 @@
|
||||
Revision history for Perl extension Unicode::Normalize.
|
||||
|
||||
+1.26 *** RELEASE DATE HERE ***
|
||||
+ - Switch to XSLoader from Dynaloader
|
||||
+
|
||||
1.25 Wed Dec 16 03:05:57 UTC 2015
|
||||
- Fix Normalize.xs to work on releases earlier than 5.8. The problem was
|
||||
introduced in this module's version 1.24
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index 44a4b8d..18bc2e2 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -8,7 +8,7 @@ my $mm_ver = ExtUtils::MakeMaker->VERSION;
|
||||
if (-f "Normalize.xs") {
|
||||
print STDERR "Making header files for XS...\n";
|
||||
|
||||
- do 'mkheader' or die $@ || "mkheader: $!";
|
||||
+ do './mkheader' or die $@ || "mkheader: $!";
|
||||
|
||||
$clean = { FILES => 'unfcan.h unfcmb.h unfcmp.h unfcpt.h unfexc.h' };
|
||||
}
|
||||
diff --git a/Normalize.pm b/Normalize.pm
|
||||
index ff6c0f0..adf3db5 100644
|
||||
--- a/Normalize.pm
|
||||
+++ b/Normalize.pm
|
||||
@@ -16,7 +16,7 @@ use Carp;
|
||||
|
||||
no warnings 'utf8';
|
||||
|
||||
-our $VERSION = '1.25';
|
||||
+our $VERSION = '1.26';
|
||||
our $PACKAGE = __PACKAGE__;
|
||||
|
||||
our @EXPORT = qw( NFC NFD NFKC NFKD );
|
||||
@@ -56,9 +56,9 @@ require Exporter;
|
||||
|
||||
##### The above part is common to XS and PP #####
|
||||
|
||||
-our @ISA = qw(Exporter DynaLoader);
|
||||
-require DynaLoader;
|
||||
-bootstrap Unicode::Normalize $VERSION;
|
||||
+our @ISA = qw(Exporter);
|
||||
+use XSLoader ();
|
||||
+XSLoader::load( 'Unicode::Normalize', $VERSION );
|
||||
|
||||
##### The below part is common to XS and PP #####
|
||||
|
||||
@@ -161,7 +161,7 @@ Unicode::Normalize - Unicode Normalization Forms
|
||||
|
||||
Parameters:
|
||||
|
||||
-C<$string> is used as a string under character semantics (see F<perlunicode>).
|
||||
+C<$string> is used as a string under character semantics (see L<perlunicode>).
|
||||
|
||||
C<$code_point> should be an unsigned integer representing a Unicode code point.
|
||||
|
||||
@@ -238,8 +238,8 @@ the decomposition is compatibility decomposition.
|
||||
|
||||
The string returned is not always in NFD/NFKD. Reordering may be required.
|
||||
|
||||
- $NFD_string = reorder(decompose($string)); # eq. to NFD()
|
||||
- $NFKD_string = reorder(decompose($string, TRUE)); # eq. to NFKD()
|
||||
+ $NFD_string = reorder(decompose($string)); # eq. to NFD()
|
||||
+ $NFKD_string = reorder(decompose($string, TRUE)); # eq. to NFKD()
|
||||
|
||||
=item C<$reordered_string = reorder($string)>
|
||||
|
||||
@@ -277,12 +277,12 @@ should be equal to the entire C<$normalized>.
|
||||
When you have a C<$normalized> string and an C<$unnormalized> string
|
||||
following it, a simple concatenation is wrong:
|
||||
|
||||
- $concat = $normalized . normalize($form, $unnormalized); # wrong!
|
||||
+ $concat = $normalized . normalize($form, $unnormalized); # wrong!
|
||||
|
||||
Instead of it, do like this:
|
||||
|
||||
- ($processed, $unprocessed) = splitOnLastStarter($normalized);
|
||||
- $concat = $processed . normalize($form, $unprocessed.$unnormalized);
|
||||
+ ($processed, $unprocessed) = splitOnLastStarter($normalized);
|
||||
+ $concat = $processed . normalize($form,$unprocessed.$unnormalized);
|
||||
|
||||
C<splitOnLastStarter()> should be called with a pre-normalized parameter
|
||||
C<$normalized>, that is in the same form as C<$form> you want.
|
||||
@@ -548,7 +548,7 @@ compiled into your perl. The following table lists the default Unicode
|
||||
version that comes with various perl versions. (It is possible to change
|
||||
the Unicode version in any perl version to be any earlier Unicode version,
|
||||
so one could cause Unicode 3.2 to be used in any perl version starting with
|
||||
-5.8.0. See C<$Config{privlib}>/F<unicore/README.perl>.
|
||||
+5.8.0. Read F<C<$Config{privlib}>/unicore/README.perl> for details.
|
||||
|
||||
perl's version implemented Unicode version
|
||||
5.6.1 3.0.1
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1,59 +0,0 @@
|
||||
From 95cca0326ee38020d55382493e6d42b16ae889c9 Mon Sep 17 00:00:00 2001
|
||||
From: Jitka Plesnikova <jplesnik@redhat.com>
|
||||
Date: Tue, 21 Apr 2020 13:05:51 +0200
|
||||
Subject: [PATCH] Upgrade to 1.27
|
||||
|
||||
---
|
||||
Normalize.pm | 14 +++++++-------
|
||||
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/Normalize.pm b/Normalize.pm
|
||||
index adf3db5..d06fb8b 100644
|
||||
--- a/Normalize.pm
|
||||
+++ b/Normalize.pm
|
||||
@@ -16,7 +16,7 @@ use Carp;
|
||||
|
||||
no warnings 'utf8';
|
||||
|
||||
-our $VERSION = '1.26';
|
||||
+our $VERSION = '1.27';
|
||||
our $PACKAGE = __PACKAGE__;
|
||||
|
||||
our @EXPORT = qw( NFC NFD NFKC NFKD );
|
||||
@@ -606,27 +606,27 @@ and/or modify it under the same terms as Perl itself.
|
||||
|
||||
=over 4
|
||||
|
||||
-=item http://www.unicode.org/reports/tr15/
|
||||
+=item L<http://www.unicode.org/reports/tr15/>
|
||||
|
||||
Unicode Normalization Forms - UAX #15
|
||||
|
||||
-=item http://www.unicode.org/Public/UNIDATA/CompositionExclusions.txt
|
||||
+=item L<http://www.unicode.org/Public/UNIDATA/CompositionExclusions.txt>
|
||||
|
||||
Composition Exclusion Table
|
||||
|
||||
-=item http://www.unicode.org/Public/UNIDATA/DerivedNormalizationProps.txt
|
||||
+=item L<http://www.unicode.org/Public/UNIDATA/DerivedNormalizationProps.txt>
|
||||
|
||||
Derived Normalization Properties
|
||||
|
||||
-=item http://www.unicode.org/Public/UNIDATA/NormalizationCorrections.txt
|
||||
+=item L<http://www.unicode.org/Public/UNIDATA/NormalizationCorrections.txt>
|
||||
|
||||
Normalization Corrections
|
||||
|
||||
-=item http://www.unicode.org/review/pr-29.html
|
||||
+=item L<http://www.unicode.org/review/pr-29.html>
|
||||
|
||||
Public Review Issue #29: Normalization Issue
|
||||
|
||||
-=item http://www.unicode.org/notes/tn5/
|
||||
+=item L<http://www.unicode.org/notes/tn5/>
|
||||
|
||||
Canonical Equivalence in Applications - UTN #5
|
||||
|
||||
--
|
||||
2.21.1
|
||||
|
@ -1,26 +1,26 @@
|
||||
From 928fae029c3e47b7d3ff05016584133c622565d4 Mon Sep 17 00:00:00 2001
|
||||
From 0850dba96e3cb8ee37fe405b0cf76d7f910e90e4 Mon Sep 17 00:00:00 2001
|
||||
From: Jitka Plesnikova <jplesnik@redhat.com>
|
||||
Date: Thu, 12 May 2022 15:38:40 +0200
|
||||
Subject: [PATCH] Upgrade to 1.31
|
||||
Date: Thu, 18 May 2023 21:02:00 +0200
|
||||
Subject: [PATCH] Upgrade to 1.32
|
||||
|
||||
---
|
||||
Makefile.PL | 22 +++++++++-------
|
||||
Normalize.pm | 73 ++++++++++++++++++++++++++++++++++++++--------------
|
||||
Normalize.xs | 71 ++++++++++++++++----------------------------------
|
||||
mkheader | 20 +++-----------
|
||||
t/fcdc.t | 22 ++--------------
|
||||
t/form.t | 20 +-------------
|
||||
t/func.t | 22 ++--------------
|
||||
t/illegal.t | 22 ++--------------
|
||||
t/norm.t | 24 +++--------------
|
||||
t/null.t | 11 --------
|
||||
t/partial1.t | 20 +-------------
|
||||
t/partial2.t | 24 +++--------------
|
||||
t/proto.t | 20 +-------------
|
||||
t/split.t | 24 +++--------------
|
||||
t/test.t | 24 +++--------------
|
||||
t/tie.t | 20 +-------------
|
||||
16 files changed, 113 insertions(+), 326 deletions(-)
|
||||
Makefile.PL | 22 +++++++-------
|
||||
Normalize.pm | 81 +++++++++++++++++++++++++++++++++++++---------------
|
||||
Normalize.xs | 71 ++++++++++++++-------------------------------
|
||||
mkheader | 20 +++----------
|
||||
t/fcdc.t | 22 ++------------
|
||||
t/form.t | 20 +------------
|
||||
t/func.t | 22 ++------------
|
||||
t/illegal.t | 22 ++------------
|
||||
t/norm.t | 24 ++--------------
|
||||
t/null.t | 11 -------
|
||||
t/partial1.t | 20 +------------
|
||||
t/partial2.t | 24 ++--------------
|
||||
t/proto.t | 20 +------------
|
||||
t/split.t | 24 ++--------------
|
||||
t/test.t | 24 ++--------------
|
||||
t/tie.t | 20 +------------
|
||||
16 files changed, 118 insertions(+), 329 deletions(-)
|
||||
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index 18bc2e2..a848b0d 100644
|
||||
@ -67,7 +67,7 @@ index 18bc2e2..a848b0d 100644
|
||||
($mm_ver < 6.48 ? () : MIN_PERL_VERSION => 5.6.0),
|
||||
($mm_ver < 6.46 ? () : (META_MERGE => {
|
||||
diff --git a/Normalize.pm b/Normalize.pm
|
||||
index adf3db5..b67a293 100644
|
||||
index adf3db5..c8053f7 100644
|
||||
--- a/Normalize.pm
|
||||
+++ b/Normalize.pm
|
||||
@@ -1,14 +1,5 @@
|
||||
@ -90,7 +90,7 @@ index adf3db5..b67a293 100644
|
||||
no warnings 'utf8';
|
||||
|
||||
-our $VERSION = '1.26';
|
||||
+our $VERSION = '1.31';
|
||||
+our $VERSION = '1.32';
|
||||
our $PACKAGE = __PACKAGE__;
|
||||
|
||||
our @EXPORT = qw( NFC NFD NFKC NFKD );
|
||||
@ -157,7 +157,29 @@ index adf3db5..b67a293 100644
|
||||
}
|
||||
|
||||
require Exporter;
|
||||
@@ -606,27 +639,27 @@ and/or modify it under the same terms as Perl itself.
|
||||
@@ -343,7 +376,7 @@ Note that C<$unprocessed> will be modified as a side-effect.
|
||||
|
||||
=head2 Quick Check
|
||||
|
||||
-(see Annex 8, UAX #15; and F<DerivedNormalizationProps.txt>)
|
||||
+(see Annex 8, UAX #15; and F<lib/unicore/DerivedNormalizationProps.txt>)
|
||||
|
||||
The following functions check whether the string is in that normalization form.
|
||||
|
||||
@@ -571,8 +604,10 @@ so one could cause Unicode 3.2 to be used in any perl version starting with
|
||||
|
||||
In older Unicode versions, a small number of characters (all of which are
|
||||
CJK compatibility ideographs as far as they have been found) may have
|
||||
-an erroneous decomposition mapping (see F<NormalizationCorrections.txt>).
|
||||
-Anyhow, this module will neither refer to F<NormalizationCorrections.txt>
|
||||
+an erroneous decomposition mapping (see
|
||||
+F<lib/unicore/NormalizationCorrections.txt>).
|
||||
+Anyhow, this module will neither refer to
|
||||
+F<lib/unicore/NormalizationCorrections.txt>
|
||||
nor provide any specific version of normalization. Therefore this module
|
||||
running on an older perl with an older Unicode database may use
|
||||
the erroneous decomposition mapping blindly conforming to the Unicode database.
|
||||
@@ -606,27 +641,27 @@ and/or modify it under the same terms as Perl itself.
|
||||
|
||||
=over 4
|
||||
|
||||
@ -901,5 +923,5 @@ index 4fdd121..1282405 100644
|
||||
ok(1);
|
||||
|
||||
--
|
||||
2.34.3
|
||||
2.40.1
|
||||
|
@ -1,84 +0,0 @@
|
||||
From 1ca4f61657f805ac5a074b7b1ba5e2e3fa5d6747 Mon Sep 17 00:00:00 2001
|
||||
From: Jitka Plesnikova <jplesnik@redhat.com>
|
||||
Date: Thu, 6 May 2021 13:36:14 +0200
|
||||
Subject: [PATCH] Upgrade to 1.28
|
||||
|
||||
---
|
||||
Makefile.PL | 22 ++++++++++++----------
|
||||
Normalize.pm | 2 +-
|
||||
Normalize.xs | 2 +-
|
||||
3 files changed, 14 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index 18bc2e2..a848b0d 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -1,4 +1,6 @@
|
||||
-require 5.006001;
|
||||
+use strict;
|
||||
+use warnings;
|
||||
+
|
||||
use ExtUtils::MakeMaker;
|
||||
|
||||
my $clean = {};
|
||||
@@ -6,7 +8,7 @@ my $clean = {};
|
||||
my $mm_ver = ExtUtils::MakeMaker->VERSION;
|
||||
|
||||
if (-f "Normalize.xs") {
|
||||
- print STDERR "Making header files for XS...\n";
|
||||
+ print "Making header files for XS...\n";
|
||||
|
||||
do './mkheader' or die $@ || "mkheader: $!";
|
||||
|
||||
@@ -29,14 +31,14 @@ WriteMakefile(
|
||||
'clean' => $clean,
|
||||
'depend' => { 'Normalize.o' => '$(H_FILES)' },
|
||||
'PREREQ_PM' => {
|
||||
- Carp => 0,
|
||||
- constant => 0,
|
||||
- DynaLoader => 0,
|
||||
- Exporter => 0,
|
||||
- File::Spec => 0,
|
||||
- strict => 0,
|
||||
- warnings => 0,
|
||||
- SelectSaver => 0,
|
||||
+ 'Carp' => 0,
|
||||
+ 'constant' => 0,
|
||||
+ 'DynaLoader' => 0,
|
||||
+ 'Exporter' => 0,
|
||||
+ 'File::Spec' => 0,
|
||||
+ 'strict' => 0,
|
||||
+ 'warnings' => 0,
|
||||
+ 'SelectSaver' => 0,
|
||||
},
|
||||
($mm_ver < 6.48 ? () : MIN_PERL_VERSION => 5.6.0),
|
||||
($mm_ver < 6.46 ? () : (META_MERGE => {
|
||||
diff --git a/Normalize.pm b/Normalize.pm
|
||||
index d06fb8b..fd6f1cb 100644
|
||||
--- a/Normalize.pm
|
||||
+++ b/Normalize.pm
|
||||
@@ -16,7 +16,7 @@ use Carp;
|
||||
|
||||
no warnings 'utf8';
|
||||
|
||||
-our $VERSION = '1.27';
|
||||
+our $VERSION = '1.28';
|
||||
our $PACKAGE = __PACKAGE__;
|
||||
|
||||
our @EXPORT = qw( NFC NFD NFKC NFKD );
|
||||
diff --git a/Normalize.xs b/Normalize.xs
|
||||
index 4acff7f..0c151b7 100644
|
||||
--- a/Normalize.xs
|
||||
+++ b/Normalize.xs
|
||||
@@ -23,7 +23,7 @@
|
||||
/* The generated normalization tables since v5.20 are in native character set
|
||||
* terms. Prior to that, they were in Unicode terms. So we use 'uvchr' for
|
||||
* later perls, and redefine that to be 'uvuni' for earlier ones */
|
||||
-#if PERL_VERSION < 20
|
||||
+#if PERL_VERSION_LT(5,20,0)
|
||||
# undef uvchr_to_utf8
|
||||
# ifdef uvuni_to_utf8
|
||||
# define uvchr_to_utf8 uvuni_to_utf8
|
||||
--
|
||||
2.30.2
|
||||
|
@ -1,13 +1,13 @@
|
||||
%global base_version 1.26
|
||||
Name: perl-Unicode-Normalize
|
||||
Version: 1.31
|
||||
Release: 490%{?dist}
|
||||
Version: 1.32
|
||||
Release: 1%{?dist}
|
||||
Summary: Unicode Normalization Forms
|
||||
License: GPL-1.0-or-later OR Artistic-1.0-Perl
|
||||
URL: https://metacpan.org/release/Unicode-Normalize
|
||||
Source0: https://cpan.metacpan.org/authors/id/K/KH/KHW/Unicode-Normalize-%{base_version}.tar.gz
|
||||
# Unbundled from perl 5.35.11
|
||||
Patch0: Unicode-Normalize-1.26-Upgrade-to-1.31.patch
|
||||
# Unbundled from perl 5.37.11
|
||||
Patch0: Unicode-Normalize-1.26-Upgrade-to-1.32.patch
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: gcc
|
||||
@ -37,9 +37,9 @@ Unicode normalization forms as defined in Unicode Standard Annex #15.
|
||||
|
||||
%prep
|
||||
%setup -q -n Unicode-Normalize-%{base_version}
|
||||
%patch0 -p1
|
||||
%patch -P0 -p1
|
||||
|
||||
# Generate ppport.h which is used since 1.31
|
||||
# Generate ppport.h which is used since 1.32
|
||||
perl -MDevel::PPPort \
|
||||
-e 'Devel::PPPort::WriteFile() or die "Could not generate ppport.h: $!"'
|
||||
|
||||
@ -49,8 +49,8 @@ perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1 OPTIMIZE="%{opt
|
||||
|
||||
%install
|
||||
%{make_install}
|
||||
find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -delete
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
find %{buildroot} -type f -name '*.bs' -size 0 -delete
|
||||
%{_fixperms} %{buildroot}/*
|
||||
|
||||
%check
|
||||
make test
|
||||
@ -60,9 +60,12 @@ make test
|
||||
%doc Changes README
|
||||
%{perl_vendorarch}/auto/*
|
||||
%{perl_vendorarch}/Unicode
|
||||
%{_mandir}/man3/*
|
||||
%{_mandir}/man3/Unicode::Normalize*
|
||||
|
||||
%changelog
|
||||
* Thu May 18 2023 Jitka Plesnikova <jplesnik@redhat.com> - 1.32-1
|
||||
- Upgrade to 1.32 as provided in perl-5.37.11
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.31-490
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user