- fix getOpenFile (#487122)
This commit is contained in:
parent
aaa94fbc37
commit
98cf17e4e8
11
perl-Tk-getOpenFile.patch
Normal file
11
perl-Tk-getOpenFile.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- Tk/FBox.pm.orig 2009-06-22 19:18:49.000000000 +0200
|
||||||
|
+++ Tk/FBox.pm 2009-06-22 19:19:30.000000000 +0200
|
||||||
|
@@ -906,7 +906,7 @@
|
||||||
|
if ($w->cget('-multiple')) {
|
||||||
|
$selectFilePath = [];
|
||||||
|
for my $f (@{ $w->{'selectFile'} }) {
|
||||||
|
- push @$selectFilePath, JoinFile($w->_get_select_Path, $f);
|
||||||
|
+ push @$selectFilePath, JoinFile($w->_get_select_path, $f);
|
||||||
|
}
|
||||||
|
} else {
|
||||||
|
$selectFilePath = JoinFile($w->_get_select_path,
|
10
perl-Tk.spec
10
perl-Tk.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: perl-Tk
|
Name: perl-Tk
|
||||||
Version: 804.028
|
Version: 804.028
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
Summary: Perl Graphical User Interface ToolKit
|
Summary: Perl Graphical User Interface ToolKit
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -20,6 +20,9 @@ Patch3: perl-Tk-XIM.patch
|
|||||||
# fix for bugs #491536 & #489228 & #506496 (see comment #8)
|
# fix for bugs #491536 & #489228 & #506496 (see comment #8)
|
||||||
# see http://rt.cpan.org/Public/Bug/Display.html?id=38746
|
# see http://rt.cpan.org/Public/Bug/Display.html?id=38746
|
||||||
Patch4: perl-Tk-events.patch
|
Patch4: perl-Tk-events.patch
|
||||||
|
# fix for bug #487122
|
||||||
|
# see http://rt.cpan.org/Public/Bug/Display.html?id=31989
|
||||||
|
Patch5: perl-Tk-getOpenFile.patch
|
||||||
|
|
||||||
# fix gif overflow in tk see CVE-2006-4484 and CVE-2007-6697 or #431518 and
|
# fix gif overflow in tk see CVE-2006-4484 and CVE-2007-6697 or #431518 and
|
||||||
# #431529
|
# #431529
|
||||||
@ -64,6 +67,7 @@ chmod -x pod/Popup.pod Tixish/lib/Tk/balArrow.xbm
|
|||||||
%patch2 -p1 -b .seg
|
%patch2 -p1 -b .seg
|
||||||
%patch3 -p1 -b .xim
|
%patch3 -p1 -b .xim
|
||||||
%patch4 -b .events
|
%patch4 -b .events
|
||||||
|
%patch5 -b .getOpenFile
|
||||||
%patch100
|
%patch100
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -109,6 +113,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%exclude %{perl_vendorarch}/Tk/reindex.pl
|
%exclude %{perl_vendorarch}/Tk/reindex.pl
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 22 2009 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
- 804.028-9
|
||||||
|
- fix getOpenFile (#487122)
|
||||||
|
|
||||||
* Mon Jun 15 2009 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
* Mon Jun 15 2009 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
- 804.028-8
|
- 804.028-8
|
||||||
- fix events (#489228, #491536, #506496)
|
- fix events (#489228, #491536, #506496)
|
||||||
|
Loading…
Reference in New Issue
Block a user