804.031-6
- add patch from Yaakov Selkowitz to fix freetype detection (rhbz#1110872)
This commit is contained in:
parent
2db10eb613
commit
85c5767e45
19
perl-Tk-freetype25.patch
Normal file
19
perl-Tk-freetype25.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- a/perl-Tk-freetype25.patch
|
||||
+++ a/perl-Tk-freetype25.patch
|
||||
@@ -0,0 +1,16 @@
|
||||
+diff --git a/myConfig b/myConfig
|
||||
+index e0ace45..c0ae343 100755
|
||||
+--- a/myConfig
|
||||
++++ b/myConfig
|
||||
+@@ -147,9 +147,9 @@ sub Ift
|
||||
+ {
|
||||
+ foreach (map { "$_/freetype2" } @_)
|
||||
+ {
|
||||
+- if (-d $_ && -d "$_/freetype" && -r "$_/freetype/freetype.h")
|
||||
++ if (-d $_ && -r "$_/freetype.h")
|
||||
+ {
|
||||
+- print "Using -I$_ to find $_/freetype/freetype.h\n";
|
||||
++ print "Using -I$_ to find $_/freetype.h\n";
|
||||
+ return "-I$_";
|
||||
+ }
|
||||
+ }
|
10
perl-Tk.spec
10
perl-Tk.spec
@ -4,7 +4,7 @@
|
||||
Name: perl-Tk
|
||||
# devel version fix for perl 5.14:
|
||||
Version: 804.031
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Summary: Perl Graphical User Interface ToolKit
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -18,6 +18,8 @@ Patch1: perl-Tk-debian.patch.gz
|
||||
Patch2: perl-Tk-seg.patch
|
||||
# Detect system libpng properly, CPAN RT#86988
|
||||
Patch3: Tk-804.031-Link-PNG-test-to-zlib.patch
|
||||
# Fix freetype detection with 2.5
|
||||
Patch4: perl-Tk-freetype25.patch
|
||||
|
||||
# Versions before this have Unicode issues
|
||||
BuildRequires: perl-devel >= 3:5.8.3
|
||||
@ -80,6 +82,8 @@ chmod -x pod/Popup.pod Tixish/lib/Tk/balArrow.xbm
|
||||
%patch2 -p1 -b .seg
|
||||
# CPAN RT #86988
|
||||
%patch3 -p1
|
||||
# freetype-2.5 detection
|
||||
%patch4 -p1
|
||||
|
||||
%build
|
||||
%{__perl} Makefile.PL INSTALLDIRS=vendor X11LIB=%{_libdir} XFT=1
|
||||
@ -126,6 +130,10 @@ find __demos/ -type f -exec chmod -x {} \;
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jun 20 2014 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||
- 804.031-6
|
||||
- add patch from Yaakov Selkowitz to fix freetype detection (rhbz#1110872)
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 804.031-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user