2021.0726 bump
This commit is contained in:
parent
9833ca7d57
commit
a319040e02
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/Text-Tabs+Wrap-2013.0523.tar.gz
|
||||
/Text-Tabs+Wrap-2021.0726.tar.gz
|
||||
|
@ -1,56 +0,0 @@
|
||||
From 425354918f774c39c68b79de55691ee262cdcb84 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Wed, 25 Mar 2015 17:57:05 +0100
|
||||
Subject: [PATCH] Build from lib
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Building from lib.modern adds "modern::" prefix to manual pages.
|
||||
|
||||
This is a work-around for CPAN RT#103116. Creating symlink is not
|
||||
enough for EU::MM.
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index a8dbc7e..1b5b51a 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -1,10 +1,15 @@
|
||||
|
||||
use ExtUtils::MakeMaker;
|
||||
|
||||
+if (!-d 'lib') {
|
||||
+ rename (($] > 5.010 ? 'lib.modern' : 'lib.old'), 'lib') or
|
||||
+ die "Could not rename to lib: $!";
|
||||
+}
|
||||
+
|
||||
WriteMakefile(
|
||||
'NAME' => 'Text-Wrap',
|
||||
'DISTNAME' => 'Text-Tabs+Wrap',
|
||||
- 'VERSION_FROM' => 'lib.modern/Text/Wrap.pm',
|
||||
+ 'VERSION_FROM' => 'lib/Text/Wrap.pm',
|
||||
($] >= 5.005 ?
|
||||
(
|
||||
ABSTRACT => 'Expand tabs and do simple line wrapping',
|
||||
@@ -21,16 +26,5 @@ WriteMakefile(
|
||||
'dist' => { COMPRESS=>"gzip", SUFFIX=>"gz" },
|
||||
'INSTALLDIRS' => 'perl',
|
||||
|
||||
- PM => ($] > 5.010 ?
|
||||
- {
|
||||
- 'lib.modern/Text/Tabs.pm' => '$(INST_LIBDIR)/Text/Tabs.pm',
|
||||
- 'lib.modern/Text/Wrap.pm' => '$(INST_LIBDIR)/Text/Wrap.pm',
|
||||
- }
|
||||
- :
|
||||
- {
|
||||
- 'lib.old/Text/Tabs.pm' => '$(INST_LIBDIR)/Text/Tabs.pm',
|
||||
- 'lib.old/Text/Wrap.pm' => '$(INST_LIBDIR)/Text/Wrap.pm',
|
||||
- })
|
||||
-
|
||||
);
|
||||
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,27 +1,24 @@
|
||||
Name: perl-Text-Tabs+Wrap
|
||||
Version: 2013.0523
|
||||
Release: 478%{?dist}
|
||||
Version: 2021.0726
|
||||
Release: 1%{?dist}
|
||||
Summary: Expand tabs and do simple line wrapping
|
||||
License: TTWL
|
||||
URL: https://metacpan.org/release/Text-Tabs%2BWrap
|
||||
Source0: https://cpan.metacpan.org/authors/id/M/MU/MUIR/modules/Text-Tabs+Wrap-%{version}.tar.gz
|
||||
# Work around CPAN RT#103116
|
||||
Patch0: Text-Tabs+Wrap-2013.0523-Build-from-lib.patch
|
||||
Source0: https://cpan.metacpan.org/authors/id/A/AR/ARISTOTLE/Text-Tabs+Wrap-%{version}.tar.gz
|
||||
BuildArch: noarch
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(warnings)
|
||||
# Run-time:
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(re)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(vars)
|
||||
BuildRequires: perl(warnings::register)
|
||||
# Tests:
|
||||
BuildRequires: perl(bytes)
|
||||
BuildRequires: perl(Test::More)
|
||||
BuildRequires: perl(warnings)
|
||||
# Optional tests:
|
||||
# Benchmark not used
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
@ -37,15 +34,13 @@ up long lines, it will not join short lines together.
|
||||
|
||||
%prep
|
||||
%setup -q -n Text-Tabs+Wrap-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor
|
||||
make %{?_smp_mflags}
|
||||
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
|
||||
%{make_build}
|
||||
|
||||
%install
|
||||
make pure_install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
|
||||
%{make_install}
|
||||
%{_fixperms} %{buildroot}/*
|
||||
|
||||
%check
|
||||
@ -57,6 +52,9 @@ make test
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 03 2021 Jitka Plesnikova <jplesnik@redhat.com> - 2021.0726-1
|
||||
- 2021.0726 bump
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2013.0523-478
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Text-Tabs+Wrap-2013.0523.tar.gz) = 870010e150d23ad1b9396642858f96a4f370a3d44dd7423884e103554f1e6a2e2ce70288ed2a773667cdebbaabecdd76b193954288be79e397ea2e029050da22
|
||||
SHA512 (Text-Tabs+Wrap-2021.0726.tar.gz) = 5ebc3c77e33edb7050bad86e342ca3838fbe123ca15310a83ca50baf2590f93dc0af06d5a4770dbc7ec02b4a9d270dec2349dece7b3cfe31371a7a63e94c42cc
|
||||
|
Loading…
Reference in New Issue
Block a user