import perl-Text-Tabs+Wrap-2013.0523-395.el8
This commit is contained in:
commit
7c3153e347
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/Text-Tabs+Wrap-2013.0523.tar.gz
|
1
.perl-Text-Tabs+Wrap.metadata
Normal file
1
.perl-Text-Tabs+Wrap.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
f4f13083ada37f490a48c63e9d76ea8916a814c3 SOURCES/Text-Tabs+Wrap-2013.0523.tar.gz
|
56
SOURCES/Text-Tabs+Wrap-2013.0523-Build-from-lib.patch
Normal file
56
SOURCES/Text-Tabs+Wrap-2013.0523-Build-from-lib.patch
Normal file
@ -0,0 +1,56 @@
|
|||||||
|
From 425354918f774c39c68b79de55691ee262cdcb84 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||||
|
Date: Wed, 25 Mar 2015 17:57:05 +0100
|
||||||
|
Subject: [PATCH] Build from lib
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Building from lib.modern adds "modern::" prefix to manual pages.
|
||||||
|
|
||||||
|
This is a work-around for CPAN RT#103116. Creating symlink is not
|
||||||
|
enough for EU::MM.
|
||||||
|
|
||||||
|
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||||
|
|
||||||
|
diff --git a/Makefile.PL b/Makefile.PL
|
||||||
|
index a8dbc7e..1b5b51a 100644
|
||||||
|
--- a/Makefile.PL
|
||||||
|
+++ b/Makefile.PL
|
||||||
|
@@ -1,10 +1,15 @@
|
||||||
|
|
||||||
|
use ExtUtils::MakeMaker;
|
||||||
|
|
||||||
|
+if (!-d 'lib') {
|
||||||
|
+ rename (($] > 5.010 ? 'lib.modern' : 'lib.old'), 'lib') or
|
||||||
|
+ die "Could not rename to lib: $!";
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
WriteMakefile(
|
||||||
|
'NAME' => 'Text-Wrap',
|
||||||
|
'DISTNAME' => 'Text-Tabs+Wrap',
|
||||||
|
- 'VERSION_FROM' => 'lib.modern/Text/Wrap.pm',
|
||||||
|
+ 'VERSION_FROM' => 'lib/Text/Wrap.pm',
|
||||||
|
($] >= 5.005 ?
|
||||||
|
(
|
||||||
|
ABSTRACT => 'Expand tabs and do simple line wrapping',
|
||||||
|
@@ -21,16 +26,5 @@ WriteMakefile(
|
||||||
|
'dist' => { COMPRESS=>"gzip", SUFFIX=>"gz" },
|
||||||
|
'INSTALLDIRS' => 'perl',
|
||||||
|
|
||||||
|
- PM => ($] > 5.010 ?
|
||||||
|
- {
|
||||||
|
- 'lib.modern/Text/Tabs.pm' => '$(INST_LIBDIR)/Text/Tabs.pm',
|
||||||
|
- 'lib.modern/Text/Wrap.pm' => '$(INST_LIBDIR)/Text/Wrap.pm',
|
||||||
|
- }
|
||||||
|
- :
|
||||||
|
- {
|
||||||
|
- 'lib.old/Text/Tabs.pm' => '$(INST_LIBDIR)/Text/Tabs.pm',
|
||||||
|
- 'lib.old/Text/Wrap.pm' => '$(INST_LIBDIR)/Text/Wrap.pm',
|
||||||
|
- })
|
||||||
|
-
|
||||||
|
);
|
||||||
|
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
93
SPECS/perl-Text-Tabs+Wrap.spec
Normal file
93
SPECS/perl-Text-Tabs+Wrap.spec
Normal file
@ -0,0 +1,93 @@
|
|||||||
|
Name: perl-Text-Tabs+Wrap
|
||||||
|
Version: 2013.0523
|
||||||
|
Release: 395%{?dist}
|
||||||
|
Summary: Expand tabs and do simple line wrapping
|
||||||
|
License: TTWL
|
||||||
|
Group: Development/Libraries
|
||||||
|
URL: http://search.cpan.org/dist/Text-Tabs%2BWrap/
|
||||||
|
Source0: http://www.cpan.org/authors/id/M/MU/MUIR/modules/Text-Tabs+Wrap-%{version}.tar.gz
|
||||||
|
# Work around CPAN RT#103116
|
||||||
|
Patch0: Text-Tabs+Wrap-2013.0523-Build-from-lib.patch
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: perl-interpreter
|
||||||
|
BuildRequires: perl-generators
|
||||||
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||||
|
# Run-time:
|
||||||
|
BuildRequires: perl(Exporter)
|
||||||
|
BuildRequires: perl(re)
|
||||||
|
BuildRequires: perl(strict)
|
||||||
|
BuildRequires: perl(vars)
|
||||||
|
BuildRequires: perl(warnings::register)
|
||||||
|
# Tests:
|
||||||
|
BuildRequires: perl(bytes)
|
||||||
|
BuildRequires: perl(Test::More)
|
||||||
|
BuildRequires: perl(warnings)
|
||||||
|
# Optional tests:
|
||||||
|
# Benchmark not used
|
||||||
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||||
|
# Sub-packaged from perl.spec, it would conflicted on manual pages
|
||||||
|
Conflicts: perl < 4:5.20.2-325
|
||||||
|
|
||||||
|
%description
|
||||||
|
Text::Tabs performs the same job that the UNIX expand(1) and unexpand(1)
|
||||||
|
commands do: adding or removing tabs from a document.
|
||||||
|
|
||||||
|
Text::Wrap::wrap() will reformat lines into paragraphs. All it does is break
|
||||||
|
up long lines, it will not join short lines together.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n Text-Tabs+Wrap-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL INSTALLDIRS=vendor
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
make pure_install DESTDIR=%{buildroot}
|
||||||
|
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
|
||||||
|
%{_fixperms} %{buildroot}/*
|
||||||
|
|
||||||
|
%check
|
||||||
|
make test
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc CHANGELOG README
|
||||||
|
%{perl_vendorlib}/*
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2013.0523-395
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2013.0523-394
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 03 2017 Jitka Plesnikova <jplesnik@redhat.com> - 2013.0523-393
|
||||||
|
- Perl 5.26 rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2013.0523-366
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 2013.0523-365
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2013.0523-347
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2013.0523-346
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2013.0523-345
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2013.0523-327
|
||||||
|
- Perl 5.22 rebuild
|
||||||
|
|
||||||
|
* Wed Mar 25 2015 Petr Pisar <ppisar@redhat.com> - 2013.0523-326
|
||||||
|
- Increase release number to compete with perl's sub-package
|
||||||
|
- Fix manual pages names
|
||||||
|
|
||||||
|
* Wed Feb 13 2013 Petr Pisar <ppisar@redhat.com> - 2013.0523-1
|
||||||
|
- Version 2013.0523 packaged
|
||||||
|
|
Loading…
Reference in New Issue
Block a user