Update to 0.011

- New upstream release 0.011
  - More clearly (and correctly) document the way NOT to use Test::Fatal
  - Try to fix $TODO not working when the user test uses $T::B::Level
- Explicitly run the extra tests
- Package examples directory as documentation
- Don't need to remove empty directories from the buildroot
- Drop %defattr, redundant since rpm 4.4
This commit is contained in:
Paul Howarth 2013-09-17 10:32:05 +01:00
parent 4575111fe9
commit a0d97cf90e
3 changed files with 21 additions and 45 deletions

View File

@ -1,30 +0,0 @@
--- Test-Fatal/Makefile.PL
+++ Test-Fatal/Makefile.PL
@@ -4,7 +4,7 @@
-use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker;
@@ -17,7 +17,7 @@
"overload" => 0
},
"CONFIGURE_REQUIRES" => {
- "ExtUtils::MakeMaker" => "6.30"
+ "ExtUtils::MakeMaker" => "0"
},
"DISTNAME" => "Test-Fatal",
"EXE_FILES" => [],
@@ -54,6 +54,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

View File

@ -1,22 +1,25 @@
Summary: Incredibly simple helpers for testing code with exceptions
Name: perl-Test-Fatal
Version: 0.010
Release: 7%{?dist}
Version: 0.011
Release: 1%{?dist}
License: GPL+ or Artistic
Group: Development/Libraries
Url: http://search.cpan.org/dist/Test-Fatal/
Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-%{version}.tar.gz
Patch0: Test-Fatal-0.008-old-EU::MM.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch
BuildRequires: perl(blib)
BuildRequires: perl(Capture::Tiny)
BuildRequires: perl(Carp)
BuildRequires: perl(Exporter) >= 5.57
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(overload)
BuildRequires: perl(Test::Builder)
BuildRequires: perl(Test::Builder::Tester)
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::More) >= 0.96
BuildRequires: perl(Test::Pod) >= 1.41
BuildRequires: perl(Try::Tiny) >= 0.07
BuildRequires: perl(version)
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires: perl(Test::Builder)
@ -28,11 +31,6 @@ with about the same amount of typing.
%prep
%setup -q -n Test-Fatal-%{version}
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%if "%{?rhel}" == "4"
%patch0 -p1
%endif
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
@ -41,22 +39,30 @@ make %{?_smp_mflags}
rm -rf %{buildroot}
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
%{_fixperms} %{buildroot}
%check
make test RELEASE_TESTING=1
make test
make test TEST_FILES="$(echo $(find xt/ -name '*.t'))"
%clean
rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc Changes LICENSE README
%doc Changes LICENSE README examples/
%{perl_vendorlib}/Test/
%{_mandir}/man3/Test::Fatal.3pm*
%changelog
* Tue Sep 17 2013 Paul Howarth <paul@city-fan.org> - 0.011-1
- Update to 0.011
- More clearly (and correctly) document the way NOT to use Test::Fatal
- Try to fix $TODO not working when the user test uses $T::B::Level
- Explicitly run the extra tests
- Package examples directory as documentation
- Don't need to remove empty directories from the buildroot
- Drop %%defattr, redundant since rpm 4.4
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.010-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

View File

@ -1 +1 @@
d8052d4160e8d999cbeb574592f26541 Test-Fatal-0.010.tar.gz
3e635215d4d9d1f40b8901b7987cadb6 Test-Fatal-0.011.tar.gz