Initial import of perl-Test-Fatal 0.003-1

This commit is contained in:
Paul Howarth 2010-11-05 18:44:58 +00:00
parent 13918bb597
commit 781ff92ee4
4 changed files with 132 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/Test-Fatal-0.003.tar.gz

View File

@ -0,0 +1,59 @@
There's no need to be as strict about versions as this.
diff -up Test-Fatal-0.003/lib/Test/Fatal.pm.orig Test-Fatal-0.003/lib/Test/Fatal.pm
--- Test-Fatal-0.003/lib/Test/Fatal.pm.orig 2010-10-29 03:11:02.000000000 +0100
+++ Test-Fatal-0.003/lib/Test/Fatal.pm 2010-10-29 09:06:06.608473151 +0100
@@ -10,7 +10,7 @@ BEGIN {
use Carp ();
use Try::Tiny 0.07;
-use Exporter 5.59 'import';
+use Exporter 5.57 'import';
our @EXPORT = qw(exception);
our @EXPORT_OK = qw(exception success);
diff -up Test-Fatal-0.003/Makefile.PL.orig Test-Fatal-0.003/Makefile.PL
--- Test-Fatal-0.003/Makefile.PL.orig 2010-10-29 03:11:02.000000000 +0100
+++ Test-Fatal-0.003/Makefile.PL 2010-10-29 09:07:28.605285870 +0100
@@ -4,7 +4,7 @@ use warnings;
-use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker 6.17;
@@ -12,11 +12,11 @@ my %WriteMakefileArgs = (
'ABSTRACT' => 'incredibly simple helpers for testing code with exceptions',
'AUTHOR' => 'Ricardo Signes <rjbs@cpan.org>',
'BUILD_REQUIRES' => {
- 'Test::More' => '0.96',
+ 'Test::More' => '0.47',
'overload' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '6.17'
},
'DISTNAME' => 'Test-Fatal',
'EXE_FILES' => [],
@@ -24,7 +24,7 @@ my %WriteMakefileArgs = (
'NAME' => 'Test::Fatal',
'PREREQ_PM' => {
'Carp' => '0',
- 'Exporter' => '5.59',
+ 'Exporter' => '5.57',
'Try::Tiny' => '0.07'
},
'VERSION' => '0.003',
@@ -50,6 +50,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

71
perl-Test-Fatal.spec Normal file
View File

@ -0,0 +1,71 @@
Summary: Incredibly simple helpers for testing code with exceptions
Name: perl-Test-Fatal
Version: 0.003
Release: 1%{?dist}
License: GPL+ or Artistic
Group: Development/Libraries
Url: http://search.cpan.org/dist/Test-Fatal/
Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-%{version}.tar.gz
Patch0: Test-Fatal-0.003-versions.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: perl(Exporter) >= 5.57
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Try::Tiny) >= 0.07
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description
Test::Fatal is an alternative to the popular Test::Exception. It does much
less, but should allow greater flexibility in testing exception-throwing code
with about the same amount of typing.
It exports one routine by default: exception.
%prep
%setup -q -n Test-Fatal-%{version}
# No need to have bleeding edge versions of modules really
%patch0 -p1
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%check
make test RELEASE_TESTING=1
%clean
rm -rf %{buildroot}
%install
rm -rf %{buildroot}
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
%{_fixperms} %{buildroot}
%files
%defattr(-,root,root,-)
%doc Changes LICENSE README
%{perl_vendorlib}/Test/
%{_mandir}/man3/Test::Fatal.3pm*
%changelog
* Fri Oct 29 2010 Paul Howarth <paul@city-fan.org> 0.003-1
- Update to 0.003
- More tests for false exceptions, especially on 5.13
- Update versions patch
* Thu Oct 28 2010 Paul Howarth <paul@city-fan.org> 0.002-1
- Update to 0.002
- Add tests for handling of false exceptions
- Fix precedence error in documentation
- Update versions patch
* Wed Oct 27 2010 Paul Howarth <paul@city-fan.org> 0.001-2
- Sanitize spec for Fedora submission
* Tue Oct 26 2010 Paul Howarth <paul@city-fan.org> 0.001-1
- Initial RPM version

View File

@ -0,0 +1 @@
e73e90b65a5f07ff77f7e5f3bd336fcf Test-Fatal-0.003.tar.gz