perl-Package-Stash/Package-Stash-0.32-EU::MM-version.patch
Paul Howarth 1a294d28ce Update to 0.32
- New upstream release 0.32
  - Bring the behavior of has_symbol for nonexistant scalars into line with the
    XS version
  - Invalid package names (for instance, Foo:Bar) are not allowed
  - Invalid stash entry names (anything containing ::) are not allowed
- Update patches to apply cleanly
- Bump perl(Package::Stash::XS) version requirement to 0.24
2011-09-06 20:29:32 +01:00

31 lines
752 B
Diff

--- Package-Stash/Makefile.PL
+++ Package-Stash/Makefile.PL
@@ -3,7 +3,7 @@
BEGIN { require 5.8.1; }
use strict;
use warnings;
-use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker;
check_conflicts();
my %WriteMakefileArgs = (
@@ -16,7 +16,7 @@
},
'CONFIGURE_REQUIRES' => {
'Dist::CheckConflicts' => '0.02',
- 'ExtUtils::MakeMaker' => '6.30'
+ 'ExtUtils::MakeMaker' => '0'
},
'DISTNAME' => 'Package-Stash',
'EXE_FILES' => [
@@ -52,6 +52,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.30) };
+
$WriteMakefileArgs{PREREQ_PM}{'Package::Stash::XS'} = 0.24
if can_cc();