import perl-Package-Stash-0.37-9.el8
This commit is contained in:
commit
ca4a552a5e
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/Package-Stash-0.37.tar.gz
|
1
.perl-Package-Stash.metadata
Normal file
1
.perl-Package-Stash.metadata
Normal file
@ -0,0 +1 @@
|
||||
43fc4e362ac1a45eb27fe779806cbd96c891e2dc SOURCES/Package-Stash-0.37.tar.gz
|
535
SOURCES/Package-Stash-0.37-old-Test::More.patch
Normal file
535
SOURCES/Package-Stash-0.37-old-Test::More.patch
Normal file
@ -0,0 +1,535 @@
|
||||
--- t/addsub.t
|
||||
+++ t/addsub.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 7;
|
||||
use Test::Fatal;
|
||||
|
||||
BEGIN { $^P |= 0x210 } # PERLDBf_SUBLINE
|
||||
@@ -42,5 +42,3 @@ $foo_stash->add_symbol(
|
||||
|
||||
is $DB::sub{'Foo::dunk'}, sprintf "%s:%d-%d", "FileName", 100, 199,
|
||||
'... got the right %DB::sub value for dunk with specified args';
|
||||
-
|
||||
-done_testing;
|
||||
--- t/anon-basic.t
|
||||
+++ t/anon-basic.t
|
||||
@@ -16,6 +16,8 @@ BEGIN {
|
||||
use Test::Requires 'Package::Anon';
|
||||
use Symbol;
|
||||
|
||||
+plan tests => 122;
|
||||
+
|
||||
my $Foo = Package::Anon->new('Foo');
|
||||
$Foo->{SOME_CONSTANT} = \1;
|
||||
|
||||
@@ -402,5 +404,3 @@ $Quuux->{quuuux} = -1;
|
||||
|
||||
is_deeply([Package::Stash->new('Quuux')->list_all_symbols], [],
|
||||
"Quuux:: isn't touched");
|
||||
-
|
||||
-done_testing;
|
||||
--- t/anon.t
|
||||
+++ t/anon.t
|
||||
@@ -16,6 +16,8 @@ BEGIN {
|
||||
use Test::Requires 'Package::Anon';
|
||||
use Symbol;
|
||||
|
||||
+plan tests => 7;
|
||||
+
|
||||
my $anon = Package::Anon->new;
|
||||
my $stash = Package::Stash->new($anon);
|
||||
my $obj = $anon->bless({});
|
||||
@@ -47,5 +49,3 @@ my $obj = $anon->bless({});
|
||||
qr/Undefined subroutine \&__ANON__::baz called/
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/bare-anon-basic.t
|
||||
+++ t/bare-anon-basic.t
|
||||
@@ -17,6 +17,8 @@ BEGIN {
|
||||
|
||||
use Symbol;
|
||||
|
||||
+plan tests => 10;
|
||||
+
|
||||
my $Foo = {};
|
||||
$Foo->{SOME_CONSTANT} = \1;
|
||||
|
||||
@@ -396,5 +398,3 @@ $Quuux->{quuuux} = -1;
|
||||
|
||||
is_deeply([Package::Stash->new('Quuux')->list_all_symbols], [],
|
||||
"Quuux:: isn't touched");
|
||||
-
|
||||
-done_testing;
|
||||
--- t/bare-anon.t
|
||||
+++ t/bare-anon.t
|
||||
@@ -17,6 +17,8 @@ BEGIN {
|
||||
|
||||
use Symbol;
|
||||
|
||||
+plan tests => 10;
|
||||
+
|
||||
my $anon = {};
|
||||
my $stash = Package::Stash->new($anon);
|
||||
# no way to bless something into a hashref yet
|
||||
@@ -61,5 +63,3 @@ my $stash = Package::Stash->new($anon);
|
||||
undef
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/basic.t
|
||||
+++ t/basic.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 131;
|
||||
use Test::Fatal;
|
||||
|
||||
use Package::Stash;
|
||||
@@ -444,5 +444,3 @@ like(
|
||||
qr/^Package::Stash->new must be passed the name of the package to access/,
|
||||
"module name must be a string"
|
||||
);
|
||||
-
|
||||
-done_testing;
|
||||
--- t/compile-time.t
|
||||
+++ t/compile-time.t
|
||||
@@ -2,8 +2,6 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 1;
|
||||
|
||||
use_ok('CompileTime');
|
||||
-
|
||||
-done_testing;
|
||||
--- t/edge-cases.t
|
||||
+++ t/edge-cases.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 19;
|
||||
use Test::Fatal;
|
||||
|
||||
use Package::Stash;
|
||||
@@ -109,5 +109,3 @@ SKIP: {
|
||||
my $stash = Package::Stash->new('HasISA');
|
||||
is_deeply([$stash->list_all_symbols('SCALAR')], []);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/extension.t
|
||||
+++ t/extension.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 15;
|
||||
use Test::Fatal;
|
||||
|
||||
{
|
||||
@@ -72,5 +72,3 @@ is(exception {
|
||||
}, undef, '... created %Foo::baz successfully');
|
||||
|
||||
ok(!defined($Foo::{baz}), '... the %baz slot has still not been created');
|
||||
-
|
||||
-done_testing;
|
||||
--- t/get.t
|
||||
+++ t/get.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 36;
|
||||
|
||||
use Package::Stash;
|
||||
use Scalar::Util;
|
||||
@@ -182,5 +182,3 @@ use Scalar::Util;
|
||||
"stash has the right variable");
|
||||
}
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/impl-selection/basic-pp.t
|
||||
+++ t/impl-selection/basic-pp.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 133;
|
||||
use Test::Fatal;
|
||||
|
||||
BEGIN { $Package::Stash::IMPLEMENTATION = 'PP' }
|
||||
@@ -448,5 +448,3 @@ like(
|
||||
qr/^Package::Stash->new must be passed the name of the package to access/,
|
||||
"module name must be a string"
|
||||
);
|
||||
-
|
||||
-done_testing;
|
||||
--- t/impl-selection/basic-xs.t
|
||||
+++ t/impl-selection/basic-xs.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 133;
|
||||
use Test::Fatal;
|
||||
use Test::Requires 'Package::Stash::XS';
|
||||
|
||||
@@ -449,5 +449,3 @@ like(
|
||||
qr/^Package::Stash->new must be passed the name of the package to access/,
|
||||
"module name must be a string"
|
||||
);
|
||||
-
|
||||
-done_testing;
|
||||
--- t/impl-selection/bug-rt-78272.t
|
||||
+++ t/impl-selection/bug-rt-78272.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 2;
|
||||
use Test::Fatal;
|
||||
|
||||
# https://rt.cpan.org/Public/Bug/Display.html?id=78272
|
||||
@@ -22,18 +22,3 @@ like(
|
||||
'Sanity check: forcing package reload throws the exception again'
|
||||
);
|
||||
|
||||
-is(
|
||||
- exception {
|
||||
- $ENV{PACKAGE_STASH_IMPLEMENTATION} = "PP";
|
||||
- delete $INC{'Package/Stash.pm'};
|
||||
- require Package::Stash;
|
||||
- new_ok(
|
||||
- 'Package::Stash' => ['Foo'],
|
||||
- 'Loaded and able to create instances'
|
||||
- );
|
||||
- },
|
||||
- undef,
|
||||
- 'Valid $ENV value loads correctly'
|
||||
-);
|
||||
-
|
||||
-done_testing;
|
||||
--- t/impl-selection/choice.t
|
||||
+++ t/impl-selection/choice.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 2;
|
||||
|
||||
my $has_xs = eval "require Package::Stash::XS; 1";
|
||||
|
||||
@@ -13,5 +13,3 @@ my $expected = $has_xs ? 'XS' : 'PP';
|
||||
is($Package::Stash::IMPLEMENTATION, $expected,
|
||||
"autodetected properly: $expected");
|
||||
can_ok('Package::Stash', 'new');
|
||||
-
|
||||
-done_testing;
|
||||
--- t/impl-selection/env.t
|
||||
+++ t/impl-selection/env.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 6;
|
||||
|
||||
# XXX: work around dumb core segfault bug when you delete stashes
|
||||
sub get_impl { eval '$Package::Stash::IMPLEMENTATION' }
|
||||
@@ -35,5 +35,3 @@ SKIP: {
|
||||
is(get_impl, 'PP', '$ENV takes precedence over $Package::Stash::IMPLEMENTATION');
|
||||
can_ok('Package::Stash', 'new');
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/impl-selection/var.t
|
||||
+++ t/impl-selection/var.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 4;
|
||||
|
||||
# XXX: work around dumb core segfault bug when you delete stashes
|
||||
sub get_impl { eval '$Package::Stash::IMPLEMENTATION' }
|
||||
@@ -25,5 +25,3 @@ SKIP: {
|
||||
is(get_impl, 'XS', "autodetected properly: XS");
|
||||
can_ok('Package::Stash', 'new');
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/io.t
|
||||
+++ t/io.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 11;
|
||||
use Test::Fatal;
|
||||
|
||||
{
|
||||
@@ -47,5 +47,3 @@ use Package::Stash;
|
||||
ok($stash->has_symbol('baz'), "has baz");
|
||||
is($stash->get_symbol('baz'), *Foo::foo{IO}, "got the right baz");
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/isa.t
|
||||
+++ t/isa.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 8;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -19,7 +19,10 @@ use Package::Stash;
|
||||
my $stash = Package::Stash->new('Foo');
|
||||
my @ISA = ('Bar');
|
||||
@{$stash->get_or_add_symbol('@ISA')} = @ISA;
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Foo', 'Bar');
|
||||
+ }
|
||||
isa_ok(bless({}, 'Foo'), 'Bar');
|
||||
}
|
||||
|
||||
@@ -33,17 +36,21 @@ use Package::Stash;
|
||||
{
|
||||
my $isa = $stash->get_or_add_symbol('@ISA');
|
||||
@$isa = ('Baz');
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Quux', 'Baz');
|
||||
+ }
|
||||
isa_ok(bless({}, 'Quux'), 'Baz');
|
||||
ok(Quux->can('foo'));
|
||||
}
|
||||
{
|
||||
my $isa = $stash->get_or_add_symbol('@ISA');
|
||||
@$isa = ('Bar');
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Quux', 'Bar');
|
||||
+ }
|
||||
isa_ok(bless({}, 'Quux'), 'Bar');
|
||||
ok(Quux->can('bar'));
|
||||
}
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/magic.t
|
||||
+++ t/magic.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 14;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -77,4 +77,3 @@ SKIP: {
|
||||
is($store, 0, "get_or_add_symbol stores (populated slot)");
|
||||
}
|
||||
|
||||
-done_testing;
|
||||
--- t/paamayim_nekdotayim.t
|
||||
+++ t/paamayim_nekdotayim.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 3;
|
||||
use Test::Fatal;
|
||||
|
||||
use Package::Stash;
|
||||
@@ -24,5 +24,3 @@ like(
|
||||
qr/^Variable names may not contain ::/,
|
||||
"can't add symbol with ::"
|
||||
);
|
||||
-
|
||||
-done_testing;
|
||||
--- t/scalar-values.t
|
||||
+++ t/scalar-values.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 14;
|
||||
use Test::Fatal;
|
||||
|
||||
use B;
|
||||
@@ -49,5 +49,3 @@ my $vstring = v1.2.3;
|
||||
is(reftype(\$vstring), ($] < 5.010 ? 'SCALAR' : 'VSTRING'));
|
||||
is(exception { $Bar->add_symbol('$vstring', \$vstring) }, undef,
|
||||
"can add vstring values");
|
||||
-
|
||||
-done_testing;
|
||||
--- t/stash-deletion.t
|
||||
+++ t/stash-deletion.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 2;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -20,5 +20,3 @@ use Package::Stash;
|
||||
}
|
||||
ok(!$delete->has_symbol('&bar'), "method goes away when stash is deleted");
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/synopsis.t
|
||||
+++ t/synopsis.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 3;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -15,5 +15,3 @@ $stash->add_symbol('%foo', {bar => 1});
|
||||
ok(!$stash->has_symbol('$foo'), "doesn't have anything in scalar slot");
|
||||
my $namespace = $stash->namespace;
|
||||
is_deeply(*{ $namespace->{foo} }{HASH}, {bar => 1}, "namespace works properly");
|
||||
-
|
||||
-done_testing;
|
||||
--- t/warnings-taint.t
|
||||
+++ t/warnings-taint.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 1;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -19,4 +19,3 @@ BEGIN {
|
||||
|
||||
is($warnings, '');
|
||||
|
||||
-done_testing;
|
||||
--- t/warnings.t
|
||||
+++ t/warnings.t
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 1;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -18,5 +18,3 @@ BEGIN {
|
||||
}
|
||||
|
||||
is($warnings, '');
|
||||
-
|
||||
-done_testing;
|
||||
--- xt/author/leaks-debug.t
|
||||
+++ xt/author/leaks-debug.t
|
||||
@@ -6,6 +6,8 @@ use Test::More;
|
||||
use Test::Fatal;
|
||||
use Test::LeakTrace;
|
||||
|
||||
+plan tests => 45;
|
||||
+
|
||||
BEGIN { $^P |= 0x210 } # PERLDBf_SUBLINE
|
||||
|
||||
use Package::Stash;
|
||||
@@ -176,7 +178,10 @@ use Symbol;
|
||||
ok($foo->has_symbol('@ISA'));
|
||||
is(ref($foo->get_symbol('@ISA')), 'ARRAY');
|
||||
is_deeply($foo->get_symbol('@ISA'), ['Exporter']);
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Foo', 'Exporter');
|
||||
+ }
|
||||
}
|
||||
|
||||
{
|
||||
@@ -226,5 +231,3 @@ use Symbol;
|
||||
eval { $foo->add_symbol('&blorg') };
|
||||
} "doesn't leak on errors";
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- xt/author/leaks.t
|
||||
+++ xt/author/leaks.t
|
||||
@@ -6,6 +6,8 @@ use Test::More;
|
||||
use Test::Fatal;
|
||||
use Test::LeakTrace;
|
||||
|
||||
+plan tests => 45;
|
||||
+
|
||||
use Package::Stash;
|
||||
use Symbol;
|
||||
|
||||
@@ -174,7 +176,10 @@ use Symbol;
|
||||
ok($foo->has_symbol('@ISA'));
|
||||
is(ref($foo->get_symbol('@ISA')), 'ARRAY');
|
||||
is_deeply($foo->get_symbol('@ISA'), ['Exporter']);
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Foo', 'Exporter');
|
||||
+ }
|
||||
}
|
||||
|
||||
{
|
||||
@@ -224,5 +229,3 @@ use Symbol;
|
||||
eval { $foo->add_symbol('&blorg') };
|
||||
} "doesn't leak on errors";
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- xt/release/no-tabs.t
|
||||
+++ xt/release/no-tabs.t
|
||||
@@ -3,7 +3,7 @@ use warnings;
|
||||
|
||||
# this test was generated with Dist::Zilla::Plugin::Test::NoTabs 0.08
|
||||
|
||||
-use Test::More 0.88;
|
||||
+use Test::More;
|
||||
use Test::NoTabs;
|
||||
|
||||
my @files = (
|
||||
@@ -41,5 +41,6 @@ my @files = (
|
||||
't/warnings.t'
|
||||
);
|
||||
|
||||
+plan tests => scalar @files;
|
||||
+
|
||||
notabs_ok($_) foreach @files;
|
||||
-done_testing;
|
349
SPECS/perl-Package-Stash.spec
Normal file
349
SPECS/perl-Package-Stash.spec
Normal file
@ -0,0 +1,349 @@
|
||||
# We need to patch the test suite if we have an old version of Test::More
|
||||
%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
|
||||
# Run extra test
|
||||
%if ! (0%{?rhel})
|
||||
%bcond_without perl_Package_Stash_enables_extra_test
|
||||
%else
|
||||
%bcond_with perl_Package_Stash_enables_extra_test
|
||||
%endif
|
||||
# Run optional test
|
||||
%if ! (0%{?rhel})
|
||||
%bcond_without perl_Package_Stash_enables_optional_test
|
||||
%else
|
||||
%bcond_with perl_Package_Stash_enables_optional_test
|
||||
%endif
|
||||
|
||||
Name: perl-Package-Stash
|
||||
Version: 0.37
|
||||
Release: 9%{?dist}
|
||||
Summary: Routines for manipulating stashes
|
||||
Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/Package-Stash/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz
|
||||
Patch1: Package-Stash-0.37-old-Test::More.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
|
||||
BuildArch: noarch
|
||||
# Module Build
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl(Config)
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
BuildRequires: perl(File::Spec)
|
||||
BuildRequires: perl(Text::ParseWords)
|
||||
# Module Runtime
|
||||
BuildRequires: perl(B)
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(constant)
|
||||
BuildRequires: perl(Dist::CheckConflicts) >= 0.02
|
||||
BuildRequires: perl(Getopt::Long)
|
||||
BuildRequires: perl(Module::Implementation) >= 0.06
|
||||
BuildRequires: perl(Package::Stash::XS) >= 0.26
|
||||
BuildRequires: perl(Scalar::Util)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(Symbol)
|
||||
BuildRequires: perl(warnings)
|
||||
# Test Suite
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(IO::Handle)
|
||||
BuildRequires: perl(IPC::Open3)
|
||||
BuildRequires: perl(lib)
|
||||
BuildRequires: perl(Test::Fatal)
|
||||
BuildRequires: perl(Test::More)
|
||||
BuildRequires: perl(Test::Requires)
|
||||
%if %{with perl_Package_Stash_enables_optional_test}
|
||||
# Optional Tests
|
||||
BuildRequires: perl(Package::Anon)
|
||||
BuildRequires: perl(Variable::Magic)
|
||||
%endif
|
||||
%if %{with perl_Package_Stash_enables_extra_test}
|
||||
# Extra Tests
|
||||
BuildRequires: perl(Pod::Coverage::TrustPod)
|
||||
BuildRequires: perl(Test::EOL)
|
||||
BuildRequires: perl(Test::LeakTrace)
|
||||
BuildRequires: perl(Test::NoTabs)
|
||||
BuildRequires: perl(Test::Pod) >= 1.41
|
||||
BuildRequires: perl(Test::Pod::Coverage) >= 1.08
|
||||
%endif
|
||||
# Runtime
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
# For performance and consistency
|
||||
Requires: perl(Package::Stash::XS) >= 0.26
|
||||
# Not found by rpm auto-provides
|
||||
Provides: perl(Package::Stash::Conflicts) = 0
|
||||
|
||||
%description
|
||||
Manipulating stashes (Perl's symbol tables) is occasionally necessary, but
|
||||
incredibly messy, and easy to get wrong. This module hides all of that behind
|
||||
a simple API.
|
||||
|
||||
%prep
|
||||
%setup -q -n Package-Stash-%{version}
|
||||
|
||||
# Compatibility with old Test::More versions
|
||||
%if %{old_test_more}
|
||||
%patch1
|
||||
%endif
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make pure_install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
|
||||
%{_fixperms} %{buildroot}
|
||||
|
||||
%check
|
||||
make test
|
||||
# Extra Tests: Pod Coverage test fails due to lack of POD for Package::Stash::Conflicts
|
||||
%if %{with perl_Package_Stash_enables_extra_test}
|
||||
make test TEST_FILES="$(echo $(find xt/ -name '*.t' | grep -v pod-coverage))"
|
||||
%endif
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%if 0%{?_licensedir:1}
|
||||
%license LICENSE
|
||||
%else
|
||||
%doc LICENSE
|
||||
%endif
|
||||
%doc Changes README
|
||||
%{_bindir}/package-stash-conflicts
|
||||
%{perl_vendorlib}/Package/
|
||||
%{_mandir}/man1/package-stash-conflicts.1*
|
||||
%{_mandir}/man3/Package::Stash.3pm*
|
||||
%{_mandir}/man3/Package::Stash::PP.3pm*
|
||||
|
||||
%changelog
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.37-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.37-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.37-7
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.37-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.37-5
|
||||
- Perl 5.24 rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.37-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.37-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.37-2
|
||||
- Perl 5.22 rebuild
|
||||
|
||||
* Tue Sep 23 2014 Paul Howarth <paul@city-fan.org> - 0.37-1
|
||||
- Update to 0.37
|
||||
- Fix spurious warning in taint mode (GH#12)
|
||||
- Update patch for building with old Test::More versions
|
||||
- No documentation for Package::Stash::Conflicts in this release
|
||||
- Classify buildreqs by usage
|
||||
- Use %%license where possible
|
||||
- Don't try to run the extra tests for EL builds as we won't have the
|
||||
dependencies
|
||||
|
||||
* Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.36-3
|
||||
- Perl 5.20 rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.36-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Wed Sep 4 2013 Paul Howarth <paul@city-fan.org> - 0.36-1
|
||||
- Update to 0.36
|
||||
- Support building with PUREPERL_ONLY
|
||||
- BR: perl(Config), perl(Text::ParseWords) and perl(Variable::Magic)
|
||||
- Update patch for building with old Test::More version in EPEL-5
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.35-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Mon Jul 29 2013 Petr Pisar <ppisar@redhat.com> - 0.35-2
|
||||
- Perl 5.18 rebuild
|
||||
|
||||
* Wed Jul 10 2013 Paul Howarth <paul@city-fan.org> - 0.35-1
|
||||
- Update to 0.35
|
||||
- Remove old, deprecated API
|
||||
- BR: perl(Getopt::Long)
|
||||
- perl(Package::DeprecationManager) is no longer needed
|
||||
|
||||
* Thu Jan 24 2013 Paul Howarth <paul@city-fan.org> - 0.34-2
|
||||
- BR: perl(Package::Anon) if we have Perl ≥ 5.14
|
||||
|
||||
* Sun Jan 6 2013 Paul Howarth <paul@city-fan.org> - 0.34-1
|
||||
- Update to 0.34
|
||||
- Support anonymous stashes on newer perl versions
|
||||
- Prevent harmful effects from invalid settings for
|
||||
$ENV{PACKAGE_STASH_IMPLEMENTATION}
|
||||
- Switch to Module::Implementation
|
||||
- BR: perl(Module::Implementation) ≥ 0.06
|
||||
- BR: perl(base) for test suite
|
||||
- Bump Package::Stash::XS version requirement to 0.26
|
||||
- Explicitly run extra tests (except on RHEL ≥ 7, where the necessary
|
||||
build dependencies may not be available)
|
||||
- Update patch for building with old Test::More version in EPEL-5
|
||||
|
||||
* Mon Aug 27 2012 Petr Pisar <ppisar@redhat.com> - 0.33-7
|
||||
- Disable author tests on RHEL >= 7
|
||||
|
||||
* Fri Aug 24 2012 Paul Howarth <paul@city-fan.org> - 0.33-6
|
||||
- Drop EPEL-4 support
|
||||
- Drop %%defattr, redundant since rpm 4.4
|
||||
- Test::LeakTrace, Test::Requires and Test::Script are now universally available
|
||||
- A suitably recent version of ExtUtils::MakeMaker is now universally available
|
||||
- Don't need to remove empty directories from the buildroot
|
||||
|
||||
* Tue Aug 14 2012 Petr Pisar <ppisar@redhat.com> - 0.33-5
|
||||
- Specify all dependendencies
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.33-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Jun 19 2012 Petr Pisar <ppisar@redhat.com> - 0.33-3
|
||||
- Perl 5.16 rebuild
|
||||
|
||||
* Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.33-2
|
||||
- Fedora 17 mass rebuild
|
||||
|
||||
* Thu Sep 29 2011 Paul Howarth <paul@city-fan.org> - 0.33-1
|
||||
- Update to 0.33
|
||||
- Add conflict on MooseX::Method::Signatures 0.36
|
||||
- BR: perl(Carp)
|
||||
|
||||
* Tue Sep 6 2011 Paul Howarth <paul@city-fan.org> - 0.32-1
|
||||
- Update to 0.32
|
||||
- Bring the behavior of has_symbol for nonexistant scalars into line with the
|
||||
XS version
|
||||
- Invalid package names (for instance, Foo:Bar) are not allowed
|
||||
- Invalid stash entry names (anything containing ::) are not allowed
|
||||
- Update patches to apply cleanly
|
||||
- Bump perl(Package::Stash::XS) version requirement to 0.24
|
||||
|
||||
* Tue Aug 9 2011 Paul Howarth <paul@city-fan.org> - 0.31-1
|
||||
- Update to 0.31
|
||||
- Fix ->add_symbol('$foo', qr/sdlfk/) on 5.12+
|
||||
- Fix ->add_symbol('$foo', \v1.2.3) on 5.10+
|
||||
- Update patch for old Test::More versions
|
||||
- Update patch for no Test::Requires
|
||||
|
||||
* Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 0.30-2
|
||||
- Perl mass rebuild
|
||||
|
||||
* Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 0.30-1
|
||||
- Update to 0.30
|
||||
- Fix compiler detection in Makefile.PL
|
||||
- Update patch for old ExtUtils::MakeMaker versions
|
||||
- Drop usage of macros for commands
|
||||
- Drop redundant %%{?perl_default_filter}
|
||||
- perl(Pod::Coverage::TrustPod) now available everywhere
|
||||
|
||||
* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.29-2
|
||||
- Perl mass rebuild
|
||||
|
||||
* Wed Apr 6 2011 Paul Howarth <paul@city-fan.org> - 0.29-1
|
||||
- Update to 0.29
|
||||
- Really skip the package-stash-conflict script in the compile test
|
||||
|
||||
* Wed Mar 30 2011 Paul Howarth <paul@city-fan.org> - 0.28-1
|
||||
- Update to 0.28
|
||||
- META.json fixes
|
||||
- Update patch for old ExtUtils::MakeMaker versions to apply cleanly
|
||||
|
||||
* Mon Mar 28 2011 Paul Howarth <paul@city-fan.org> - 0.27-1
|
||||
- Update to 0.27
|
||||
- Skip the package-stash-conflicts script in the compile test
|
||||
|
||||
* Sat Mar 5 2011 Paul Howarth <paul@city-fan.org> - 0.26-1
|
||||
- Update to 0.26
|
||||
- Make the namespace cache lazy and weak, in case the stash is deleted
|
||||
- However, this doesn't work on 5.8, so disable the namespace caching
|
||||
entirely there
|
||||
- Update patches to apply cleanly
|
||||
- Bump perl(Package::Stash::XS) version requirement to 0.22
|
||||
- Bump perl(Dist::CheckConflicts) version requirement to 0.02
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Jan 25 2011 Paul Howarth <paul@city-fan.org> - 0.25-1
|
||||
- Update to 0.25 (make the leak tests author-only, since some smokers run
|
||||
release tests)
|
||||
- Update patches to apply cleanly
|
||||
- Bump perl(Package::Stash::XS) version requirement to 0.21
|
||||
- Drop buildreq perl(Test::Exception), no longer needed
|
||||
|
||||
* Tue Jan 18 2011 Paul Howarth <paul@city-fan.org> - 0.24-1
|
||||
- Update to 0.24 (reinstate Test::Requires dependency)
|
||||
|
||||
* Wed Jan 12 2011 Paul Howarth <paul@city-fan.org> - 0.23-1
|
||||
- Update to 0.23
|
||||
- Lower perl prereq to 5.8.1
|
||||
- Make the leak tests release-only
|
||||
- Update patches to apply cleanly
|
||||
- Add patch to skip memory leak tests if we don't have Test::LeakTrace
|
||||
|
||||
* Thu Jan 6 2011 Paul Howarth <paul@city-fan.org> - 0.22-1
|
||||
- Update to 0.22 (bump Package::Stash::XS version requirement since a bug was
|
||||
fixed there)
|
||||
- Update patches for old ExtUtils::MakeMaker and Test::More versions
|
||||
- BR/R perl(Package::Stash::XS) >= 0.19
|
||||
- Content-free manpages for package-stash-conflicts and
|
||||
Package::Stash::Conflicts dropped upstream
|
||||
|
||||
* Tue Jan 4 2011 Paul Howarth <paul@city-fan.org> - 0.20-1
|
||||
- Update to 0.20
|
||||
- Methods were renamed for brevity: s/_package//
|
||||
- Convert Package::Stash into a module which loads either the XS or pure perl
|
||||
implementation, depending on what's available
|
||||
- Use Test::Fatal instead of Test::Exception
|
||||
- Use Dist::CheckConflicts
|
||||
- Silence deprecation warnings for the method renaming for now
|
||||
- New script and manpage: package-stash-conflicts
|
||||
- New modules and manpages: Package::Stash::Conflicts and Package::Stash::PP
|
||||
- New build requirements:
|
||||
- perl(Dist::CheckConflicts)
|
||||
- perl(Package::DeprecationManager)
|
||||
- perl(Package::Stash::XS)
|
||||
- perl(Test::LeakTrace)
|
||||
- perl(Test::Requires)
|
||||
- perl(Test::Script)
|
||||
- Update patches for old ExtUtils::MakeMaker and Test::More versions
|
||||
- Add new patch to work around absence of Test::Requires in EPEL-4
|
||||
- Require perl(Package::Stash::XS) for performance and consistency
|
||||
- Manually provide perl(Package::Stash::Conflicts), hidden from auto-provides
|
||||
|
||||
* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-2
|
||||
- Rebuild to fix problems with vendorarch/lib (#661697)
|
||||
|
||||
* Mon Sep 20 2010 Paul Howarth <paul@city-fan.org> - 0.08-1
|
||||
- Update to 0.08 (re-enable the caching of the stash)
|
||||
- Update patch for old ExtUtils::MakeMaker and Test::More versions
|
||||
|
||||
* Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> - 0.05-1
|
||||
- Update to 0.05
|
||||
- Bump Test::More requirement for done_testing
|
||||
- Update packaging stuff
|
||||
- BR: perl(Test::EOL) and perl(Test::NoTabs)
|
||||
- Unify spec for all active branches, adding patches for back-compatibility
|
||||
|
||||
* Mon Jun 14 2010 Paul Howarth <paul@city-fan.org> - 0.04-1
|
||||
- Update to 0.04 (get_package_symbol now doesn't autovivify stash entries; a
|
||||
new method get_or_add_package_symbol can now be used for that behavior)
|
||||
|
||||
* Mon Jun 14 2010 Paul Howarth <paul@city-fan.org> - 0.03-2
|
||||
- Incorporate package review suggestions (#602597)
|
||||
- Use %%{?perl_default_filter}
|
||||
- Use DESTDIR instead of PERL_INSTALL_ROOT
|
||||
|
||||
* Mon Jun 7 2010 Paul Howarth <paul@city-fan.org> - 0.03-1
|
||||
- Initial RPM version
|
Loading…
Reference in New Issue
Block a user