Update to 0.26
- New upstream release 0.26 - Make the namespace cache lazy and weak, in case the stash is deleted - However, this doesn't work on 5.8, so disable the namespace caching entirely there - Update patches to apply cleanly - Bump perl(Package::Stash::XS) version requirement to 0.22 - Bump perl(Dist::CheckConflicts) version requirement to 0.02
This commit is contained in:
parent
a5bb151531
commit
c924b51b5d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/Package-Stash-0.25.tar.gz
|
||||
/Package-Stash-0.26.tar.gz
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Package-Stash-0.23/Makefile.PL.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/Makefile.PL 2011-01-12 09:40:40.425398934 +0000
|
||||
--- Package-Stash-0.26/Makefile.PL.orig 2011-03-04 19:14:06.000000000 +0000
|
||||
+++ Package-Stash-0.26/Makefile.PL 2011-03-05 10:00:04.915785881 +0000
|
||||
@@ -3,7 +3,7 @@
|
||||
BEGIN { require 5.8.1; }
|
||||
use strict;
|
||||
@ -9,16 +9,16 @@
|
||||
check_conflicts();
|
||||
|
||||
my %WriteMakefileArgs = (
|
||||
@@ -15,7 +15,7 @@
|
||||
@@ -16,7 +16,7 @@
|
||||
},
|
||||
'CONFIGURE_REQUIRES' => {
|
||||
'Dist::CheckConflicts' => '0.01',
|
||||
'Dist::CheckConflicts' => '0.02',
|
||||
- 'ExtUtils::MakeMaker' => '6.31'
|
||||
+ 'ExtUtils::MakeMaker' => '0'
|
||||
},
|
||||
'DISTNAME' => 'Package-Stash',
|
||||
'EXE_FILES' => [
|
||||
@@ -51,6 +51,9 @@
|
||||
@@ -52,6 +52,9 @@
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up Package-Stash-0.23/t/01-basic.t.orig Package-Stash-0.23/t/01-basic.t
|
||||
--- Package-Stash-0.23/t/01-basic.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/01-basic.t 2011-01-12 09:43:15.946857521 +0000
|
||||
diff -up Package-Stash-0.26/t/01-basic.t.orig Package-Stash-0.26/t/01-basic.t
|
||||
--- Package-Stash-0.26/t/01-basic.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/01-basic.t 2011-03-05 10:03:21.020143527 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
@ -16,9 +16,9 @@ diff -up Package-Stash-0.23/t/01-basic.t.orig Package-Stash-0.23/t/01-basic.t
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/02-extension.t.orig Package-Stash-0.23/t/02-extension.t
|
||||
--- Package-Stash-0.23/t/02-extension.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/02-extension.t 2011-01-12 09:43:15.963858007 +0000
|
||||
diff -up Package-Stash-0.26/t/02-extension.t.orig Package-Stash-0.26/t/02-extension.t
|
||||
--- Package-Stash-0.26/t/02-extension.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/02-extension.t 2011-03-05 10:03:21.031145231 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
@ -28,15 +28,15 @@ diff -up Package-Stash-0.23/t/02-extension.t.orig Package-Stash-0.23/t/02-extens
|
||||
use Test::Fatal;
|
||||
|
||||
{
|
||||
@@ -70,5 +70,3 @@ is(exception {
|
||||
@@ -72,5 +72,3 @@ is(exception {
|
||||
}, undef, '... created %Foo::baz successfully');
|
||||
|
||||
ok(!defined($Foo::{baz}), '... the %baz slot has still not been created');
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/03-io.t.orig Package-Stash-0.23/t/03-io.t
|
||||
--- Package-Stash-0.23/t/03-io.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/03-io.t 2011-01-12 09:43:15.963858007 +0000
|
||||
diff -up Package-Stash-0.26/t/03-io.t.orig Package-Stash-0.26/t/03-io.t
|
||||
--- Package-Stash-0.26/t/03-io.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/03-io.t 2011-03-05 10:03:21.032145386 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
@ -52,9 +52,9 @@ diff -up Package-Stash-0.23/t/03-io.t.orig Package-Stash-0.23/t/03-io.t
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/04-get.t.orig Package-Stash-0.23/t/04-get.t
|
||||
--- Package-Stash-0.23/t/04-get.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/04-get.t 2011-01-12 09:43:15.964858036 +0000
|
||||
diff -up Package-Stash-0.26/t/04-get.t.orig Package-Stash-0.26/t/04-get.t
|
||||
--- Package-Stash-0.26/t/04-get.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/04-get.t 2011-03-05 10:03:21.033145540 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
@ -70,9 +70,9 @@ diff -up Package-Stash-0.23/t/04-get.t.orig Package-Stash-0.23/t/04-get.t
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/05-isa.t.orig Package-Stash-0.23/t/05-isa.t
|
||||
--- Package-Stash-0.23/t/05-isa.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/05-isa.t 2011-01-12 09:43:15.965858065 +0000
|
||||
diff -up Package-Stash-0.26/t/05-isa.t.orig Package-Stash-0.26/t/05-isa.t
|
||||
--- Package-Stash-0.26/t/05-isa.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/05-isa.t 2011-03-05 10:03:21.033145540 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
@ -92,9 +92,9 @@ diff -up Package-Stash-0.23/t/05-isa.t.orig Package-Stash-0.23/t/05-isa.t
|
||||
-
|
||||
-done_testing;
|
||||
+}
|
||||
diff -up Package-Stash-0.23/t/06-addsub.t.orig Package-Stash-0.23/t/06-addsub.t
|
||||
--- Package-Stash-0.23/t/06-addsub.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/06-addsub.t 2011-01-12 09:43:15.965858065 +0000
|
||||
diff -up Package-Stash-0.26/t/06-addsub.t.orig Package-Stash-0.26/t/06-addsub.t
|
||||
--- Package-Stash-0.26/t/06-addsub.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/06-addsub.t 2011-03-05 10:03:21.034145695 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
@ -110,27 +110,27 @@ diff -up Package-Stash-0.23/t/06-addsub.t.orig Package-Stash-0.23/t/06-addsub.t
|
||||
'... got the right %DB::sub value for dunk with specified args';
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/07-edge-cases.t.orig Package-Stash-0.23/t/07-edge-cases.t
|
||||
--- Package-Stash-0.23/t/07-edge-cases.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/07-edge-cases.t 2011-01-12 09:43:15.966858093 +0000
|
||||
diff -up Package-Stash-0.26/t/07-edge-cases.t.orig Package-Stash-0.26/t/07-edge-cases.t
|
||||
--- Package-Stash-0.26/t/07-edge-cases.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/07-edge-cases.t 2011-03-05 10:03:44.932845747 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 14;
|
||||
+use Test::More tests => 16;
|
||||
use Test::Fatal;
|
||||
|
||||
use Package::Stash;
|
||||
@@ -65,5 +65,3 @@ is(exception { $Bar->add_symbol('$bar',
|
||||
"can add PVNV values");
|
||||
|
||||
use_ok('CompileTime');
|
||||
@@ -80,5 +80,3 @@ use_ok('CompileTime');
|
||||
}
|
||||
ok(!$delete->has_symbol('&bar'), "method goes away when stash is deleted");
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/10-synopsis.t.orig Package-Stash-0.23/t/10-synopsis.t
|
||||
--- Package-Stash-0.23/t/10-synopsis.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/10-synopsis.t 2011-01-12 09:43:15.966858093 +0000
|
||||
diff -up Package-Stash-0.26/t/10-synopsis.t.orig Package-Stash-0.26/t/10-synopsis.t
|
||||
--- Package-Stash-0.26/t/10-synopsis.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/10-synopsis.t 2011-03-05 10:03:21.035145851 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
@ -146,99 +146,9 @@ diff -up Package-Stash-0.23/t/10-synopsis.t.orig Package-Stash-0.23/t/10-synopsi
|
||||
is_deeply(*{ $namespace->{foo} }{HASH}, {bar => 1}, "namespace works properly");
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/impl-selection/01-choice.t.orig Package-Stash-0.23/t/impl-selection/01-choice.t
|
||||
--- Package-Stash-0.23/t/impl-selection/01-choice.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/impl-selection/01-choice.t 2011-01-12 09:43:15.969858179 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 2;
|
||||
|
||||
my $has_xs = eval "require Package::Stash::XS; 1";
|
||||
|
||||
@@ -13,5 +13,3 @@ my $expected = $has_xs ? 'XS' : 'PP';
|
||||
is($Package::Stash::IMPLEMENTATION, $expected,
|
||||
"autodetected properly: $expected");
|
||||
can_ok('Package::Stash', 'new');
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/impl-selection/02-env.t.orig Package-Stash-0.23/t/impl-selection/02-env.t
|
||||
--- Package-Stash-0.23/t/impl-selection/02-env.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/impl-selection/02-env.t 2011-01-12 09:43:15.969858179 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 4;
|
||||
|
||||
# XXX: work around dumb core segfault bug when you delete stashes
|
||||
sub get_impl { eval '$Package::Stash::IMPLEMENTATION' }
|
||||
@@ -25,5 +25,3 @@ SKIP: {
|
||||
is(get_impl, 'XS', "autodetected properly: XS");
|
||||
can_ok('Package::Stash', 'new');
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/impl-selection/03-var.t.orig Package-Stash-0.23/t/impl-selection/03-var.t
|
||||
--- Package-Stash-0.23/t/impl-selection/03-var.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/impl-selection/03-var.t 2011-01-12 09:43:15.970858208 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 4;
|
||||
|
||||
# XXX: work around dumb core segfault bug when you delete stashes
|
||||
sub get_impl { eval '$Package::Stash::IMPLEMENTATION' }
|
||||
@@ -25,5 +25,3 @@ SKIP: {
|
||||
is(get_impl, 'XS', "autodetected properly: XS");
|
||||
can_ok('Package::Stash', 'new');
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/impl-selection/10-basic-pp.t.orig Package-Stash-0.23/t/impl-selection/10-basic-pp.t
|
||||
--- Package-Stash-0.23/t/impl-selection/10-basic-pp.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/impl-selection/10-basic-pp.t 2011-01-12 09:43:15.971858237 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 124;
|
||||
use Test::Fatal;
|
||||
|
||||
BEGIN { $Package::Stash::IMPLEMENTATION = 'PP' }
|
||||
@@ -420,5 +420,3 @@ like(exception {
|
||||
"list_all_symbols CODE",
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/impl-selection/11-basic-xs.t.orig Package-Stash-0.23/t/impl-selection/11-basic-xs.t
|
||||
--- Package-Stash-0.23/t/impl-selection/11-basic-xs.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/impl-selection/11-basic-xs.t 2011-01-12 09:43:15.972858265 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 124;
|
||||
use Test::Fatal;
|
||||
use Test::Requires 'Package::Stash::XS';
|
||||
|
||||
@@ -421,5 +421,3 @@ like(exception {
|
||||
"list_all_symbols CODE",
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/author-20-leaks.t.orig Package-Stash-0.23/t/author-20-leaks.t
|
||||
--- Package-Stash-0.23/t/author-20-leaks.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/author-20-leaks.t 2011-01-12 09:44:54.067671046 +0000
|
||||
diff -up Package-Stash-0.26/t/author-20-leaks.t.orig Package-Stash-0.26/t/author-20-leaks.t
|
||||
--- Package-Stash-0.26/t/author-20-leaks.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/author-20-leaks.t 2011-03-05 10:03:21.060149721 +0000
|
||||
@@ -14,6 +14,8 @@ use Test::More;
|
||||
use Test::Fatal;
|
||||
use Test::LeakTrace;
|
||||
@ -265,9 +175,9 @@ diff -up Package-Stash-0.23/t/author-20-leaks.t.orig Package-Stash-0.23/t/author
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.23/t/author-21-leaks-debug.t.orig Package-Stash-0.23/t/author-21-leaks-debug.t
|
||||
--- Package-Stash-0.23/t/author-21-leaks-debug.t.orig 2011-01-11 17:44:23.000000000 +0000
|
||||
+++ Package-Stash-0.23/t/author-21-leaks-debug.t 2011-01-12 09:44:37.395192951 +0000
|
||||
diff -up Package-Stash-0.26/t/author-21-leaks-debug.t.orig Package-Stash-0.26/t/author-21-leaks-debug.t
|
||||
--- Package-Stash-0.26/t/author-21-leaks-debug.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/author-21-leaks-debug.t 2011-03-05 10:03:21.060149721 +0000
|
||||
@@ -14,6 +14,8 @@ use Test::More;
|
||||
use Test::Fatal;
|
||||
use Test::LeakTrace;
|
||||
@ -294,3 +204,93 @@ diff -up Package-Stash-0.23/t/author-21-leaks-debug.t.orig Package-Stash-0.23/t/
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.26/t/impl-selection/01-choice.t.orig Package-Stash-0.26/t/impl-selection/01-choice.t
|
||||
--- Package-Stash-0.26/t/impl-selection/01-choice.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/impl-selection/01-choice.t 2011-03-05 10:03:21.036146006 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 2;
|
||||
|
||||
my $has_xs = eval "require Package::Stash::XS; 1";
|
||||
|
||||
@@ -13,5 +13,3 @@ my $expected = $has_xs ? 'XS' : 'PP';
|
||||
is($Package::Stash::IMPLEMENTATION, $expected,
|
||||
"autodetected properly: $expected");
|
||||
can_ok('Package::Stash', 'new');
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.26/t/impl-selection/02-env.t.orig Package-Stash-0.26/t/impl-selection/02-env.t
|
||||
--- Package-Stash-0.26/t/impl-selection/02-env.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/impl-selection/02-env.t 2011-03-05 10:03:21.037146160 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 4;
|
||||
|
||||
# XXX: work around dumb core segfault bug when you delete stashes
|
||||
sub get_impl { eval '$Package::Stash::IMPLEMENTATION' }
|
||||
@@ -25,5 +25,3 @@ SKIP: {
|
||||
is(get_impl, 'XS', "autodetected properly: XS");
|
||||
can_ok('Package::Stash', 'new');
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.26/t/impl-selection/03-var.t.orig Package-Stash-0.26/t/impl-selection/03-var.t
|
||||
--- Package-Stash-0.26/t/impl-selection/03-var.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/impl-selection/03-var.t 2011-03-05 10:03:21.037146160 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 4;
|
||||
|
||||
# XXX: work around dumb core segfault bug when you delete stashes
|
||||
sub get_impl { eval '$Package::Stash::IMPLEMENTATION' }
|
||||
@@ -25,5 +25,3 @@ SKIP: {
|
||||
is(get_impl, 'XS', "autodetected properly: XS");
|
||||
can_ok('Package::Stash', 'new');
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.26/t/impl-selection/10-basic-pp.t.orig Package-Stash-0.26/t/impl-selection/10-basic-pp.t
|
||||
--- Package-Stash-0.26/t/impl-selection/10-basic-pp.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/impl-selection/10-basic-pp.t 2011-03-05 10:03:21.048147863 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 124;
|
||||
use Test::Fatal;
|
||||
|
||||
BEGIN { $Package::Stash::IMPLEMENTATION = 'PP' }
|
||||
@@ -420,5 +420,3 @@ like(exception {
|
||||
"list_all_symbols CODE",
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Package-Stash-0.26/t/impl-selection/11-basic-xs.t.orig Package-Stash-0.26/t/impl-selection/11-basic-xs.t
|
||||
--- Package-Stash-0.26/t/impl-selection/11-basic-xs.t.orig 2011-03-04 19:14:05.000000000 +0000
|
||||
+++ Package-Stash-0.26/t/impl-selection/11-basic-xs.t 2011-03-05 10:03:21.056149102 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 124;
|
||||
use Test::Fatal;
|
||||
use Test::Requires 'Package::Stash::XS';
|
||||
|
||||
@@ -421,5 +421,3 @@ like(exception {
|
||||
"list_all_symbols CODE",
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
@ -5,24 +5,24 @@
|
||||
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0)
|
||||
|
||||
Name: perl-Package-Stash
|
||||
Version: 0.25
|
||||
Release: 2%{?dist}
|
||||
Version: 0.26
|
||||
Release: 1%{?dist}
|
||||
Summary: Routines for manipulating stashes
|
||||
Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/Package-Stash/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz
|
||||
Patch0: Package-Stash-0.23-EU::MM-version.patch
|
||||
Patch1: Package-Stash-0.25-old-Test::More.patch
|
||||
Patch0: Package-Stash-0.26-EU::MM-version.patch
|
||||
Patch1: Package-Stash-0.26-old-Test::More.patch
|
||||
Patch2: Package-Stash-0.23-no-Test::Requires.patch
|
||||
Patch3: Package-Stash-0.25-no-Test::LeakTrace.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(Dist::CheckConflicts)
|
||||
BuildRequires: perl(Dist::CheckConflicts) >= 0.02
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
BuildRequires: perl(Scalar::Util)
|
||||
BuildRequires: perl(Package::DeprecationManager)
|
||||
BuildRequires: perl(Package::Stash::XS) >= 0.21
|
||||
BuildRequires: perl(Package::Stash::XS) >= 0.22
|
||||
BuildRequires: perl(Test::EOL)
|
||||
BuildRequires: perl(Test::Fatal)
|
||||
BuildRequires: perl(Test::More)
|
||||
@ -41,7 +41,7 @@ BuildRequires: perl(Test::Script)
|
||||
%endif
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||
# For performance and consistency
|
||||
Requires: perl(Package::Stash::XS) >= 0.21
|
||||
Requires: perl(Package::Stash::XS) >= 0.22
|
||||
# Not found by rpm auto-provides
|
||||
Provides: perl(Package::Stash::Conflicts) = 0
|
||||
|
||||
@ -101,6 +101,15 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man3/Package::Stash::PP.3pm*
|
||||
|
||||
%changelog
|
||||
* Sat Mar 5 2011 Paul Howarth <paul@city-fan.org> - 0.26-1
|
||||
- Update to 0.26
|
||||
- Make the namespace cache lazy and weak, in case the stash is deleted
|
||||
- However, this doesn't work on 5.8, so disable the namespace caching
|
||||
entirely there
|
||||
- Update patches to apply cleanly
|
||||
- Bump perl(Package::Stash::XS) version requirement to 0.22
|
||||
- Bump perl(Dist::CheckConflicts) version requirement to 0.02
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user