Update to 0.30

- New upstream release 0.30
  - Fix compiler detection in Makefile.PL
- Update patch for old ExtUtils::MakeMaker versions
- Drop usage of macros for commands
- Drop redundant %{?perl_default_filter}
- perl(Pod::Coverage::TrustPod) now available everywhere
This commit is contained in:
Paul Howarth 2011-07-21 22:32:29 +01:00
parent 70b41f1fb4
commit 9957c0744f
4 changed files with 25 additions and 19 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/Package-Stash-0.29.tar.gz /Package-Stash-[0-9.]*\.tar\.gz

View File

@ -1,10 +1,10 @@
--- Package-Stash-0.28/Makefile.PL.orig 2011-03-29 20:22:52.000000000 +0100 --- Package-Stash/Makefile.PL
+++ Package-Stash-0.28/Makefile.PL 2011-03-30 11:32:41.861104891 +0100 +++ Package-Stash/Makefile.PL
@@ -3,7 +3,7 @@ @@ -3,7 +3,7 @@
BEGIN { require 5.8.1; } BEGIN { require 5.8.1; }
use strict; use strict;
use warnings; use warnings;
-use ExtUtils::MakeMaker 6.31; -use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker; +use ExtUtils::MakeMaker;
check_conflicts(); check_conflicts();
@ -13,7 +13,7 @@
}, },
'CONFIGURE_REQUIRES' => { 'CONFIGURE_REQUIRES' => {
'Dist::CheckConflicts' => '0.02', 'Dist::CheckConflicts' => '0.02',
- 'ExtUtils::MakeMaker' => '6.31' - 'ExtUtils::MakeMaker' => '6.30'
+ 'ExtUtils::MakeMaker' => '0' + 'ExtUtils::MakeMaker' => '0'
}, },
'DISTNAME' => 'Package-Stash', 'DISTNAME' => 'Package-Stash',
@ -23,7 +23,7 @@
unless eval { ExtUtils::MakeMaker->VERSION(6.52) }; unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE} +delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) }; + unless eval { ExtUtils::MakeMaker->VERSION(6.30) };
+ +
$WriteMakefileArgs{PREREQ_PM}{'Package::Stash::XS'} = 0.22 $WriteMakefileArgs{PREREQ_PM}{'Package::Stash::XS'} = 0.22
if can_cc(); if can_cc();

View File

@ -1,37 +1,37 @@
# We need to patch the test suite if we have an old version of Test::More # We need to patch the test suite if we have an old version of Test::More
%global old_test_more %(perl -MTest::More -e 'printf "%d\\n", $Test::More::VERSION < 0.88 ? 1 : 0;' 2>/dev/null || echo 0) %global old_test_more %(perl -MTest::More -e 'printf "%d\\n", $Test::More::VERSION < 0.88 ? 1 : 0;' 2>/dev/null || echo 0)
# We don't really need ExtUtils::MakeMaker > 6.31 # We don't really need ExtUtils::MakeMaker ≥ 6.30
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0) %global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.30 ? 1 : 0;' 2>/dev/null || echo 0)
Name: perl-Package-Stash Name: perl-Package-Stash
Version: 0.29 Version: 0.30
Release: 2%{?dist} Release: 1%{?dist}
Summary: Routines for manipulating stashes Summary: Routines for manipulating stashes
Group: Development/Libraries Group: Development/Libraries
License: GPL+ or Artistic License: GPL+ or Artistic
URL: http://search.cpan.org/dist/Package-Stash/ URL: http://search.cpan.org/dist/Package-Stash/
Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz
Patch0: Package-Stash-0.28-EU::MM-version.patch Patch0: Package-Stash-0.30-EU::MM-version.patch
Patch1: Package-Stash-0.26-old-Test::More.patch Patch1: Package-Stash-0.26-old-Test::More.patch
Patch2: Package-Stash-0.23-no-Test::Requires.patch Patch2: Package-Stash-0.23-no-Test::Requires.patch
Patch3: Package-Stash-0.25-no-Test::LeakTrace.patch Patch3: Package-Stash-0.25-no-Test::LeakTrace.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch BuildArch: noarch
BuildRequires: perl(Dist::CheckConflicts) >= 0.02 BuildRequires: perl(Dist::CheckConflicts) >= 0.02
BuildRequires: perl(ExtUtils::MakeMaker) BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(Scalar::Util) BuildRequires: perl(Scalar::Util)
BuildRequires: perl(Package::DeprecationManager) BuildRequires: perl(Package::DeprecationManager)
BuildRequires: perl(Package::Stash::XS) >= 0.22 BuildRequires: perl(Package::Stash::XS) >= 0.22
BuildRequires: perl(Pod::Coverage::TrustPod)
BuildRequires: perl(Test::EOL) BuildRequires: perl(Test::EOL)
BuildRequires: perl(Test::Fatal) BuildRequires: perl(Test::Fatal)
BuildRequires: perl(Test::More) BuildRequires: perl(Test::More)
BuildRequires: perl(Test::NoTabs) BuildRequires: perl(Test::NoTabs)
BuildRequires: perl(Test::Pod) BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage) BuildRequires: perl(Test::Pod::Coverage)
# Pod::Coverage::TrustPod and Test::Requires not in EPEL-4 # Test::Requires not in EPEL-4
%if "%{?rhel}" != "4" %if "%{?rhel}" != "4"
BuildRequires: perl(Pod::Coverage::TrustPod)
BuildRequires: perl(Test::Requires) BuildRequires: perl(Test::Requires)
%endif %endif
# Test::LeakTrace and Test::Script not in EPEL-4 or EPEL-5 # Test::LeakTrace and Test::Script not in EPEL-4 or EPEL-5
@ -39,14 +39,12 @@ BuildRequires: perl(Test::Requires)
BuildRequires: perl(Test::LeakTrace) BuildRequires: perl(Test::LeakTrace)
BuildRequires: perl(Test::Script) BuildRequires: perl(Test::Script)
%endif %endif
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
# For performance and consistency # For performance and consistency
Requires: perl(Package::Stash::XS) >= 0.22 Requires: perl(Package::Stash::XS) >= 0.22
# Not found by rpm auto-provides # Not found by rpm auto-provides
Provides: perl(Package::Stash::Conflicts) = 0 Provides: perl(Package::Stash::Conflicts) = 0
%{?perl_default_filter}
%description %description
Manipulating stashes (Perl's symbol tables) is occasionally necessary, but Manipulating stashes (Perl's symbol tables) is occasionally necessary, but
incredibly messy, and easy to get wrong. This module hides all of that behind incredibly messy, and easy to get wrong. This module hides all of that behind
@ -55,7 +53,7 @@ a simple API.
%prep %prep
%setup -q -n Package-Stash-%{version} %setup -q -n Package-Stash-%{version}
# Don't really need ExtUtils::MakeMaker >= 6.31 # Don't really need ExtUtils::MakeMaker ≥ 6.30
%if %{old_eumm} %if %{old_eumm}
%patch0 -p1 %patch0 -p1
%endif %endif
@ -101,6 +99,14 @@ rm -rf %{buildroot}
%{_mandir}/man3/Package::Stash::PP.3pm* %{_mandir}/man3/Package::Stash::PP.3pm*
%changelog %changelog
* Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 0.30-1
- Update to 0.30
- Fix compiler detection in Makefile.PL
- Update patch for old ExtUtils::MakeMaker versions
- Drop usage of macros for commands
- Drop redundant %%{?perl_default_filter}
- perl(Pod::Coverage::TrustPod) now available everywhere
* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.29-2 * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.29-2
- Perl mass rebuild - Perl mass rebuild

View File

@ -1 +1 @@
d7d2ee9dde5c0109c3a6d229458405f9 Package-Stash-0.29.tar.gz 15877ab44448d85ce36418a7d3b8a5af Package-Stash-0.30.tar.gz