Update to 0.08
Update to latest upstream release, 0.08: - Re-enable the caching of the stash Update patch for old ExtUtils::MakeMaker and Test::More versions
This commit is contained in:
parent
6730da510c
commit
58da17c7ec
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
Package-Stash-0.05.tar.gz
|
||||
/Package-Stash-0.08.tar.gz
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Package-Stash-0.03/Makefile.PL 2010-05-14 17:41:34.000000000 +0100
|
||||
+++ Package-Stash-0.03/Makefile.PL 2010-06-14 07:48:41.809872623 +0100
|
||||
--- Package-Stash-0.08/Makefile.PL 2010-09-19 02:17:49.000000000 +0100
|
||||
+++ Package-Stash-0.08/Makefile.PL 2010-09-20 11:34:35.619285663 +0100
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
|
||||
@ -9,16 +9,16 @@
|
||||
|
||||
|
||||
|
||||
@@ -13,7 +13,7 @@
|
||||
'AUTHOR' => 'Jesse Luehrs <doy at tozt dot net>',
|
||||
'BUILD_REQUIRES' => {},
|
||||
@@ -16,7 +16,7 @@
|
||||
'Test::More' => '0.88'
|
||||
},
|
||||
'CONFIGURE_REQUIRES' => {
|
||||
- 'ExtUtils::MakeMaker' => '6.31'
|
||||
+ 'ExtUtils::MakeMaker' => '0'
|
||||
},
|
||||
'DISTNAME' => 'Package-Stash',
|
||||
'EXE_FILES' => [],
|
||||
@@ -46,6 +46,9 @@
|
||||
@@ -48,6 +48,9 @@
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
||||
|
@ -1,18 +1,18 @@
|
||||
diff -up Package-Stash-0.05/t/01-basic.t.orig Package-Stash-0.05/t/01-basic.t
|
||||
--- Package-Stash-0.05/t/01-basic.t.orig 2010-05-14 17:41:34.000000000 +0100
|
||||
+++ Package-Stash-0.05/t/01-basic.t 2010-06-07 09:53:18.570100938 +0100
|
||||
diff -up Package-Stash-0.08/t/01-basic.t.orig Package-Stash-0.08/t/01-basic.t
|
||||
--- Package-Stash-0.08/t/01-basic.t.orig 2010-09-19 02:17:49.000000000 +0100
|
||||
+++ Package-Stash-0.08/t/01-basic.t 2010-09-20 11:37:09.187162663 +0100
|
||||
@@ -1,7 +1,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
|
||||
-use Test::More;
|
||||
+use Test::More tests => 93;
|
||||
+use Test::More tests => 110;
|
||||
use Test::Exception;
|
||||
|
||||
use Package::Stash;
|
||||
@@ -269,5 +269,3 @@ dies_ok {
|
||||
ok(!$stash->has_package_symbol('&foo'), "got \&foo");
|
||||
is($stash->get_package_symbol('foo'), *Baz::foo{IO}, "got foo");
|
||||
@@ -323,5 +323,3 @@
|
||||
);
|
||||
}
|
||||
}
|
||||
-
|
||||
-done_testing;
|
@ -5,15 +5,15 @@
|
||||
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0)
|
||||
|
||||
Name: perl-Package-Stash
|
||||
Version: 0.05
|
||||
Version: 0.08
|
||||
Release: 1%{?dist}
|
||||
Summary: Routines for manipulating stashes
|
||||
Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/Package-Stash/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz
|
||||
Patch0: Package-Stash-0.03-EU::MM-version.patch
|
||||
Patch1: Package-Stash-0.05-old-Test::More.patch
|
||||
Patch0: Package-Stash-0.08-EU::MM-version.patch
|
||||
Patch1: Package-Stash-0.08-old-Test::More.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
@ -74,6 +74,10 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man3/Package::Stash.3pm*
|
||||
|
||||
%changelog
|
||||
* Mon Sep 20 2010 Paul Howarth <paul@city-fan.org> - 0.08-1
|
||||
- Update to 0.08 (re-enable the caching of the stash)
|
||||
- Update patch for old ExtUtils::MakeMaker and Test::More versions
|
||||
|
||||
* Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> - 0.05-1
|
||||
- Update to 0.05
|
||||
- Bump Test::More requirement for done_testing
|
||||
|
Loading…
Reference in New Issue
Block a user