import perl-Package-Stash-XS-0.28-17.el8
This commit is contained in:
commit
5d421d0aff
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/Package-Stash-XS-0.28.tar.gz
|
1
.perl-Package-Stash-XS.metadata
Normal file
1
.perl-Package-Stash-XS.metadata
Normal file
@ -0,0 +1 @@
|
||||
9b87618d7cd5b26da683c644f69d4e59f0511aa9 SOURCES/Package-Stash-XS-0.28.tar.gz
|
387
SOURCES/Package-Stash-XS-0.27-old-Test::More.patch
Normal file
387
SOURCES/Package-Stash-XS-0.27-old-Test::More.patch
Normal file
@ -0,0 +1,387 @@
|
||||
diff -up ./t/addsub.t.orig ./t/addsub.t
|
||||
--- ./t/addsub.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/addsub.t 2013-07-16 09:28:05.247418080 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 7;
|
||||
use Test::Fatal;
|
||||
|
||||
BEGIN { $^P |= 0x210 } # PERLDBf_SUBLINE
|
||||
@@ -42,5 +42,3 @@ $foo_stash->add_symbol(
|
||||
|
||||
is $DB::sub{'Foo::dunk'}, sprintf "%s:%d-%d", "FileName", 100, 199,
|
||||
'... got the right %DB::sub value for dunk with specified args';
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/anon-basic.t.orig ./t/anon-basic.t
|
||||
--- ./t/anon-basic.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/anon-basic.t 2013-07-16 09:28:05.247418080 +0100
|
||||
@@ -399,5 +399,3 @@ $Quuux->{quuuux} = -1;
|
||||
|
||||
is_deeply([Package::Stash->new('Quuux')->list_all_symbols], [],
|
||||
"Quuux:: isn't touched");
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/anon.t.orig ./t/anon.t
|
||||
--- ./t/anon.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/anon.t 2013-07-16 09:28:05.247418080 +0100
|
||||
@@ -45,5 +45,3 @@ my $obj = $anon->bless({});
|
||||
qr/Undefined subroutine \&__ANON__::baz called/
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/bare-anon-basic.t.orig ./t/bare-anon-basic.t
|
||||
--- ./t/bare-anon-basic.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/bare-anon-basic.t 2013-07-16 09:28:05.247418080 +0100
|
||||
@@ -14,6 +14,8 @@ plan skip_all => "Anonymous stashes in P
|
||||
|
||||
plan skip_all => "This isn't really going to work yet, probably";
|
||||
|
||||
+plan tests => 1; # Will count properly when this test isn't unconditionally skipped
|
||||
+
|
||||
my $Foo = {};
|
||||
$Foo->{SOME_CONSTANT} = \1;
|
||||
|
||||
@@ -393,5 +395,3 @@ $Quuux->{quuuux} = -1;
|
||||
|
||||
is_deeply([Package::Stash->new('Quuux')->list_all_symbols], [],
|
||||
"Quuux:: isn't touched");
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/bare-anon.t.orig ./t/bare-anon.t
|
||||
--- ./t/bare-anon.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/bare-anon.t 2013-07-16 09:28:05.248418078 +0100
|
||||
@@ -14,6 +14,8 @@ plan skip_all => "Anonymous stashes in P
|
||||
|
||||
plan skip_all => "This isn't really going to work yet, probably";
|
||||
|
||||
+plan tests => 7;
|
||||
+
|
||||
my $anon = {};
|
||||
my $stash = Package::Stash->new($anon);
|
||||
# no way to bless something into a hashref yet
|
||||
@@ -58,5 +60,3 @@ my $stash = Package::Stash->new($anon);
|
||||
undef
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/basic.t.orig ./t/basic.t
|
||||
--- ./t/basic.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/basic.t 2013-07-16 09:28:05.248418078 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 131;
|
||||
use Test::Fatal;
|
||||
|
||||
use Package::Stash;
|
||||
@@ -444,5 +444,3 @@ like(
|
||||
qr/^Package::Stash->new must be passed the name of the package to access/,
|
||||
"module name must be a string"
|
||||
);
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/compile-time.t.orig ./t/compile-time.t
|
||||
--- ./t/compile-time.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/compile-time.t 2013-07-16 09:28:05.248418078 +0100
|
||||
@@ -2,8 +2,6 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 1;
|
||||
|
||||
use_ok('CompileTime');
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/edge-cases.t.orig ./t/edge-cases.t
|
||||
--- ./t/edge-cases.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/edge-cases.t 2013-07-16 09:28:05.249418076 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 19;
|
||||
use Test::Fatal;
|
||||
|
||||
use Package::Stash;
|
||||
@@ -109,5 +109,3 @@ SKIP: {
|
||||
my $stash = Package::Stash->new('HasISA');
|
||||
is_deeply([$stash->list_all_symbols('SCALAR')], []);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/extension.t.orig ./t/extension.t
|
||||
--- ./t/extension.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/extension.t 2013-07-16 09:28:05.249418076 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 15;
|
||||
use Test::Fatal;
|
||||
|
||||
{
|
||||
@@ -72,5 +72,3 @@ is(exception {
|
||||
}, undef, '... created %Foo::baz successfully');
|
||||
|
||||
ok(!defined($Foo::{baz}), '... the %baz slot has still not been created');
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/get.t.orig ./t/get.t
|
||||
--- ./t/get.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/get.t 2013-07-16 09:28:05.249418076 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 36;
|
||||
|
||||
use Package::Stash;
|
||||
use Scalar::Util;
|
||||
@@ -182,5 +182,3 @@ use Scalar::Util;
|
||||
"stash has the right variable");
|
||||
}
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/io.t.orig ./t/io.t
|
||||
--- ./t/io.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/io.t 2013-07-16 09:28:05.249418076 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 11;
|
||||
use Test::Fatal;
|
||||
|
||||
{
|
||||
@@ -47,5 +47,3 @@ use Package::Stash;
|
||||
ok($stash->has_symbol('baz'), "has baz");
|
||||
is($stash->get_symbol('baz'), *Foo::foo{IO}, "got the right baz");
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/isa.t.orig ./t/isa.t
|
||||
--- ./t/isa.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/isa.t 2013-07-16 09:28:05.250418075 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 8;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -19,7 +19,10 @@ use Package::Stash;
|
||||
my $stash = Package::Stash->new('Foo');
|
||||
my @ISA = ('Bar');
|
||||
@{$stash->get_or_add_symbol('@ISA')} = @ISA;
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Foo', 'Bar');
|
||||
+ }
|
||||
isa_ok(bless({}, 'Foo'), 'Bar');
|
||||
}
|
||||
|
||||
@@ -33,17 +36,22 @@ use Package::Stash;
|
||||
{
|
||||
my $isa = $stash->get_or_add_symbol('@ISA');
|
||||
@$isa = ('Baz');
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Quux', 'Baz');
|
||||
+ }
|
||||
isa_ok(bless({}, 'Quux'), 'Baz');
|
||||
ok(Quux->can('foo'));
|
||||
}
|
||||
{
|
||||
my $isa = $stash->get_or_add_symbol('@ISA');
|
||||
@$isa = ('Bar');
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Quux', 'Bar');
|
||||
+ }
|
||||
isa_ok(bless({}, 'Quux'), 'Bar');
|
||||
ok(Quux->can('bar'));
|
||||
}
|
||||
}
|
||||
|
||||
-done_testing;
|
||||
diff -up ./t/magic.t.orig ./t/magic.t
|
||||
--- ./t/magic.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/magic.t 2013-07-16 09:28:05.250418075 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 14;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -76,5 +76,3 @@ SKIP: {
|
||||
is($fetch, 1, "get_or_add_symbol fetches (populated slot)");
|
||||
is($store, 0, "get_or_add_symbol stores (populated slot)");
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/paamayim_nekdotayim.t.orig ./t/paamayim_nekdotayim.t
|
||||
--- ./t/paamayim_nekdotayim.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/paamayim_nekdotayim.t 2013-07-16 09:28:05.250418075 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 3;
|
||||
use Test::Fatal;
|
||||
|
||||
use Package::Stash;
|
||||
@@ -24,5 +24,3 @@ like(
|
||||
qr/^Variable names may not contain ::/,
|
||||
"can't add symbol with ::"
|
||||
);
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/scalar-values.t.orig ./t/scalar-values.t
|
||||
--- ./t/scalar-values.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/scalar-values.t 2013-07-16 09:28:05.250418075 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 14;
|
||||
use Test::Fatal;
|
||||
|
||||
use B;
|
||||
@@ -49,5 +49,3 @@ my $vstring = v1.2.3;
|
||||
is(reftype(\$vstring), ($] < 5.010 ? 'SCALAR' : 'VSTRING'));
|
||||
is(exception { $Bar->add_symbol('$vstring', \$vstring) }, undef,
|
||||
"can add vstring values");
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/stash-deletion.t.orig ./t/stash-deletion.t
|
||||
--- ./t/stash-deletion.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/stash-deletion.t 2013-07-16 09:28:05.250418075 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 2;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -20,5 +20,3 @@ use Package::Stash;
|
||||
}
|
||||
ok(!$delete->has_symbol('&bar'), "method goes away when stash is deleted");
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/synopsis.t.orig ./t/synopsis.t
|
||||
--- ./t/synopsis.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./t/synopsis.t 2013-07-16 09:28:05.251418072 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 3;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -15,5 +15,3 @@ $stash->add_symbol('%foo', {bar => 1});
|
||||
ok(!$stash->has_symbol('$foo'), "doesn't have anything in scalar slot");
|
||||
my $namespace = $stash->namespace;
|
||||
is_deeply(*{ $namespace->{foo} }{HASH}, {bar => 1}, "namespace works properly");
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./t/warnings.t.orig ./t/warnings.t
|
||||
--- ./t/warnings.t.orig 2013-07-16 09:28:05.244418086 +0100
|
||||
+++ ./t/warnings.t 2013-07-16 09:28:25.408377267 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
use lib 't/lib';
|
||||
-use Test::More;
|
||||
+use Test::More tests => 1;
|
||||
|
||||
use Package::Stash;
|
||||
|
||||
@@ -19,4 +19,3 @@ BEGIN {
|
||||
|
||||
is($warnings, '');
|
||||
|
||||
-done_testing;
|
||||
diff -up ./xt/author/leaks-debug.t.orig ./xt/author/leaks-debug.t
|
||||
--- ./xt/author/leaks-debug.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./xt/author/leaks-debug.t 2013-07-16 09:28:05.251418072 +0100
|
||||
@@ -11,6 +11,8 @@ BEGIN { $^P |= 0x210 } # PERLDBf_SUBLINE
|
||||
use Package::Stash;
|
||||
use Symbol;
|
||||
|
||||
+plan tests => 45;
|
||||
+
|
||||
{
|
||||
package Bar;
|
||||
}
|
||||
@@ -176,7 +178,10 @@ use Symbol;
|
||||
ok($foo->has_symbol('@ISA'));
|
||||
is(ref($foo->get_symbol('@ISA')), 'ARRAY');
|
||||
is_deeply($foo->get_symbol('@ISA'), ['Exporter']);
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Foo', 'Exporter');
|
||||
+ }
|
||||
}
|
||||
|
||||
{
|
||||
@@ -226,5 +231,3 @@ use Symbol;
|
||||
eval { $foo->add_symbol('&blorg') };
|
||||
} "doesn't leak on errors";
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up ./xt/author/leaks.t.orig ./xt/author/leaks.t
|
||||
--- ./xt/author/leaks.t.orig 2013-07-15 20:57:19.000000000 +0100
|
||||
+++ ./xt/author/leaks.t 2013-07-16 09:28:05.252418070 +0100
|
||||
@@ -9,6 +9,8 @@ use Test::LeakTrace;
|
||||
use Package::Stash;
|
||||
use Symbol;
|
||||
|
||||
+plan tests => 45;
|
||||
+
|
||||
{
|
||||
package Bar;
|
||||
}
|
||||
@@ -174,7 +176,10 @@ use Symbol;
|
||||
ok($foo->has_symbol('@ISA'));
|
||||
is(ref($foo->get_symbol('@ISA')), 'ARRAY');
|
||||
is_deeply($foo->get_symbol('@ISA'), ['Exporter']);
|
||||
+ SKIP: {
|
||||
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
|
||||
isa_ok('Foo', 'Exporter');
|
||||
+ }
|
||||
}
|
||||
|
||||
{
|
||||
@@ -224,5 +229,3 @@ use Symbol;
|
||||
eval { $foo->add_symbol('&blorg') };
|
||||
} "doesn't leak on errors";
|
||||
}
|
||||
-
|
||||
-done_testing;
|
265
SPECS/perl-Package-Stash-XS.spec
Normal file
265
SPECS/perl-Package-Stash-XS.spec
Normal file
@ -0,0 +1,265 @@
|
||||
%if ! (0%{?rhel})
|
||||
# Run extra test
|
||||
%bcond_without perl_Package_Stash_XS_enables_extra_test
|
||||
# Run optional test
|
||||
%bcond_without perl_Package_Stash_XS_enables_optional_test
|
||||
%else
|
||||
%bcond_with perl_Package_Stash_XS_enables_extra_test
|
||||
%bcond_with perl_Package_Stash_XS_enables_optional_test
|
||||
%endif
|
||||
|
||||
Name: perl-Package-Stash-XS
|
||||
Version: 0.28
|
||||
Release: 17%{?dist}
|
||||
Summary: Faster and more correct implementation of the Package::Stash API
|
||||
Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/Package-Stash-XS/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-XS-%{version}.tar.gz
|
||||
Patch1: Package-Stash-XS-0.27-old-Test::More.patch
|
||||
# Module Build
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: gcc
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-interpreter >= 3:5.8.1
|
||||
%if "%{?rhel}" != "5"
|
||||
BuildRequires: perl-devel
|
||||
%endif
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
|
||||
# Module Runtime
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(warnings)
|
||||
BuildRequires: perl(XSLoader)
|
||||
# Test Suite
|
||||
BuildRequires: perl(B)
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(constant)
|
||||
BuildRequires: perl(File::Find)
|
||||
BuildRequires: perl(File::Temp)
|
||||
BuildRequires: perl(lib)
|
||||
BuildRequires: perl(Scalar::Util)
|
||||
BuildRequires: perl(Symbol)
|
||||
BuildRequires: perl(Test::Fatal)
|
||||
BuildRequires: perl(Test::More)
|
||||
BuildRequires: perl(Test::Requires)
|
||||
%if %{with perl_Package_Stash_XS_enables_optional_test}
|
||||
# Optional Tests
|
||||
%if 0%{?fedora} > 15 || 0%{?rhel} > 6
|
||||
BuildRequires: perl(Package::Anon)
|
||||
%endif
|
||||
%if "%{?rhel}" != "5"
|
||||
BuildRequires: perl(Variable::Magic)
|
||||
%endif
|
||||
%endif
|
||||
%if %{with perl_Package_Stash_XS_enables_extra_test}
|
||||
# Author Tests
|
||||
%if ! (0%{?rhel} >= 7)
|
||||
BuildRequires: perl(Test::LeakTrace)
|
||||
%endif
|
||||
# Release Tests
|
||||
BuildRequires: perl(Pod::Coverage::TrustPod)
|
||||
BuildRequires: perl(Test::EOL)
|
||||
BuildRequires: perl(Test::NoTabs)
|
||||
BuildRequires: perl(Test::Pod)
|
||||
BuildRequires: perl(Test::Pod::Coverage)
|
||||
%endif
|
||||
# Dependencies
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
|
||||
# Don't "provide" private Perl libs
|
||||
%{?perl_default_filter}
|
||||
|
||||
%description
|
||||
This is a back-end for Package::Stash, which provides the functionality in a
|
||||
way that's less buggy and much faster. It will be used by default if it's
|
||||
installed, and should be preferred in all environments with a compiler.
|
||||
|
||||
%prep
|
||||
%setup -q -n Package-Stash-XS-%{version}
|
||||
|
||||
# Patch test suite to work with old Test::More versions if necessary
|
||||
%if "%{?rhel}" == "5"
|
||||
%patch1 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make pure_install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name .packlist -delete
|
||||
find %{buildroot} -type f -name '*.bs' -empty -delete
|
||||
%{_fixperms} %{buildroot}
|
||||
|
||||
%check
|
||||
make test
|
||||
%if %{with perl_Package_Stash_XS_enables_extra_test}
|
||||
%if ! (0%{?rhel} >= 7)
|
||||
make test TEST_FILES="$(echo $(find xt/ -name '*.t'))"
|
||||
%else
|
||||
make test TEST_FILES="$(echo $(find xt/release/ -name '*.t'))"
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%files
|
||||
%if 0%{?_licensedir:1}
|
||||
%license LICENSE
|
||||
%else
|
||||
%doc LICENSE
|
||||
%endif
|
||||
%doc Changes README
|
||||
%{perl_vendorarch}/auto/Package/
|
||||
%{perl_vendorarch}/Package/
|
||||
%{_mandir}/man3/Package::Stash::XS.3*
|
||||
|
||||
%changelog
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-14
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Jul 21 2016 Paul Howarth <paul@city-fan.org> - 0.28-12
|
||||
- Fix FTBFS when perl is not in the SRPM build root
|
||||
|
||||
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-11
|
||||
- Perl 5.24 rebuild
|
||||
|
||||
* Tue Apr 19 2016 Paul Howarth <paul@city-fan.org> - 0.28-10
|
||||
- Classify buildreqs by usage
|
||||
- Use %%license where possible
|
||||
- Simplify find commands using -empty and -delete
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-7
|
||||
- Perl 5.22 rebuild
|
||||
|
||||
* Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-6
|
||||
- Perl 5.20 rebuild
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Jul 26 2013 Petr Pisar <ppisar@redhat.com> - 0.28-2
|
||||
- Perl 5.18 rebuild
|
||||
|
||||
* Tue Jul 16 2013 Paul Howarth <paul@city-fan.org> - 0.28-1
|
||||
- Update to 0.28
|
||||
- Fix test issue
|
||||
|
||||
* Tue Jul 16 2013 Paul Howarth <paul@city-fan.org> - 0.27-1
|
||||
- Update to 0.27
|
||||
- Handle magic more correctly in add_symbol and get_or_add_symbol
|
||||
- Add upstream patch to avoid build dependency on Package::Stash
|
||||
- BR: perl(Variable::Magic) for the test suite
|
||||
- Update patch for building with old Test::More versions
|
||||
|
||||
* Thu Jan 24 2013 Paul Howarth <paul@city-fan.org> - 0.26-2
|
||||
- BR: perl(Package::Anon) if we have Perl ≥ 5.14
|
||||
|
||||
* Fri Jan 4 2013 Paul Howarth <paul@city-fan.org> - 0.26-1
|
||||
- Update to 0.26
|
||||
- Internal refactorings to support Package::Anon stashes
|
||||
- BR: perl(base) and perl(Test::Requires) for test suite
|
||||
- Update patch for old distro compatibility
|
||||
- Explicitly run the release/author tests
|
||||
|
||||
* Mon Aug 27 2012 Petr Pisar <ppisar@redhat.com> - 0.25-7
|
||||
- Disable author tests on RHEL >= 7
|
||||
|
||||
* Sat Aug 25 2012 Paul Howarth <paul@city-fan.org> - 0.25-6
|
||||
- Drop EPEL-4 support
|
||||
- Test::LeakTrace now universally available
|
||||
- Suitably recent version of ExtUtils::MakeMaker now universally available
|
||||
- Drop %%defattr, redundant since rpm 4.4
|
||||
- BR: perl(File::Temp)
|
||||
- Don't need to remove empty directories from the buildroot
|
||||
|
||||
* Tue Aug 14 2012 Petr Pisar <ppisar@redhat.com> - 0.25-5
|
||||
- Specify all dependencies
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Jun 19 2012 Petr Pisar <ppisar@redhat.com> - 0.25-3
|
||||
- Perl 5.16 rebuild
|
||||
|
||||
* Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.25-2
|
||||
- Use %%{_fixperms} macro instead of our own chmod incantation
|
||||
|
||||
* Tue Sep 6 2011 Paul Howarth <paul@city-fan.org> - 0.25-1
|
||||
- Update to 0.25
|
||||
- Invalid package names (for instance, Foo:Bar) are not allowed
|
||||
- Invalid stash entry names (anything containing ::) are not allowed
|
||||
- Update patches to apply cleanly
|
||||
|
||||
* Tue Aug 9 2011 Paul Howarth <paul@city-fan.org> - 0.23-1
|
||||
- Update to 0.23
|
||||
- Fix the test for scalar values, again
|
||||
- Disallow assigning globrefs to scalar glob slots (this doesn't actually
|
||||
make any sense)
|
||||
- Update patches for old ExtUtils::MakeMaker and Test::More versions
|
||||
- perl(Pod::Coverage::TrustPod) now available in EPEL-4 too
|
||||
- Don't use macros for commands
|
||||
|
||||
* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.22-2
|
||||
- Perl mass rebuild
|
||||
|
||||
* Sat Mar 5 2011 Paul Howarth <paul@city-fan.org> - 0.22-1
|
||||
- Update to 0.22
|
||||
- Make the namespace cache lazy and weak, in case the stash is deleted
|
||||
- However, this doesn't work on 5.8, so disable the namespace caching
|
||||
entirely there
|
||||
- Update patches to apply cleanly
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.21-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Jan 25 2011 Paul Howarth <paul@city-fan.org> - 0.21-1
|
||||
- Update to 0.21
|
||||
- Make the leak tests author-only, since some smokers run release tests
|
||||
- Fix some XS forward compat stuff
|
||||
- Update patches to apply cleanly
|
||||
|
||||
* Wed Jan 12 2011 Paul Howarth <paul@city-fan.org> - 0.20-1
|
||||
- Update to 0.20
|
||||
- Lower perl prereq to 5.8.1
|
||||
- Make the leak tests release-only
|
||||
- Update patches to apply cleanly
|
||||
- Drop no-Test::Requires patch, no longer needed
|
||||
- Drop buildreq perl(Test::Requires), no longer needed
|
||||
- Add patch to skip memory leak tests if we don't have Test::LeakTrace
|
||||
|
||||
* Thu Jan 6 2011 Paul Howarth <paul@city-fan.org> - 0.19-1
|
||||
- Update to 0.19 (more correct validity test for scalars)
|
||||
- Update patch for old Test::More versions
|
||||
|
||||
* Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.17-2
|
||||
- Sanitize spec for Fedora submission
|
||||
|
||||
* Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.17-1
|
||||
- Initial RPM build
|
Loading…
Reference in New Issue
Block a user