Fix building on Perl without '.' in @INC (CPAN RT#121744)

This commit is contained in:
Jitka Plesnikova 2017-05-17 14:28:01 +02:00
parent cd9c2ed6f4
commit 58304f2c8a
2 changed files with 27 additions and 5 deletions

View File

@ -0,0 +1,8 @@
diff -up Module-Install-ReadmeMarkdownFromPod-0.03/Makefile.PL.orig Module-Install-ReadmeMarkdownFromPod-0.03/Makefile.PL
--- Module-Install-ReadmeMarkdownFromPod-0.03/Makefile.PL.orig 2017-05-17 14:10:48.175903465 +0200
+++ Module-Install-ReadmeMarkdownFromPod-0.03/Makefile.PL 2017-05-17 14:22:29.436971976 +0200
@@ -1,3 +1,4 @@
+BEGIN { push @INC, '.'; }
use inc::Module::Install;
include 'Module::AutoInstall';

View File

@ -1,12 +1,16 @@
Name: perl-Module-Install-ReadmeMarkdownFromPod
Version: 0.03
Release: 11%{?dist}
Release: 12%{?dist}
Summary: Create README.mkdn from POD
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/Module-Install-ReadmeMarkdownFromPod/
Source0: http://www.cpan.org/authors/id/M/MA/MARCEL/Module-Install-ReadmeMarkdownFromPod-%{version}.tar.gz
Patch0: Module-Install-ReadmeMarkdownFromPod-0.03-Fix-building-on-Perl-without-dot-in-INC.patch
BuildArch: noarch
BuildRequires: findutils
BuildRequires: glibc-common
BuildRequires: make
BuildRequires: perl >= 1:5.6.0
BuildRequires: perl-generators
# XXX: We cannot remove ./inc because it build-requires this module
@ -17,17 +21,23 @@ BuildRequires: perl(Cwd)
BuildRequires: perl(ExtUtils::Command)
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(ExtUtils::Manifest)
BuildRequires: perl(ExtUtils::MM_Unix)
BuildRequires: perl(File::Find)
BuildRequires: perl(File::Path)
BuildRequires: perl(File::Spec)
BuildRequires: perl(FindBin)
BuildRequires: perl(Pod::Parser)
BuildRequires: perl(Pod::Text)
BuildRequires: perl(strict)
BuildRequires: perl(Test::Builder::Module)
BuildRequires: perl(Test::Harness)
BuildRequires: perl(URI::Escape)
BuildRequires: perl(vars)
BuildRequires: perl(warnings)
Requires: perl(Module::Install)
Requires: perl(Module::Install::ReadmeFromPod)
Requires: perl(Pod::Markdown)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
%description
Module::Install::ReadmeMarkdownFromPod is a Module::Install extension that
@ -37,18 +47,19 @@ GitHub to display nicely formatted information about a repository.
%prep
%setup -q -n Module-Install-ReadmeMarkdownFromPod-%{version}
%patch0 -p1
# README is ISO-8859-1 encoded
iconv -f iso-8859-1 -t utf8 < README > README.utf8
mv README.utf8 README
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
make pure_install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name .packlist -delete
%{_fixperms} $RPM_BUILD_ROOT/*
%check
@ -60,6 +71,9 @@ make test
%{_mandir}/man3/*
%changelog
* Wed May 17 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.03-12
- Fix building on Perl without '.' in @INC
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.03-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild