5.20180414 bump
This commit is contained in:
parent
7f507f8671
commit
931135568d
@ -1,211 +0,0 @@
|
|||||||
From f9b3e9c76a537979fda65f2488521528dc63a57b Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
|
||||||
Date: Fri, 13 Apr 2018 11:12:44 +0200
|
|
||||||
Subject: [PATCH] Upgrade database to 5.20180414_26
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Taken from perl-5.26.2-RC1.
|
|
||||||
|
|
||||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
|
||||||
---
|
|
||||||
Changes | 3 +++
|
|
||||||
lib/Module/CoreList.pm | 63 ++++++++++++++++++++------------------------
|
|
||||||
lib/Module/CoreList/Utils.pm | 9 ++++++-
|
|
||||||
3 files changed, 39 insertions(+), 36 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Changes b/Changes
|
|
||||||
index f19640a..aec180f 100644
|
|
||||||
--- a/Changes
|
|
||||||
+++ b/Changes
|
|
||||||
@@ -1,3 +1,6 @@
|
|
||||||
+5.20180414_26
|
|
||||||
+ - Updated for v5.26.2
|
|
||||||
+
|
|
||||||
5.20180221
|
|
||||||
- Updated for v5.27.10
|
|
||||||
|
|
||||||
diff --git a/lib/Module/CoreList.pm b/lib/Module/CoreList.pm
|
|
||||||
index ad9a9b0..dfcc188 100644
|
|
||||||
--- a/lib/Module/CoreList.pm
|
|
||||||
+++ b/lib/Module/CoreList.pm
|
|
||||||
@@ -4,7 +4,7 @@ use strict;
|
|
||||||
our ( %released, %version, %families, %upstream, %bug_tracker, %deprecated, %delta );
|
|
||||||
|
|
||||||
use version;
|
|
||||||
-our $VERSION = '5.20180221';
|
|
||||||
+our $VERSION = '5.20180414_26';
|
|
||||||
|
|
||||||
sub PKG_PATTERN () { q#\A[a-zA-Z_][0-9a-zA-Z_]*(?:(::|')[0-9a-zA-Z_]+)*\z# }
|
|
||||||
sub _looks_like_invocant ($) { local $@; !!eval { $_[0]->isa(__PACKAGE__) } }
|
|
||||||
@@ -330,6 +330,7 @@ sub changes_between {
|
|
||||||
5.027008 => '2018-01-20',
|
|
||||||
5.027009 => '2018-02-20',
|
|
||||||
5.027010 => '2018-03-20',
|
|
||||||
+ 5.026002 => '????-??-??',
|
|
||||||
);
|
|
||||||
|
|
||||||
for my $version ( sort { $a <=> $b } keys %released ) {
|
|
||||||
@@ -15366,6 +15367,21 @@ for my $version ( sort { $a <=> $b } keys %released ) {
|
|
||||||
removed => {
|
|
||||||
}
|
|
||||||
},
|
|
||||||
+ 5.026002 => {
|
|
||||||
+ delta_from => 5.026001,
|
|
||||||
+ changed => {
|
|
||||||
+ 'B::Op_private' => '5.026002',
|
|
||||||
+ 'Config' => '5.026002',
|
|
||||||
+ 'Module::CoreList' => '5.20180414_26',
|
|
||||||
+ 'Module::CoreList::TieHashDelta'=> '5.20180414_26',
|
|
||||||
+ 'Module::CoreList::Utils'=> '5.20180414_26',
|
|
||||||
+ 'PerlIO::via' => '0.17',
|
|
||||||
+ 'Term::ReadLine' => '1.17',
|
|
||||||
+ 'Unicode::UCD' => '0.69',
|
|
||||||
+ },
|
|
||||||
+ removed => {
|
|
||||||
+ }
|
|
||||||
+ },
|
|
||||||
);
|
|
||||||
|
|
||||||
sub is_core
|
|
||||||
@@ -16234,6 +16250,13 @@ sub is_core
|
|
||||||
removed => {
|
|
||||||
}
|
|
||||||
},
|
|
||||||
+ 5.026002 => {
|
|
||||||
+ delta_from => 5.026001,
|
|
||||||
+ changed => {
|
|
||||||
+ },
|
|
||||||
+ removed => {
|
|
||||||
+ }
|
|
||||||
+ },
|
|
||||||
);
|
|
||||||
|
|
||||||
%deprecated = _undelta(\%deprecated);
|
|
||||||
@@ -16300,6 +16323,7 @@ sub is_core
|
|
||||||
'Compress::Zlib' => 'cpan',
|
|
||||||
'Config::Perl::V' => 'cpan',
|
|
||||||
'DB_File' => 'cpan',
|
|
||||||
+ 'Devel::PPPort' => 'cpan',
|
|
||||||
'Digest' => 'cpan',
|
|
||||||
'Digest::MD5' => 'cpan',
|
|
||||||
'Digest::SHA' => 'cpan',
|
|
||||||
@@ -16601,30 +16625,15 @@ sub is_core
|
|
||||||
'Test2::Event::Diag' => 'cpan',
|
|
||||||
'Test2::Event::Encoding'=> 'cpan',
|
|
||||||
'Test2::Event::Exception'=> 'cpan',
|
|
||||||
- 'Test2::Event::Fail' => 'cpan',
|
|
||||||
'Test2::Event::Generic' => 'cpan',
|
|
||||||
+ 'Test2::Event::Info' => 'cpan',
|
|
||||||
'Test2::Event::Note' => 'cpan',
|
|
||||||
'Test2::Event::Ok' => 'cpan',
|
|
||||||
- 'Test2::Event::Pass' => 'cpan',
|
|
||||||
'Test2::Event::Plan' => 'cpan',
|
|
||||||
'Test2::Event::Skip' => 'cpan',
|
|
||||||
'Test2::Event::Subtest' => 'cpan',
|
|
||||||
'Test2::Event::TAP::Version'=> 'cpan',
|
|
||||||
- 'Test2::Event::V2' => 'cpan',
|
|
||||||
'Test2::Event::Waiting' => 'cpan',
|
|
||||||
- 'Test2::EventFacet' => 'cpan',
|
|
||||||
- 'Test2::EventFacet::About'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Amnesty'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Assert'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Control'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Error'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Hub'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Info'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Meta'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Parent'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Plan'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Render'=> 'cpan',
|
|
||||||
- 'Test2::EventFacet::Trace'=> 'cpan',
|
|
||||||
'Test2::Formatter' => 'cpan',
|
|
||||||
'Test2::Formatter::TAP' => 'cpan',
|
|
||||||
'Test2::Hub' => 'cpan',
|
|
||||||
@@ -16637,7 +16646,6 @@ sub is_core
|
|
||||||
'Test2::Tools::Tiny' => 'cpan',
|
|
||||||
'Test2::Util' => 'cpan',
|
|
||||||
'Test2::Util::ExternalMeta'=> 'cpan',
|
|
||||||
- 'Test2::Util::Facets2Legacy'=> 'cpan',
|
|
||||||
'Test2::Util::HashBase' => 'cpan',
|
|
||||||
'Test2::Util::Trace' => 'cpan',
|
|
||||||
'Test::Builder' => 'cpan',
|
|
||||||
@@ -16755,6 +16763,7 @@ sub is_core
|
|
||||||
'Compress::Zlib' => undef,
|
|
||||||
'Config::Perl::V' => undef,
|
|
||||||
'DB_File' => undef,
|
|
||||||
+ 'Devel::PPPort' => 'https://github.com/mhx/Devel-PPPort/issues/',
|
|
||||||
'Digest' => undef,
|
|
||||||
'Digest::MD5' => undef,
|
|
||||||
'Digest::SHA' => undef,
|
|
||||||
@@ -17056,30 +17065,15 @@ sub is_core
|
|
||||||
'Test2::Event::Diag' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::Encoding'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::Exception'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::Event::Fail' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::Generic' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
+ 'Test2::Event::Info' => undef,
|
|
||||||
'Test2::Event::Note' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::Ok' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::Event::Pass' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::Plan' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::Skip' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::Subtest' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::TAP::Version'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::Event::V2' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Event::Waiting' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::About'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Amnesty'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Assert'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Control'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Error'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Hub'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Info'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Meta'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Parent'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Plan'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Render'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::EventFacet::Trace'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Formatter' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Formatter::TAP' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Hub' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
@@ -17092,7 +17086,6 @@ sub is_core
|
|
||||||
'Test2::Tools::Tiny' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Util' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Util::ExternalMeta'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
- 'Test2::Util::Facets2Legacy'=> 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Util::HashBase' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test2::Util::Trace' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
'Test::Builder' => 'http://github.com/Test-More/test-more/issues',
|
|
||||||
diff --git a/lib/Module/CoreList/Utils.pm b/lib/Module/CoreList/Utils.pm
|
|
||||||
index 95bb5c7..16971f9 100644
|
|
||||||
--- a/lib/Module/CoreList/Utils.pm
|
|
||||||
+++ b/lib/Module/CoreList/Utils.pm
|
|
||||||
@@ -4,7 +4,7 @@ use strict;
|
|
||||||
use warnings;
|
|
||||||
use Module::CoreList;
|
|
||||||
|
|
||||||
-our $VERSION = '5.20180221';
|
|
||||||
+our $VERSION = '5.20180414_26';
|
|
||||||
our %utilities;
|
|
||||||
|
|
||||||
sub utilities {
|
|
||||||
@@ -1368,6 +1368,13 @@ my %delta = (
|
|
||||||
removed => {
|
|
||||||
}
|
|
||||||
},
|
|
||||||
+ 5.026002 => {
|
|
||||||
+ delta_from => 5.026001,
|
|
||||||
+ changed => {
|
|
||||||
+ },
|
|
||||||
+ removed => {
|
|
||||||
+ }
|
|
||||||
+ },
|
|
||||||
);
|
|
||||||
|
|
||||||
%utilities = Module::CoreList::_undelta(\%delta);
|
|
||||||
--
|
|
||||||
2.14.3
|
|
||||||
|
|
@ -1,20 +1,15 @@
|
|||||||
# Run optional test
|
# Run optional test
|
||||||
%bcond_without perl_Module_CoreList_enables_optional_test
|
%bcond_without perl_Module_CoreList_enables_optional_test
|
||||||
|
|
||||||
%global cpan_version 5.20180221
|
|
||||||
|
|
||||||
Name: perl-Module-CoreList
|
Name: perl-Module-CoreList
|
||||||
# Epoch to compete with perl.spec
|
# Epoch to compete with perl.spec
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 5.20180414
|
Version: 5.20180414
|
||||||
Release: 0.1.RC1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: What modules are shipped with versions of perl
|
Summary: What modules are shipped with versions of perl
|
||||||
License: GPL+ or Artistic
|
License: GPL+ or Artistic
|
||||||
URL: http://search.cpan.org/dist/Module-CoreList/
|
URL: http://search.cpan.org/dist/Module-CoreList/
|
||||||
Source0: http://www.cpan.org/authors/id/B/BI/BINGOS/Module-CoreList-%{cpan_version}.tar.gz
|
Source0: http://www.cpan.org/authors/id/B/BI/BINGOS/Module-CoreList-%{version}.tar.gz
|
||||||
# Upgrade database to 5.20180414_26. It's requires for Perl 5.26.2{,-RC*},
|
|
||||||
# so that we have metadata about packaged Perl. Some tools like Pinto need it.
|
|
||||||
Patch0: Module-CoreList-5.20180221-Upgrade-database-to-5.20180414_26.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-generators
|
||||||
@ -62,8 +57,7 @@ modules were shipped with given perl version.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n Module-CoreList-%{cpan_version}
|
%setup -q -n Module-CoreList-%{version}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
|
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
|
||||||
@ -87,6 +81,9 @@ make test
|
|||||||
%{_mandir}/man1/corelist.*
|
%{_mandir}/man1/corelist.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 16 2018 Petr Pisar <ppisar@redhat.com> - 1:5.20180414-1
|
||||||
|
- 5.20180414 bump
|
||||||
|
|
||||||
* Fri Apr 13 2018 Petr Pisar <ppisar@redhat.com> - 1:5.20180414-0.1.RC1
|
* Fri Apr 13 2018 Petr Pisar <ppisar@redhat.com> - 1:5.20180414-0.1.RC1
|
||||||
- 5.20180414_26 bump
|
- 5.20180414_26 bump
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user