5.20170530 bump
This commit is contained in:
parent
859e539834
commit
3a90b3e3c4
1
.gitignore
vendored
1
.gitignore
vendored
@ -37,3 +37,4 @@ Module-CoreList-2.13.tar.gz
|
||||
/Module-CoreList-5.20170220.tar.gz
|
||||
/Module-CoreList-5.20170320.tar.gz
|
||||
/Module-CoreList-5.20170420.tar.gz
|
||||
/Module-CoreList-5.20170530.tar.gz
|
||||
|
@ -1,127 +0,0 @@
|
||||
From aff7d60bcdecca28d498e81eeebc9d7b4a6af197 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Thu, 11 May 2017 10:57:54 +0200
|
||||
Subject: [PATCH] Upgrade to 5.20170520
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Unbundled from upstream perl git commit
|
||||
bd1a29f218b291165e47d9035aaeec14abd9732e.
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
Changes | 3 +++
|
||||
lib/Module/CoreList.pm | 22 +++++++++++++++++++++-
|
||||
lib/Module/CoreList/TieHashDelta.pm | 2 +-
|
||||
lib/Module/CoreList/Utils.pm | 9 ++++++++-
|
||||
4 files changed, 33 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Changes b/Changes
|
||||
index 3757b63..e137bb3 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -1,3 +1,6 @@
|
||||
+5.20170520
|
||||
+ - Updated for v5.26.0
|
||||
+
|
||||
5.20170420
|
||||
- Updated for v5.25.12
|
||||
|
||||
diff --git a/lib/Module/CoreList.pm b/lib/Module/CoreList.pm
|
||||
index ce7a565..7e5cd78 100644
|
||||
--- a/lib/Module/CoreList.pm
|
||||
+++ b/lib/Module/CoreList.pm
|
||||
@@ -3,7 +3,7 @@ use strict;
|
||||
use vars qw/$VERSION %released %version %families %upstream
|
||||
%bug_tracker %deprecated %delta/;
|
||||
use version;
|
||||
-$VERSION = '5.20170420';
|
||||
+$VERSION = '5.20170520';
|
||||
|
||||
sub _undelta {
|
||||
my ($delta) = @_;
|
||||
@@ -320,6 +320,7 @@ sub changes_between {
|
||||
5.025010 => '2017-02-20',
|
||||
5.025011 => '2017-03-20',
|
||||
5.025012 => '2017-04-20',
|
||||
+ 5.026000 => '????-??-??',
|
||||
);
|
||||
|
||||
for my $version ( sort { $a <=> $b } keys %released ) {
|
||||
@@ -14095,6 +14096,18 @@ for my $version ( sort { $a <=> $b } keys %released ) {
|
||||
removed => {
|
||||
}
|
||||
},
|
||||
+ 5.026000 => {
|
||||
+ delta_from => 5.025012,
|
||||
+ changed => {
|
||||
+ 'B::Op_private' => '5.026000',
|
||||
+ 'Config' => '5.026',
|
||||
+ 'Module::CoreList' => '5.20170520',
|
||||
+ 'Module::CoreList::TieHashDelta'=> '5.20170520',
|
||||
+ 'Module::CoreList::Utils'=> '5.20170520',
|
||||
+ },
|
||||
+ removed => {
|
||||
+ }
|
||||
+ },
|
||||
);
|
||||
|
||||
sub is_core
|
||||
@@ -14847,6 +14860,13 @@ sub is_core
|
||||
removed => {
|
||||
}
|
||||
},
|
||||
+ 5.026000 => {
|
||||
+ delta_from => 5.025012,
|
||||
+ changed => {
|
||||
+ },
|
||||
+ removed => {
|
||||
+ }
|
||||
+ },
|
||||
);
|
||||
|
||||
%deprecated = _undelta(\%deprecated);
|
||||
diff --git a/lib/Module/CoreList/TieHashDelta.pm b/lib/Module/CoreList/TieHashDelta.pm
|
||||
index 1a96e55..4d4a50f 100644
|
||||
--- a/lib/Module/CoreList/TieHashDelta.pm
|
||||
+++ b/lib/Module/CoreList/TieHashDelta.pm
|
||||
@@ -3,7 +3,7 @@ package Module::CoreList::TieHashDelta;
|
||||
use strict;
|
||||
use vars qw($VERSION);
|
||||
|
||||
-$VERSION = '5.20170420';
|
||||
+$VERSION = '5.20170520';
|
||||
|
||||
sub TIEHASH {
|
||||
my ($class, $changed, $removed, $parent) = @_;
|
||||
diff --git a/lib/Module/CoreList/Utils.pm b/lib/Module/CoreList/Utils.pm
|
||||
index a791bfc..a25b244 100644
|
||||
--- a/lib/Module/CoreList/Utils.pm
|
||||
+++ b/lib/Module/CoreList/Utils.pm
|
||||
@@ -5,7 +5,7 @@ use warnings;
|
||||
use vars qw[$VERSION %utilities];
|
||||
use Module::CoreList;
|
||||
|
||||
-$VERSION = '5.20170420';
|
||||
+$VERSION = '5.20170520';
|
||||
|
||||
sub utilities {
|
||||
my $perl = shift;
|
||||
@@ -1256,6 +1256,13 @@ my %delta = (
|
||||
removed => {
|
||||
}
|
||||
},
|
||||
+ 5.026000 => {
|
||||
+ delta_from => 5.025012,
|
||||
+ changed => {
|
||||
+ },
|
||||
+ removed => {
|
||||
+ }
|
||||
+ },
|
||||
);
|
||||
|
||||
%utilities = Module::CoreList::_undelta(\%delta);
|
||||
--
|
||||
2.9.3
|
||||
|
@ -1,15 +1,12 @@
|
||||
%global cpan_version 5.20170420
|
||||
Name: perl-Module-CoreList
|
||||
# Epoch to compete with perl.spec
|
||||
Epoch: 1
|
||||
Version: 5.20170520
|
||||
Release: 0.1%{?dist}
|
||||
Version: 5.20170530
|
||||
Release: 1%{?dist}
|
||||
Summary: What modules are shipped with versions of perl
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/Module-CoreList/
|
||||
Source0: http://www.cpan.org/authors/id/B/BI/BINGOS/Module-CoreList-%{cpan_version}.tar.gz
|
||||
# Unbundled from perl git commit bd1a29f218b291165e47d9035aaeec14abd9732e
|
||||
Patch0: Module-CoreList-5.20170420-Upgrade-to-5.20170520.patch
|
||||
Source0: http://www.cpan.org/authors/id/B/BI/BINGOS/Module-CoreList-%{version}.tar.gz
|
||||
BuildArch: noarch
|
||||
BuildRequires: make
|
||||
BuildRequires: perl
|
||||
@ -58,8 +55,7 @@ modules were shipped with given perl version.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n Module-CoreList-%{cpan_version}
|
||||
%patch0 -p1
|
||||
%setup -q -n Module-CoreList-%{version}
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
|
||||
@ -83,6 +79,9 @@ make test
|
||||
%{_mandir}/man1/corelist.*
|
||||
|
||||
%changelog
|
||||
* Wed May 31 2017 Petr Pisar <ppisar@redhat.com> - 1:5.20170530-1
|
||||
- 5.20170530 bump
|
||||
|
||||
* Thu May 11 2017 Petr Pisar <ppisar@redhat.com> - 1:5.20170520-0.1
|
||||
- Upgrade to 5.20170520 as provided in perl's blead git branch
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Module-CoreList-5.20170420.tar.gz) = eef6ff56cbb00cefca0075487a8728e5deafd30350b40da83438b2a2a908dd89f88d390dd89ce1d317dc259e7b6adf77447a68071be98b75bea0bb1b05c17187
|
||||
SHA512 (Module-CoreList-5.20170530.tar.gz) = addc57ceac69b8002a1673c0fbf90394d46c4dcaa0af2c30b3e24062f2806be5fd48cd2c04422fed16da75eeea9942e76e64d6f01512a1d516eed8f999b964ce
|
||||
|
Loading…
Reference in New Issue
Block a user