diff --git a/perl-Module-Build.spec b/perl-Module-Build.spec
index 06bd3bf..c05a9a4 100644
--- a/perl-Module-Build.spec
+++ b/perl-Module-Build.spec
@@ -2,7 +2,7 @@
 
 Name:           perl-Module-Build
 Version:        0.2800
-Release:        1%{?dist}
+Release:        2%{?dist}
 Summary:        Perl module for building and installing Perl modules
 License:        GPL or Artistic
 Group:          Development/Libraries
@@ -48,7 +48,9 @@ find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null \;
 chmod -R u+rwX,go+rX,go-w $RPM_BUILD_ROOT/*
 
 %check
-./Build test
+# 0.28 builds fail in the build system due
+# to no stdin in t/extend, so we cheat.
+./Build test < /dev/zero
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -62,6 +64,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/Module::Build*.3*
 
 %changelog
+* Thu May 18 2006 Steven Pritchard <steve@kspei.com> 0.2800-2
+- Take input from /dev/zero during "Build test" to avoid test failure.
+
 * Wed May 17 2006 Steven Pritchard <steve@kspei.com> 0.2800-1
 - Update to 0.28, but call it 0.2800 to avoid an epoch bump.
 - Various spec cleanups to closer match cpanspec output.