1.012 bump
This commit is contained in:
parent
489990144b
commit
ddd7b0c43a
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ MIME-Charset-1.006.2.tar.gz
|
||||
/MIME-Charset-1.010.tar.gz
|
||||
/MIME-Charset-1.010.1.tar.gz
|
||||
/MIME-Charset-1.011.1.tar.gz
|
||||
/MIME-Charset-1.012.tar.gz
|
||||
|
@ -0,0 +1,35 @@
|
||||
From f0334077907769117b627d6388d2df8d87828ee4 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Thu, 25 Jun 2015 13:54:15 +0200
|
||||
Subject: [PATCH] Do not install modules from the Internet
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
Makefile.PL | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index 410cc85..962b517 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -12,7 +12,6 @@ configure_requires 'CPAN' => 0; # for inc::Module::AutoInstall
|
||||
test_requires 'Test::More' => '0';
|
||||
if ( $] >= 5.007003 ) {
|
||||
requires 'Encode' => '1.98';
|
||||
- include 'Module::AutoInstall';
|
||||
feature 'Extended mappings by Japanese codepages',
|
||||
-default => 0,
|
||||
'Encode::EUCJPASCII' => '0.02';
|
||||
@@ -29,6 +28,5 @@ if ( $] >= 5.007003 ) {
|
||||
|
||||
# Write out
|
||||
no_index directory => 't', 'inc';
|
||||
-auto_install force => 0, do_once => 1;
|
||||
WriteAll;
|
||||
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,23 +1,45 @@
|
||||
Name: perl-MIME-Charset
|
||||
Version: 1.011.1
|
||||
Release: 5%{?dist}
|
||||
Version: 1.012
|
||||
Release: 1%{?dist}
|
||||
Summary: Charset Informations for MIME
|
||||
License: GPL+ or Artistic
|
||||
Group: Development/Libraries
|
||||
URL: http://search.cpan.org/dist/MIME-Charset/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/N/NE/NEZUMI/MIME-Charset-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
# Disable Module::AutoInstall
|
||||
Patch0: MIME-Charset-1.012-Do-not-install-modules-from-the-Internet.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: make
|
||||
BuildRequires: perl
|
||||
BuildRequires: perl(inc::Module::Install)
|
||||
BuildRequires: perl(Module::Install::Metadata)
|
||||
BuildRequires: perl(Module::Install::Win32)
|
||||
BuildRequires: perl(Module::Install::WriteAll)
|
||||
# Run-time:
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(constant)
|
||||
BuildRequires: perl(Encode::Encoding)
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(vars)
|
||||
# Optional run-time:
|
||||
# Encode::JISX0213 0.03 not yet packaged
|
||||
# Encode::HanExtra 0.20 not needed at tests
|
||||
BuildRequires: perl(Encode::EUCJPASCII) >= 0.02
|
||||
# Tests:
|
||||
# Encode::CN not used
|
||||
# Encode::JP not used
|
||||
BuildRequires: perl(Test)
|
||||
BuildRequires: perl(Test::More)
|
||||
BuildRequires: perl(Test::Pod)
|
||||
BuildRequires: perl(Test::Pod::Coverage)
|
||||
BuildRequires: perl(Encode::JIS2K)
|
||||
BuildRequires: perl(Encode::HanExtra)
|
||||
BuildRequires: perl(Encode::EUCJPASCII)
|
||||
BuildRequires: perl(CPAN)
|
||||
# Optional tests:
|
||||
BuildRequires: perl(Test::Pod) >= 1.00
|
||||
BuildRequires: sed
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||
# Filter under-specified symbols
|
||||
%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(MIME::Charset\\)$
|
||||
|
||||
%description
|
||||
MIME::Charset provides information about character sets used for MIME
|
||||
@ -25,44 +47,33 @@ messages on Internet.
|
||||
|
||||
%prep
|
||||
%setup -q -n MIME-Charset-%{version}
|
||||
|
||||
cat << \EOF > %{name}-prov
|
||||
#!/bin/sh
|
||||
%{__perl_provides} $* |\
|
||||
sed -e '/perl(MIME::Charset)$/d'
|
||||
EOF
|
||||
|
||||
%global __perl_provides %{_builddir}/MIME-Charset-%{version}/%{name}-prov
|
||||
chmod +x %{__perl_provides}
|
||||
|
||||
%patch0 -p1
|
||||
# Remove bundled modules
|
||||
rm -rf ./inc
|
||||
sed -i -e '/^inc\//d' MANIFEST
|
||||
|
||||
%build
|
||||
%{__perl} Makefile.PL INSTALLDIRS=vendor
|
||||
perl Makefile.PL INSTALLDIRS=vendor
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
|
||||
|
||||
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
||||
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
|
||||
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
|
||||
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc ARTISTIC Changes COPYING README
|
||||
%license ARTISTIC COPYING
|
||||
%doc Changes README
|
||||
%{perl_vendorlib}/*
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Thu Jun 25 2015 Petr Pisar <ppisar@redhat.com> - 1.012-1
|
||||
- 1.012 bump
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.011.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user