import perl-List-MoreUtils-XS-0.430-5.el9
This commit is contained in:
commit
c325fd8e73
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/List-MoreUtils-XS-0.430.tar.gz
|
1
.perl-List-MoreUtils-XS.metadata
Normal file
1
.perl-List-MoreUtils-XS.metadata
Normal file
@ -0,0 +1 @@
|
||||
7e67d74659ba063c9e7477f1513210c42366f972 SOURCES/List-MoreUtils-XS-0.430.tar.gz
|
41
SOURCES/List-MoreUtils-XS-0.430-unbundle.patch
Normal file
41
SOURCES/List-MoreUtils-XS-0.430-unbundle.patch
Normal file
@ -0,0 +1,41 @@
|
||||
--- Makefile.PL
|
||||
+++ Makefile.PL
|
||||
@@ -13,18 +13,8 @@ BEGIN
|
||||
}
|
||||
}
|
||||
|
||||
-use inc::latest 'Capture::Tiny';
|
||||
-use inc::latest 'Config::AutoConf';
|
||||
-
|
||||
-if (inc::latest->can("write"))
|
||||
-{
|
||||
- inc::latest->write("inc");
|
||||
- for my $mod (inc::latest->loaded_modules)
|
||||
- {
|
||||
- inc::latest->bundle_module($mod, "inc");
|
||||
- }
|
||||
-}
|
||||
-
|
||||
+use Capture::Tiny;
|
||||
+use Config::AutoConf;
|
||||
use ExtUtils::MakeMaker;
|
||||
|
||||
use inc::Config::AutoConf::LMU ();
|
||||
@@ -48,7 +38,6 @@ my %RUN_DEPS = (
|
||||
'XSLoader' => "0.22",
|
||||
);
|
||||
my %BUNDLE_CONFIGURE_DEPS = (
|
||||
- 'inc::latest' => '0.500',
|
||||
'Config::AutoConf' => '0.315',
|
||||
);
|
||||
my %CONFIGURE_DEPS = (
|
||||
--- t/lib/Test/LMU.pm
|
||||
+++ t/lib/Test/LMU.pm
|
||||
@@ -16,7 +16,6 @@ my $CLASS = __PACKAGE__;
|
||||
eval "use Storable qw();";
|
||||
$@ or Storable->import(qw(freeze));
|
||||
__PACKAGE__->can("freeze") or eval <<'EOFR';
|
||||
-use inc::latest 'JSON::PP';
|
||||
use JSON::PP qw();
|
||||
sub freeze {
|
||||
my $json = JSON::PP->new();
|
207
SPECS/perl-List-MoreUtils-XS.spec
Normal file
207
SPECS/perl-List-MoreUtils-XS.spec
Normal file
@ -0,0 +1,207 @@
|
||||
# Run optional test
|
||||
%if ! (0%{?rhel})
|
||||
%bcond_without perl_List_MoreUtils_XS_enables_optional_test
|
||||
%else
|
||||
%bcond_with perl_List_MoreUtils_XS_enables_optional_test
|
||||
%endif
|
||||
|
||||
Name: perl-List-MoreUtils-XS
|
||||
Version: 0.430
|
||||
Release: 5%{?dist}
|
||||
Summary: Provide compiled List::MoreUtils functions
|
||||
# Code from List-MoreUtils < 0.417 is GPL+ or Artistic
|
||||
# Anything after that is ASL 2.0
|
||||
# "git blame" on the upstream repo will probably be needed to
|
||||
# determine the license of any particular chunk of code
|
||||
License: (GPL+ or Artistic) and ASL 2.0
|
||||
URL: https://metacpan.org/release/List-MoreUtils-XS
|
||||
Source0: https://cpan.metacpan.org/modules/by-module/List/List-MoreUtils-XS-%{version}.tar.gz
|
||||
Patch0: List-MoreUtils-XS-0.430-unbundle.patch
|
||||
# Module Build
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: gcc
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl(Capture::Tiny)
|
||||
BuildRequires: perl(Config::AutoConf) >= 0.315
|
||||
BuildRequires: perl(ExtUtils::CBuilder)
|
||||
# Module Runtime
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(vars)
|
||||
BuildRequires: perl(warnings)
|
||||
BuildRequires: perl(XSLoader) >= 0.22
|
||||
# Test Suite
|
||||
BuildRequires: perl(JSON::PP)
|
||||
BuildRequires: perl(List::Util)
|
||||
BuildRequires: perl(Math::Trig)
|
||||
BuildRequires: perl(overload)
|
||||
BuildRequires: perl(POSIX)
|
||||
BuildRequires: perl(Storable)
|
||||
BuildRequires: perl(Test::Builder::Module)
|
||||
%if %{with perl_List_MoreUtils_XS_enables_optional_test}
|
||||
BuildRequires: perl(Test::LeakTrace)
|
||||
%endif
|
||||
BuildRequires: perl(Test::More) >= 0.96
|
||||
BuildRequires: perl(Tie::Array)
|
||||
# Runtime
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
|
||||
# Don't "provide" private Perl libs
|
||||
%{?perl_default_filter}
|
||||
|
||||
%description
|
||||
This module provides accelerated versions of functions in List::MoreUtils.
|
||||
|
||||
%prep
|
||||
%setup -q -n List-MoreUtils-XS-%{version}
|
||||
|
||||
# Unbundle bundled modules except private inc::Config::AutoConf::LMU
|
||||
%patch0
|
||||
find inc/ -type f ! -name LMU.pm -print -delete
|
||||
|
||||
%build
|
||||
perl Makefile.PL \
|
||||
INSTALLDIRS=vendor \
|
||||
OPTIMIZE="%{optflags}"\
|
||||
NO_PERLLOCAL=1 \
|
||||
NO_PACKLIST=1
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name '*.bs' -empty -delete
|
||||
%{_fixperms} -c %{buildroot}
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%files
|
||||
%license ARTISTIC-1.0 GPL-1 LICENSE
|
||||
%doc Changes MAINTAINER.md README.md
|
||||
%{perl_vendorarch}/auto/List/
|
||||
%{perl_vendorarch}/List/
|
||||
%{_mandir}/man3/List::MoreUtils::XS.3*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.430-5
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.430-4
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Thu Apr 08 2021 Jitka Plesnikova <jplesnik@redhat.com> - 0.430-3
|
||||
- Do not run optional test on RHEL (bug #1947387)
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.430-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Oct 21 2020 Paul Howarth <paul@city-fan.org> - 0.430-1
|
||||
- Update to 0.430
|
||||
- Fix parts of CPAN RT#123989: more $a/$b/$_ refcounting bugs
|
||||
- Since some bugs are simply reported wrong, dealing with them breaks more
|
||||
(including running code) than it solves - way too heavy to feel better...
|
||||
- Introduce functions slide and slideatatime
|
||||
- Toolchain fixes
|
||||
- Fix LANG=nb_NO.utf8 related str tests fails (CPAN RT#133128)
|
||||
- Fix typo (GH#7)
|
||||
- Fix parts of CPAN RT#132043: listcmp misbehave in XS implementation
|
||||
- Use author-independent source URL
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jun 23 2020 Jitka Plesnikova <jplesnik@redhat.com> - 0.428-9
|
||||
- Perl 5.32 rebuild
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri May 31 2019 Jitka Plesnikova <jplesnik@redhat.com> - 0.428-6
|
||||
- Perl 5.30 rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.428-3
|
||||
- Perl 5.28 rebuild
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Dec 21 2017 Paul Howarth <paul@city-fan.org> - 0.428-1
|
||||
- Update to 0.428
|
||||
- Fix build fails on perl ≥ 5.27.4 with -DDEBUGGING (CPAN RT#123613)
|
||||
- Update ppport.h to 3.37 for improved blead support
|
||||
- Fix context arg to croak() (CPAN RT#123869)
|
||||
- Fix one() returning true on empty list (CPAN RT#123870)
|
||||
- Pamper $a/$b/$_ refcounting bugs (CPAN RT#123868)
|
||||
|
||||
* Tue Oct 3 2017 Paul Howarth <paul@city-fan.org> - 0.426-1
|
||||
- Update to 0.426
|
||||
- Fix broken format in part (GH#4)
|
||||
- Fix gcc 4.7 sequence point warning (GH#5)
|
||||
- Fix incorrect padname resolving for perl > 5.21.6 (CPAN RT#122883)
|
||||
- Fix compiling issue on CentOS 4 and CentOS 5
|
||||
|
||||
* Sat Aug 19 2017 Paul Howarth <paul@city-fan.org> - 0.423-1
|
||||
- Update to 0.423
|
||||
- Fix dealing with lists with one element on bremove/binsert (GH#2)
|
||||
- Add support for compilers before C99
|
||||
- Fix some 32-bit compiler warnings
|
||||
- Add support for compilers without statement expression feature
|
||||
|
||||
* Tue Aug 15 2017 Paul Howarth <paul@city-fan.org> - 0.422-1
|
||||
- Update to 0.422
|
||||
- Rename 'occurances' into 'occurrences' (CPAN RT#91991, CPAN RT#122806)
|
||||
- Add DESCRIPTION to Pod clarifying the role of List::MoreUtils::XS
|
||||
- Improve Makefile.PL regarding some build artifacts
|
||||
|
||||
* Tue Aug 15 2017 Paul Howarth <paul@city-fan.org> - 0.421-1
|
||||
- Update to 0.421
|
||||
- Fix a lot of potential memory leaks when callbacks throw exceptions
|
||||
- Add some new functions: qsort, binsert, bremove, listcmp, arrayify
|
||||
(CPAN RT#17230), samples (CPAN RT#77562), minmaxstr (CPAN RT#106401),
|
||||
lower_bound, upper_bound, equal_range, frequencies, occurances, mode
|
||||
(CPAN RT#91991), zip6 (CPAN RT#42921), reduce_0, reduce_1, reduce_u
|
||||
- Improve tests
|
||||
- Make List::MoreUtils::XS independent from List::MoreUtils
|
||||
Note that List::MoreUtils::XS doesn't guarantee API stability: this
|
||||
feature is only provided through List::MoreUtils as frontend
|
||||
- Improve configure toolchain to use Config::AutoConf 0.315
|
||||
- Speed up some inner loops by hinting the expected result
|
||||
- Fix mind screwed up issue in upper_bound and reduce elements visited in
|
||||
equal_range
|
||||
- Correct license in META (CPAN RT#122702)
|
||||
- Fix issues with -DPERL_IMPLICIT_SYS on Windows with Strawberry-Perl
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.418-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.418-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.418-4
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Mon Apr 3 2017 Paul Howarth <paul@city-fan.org> - 0.418-3
|
||||
- Incorporate package review feedback (#1437588)
|
||||
- Fix URL
|
||||
- Unbundle bundled modules except private inc::Config::AutoConf::LMU
|
||||
|
||||
* Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 0.418-2
|
||||
- Sanitize for Fedora submission
|
||||
|
||||
* Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 0.418-1
|
||||
- Initial RPM version
|
Loading…
Reference in New Issue
Block a user