Initial import (perl-List-MoreUtils-XS-0.418-3)
This module provides accelerated versions of functions in List::MoreUtils.
This commit is contained in:
parent
3eaedfc583
commit
454a72b374
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
||||
/List-MoreUtils-XS-0.418.tar.gz
|
41
List-MoreUtils-XS-0.418-unbundle.patch
Normal file
41
List-MoreUtils-XS-0.418-unbundle.patch
Normal file
@ -0,0 +1,41 @@
|
||||
--- Makefile.PL
|
||||
+++ Makefile.PL
|
||||
@@ -13,18 +13,8 @@ BEGIN
|
||||
}
|
||||
}
|
||||
|
||||
-use inc::latest 'Capture::Tiny';
|
||||
-use inc::latest 'Config::AutoConf';
|
||||
-
|
||||
-if (inc::latest->can("write"))
|
||||
-{
|
||||
- inc::latest->write("inc");
|
||||
- for my $mod (inc::latest->loaded_modules)
|
||||
- {
|
||||
- inc::latest->bundle_module($mod, "inc");
|
||||
- }
|
||||
-}
|
||||
-
|
||||
+use Capture::Tiny;
|
||||
+use Config::AutoConf;
|
||||
use ExtUtils::MakeMaker;
|
||||
|
||||
use inc::Config::AutoConf::LMU ();
|
||||
@@ -49,7 +39,6 @@ my %RUN_DEPS = (
|
||||
'XSLoader' => "0.22",
|
||||
);
|
||||
my %BUNDLE_CONFIGURE_DEPS = (
|
||||
- 'inc::latest' => '0.500',
|
||||
'Config::AutoConf' => '0.308',
|
||||
);
|
||||
my %CONFIGURE_DEPS = (
|
||||
--- t/lib/LMU/Test/Functions.pm
|
||||
+++ t/lib/LMU/Test/Functions.pm
|
||||
@@ -16,7 +16,6 @@ eval "use Scalar::Util qw(); \$have_scal
|
||||
eval "use Storable qw();";
|
||||
$@ or Storable->import(qw(freeze));
|
||||
__PACKAGE__->can("freeze") or eval <<'EOFR';
|
||||
-use inc::latest 'JSON::PP';
|
||||
use JSON::PP qw();
|
||||
sub freeze {
|
||||
my $json = JSON::PP->new();
|
88
perl-List-MoreUtils-XS.spec
Normal file
88
perl-List-MoreUtils-XS.spec
Normal file
@ -0,0 +1,88 @@
|
||||
Name: perl-List-MoreUtils-XS
|
||||
Version: 0.418
|
||||
Release: 3%{?dist}
|
||||
Summary: Provide compiled List::MoreUtils functions
|
||||
# Code from List-MoreUtils < 0.417 is GPL+ or Artistic
|
||||
# Anything after that is ASL 2.0
|
||||
# "git blame" on the upstream repo will probably be needed to
|
||||
# determine the license of any particular chunk of code
|
||||
License: (GPL+ or Artistic) and ASL 2.0
|
||||
URL: http://search.cpan.org/dist/List-MoreUtils-XS/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/R/RE/REHSACK/List-MoreUtils-XS-%{version}.tar.gz
|
||||
Patch0: List-MoreUtils-XS-0.418-unbundle.patch
|
||||
# Module Build
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: gcc
|
||||
BuildRequires: make
|
||||
BuildRequires: perl >= 4:5.16.0
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(Capture::Tiny)
|
||||
BuildRequires: perl(Config::AutoConf) >= 0.308
|
||||
BuildRequires: perl(ExtUtils::CBuilder)
|
||||
# Module Runtime
|
||||
BuildRequires: perl(List::MoreUtils) >= 0.418
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(vars)
|
||||
BuildRequires: perl(warnings)
|
||||
BuildRequires: perl(XSLoader)
|
||||
# Test Suite
|
||||
BuildRequires: perl(overload)
|
||||
BuildRequires: perl(Storable)
|
||||
BuildRequires: perl(Test::Builder::Module)
|
||||
BuildRequires: perl(Test::LeakTrace)
|
||||
BuildRequires: perl(Test::More) >= 0.96
|
||||
BuildRequires: perl(Tie::Array)
|
||||
# Runtime
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
Requires: perl(List::MoreUtils) >= 0.418
|
||||
|
||||
# Don't "provide" private Perl libs
|
||||
%{?perl_default_filter}
|
||||
|
||||
%description
|
||||
This module provides accelerated versions of functions in List::MoreUtils.
|
||||
|
||||
%prep
|
||||
%setup -q -n List-MoreUtils-XS-%{version}
|
||||
|
||||
# Unbundle bundled modules except private inc::Config::AutoConf::LMU
|
||||
%patch0
|
||||
find inc/ -type f ! -name LMU.pm -print -delete
|
||||
|
||||
%build
|
||||
perl Makefile.PL \
|
||||
INSTALLDIRS=vendor \
|
||||
OPTIMIZE="%{optflags}"\
|
||||
NO_PERLLOCAL=1 \
|
||||
NO_PACKLIST=1
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name '*.bs' -empty -delete
|
||||
%{_fixperms} -c %{buildroot}
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%files
|
||||
%license ARTISTIC-1.0 GPL-1 LICENSE
|
||||
%doc Changes README.md
|
||||
%{perl_vendorarch}/auto/List/
|
||||
%{perl_vendorarch}/List/
|
||||
%{_mandir}/man3/List::MoreUtils::XS.3*
|
||||
|
||||
%changelog
|
||||
* Mon Apr 3 2017 Paul Howarth <paul@city-fan.org> - 0.418-3
|
||||
- Incorporate package review feedback (#1437588)
|
||||
- Fix URL
|
||||
- Unbundle bundled modules except private inc::Config::AutoConf::LMU
|
||||
|
||||
* Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 0.418-2
|
||||
- Sanitize for Fedora submission
|
||||
|
||||
* Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 0.418-1
|
||||
- Initial RPM version
|
Loading…
Reference in New Issue
Block a user