From 55a4fc0e4fa42f56dbd162ef2cba549ba628d0fe Mon Sep 17 00:00:00 2001
From: Jitka Plesnikova <jplesnik@redhat.com>
Date: Wed, 10 Jul 2024 08:58:58 +0200
Subject: [PATCH] Resolves: RHEL-46816 - disable optional tests

---
 gating.yaml              | 8 ++++++++
 perl-LDAP.spec           | 8 ++++++--
 tests/upstream-tests.fmf | 7 +++++++
 3 files changed, 21 insertions(+), 2 deletions(-)

diff --git a/gating.yaml b/gating.yaml
index 282e16b..24a0379 100644
--- a/gating.yaml
+++ b/gating.yaml
@@ -5,3 +5,11 @@ decision_context: bodhi_update_push_stable
 subject_type: koji_build
 rules:
   - !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
+
+# RHEL
+--- !Policy
+product_versions:
+  - rhel-*
+decision_context: osci_compose_gate
+rules:
+  - !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
diff --git a/perl-LDAP.spec b/perl-LDAP.spec
index 53f8972..c5b1e45 100644
--- a/perl-LDAP.spec
+++ b/perl-LDAP.spec
@@ -1,15 +1,16 @@
 # Perform optional tests
-%bcond_without perl_LDAP_enables_optional_test
 # Support XML serialization of LDAP schemata (DSML languge)
 %if 0%{?rhel}
 %bcond_with perl_LDAP_enables_xml
+%bcond_with perl_LDAP_enables_optional_test
 %else
 %bcond_without perl_LDAP_enables_xml
+%bcond_without perl_LDAP_enables_optional_test
 %endif
 
 Name:           perl-LDAP
 Version:        0.68
-Release:        14%{?dist}
+Release:        15%{?dist}
 Epoch:          1
 Summary:        LDAP Perl module
 License:        GPL-1.0-or-later OR Artistic-1.0-Perl
@@ -209,6 +210,9 @@ make test
 %{_libexecdir}/%{name}
 
 %changelog
+* Tue Jul 09 2024 Jitka Plesnikova <jplesnik@redhat.com> - 1:0.68-15
+- Resolves: RHEL-46816 - disable optional tests
+
 * Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 1:0.68-14
 - Bump release for June 2024 mass rebuild
 
diff --git a/tests/upstream-tests.fmf b/tests/upstream-tests.fmf
index cbecfa9..2ec574f 100644
--- a/tests/upstream-tests.fmf
+++ b/tests/upstream-tests.fmf
@@ -2,3 +2,10 @@ summary: Upstream tests
 component: perl-LDAP
 require: perl-LDAP-tests
 test: /usr/libexec/perl-LDAP/test
+enabled: true
+tag:
+  - rhel-buildroot
+adjust:
+  - enabled: false
+    when: distro < rhel-10 or distro < centos-stream-10
+    continue: false