import perl-File-Slurp-Tiny-0.004-7.el8+1694+ef8073e1
This commit is contained in:
commit
a8378c004e
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/File-Slurp-Tiny-0.004.tar.gz
|
1
.perl-File-Slurp-Tiny.metadata
Normal file
1
.perl-File-Slurp-Tiny.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
016480e301a0b28f19f51fd31cf35d1ce4808b91 SOURCES/File-Slurp-Tiny-0.004.tar.gz
|
16
SOURCES/File-Slurp-Tiny-0.003-old-Test::More.patch
Normal file
16
SOURCES/File-Slurp-Tiny-0.003-old-Test::More.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- t/10-basics.t
|
||||||
|
+++ t/10-basics.t
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
use File::Slurp::Tiny qw/read_file read_lines write_file read_dir/;
|
||||||
|
use File::Temp qw/tempdir/;
|
||||||
|
|
||||||
|
-use Test::More;
|
||||||
|
+use Test::More tests => 10;
|
||||||
|
|
||||||
|
my $content = do { local $/; open my $fh, '<:raw', $0; <$fh> };
|
||||||
|
is(read_file($0), $content, 'read_file() works');
|
||||||
|
@@ -33,4 +33,3 @@
|
||||||
|
write_file($filename, $content, append => 1);
|
||||||
|
is(read_file($filename), $content x 2, 'write_file + readfile = noop');
|
||||||
|
|
||||||
|
-done_testing;
|
116
SPECS/perl-File-Slurp-Tiny.spec
Normal file
116
SPECS/perl-File-Slurp-Tiny.spec
Normal file
@ -0,0 +1,116 @@
|
|||||||
|
# Test suite needs patching if we have Test::More < 0.88
|
||||||
|
%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION) < 0.88 ? 1 : 0);' 2>/dev/null || echo 0)
|
||||||
|
|
||||||
|
Name: perl-File-Slurp-Tiny
|
||||||
|
Version: 0.004
|
||||||
|
Release: 7%{?dist}
|
||||||
|
Summary: A simple, sane and efficient file slurper
|
||||||
|
Group: Development/Libraries
|
||||||
|
License: GPL+ or Artistic
|
||||||
|
URL: http://search.cpan.org/dist/File-Slurp-Tiny/
|
||||||
|
Source0: http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/File-Slurp-Tiny-%{version}.tar.gz
|
||||||
|
Patch0: File-Slurp-Tiny-0.003-old-Test::More.patch
|
||||||
|
BuildArch: noarch
|
||||||
|
# Build
|
||||||
|
BuildRequires: coreutils
|
||||||
|
BuildRequires: findutils
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: perl-interpreter
|
||||||
|
BuildRequires: perl-generators
|
||||||
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||||
|
# Module
|
||||||
|
BuildRequires: perl(Carp)
|
||||||
|
BuildRequires: perl(Exporter) >= 5.57
|
||||||
|
BuildRequires: perl(File::Spec::Functions)
|
||||||
|
BuildRequires: perl(FileHandle)
|
||||||
|
BuildRequires: perl(strict)
|
||||||
|
BuildRequires: perl(warnings)
|
||||||
|
# Test Suite
|
||||||
|
BuildRequires: perl(File::Temp)
|
||||||
|
BuildRequires: perl(Test::More)
|
||||||
|
# Runtime
|
||||||
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||||
|
|
||||||
|
%description
|
||||||
|
This module provides functions for fast and correct slurping and spewing
|
||||||
|
of files.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n File-Slurp-Tiny-%{version}
|
||||||
|
|
||||||
|
# Test suite needs patching if we have Test::More < 0.88
|
||||||
|
%if %{old_test_more}
|
||||||
|
%patch0
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL INSTALLDIRS=vendor
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
make pure_install DESTDIR=%{buildroot}
|
||||||
|
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
|
||||||
|
%{_fixperms} %{buildroot}
|
||||||
|
|
||||||
|
%check
|
||||||
|
make test
|
||||||
|
|
||||||
|
%files
|
||||||
|
%if 0%{?_licensedir:1}
|
||||||
|
%license LICENSE
|
||||||
|
%else
|
||||||
|
%doc LICENSE
|
||||||
|
%endif
|
||||||
|
%doc Changes README
|
||||||
|
%{perl_vendorlib}/File/
|
||||||
|
%{_mandir}/man3/File::Slurp::Tiny.3*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.004-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.004-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.004-5
|
||||||
|
- Perl 5.26 rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.004-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.004-3
|
||||||
|
- Perl 5.24 rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.004-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 16 2015 Paul Howarth <paul@city-fan.org> - 0.004-1
|
||||||
|
- Update to 0.004
|
||||||
|
- Add discouragement notice (File::Slurper is a better choice)
|
||||||
|
- Don't skip '.\n' and '..\n' in read_dir
|
||||||
|
- Don't install benchmark.pl
|
||||||
|
- Use %%license where possible
|
||||||
|
- Release tests no longer part of main test suite
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.003-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.003-6
|
||||||
|
- Perl 5.22 rebuild
|
||||||
|
|
||||||
|
* Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.003-5
|
||||||
|
- Perl 5.20 rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.003-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 26 2014 Paul Howarth <paul@city-fan.org> - 0.003-3
|
||||||
|
- Make %%description explicit about the module operating on files
|
||||||
|
(#1064995)
|
||||||
|
|
||||||
|
* Thu Feb 13 2014 Paul Howarth <paul@city-fan.org> - 0.003-2
|
||||||
|
- Sanitize for Fedora submission
|
||||||
|
|
||||||
|
* Thu Feb 13 2014 Paul Howarth <paul@city-fan.org> - 0.003-1
|
||||||
|
- Initial RPM version
|
Loading…
Reference in New Issue
Block a user