RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/perl-File-Find-Object-Rule#0658983234cddb066bd176920a7040041383b941
This commit is contained in:
parent
8f186813b0
commit
2d1b859d5c
9
.gitignore
vendored
9
.gitignore
vendored
@ -0,0 +1,9 @@
|
||||
/File-Find-Object-Rule-0.0303.tar.gz
|
||||
/File-Find-Object-Rule-0.0304.tar.gz
|
||||
/File-Find-Object-Rule-0.0305.tar.gz
|
||||
/File-Find-Object-Rule-0.0306.tar.gz
|
||||
/File-Find-Object-Rule-0.0307.tar.gz
|
||||
/File-Find-Object-Rule-0.0309.tar.gz
|
||||
/File-Find-Object-Rule-0.0310.tar.gz
|
||||
/File-Find-Object-Rule-0.0311.tar.gz
|
||||
/File-Find-Object-Rule-0.0312.tar.gz
|
8
File-Find-Object-Rule-0.0310-shellbang.patch
Normal file
8
File-Find-Object-Rule-0.0310-shellbang.patch
Normal file
@ -0,0 +1,8 @@
|
||||
--- bin/findorule
|
||||
+++ bin/findorule
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env perl
|
||||
+#!/usr/bin/perl
|
||||
|
||||
use strict;
|
||||
use warnings;
|
185
perl-File-Find-Object-Rule.spec
Normal file
185
perl-File-Find-Object-Rule.spec
Normal file
@ -0,0 +1,185 @@
|
||||
%if ! (0%{?rhel})
|
||||
%{bcond_without perl_File_Find_Object_Rule_enables_optional_test}
|
||||
%else
|
||||
%{bcond_with perl_File_Find_Object_Rule_enables_optional_test}
|
||||
%endif
|
||||
|
||||
Name: perl-File-Find-Object-Rule
|
||||
Version: 0.0312
|
||||
Release: 4%{?dist}
|
||||
Summary: Alternative interface to File::Find::Object
|
||||
License: GPL+ or Artistic
|
||||
URL: https://metacpan.org/release/File-Find-Object-Rule
|
||||
Source0: https://cpan.metacpan.org/modules/by-module/File/File-Find-Object-Rule-%{version}.tar.gz
|
||||
Patch0: File-Find-Object-Rule-0.0310-shellbang.patch
|
||||
BuildArch: noarch
|
||||
# Module Build
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl(Module::Build) >= 0.28
|
||||
# Module Runtime
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(Class::XSAccessor)
|
||||
BuildRequires: perl(Cwd)
|
||||
BuildRequires: perl(File::Basename)
|
||||
BuildRequires: perl(File::Find::Object)
|
||||
BuildRequires: perl(File::Spec)
|
||||
BuildRequires: perl(Number::Compare)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(Text::Glob)
|
||||
BuildRequires: perl(vars)
|
||||
BuildRequires: perl(warnings)
|
||||
# Script Runtime
|
||||
BuildRequires: perl(File::Spec::Functions)
|
||||
# Test Suite
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(blib)
|
||||
BuildRequires: perl(File::Path)
|
||||
BuildRequires: perl(IO::Handle)
|
||||
BuildRequires: perl(IPC::Open3)
|
||||
BuildRequires: perl(lib)
|
||||
BuildRequires: perl(Test::More)
|
||||
# Dependencies
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
|
||||
%description
|
||||
File::Find::Object::Rule is a friendlier interface to File::Find::Object. It
|
||||
allows you to build rules that specify the desired files and directories.
|
||||
|
||||
%prep
|
||||
%setup -qn File-Find-Object-Rule-%{version}
|
||||
|
||||
# Avoid use of /usr/bin/env
|
||||
%patch0
|
||||
|
||||
%build
|
||||
perl Build.PL --installdirs=vendor
|
||||
./Build
|
||||
|
||||
%install
|
||||
./Build install --destdir=%{buildroot} --create_packlist=0
|
||||
%{_fixperms} -c %{buildroot}
|
||||
|
||||
%check
|
||||
./Build test
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%doc Changes Changes.F-F-R README
|
||||
%{_bindir}/findorule
|
||||
%{perl_vendorlib}/File/
|
||||
%{_mandir}/man1/findorule.1*
|
||||
%{_mandir}/man3/File::Find::Object::Rule.3*
|
||||
%{_mandir}/man3/File::Find::Object::Rule::Extending.3*
|
||||
%{_mandir}/man3/File::Find::Object::Rule::Procedural.3*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.0312-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jun 23 2020 Jitka Plesnikova <jplesnik@redhat.com> - 0.0312-3
|
||||
- Perl 5.32 rebuild
|
||||
|
||||
* Tue Mar 10 2020 Paul Howarth <paul@city-fan.org> - 0.0312-2
|
||||
- BR: perl(blib) for t/00-compile.t and t/findorule.t
|
||||
|
||||
* Tue Jan 28 2020 Paul Howarth <paul@city-fan.org> - 0.0312-1
|
||||
- Update to 0.0312
|
||||
- Rebuild for order of 'NAME' and 'VERSION' sections in the generated POD
|
||||
documentation (VERSION used to appear before NAME)
|
||||
|
||||
* Mon Aug 26 2019 Paul Howarth <paul@city-fan.org> - 0.0311-1
|
||||
- Update to 0.0311
|
||||
- Moved the VCS repo to https://github.com/shlomif/perl-file-find-object-rule
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.0310-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri May 31 2019 Jitka Plesnikova <jplesnik@redhat.com> - 0.0310-2
|
||||
- Perl 5.30 rebuild
|
||||
|
||||
* Sat Apr 6 2019 Paul Howarth <paul@city-fan.org> - 0.0310-1
|
||||
- Update to 0.0310
|
||||
- Fully qualified shebang for findorule
|
||||
- Enable tidyall in dist.ini
|
||||
- Add patch to avoid use of /usr/bin/env in findorule
|
||||
- Extra tests moved to xt/ so drop build dependencies for them
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.0309-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.0309-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Sun Jul 01 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.0309-3
|
||||
- Perl 5.28 re-rebuild of bootstrapped packages
|
||||
|
||||
* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.0309-2
|
||||
- Perl 5.28 rebuild
|
||||
|
||||
* Wed Jun 20 2018 Paul Howarth <paul@city-fan.org> - 0.0309-1
|
||||
- Update to 0.0309
|
||||
- Apply spelling fixes patch from Debian (CPAN RT#125635)
|
||||
|
||||
* Thu May 24 2018 Paul Howarth <paul@city-fan.org> - 0.0307-1
|
||||
- Update to 0.0307
|
||||
- Convert to Dist-Zilla
|
||||
- Switch upstream from search.cpan.org to metacpan.org
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.0306-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.0306-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.0306-4
|
||||
- Perl 5.26 re-rebuild of bootstrapped packages
|
||||
|
||||
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.0306-3
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.0306-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Sep 12 2016 Paul Howarth <paul@city-fan.org> - 0.0306-1
|
||||
- Update to 0.0306
|
||||
- Made the trailing space tests RELEASE_TESTING only
|
||||
|
||||
* Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.0305-8
|
||||
- Perl 5.24 re-rebuild of bootstrapped packages
|
||||
|
||||
* Mon May 16 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.0305-7
|
||||
- Perl 5.24 rebuild
|
||||
|
||||
* Mon Feb 29 2016 Paul Howarth <paul@city-fan.org> - 0.0305-6
|
||||
- Classify buildreqs by usage
|
||||
- Make %%files list more explicit
|
||||
- Use %%license
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.0305-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0305-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.0305-3
|
||||
- Perl 5.22 rebuild
|
||||
|
||||
* Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.0305-2
|
||||
- Perl 5.20 rebuild
|
||||
|
||||
* Sun Jun 08 2014 Christopher Meng <rpm@cicku.me> - 0.0305-1
|
||||
- Update to 0.0305
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0304-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Feb 13 2014 Christopher Meng <rpm@cicku.me> - 0.0304-1
|
||||
- Update to 0.0304
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0303-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Sun May 26 2013 Christopher Meng <rpm@cicku.me> - 0.0303-1
|
||||
- Initial Package.
|
Loading…
Reference in New Issue
Block a user