Replace patch update from Perl release by CPAN upstream 3.51 (rhbz#2237243)

This commit is contained in:
Jitka Plesnikova 2023-09-04 16:55:11 +02:00
parent 39dcdcd682
commit c859070953
5 changed files with 66 additions and 5882 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@ ExtUtils-ParseXS-2.18.tar.gz
/ExtUtils-ParseXS-3.30.tar.gz
/ExtUtils-ParseXS-3.35.tar.gz
/ExtUtils-ParseXS-3.44.tar.gz
/ExtUtils-ParseXS-3.51.tar.gz

File diff suppressed because it is too large Load Diff

View File

@ -4,20 +4,20 @@ Date: Fri, 7 Jan 2022 11:03:48 +0100
Subject: [PATCH] Add perlxs* man pages
---
lib/perlxs.pod | 2378 +++++++++++++++++++++++++++++++++++++++++
lib/perlxs.pod | 2429 +++++++++++++++++++++++++++++++++++++++++
lib/perlxstut.pod | 1425 ++++++++++++++++++++++++
lib/perlxstypemap.pod | 711 ++++++++++++
3 files changed, 4514 insertions(+)
3 files changed, 4565 insertions(+)
create mode 100644 lib/perlxs.pod
create mode 100644 lib/perlxstut.pod
create mode 100644 lib/perlxstypemap.pod
diff --git a/lib/perlxs.pod b/lib/perlxs.pod
new file mode 100644
index 0000000..f1bd408
index 0000000..aa7ccad
--- /dev/null
+++ b/lib/perlxs.pod
@@ -0,0 +1,2378 @@
@@ -0,0 +1,2429 @@
+=head1 NAME
+
+perlxs - XS language reference manual
@ -1352,6 +1352,46 @@ index 0000000..f1bd408
+ OUTPUT:
+ timep
+
+A warning will be produced when you create more than one alias to the same
+value. This may be worked around in a backwards compatible way by creating
+multiple defines which resolve to the same value, or with a modern version
+of ExtUtils::ParseXS you can use a symbolic alias, which are denoted with
+a C<< => >> instead of a C<< = >>. For instance you could change the above
+so that the alias section looked like this:
+
+ ALIAS:
+ FOO::gettime = 1
+ BAR::getit = 2
+ BAZ::gettime => FOO::gettime
+
+this would have the same effect as this:
+
+ ALIAS:
+ FOO::gettime = 1
+ BAR::getit = 2
+ BAZ::gettime = 1
+
+except that the latter will produce warnings during the build process. A
+mechanism that would work in a backwards compatible way with older
+versions of our tool chain would be to do this:
+
+ #define FOO_GETTIME 1
+ #define BAR_GETIT 2
+ #define BAZ_GETTIME 1
+
+ bool_t
+ rpcb_gettime(host,timep)
+ char *host
+ time_t &timep
+ ALIAS:
+ FOO::gettime = FOO_GETTIME
+ BAR::getit = BAR_GETIT
+ BAZ::gettime = BAZ_GETTIME
+ INIT:
+ printf("# ix = %d\n", ix );
+ OUTPUT:
+ timep
+
+=head2 The OVERLOAD: Keyword
+
+Instead of writing an overloaded interface using pure Perl, you
@ -2389,7 +2429,18 @@ index 0000000..f1bd408
+=head1 XS VERSION
+
+This document covers features supported by C<ExtUtils::ParseXS>
+(also known as C<xsubpp>) 3.13_01.
+(also known as C<xsubpp>) 3.51
+
+=head1 AUTHOR DIAGNOSTICS
+
+As of version 3.49 certain warnings are disabled by default. While developing
+you can set C<$ENV{AUTHOR_WARNINGS}> to true in your environment or in your
+Makefile.PL, or set C<$ExtUtils::ParseXS::AUTHOR_WARNINGS> to true via code, or
+pass C<< author_warnings=>1 >> into process_file() explicitly. Currently this will
+enable stricter alias checking but more warnings might be added in the future.
+The kind of warnings this will enable are only helpful to the author of the XS
+file, and the diagnostics produced will not include installation specific
+details so they are only useful to the maintainer of the XS code itself.
+
+=head1 AUTHOR
+

View File

@ -1,15 +1,15 @@
%global base_version 3.44
%global base_version 3.51
Name: perl-ExtUtils-ParseXS
# Epoch to compete with perl.spec
Epoch: 1
Version: 3.51
Release: 500%{?dist}
Release: 501%{?dist}
Summary: Module and a script for converting Perl XS code into C code
License: GPL-1.0-or-later OR Artistic-1.0-Perl
URL: https://metacpan.org/release/ExtUtils-ParseXS
Source0: https://cpan.metacpan.org/authors/id/X/XS/XSAWYERX/ExtUtils-ParseXS-%{base_version}.tar.gz
# Unbundled from perl 5.37.12
Patch0: ExtUtils-ParseXS-3.44-Upgrade-to-3.51.patch
Source0: https://cpan.metacpan.org/modules/by-module/ExtUtils/ExtUtils-ParseXS-%{base_version}.tar.gz
# # Added man page perlxs* which are missing in tarball
Patch0: ExtUtils-ParseXS-3.51-Add-perlxs-man-pages.patch
BuildArch: noarch
BuildRequires: coreutils
BuildRequires: make
@ -117,6 +117,9 @@ make test
%{_libexecdir}/%{name}
%changelog
* Mon Sep 04 2023 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.51-501
- Replace patch update from Perl release by CPAN upstream 3.51 (rhbz#2237243)
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1:3.51-500
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (ExtUtils-ParseXS-3.44.tar.gz) = 0a3c155bb5718814c97784c83b4a108fdd72153605f733fafb1a61c1e626f2454584f3baefc5d3a490280226e5a240e4cb95453bae3f609511d96750fcfc7389
SHA512 (ExtUtils-ParseXS-3.51.tar.gz) = f8e3a064577b62ee17c4b55349c2044da7e4075cd6da20f7b2c6b92a8522209b594a0cecd0853744f15c4fc71cb9bc3d23f05511f84d2b15da05897a86d9f660