3.31 bump in order to dual-live with perl 5.24
This commit is contained in:
parent
e83b6eac81
commit
1c210fc694
139
ExtUtils-ParseXS-3.30-Upgrade-to-3.31.patch
Normal file
139
ExtUtils-ParseXS-3.30-Upgrade-to-3.31.patch
Normal file
@ -0,0 +1,139 @@
|
|||||||
|
diff --git a/lib/ExtUtils/ParseXS.pm b/lib/ExtUtils/ParseXS.pm
|
||||||
|
index f67a82d..32d74e1 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS.pm
|
||||||
|
@@ -11,7 +11,7 @@ use Symbol;
|
||||||
|
|
||||||
|
our $VERSION;
|
||||||
|
BEGIN {
|
||||||
|
- $VERSION = '3.30';
|
||||||
|
+ $VERSION = '3.31';
|
||||||
|
}
|
||||||
|
use ExtUtils::ParseXS::Constants $VERSION;
|
||||||
|
use ExtUtils::ParseXS::CountLines $VERSION;
|
||||||
|
@@ -579,7 +579,7 @@ EOF
|
||||||
|
} );
|
||||||
|
}
|
||||||
|
else {
|
||||||
|
- print "\t$class *";
|
||||||
|
+ print "\t" . map_type($self, "$class *");
|
||||||
|
$self->{var_types}->{"THIS"} = "$class *";
|
||||||
|
$self->generate_init( {
|
||||||
|
type => "$class *",
|
||||||
|
diff --git a/lib/ExtUtils/ParseXS/Constants.pm b/lib/ExtUtils/ParseXS/Constants.pm
|
||||||
|
index 8856551..2319a24 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS/Constants.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS/Constants.pm
|
||||||
|
@@ -3,7 +3,7 @@ use strict;
|
||||||
|
use warnings;
|
||||||
|
use Symbol;
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/ParseXS/CountLines.pm b/lib/ExtUtils/ParseXS/CountLines.pm
|
||||||
|
index 2f45292..222a95c 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS/CountLines.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS/CountLines.pm
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
package ExtUtils::ParseXS::CountLines;
|
||||||
|
use strict;
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
our $SECTION_END_MARKER;
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/ParseXS/Eval.pm b/lib/ExtUtils/ParseXS/Eval.pm
|
||||||
|
index 8c075a3..7315332 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS/Eval.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS/Eval.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::ParseXS::Eval;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/ParseXS/Utilities.pm b/lib/ExtUtils/ParseXS/Utilities.pm
|
||||||
|
index 4de9f4e..41a9f6d 100644
|
||||||
|
--- a/lib/ExtUtils/ParseXS/Utilities.pm
|
||||||
|
+++ b/lib/ExtUtils/ParseXS/Utilities.pm
|
||||||
|
@@ -5,7 +5,7 @@ use Exporter;
|
||||||
|
use File::Spec;
|
||||||
|
use ExtUtils::ParseXS::Constants ();
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
our (@ISA, @EXPORT_OK);
|
||||||
|
@ISA = qw(Exporter);
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps.pm b/lib/ExtUtils/Typemaps.pm
|
||||||
|
index a16ae06..48d623e 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::Typemaps;
|
||||||
|
use 5.006001;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
require ExtUtils::ParseXS;
|
||||||
|
require ExtUtils::ParseXS::Constants;
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps/Cmd.pm b/lib/ExtUtils/Typemaps/Cmd.pm
|
||||||
|
index ccd5efe..ffed504 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps/Cmd.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps/Cmd.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::Typemaps::Cmd;
|
||||||
|
use 5.006001;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
use ExtUtils::Typemaps;
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps/InputMap.pm b/lib/ExtUtils/Typemaps/InputMap.pm
|
||||||
|
index 67ea1c2..86c646d 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps/InputMap.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps/InputMap.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::Typemaps::InputMap;
|
||||||
|
use 5.006001;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps/OutputMap.pm b/lib/ExtUtils/Typemaps/OutputMap.pm
|
||||||
|
index 42cbe5c..32cf9f9 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps/OutputMap.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps/OutputMap.pm
|
||||||
|
@@ -2,7 +2,7 @@ package ExtUtils::Typemaps::OutputMap;
|
||||||
|
use 5.006001;
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
||||||
|
diff --git a/lib/ExtUtils/Typemaps/Type.pm b/lib/ExtUtils/Typemaps/Type.pm
|
||||||
|
index 7e0f4ba..abe93cb 100644
|
||||||
|
--- a/lib/ExtUtils/Typemaps/Type.pm
|
||||||
|
+++ b/lib/ExtUtils/Typemaps/Type.pm
|
||||||
|
@@ -4,7 +4,7 @@ use strict;
|
||||||
|
use warnings;
|
||||||
|
require ExtUtils::Typemaps;
|
||||||
|
|
||||||
|
-our $VERSION = '3.30';
|
||||||
|
+our $VERSION = '3.31';
|
||||||
|
|
||||||
|
=head1 NAME
|
||||||
|
|
@ -1,13 +1,16 @@
|
|||||||
|
%global base_version 3.30
|
||||||
Name: perl-ExtUtils-ParseXS
|
Name: perl-ExtUtils-ParseXS
|
||||||
# Epoch to compete with perl.spec
|
# Epoch to compete with perl.spec
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 3.30
|
Version: 3.31
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Module and a script for converting Perl XS code into C code
|
Summary: Module and a script for converting Perl XS code into C code
|
||||||
License: GPL+ or Artistic
|
License: GPL+ or Artistic
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://search.cpan.org/dist/ExtUtils-ParseXS/
|
URL: http://search.cpan.org/dist/ExtUtils-ParseXS/
|
||||||
Source0: http://www.cpan.org/authors/id/S/SM/SMUELLER/ExtUtils-ParseXS-%{version}.tar.gz
|
Source0: http://www.cpan.org/authors/id/S/SM/SMUELLER/ExtUtils-ParseXS-%{base_version}.tar.gz
|
||||||
|
# Unbundled from perl 5.24.0
|
||||||
|
Patch0: ExtUtils-ParseXS-3.30-Upgrade-to-3.31.patch
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: coreutils
|
BuildRequires: coreutils
|
||||||
BuildRequires: findutils
|
BuildRequires: findutils
|
||||||
@ -50,7 +53,8 @@ constructs necessary to let C functions manipulate Perl values and creates
|
|||||||
the glue necessary to let Perl access those functions.
|
the glue necessary to let Perl access those functions.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n ExtUtils-ParseXS-%{version}
|
%setup -q -n ExtUtils-ParseXS-%{base_version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
perl Makefile.PL INSTALLDIRS=vendor
|
perl Makefile.PL INSTALLDIRS=vendor
|
||||||
@ -75,6 +79,9 @@ make test
|
|||||||
%{_mandir}/man3/*
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 11 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.31-1
|
||||||
|
- 3.31 bump in order to dual-live with perl 5.24
|
||||||
|
|
||||||
* Mon Apr 18 2016 Petr Pisar <ppisar@redhat.com> - 1:3.30-3
|
* Mon Apr 18 2016 Petr Pisar <ppisar@redhat.com> - 1:3.30-3
|
||||||
- Remove dependency on perl-devel (bug #1129443)
|
- Remove dependency on perl-devel (bug #1129443)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user