import perl-ExtUtils-MakeMaker-7.34-1.el8
This commit is contained in:
commit
3c9a5fe187
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/ExtUtils-MakeMaker-7.34.tar.gz
|
1
.perl-ExtUtils-MakeMaker.metadata
Normal file
1
.perl-ExtUtils-MakeMaker.metadata
Normal file
@ -0,0 +1 @@
|
||||
d0b625774460453a01f3da4bbf8a6f37576ff621 SOURCES/ExtUtils-MakeMaker-7.34.tar.gz
|
29
SOURCES/ExtUtils-MakeMaker-7.04-Unbundle-version.patch
Normal file
29
SOURCES/ExtUtils-MakeMaker-7.04-Unbundle-version.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From dd4d8926703b8be0e94aae15a5d574992be20dbe Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Mon, 27 Oct 2014 16:11:38 +0100
|
||||
Subject: [PATCH] Unbundle version
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
lib/ExtUtils/MakeMaker.pm | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/ExtUtils/MakeMaker.pm b/lib/ExtUtils/MakeMaker.pm
|
||||
index 1a5f045..71c3751 100644
|
||||
--- a/lib/ExtUtils/MakeMaker.pm
|
||||
+++ b/lib/ExtUtils/MakeMaker.pm
|
||||
@@ -7,7 +7,7 @@ BEGIN {require 5.006;}
|
||||
|
||||
require Exporter;
|
||||
use ExtUtils::MakeMaker::Config;
|
||||
-use ExtUtils::MakeMaker::version; # ensure we always have our fake version.pm
|
||||
+use version; # ensure we always have version.pm
|
||||
use Carp;
|
||||
use File::Path;
|
||||
my $CAN_DECODE = eval { require ExtUtils::MakeMaker::Locale; }; # 2 birds, 1 stone
|
||||
--
|
||||
1.9.3
|
||||
|
@ -0,0 +1,110 @@
|
||||
From e6cefdf6744b6068273a7f24956bb20fe82d4007 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Mon, 18 Apr 2016 14:46:20 +0200
|
||||
Subject: [PATCH] Provide ExtUtils::MM methods as standalone
|
||||
ExtUtils::MM::Utils
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
If you cannot afford depending on ExtUtils::MakeMaker, you can
|
||||
depend on ExtUtils::MM::Utils instead.
|
||||
|
||||
<https://bugzilla.redhat.com/show_bug.cgi?id=1129443>
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
MANIFEST | 1 +
|
||||
lib/ExtUtils/MM/Utils.pm | 68 ++++++++++++++++++++++++++++++++++++++++++++++++
|
||||
2 files changed, 69 insertions(+)
|
||||
create mode 100644 lib/ExtUtils/MM/Utils.pm
|
||||
|
||||
diff --git a/MANIFEST b/MANIFEST
|
||||
index 452c152..6d05775 100644
|
||||
--- a/MANIFEST
|
||||
+++ b/MANIFEST
|
||||
@@ -41,6 +41,7 @@ lib/ExtUtils/MakeMaker/version/vpp.pm
|
||||
lib/ExtUtils/Mkbootstrap.pm
|
||||
lib/ExtUtils/Mksymlists.pm
|
||||
lib/ExtUtils/MM.pm
|
||||
+lib/ExtUtils/MM/Utils.pm
|
||||
lib/ExtUtils/MM_AIX.pm
|
||||
lib/ExtUtils/MM_Any.pm
|
||||
lib/ExtUtils/MM_BeOS.pm
|
||||
diff --git a/lib/ExtUtils/MM/Utils.pm b/lib/ExtUtils/MM/Utils.pm
|
||||
new file mode 100644
|
||||
index 0000000..6bbc0d8
|
||||
--- /dev/null
|
||||
+++ b/lib/ExtUtils/MM/Utils.pm
|
||||
@@ -0,0 +1,68 @@
|
||||
+package ExtUtils::MM::Utils;
|
||||
+
|
||||
+require 5.006;
|
||||
+
|
||||
+use strict;
|
||||
+use vars qw($VERSION);
|
||||
+$VERSION = '7.11_06';
|
||||
+$VERSION = eval $VERSION; ## no critic [BuiltinFunctions::ProhibitStringyEval]
|
||||
+
|
||||
+=head1 NAME
|
||||
+
|
||||
+ExtUtils::MM::Utils - ExtUtils::MM methods without dependency on ExtUtils::MakeMaker
|
||||
+
|
||||
+=head1 SYNOPSIS
|
||||
+
|
||||
+ require ExtUtils::MM::Utils;
|
||||
+ MM->maybe_command($file);
|
||||
+
|
||||
+=head1 DESCRIPTION
|
||||
+
|
||||
+This is a collection of L<ExtUtils::MM> subroutines that are used by many
|
||||
+other modules but that do not need full-featured L<ExtUtils::MakeMaker>. The
|
||||
+issue with L<ExtUtils::MakeMaker> is it pulls in Perl header files and that is
|
||||
+an overkill for small subroutines.
|
||||
+
|
||||
+An example is the L<IPC::Cmd> that caused installing GCC just because of
|
||||
+three-line I<maybe_command()> from L<ExtUtils::MM_Unix>.
|
||||
+
|
||||
+The intentions is to use L<ExtUtils::MM::Utils> instead of
|
||||
+L<ExtUtils::MakeMaker> for these trivial methods. You can still call them via
|
||||
+L<MM> class name.
|
||||
+
|
||||
+=head1 METHODS
|
||||
+
|
||||
+=over 4
|
||||
+
|
||||
+=item maybe_command
|
||||
+
|
||||
+Returns true, if the argument is likely to be a command.
|
||||
+
|
||||
+=cut
|
||||
+
|
||||
+if (!exists $INC{'ExtUtils/MM.pm'}) {
|
||||
+ *MM::maybe_command = *ExtUtils::MM::maybe_command = \&maybe_command;
|
||||
+}
|
||||
+
|
||||
+sub maybe_command {
|
||||
+ my($self,$file) = @_;
|
||||
+ return $file if -x $file && ! -d $file;
|
||||
+ return;
|
||||
+}
|
||||
+
|
||||
+1;
|
||||
+
|
||||
+=back
|
||||
+
|
||||
+=head1 BUGS
|
||||
+
|
||||
+These methods are copied from L<ExtUtils::MM_Unix>. Other operating systems
|
||||
+are not supported yet. The reason is this
|
||||
+L<a hack for Linux
|
||||
+distributions|https://bugzilla.redhat.com/show_bug.cgi?id=1129443>.
|
||||
+
|
||||
+=head1 SEE ALSO
|
||||
+
|
||||
+L<ExtUtils::MakeMaker>, L<ExtUtils::MM>
|
||||
+
|
||||
+=cut
|
||||
--
|
||||
2.5.5
|
||||
|
31
SOURCES/ExtUtils-MakeMaker-7.22-Unbundle-Encode-Locale.patch
Normal file
31
SOURCES/ExtUtils-MakeMaker-7.22-Unbundle-Encode-Locale.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 04664fb41a3eaa5bc688c4095107486f8c6d2f4c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Mon, 27 Oct 2014 16:55:18 +0100
|
||||
Subject: [PATCH] Unbundle Encode::Locale
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
lib/ExtUtils/MakeMaker.pm | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/lib/ExtUtils/MakeMaker.pm b/lib/ExtUtils/MakeMaker.pm
|
||||
index 04ec5a3..759c079 100644
|
||||
--- a/lib/ExtUtils/MakeMaker.pm
|
||||
+++ b/lib/ExtUtils/MakeMaker.pm
|
||||
@@ -10,8 +10,8 @@ use ExtUtils::MakeMaker::Config;
|
||||
use version; # ensure we always have version.pm
|
||||
use Carp;
|
||||
use File::Path;
|
||||
-my $CAN_DECODE = eval { require ExtUtils::MakeMaker::Locale; }; # 2 birds, 1 stone
|
||||
-eval { ExtUtils::MakeMaker::Locale::reinit('UTF-8') }
|
||||
+my $CAN_DECODE = eval { require Encode::Locale; }; # 2 birds, 1 stone
|
||||
+eval { Encode::Locale::reinit('UTF-8') }
|
||||
if $CAN_DECODE and Encode::find_encoding('locale')->name eq 'ascii';
|
||||
|
||||
our $Verbose = 0; # exported
|
||||
--
|
||||
1.9.3
|
||||
|
@ -0,0 +1,52 @@
|
||||
From 4a4f7dd3d3e7877aa45081311c1a32421e0d32e4 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Tue, 2 Jul 2013 10:28:15 +0200
|
||||
Subject: [PATCH] Link to libperl explicitly on Linux
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
<https://bugzilla.redhat.com/show_bug.cgi?id=960048>
|
||||
<http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=327585#50>
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
lib/ExtUtils/MM_Unix.pm | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/ExtUtils/MM_Unix.pm b/lib/ExtUtils/MM_Unix.pm
|
||||
index 198f05e..d9ebe61 100644
|
||||
--- a/lib/ExtUtils/MM_Unix.pm
|
||||
+++ b/lib/ExtUtils/MM_Unix.pm
|
||||
@@ -30,6 +30,7 @@ BEGIN {
|
||||
$Is{IRIX} = $^O eq 'irix';
|
||||
$Is{NetBSD} = $^O eq 'netbsd';
|
||||
$Is{Interix} = $^O eq 'interix';
|
||||
+ $Is{Linux} = $^O eq 'linux';
|
||||
$Is{SunOS4} = $^O eq 'sunos';
|
||||
$Is{Solaris} = $^O eq 'solaris';
|
||||
$Is{SunOS} = $Is{SunOS4} || $Is{Solaris};
|
||||
@@ -1028,7 +1029,7 @@ sub xs_make_dynamic_lib {
|
||||
push(@m," \$(RM_F) \$\@\n");
|
||||
|
||||
my $libs = '$(LDLOADLIBS)';
|
||||
- if (($Is{NetBSD} || $Is{Interix} || $Is{Android}) && $Config{'useshrplib'} eq 'true') {
|
||||
+ if (($Is{Linux} || $Is{NetBSD} || $Is{Interix} || $Is{Android}) && $Config{'useshrplib'} eq 'true') {
|
||||
# Use nothing on static perl platforms, and to the flags needed
|
||||
# to link against the shared libperl library on shared perl
|
||||
# platforms. We peek at lddlflags to see if we need -Wl,-R
|
||||
@@ -1041,6 +1042,11 @@ sub xs_make_dynamic_lib {
|
||||
# The Android linker will not recognize symbols from
|
||||
# libperl unless the module explicitly depends on it.
|
||||
$libs .= ' "-L$(PERL_INC)" -lperl';
|
||||
+ } else {
|
||||
+ if ($ENV{PERL_CORE}) {
|
||||
+ $libs .= ' -L$(PERL_INC)';
|
||||
+ }
|
||||
+ $libs .= ' -lperl';
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.13.6
|
||||
|
134
SOURCES/ExtUtils-MakeMaker-7.30-USE_MM_LD_RUN_PATH.patch
Normal file
134
SOURCES/ExtUtils-MakeMaker-7.30-USE_MM_LD_RUN_PATH.patch
Normal file
@ -0,0 +1,134 @@
|
||||
From 83b4921f10f9df96ec359e20489864080f7b37ca Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Thu, 12 Jan 2012 17:05:19 +0100
|
||||
Subject: [PATCH] Do not set RPATH by default
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Former behavior can be forced by setting USE_MM_LD_RUN_PATH
|
||||
environment variable to 1.
|
||||
|
||||
This is copy from `perl' package.
|
||||
See <https://bugzilla.redhat.com/show_bug.cgi?id=773622>.
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
lib/ExtUtils/Liblist.pm | 5 +++++
|
||||
lib/ExtUtils/MM_Unix.pm | 2 +-
|
||||
lib/ExtUtils/MakeMaker.pm | 56 ++++++++++++++++++++++++++++++++++++++++++++++-
|
||||
3 files changed, 61 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/ExtUtils/Liblist.pm b/lib/ExtUtils/Liblist.pm
|
||||
index 15eed3c..219e96b 100644
|
||||
--- a/lib/ExtUtils/Liblist.pm
|
||||
+++ b/lib/ExtUtils/Liblist.pm
|
||||
@@ -89,6 +89,11 @@ libraries. LD_RUN_PATH is a colon separated list of the directories
|
||||
in LDLOADLIBS. It is passed as an environment variable to the process
|
||||
that links the shared library.
|
||||
|
||||
+Fedora extension: This generation of LD_RUN_PATH is disabled by default.
|
||||
+To use the generated LD_RUN_PATH for all links, set the USE_MM_LD_RUN_PATH
|
||||
+MakeMaker object attribute / argument, (or set the $USE_MM_LD_RUN_PATH
|
||||
+environment variable).
|
||||
+
|
||||
=head2 BSLOADLIBS
|
||||
|
||||
List of those libraries that are needed but can be linked in
|
||||
diff --git a/lib/ExtUtils/MM_Unix.pm b/lib/ExtUtils/MM_Unix.pm
|
||||
index 6233513..198f05e 100644
|
||||
--- a/lib/ExtUtils/MM_Unix.pm
|
||||
+++ b/lib/ExtUtils/MM_Unix.pm
|
||||
@@ -1045,7 +1045,7 @@ sub xs_make_dynamic_lib {
|
||||
}
|
||||
|
||||
my $ld_run_path_shell = "";
|
||||
- if ($self->{LD_RUN_PATH} ne "") {
|
||||
+ if (($self->{LD_RUN_PATH} ne "") && ($self->{USE_MM_LD_RUN_PATH})) {
|
||||
$ld_run_path_shell = 'LD_RUN_PATH="$(LD_RUN_PATH)" ';
|
||||
}
|
||||
|
||||
diff --git a/lib/ExtUtils/MakeMaker.pm b/lib/ExtUtils/MakeMaker.pm
|
||||
index 3d4913e..b52c96d 100644
|
||||
--- a/lib/ExtUtils/MakeMaker.pm
|
||||
+++ b/lib/ExtUtils/MakeMaker.pm
|
||||
@@ -317,7 +317,7 @@ sub full_setup {
|
||||
PERM_DIR PERM_RW PERM_RWX MAGICXS
|
||||
PL_FILES PM PM_FILTER PMLIBDIRS PMLIBPARENTDIRS POLLUTE
|
||||
PREREQ_FATAL PREREQ_PM PREREQ_PRINT PRINT_PREREQ
|
||||
- SIGN SKIP TEST_REQUIRES TYPEMAPS UNINST VERSION VERSION_FROM XS
|
||||
+ SIGN SKIP TEST_REQUIRES TYPEMAPS UNINST USE_MM_LD_RUN_PATH VERSION VERSION_FROM XS
|
||||
XSBUILD XSMULTI XSOPT XSPROTOARG XS_VERSION
|
||||
clean depend dist dynamic_lib linkext macro realclean tool_autosplit
|
||||
|
||||
@@ -503,6 +503,26 @@ sub new {
|
||||
$self->_PRINT_PREREQ;
|
||||
}
|
||||
|
||||
+ # USE_MM_LD_RUN_PATH - another RedHatism to disable automatic RPATH generation
|
||||
+ if ( ( ! $self->{USE_MM_LD_RUN_PATH} )
|
||||
+ &&( ("@ARGV" =~ /\bUSE_MM_LD_RUN_PATH(=([01]))?\b/)
|
||||
+ ||( exists( $ENV{USE_MM_LD_RUN_PATH} )
|
||||
+ &&( $ENV{USE_MM_LD_RUN_PATH} =~ /([01])?$/ )
|
||||
+ )
|
||||
+ )
|
||||
+ )
|
||||
+ {
|
||||
+ my $v = $1;
|
||||
+ if( $v )
|
||||
+ {
|
||||
+ $v = ($v=~/=([01])$/)[0];
|
||||
+ }else
|
||||
+ {
|
||||
+ $v = 1;
|
||||
+ };
|
||||
+ $self->{USE_MM_LD_RUN_PATH}=$v;
|
||||
+ };
|
||||
+
|
||||
print "MakeMaker (v$VERSION)\n" if $Verbose;
|
||||
if (-f "MANIFEST" && ! -f "Makefile" && ! $UNDER_CORE){
|
||||
check_manifest();
|
||||
@@ -2797,6 +2817,40 @@ precedence. A typemap in the current directory has highest
|
||||
precedence, even if it isn't listed in TYPEMAPS. The default system
|
||||
typemap has lowest precedence.
|
||||
|
||||
+=item USE_MM_LD_RUN_PATH
|
||||
+
|
||||
+boolean
|
||||
+The Fedora perl MakeMaker distribution differs from the standard
|
||||
+upstream release in that it disables use of the MakeMaker generated
|
||||
+LD_RUN_PATH by default, UNLESS this attribute is specified , or the
|
||||
+USE_MM_LD_RUN_PATH environment variable is set during the MakeMaker run.
|
||||
+
|
||||
+The upstream MakeMaker will set the ld(1) environment variable LD_RUN_PATH
|
||||
+to the concatenation of every -L ld(1) option directory in which a -l ld(1)
|
||||
+option library is found, which is used as the ld(1) -rpath option if none
|
||||
+is specified. This means that, if your application builds shared libraries
|
||||
+and your MakeMaker application links to them, that the absolute paths of the
|
||||
+libraries in the build tree will be inserted into the RPATH header of all
|
||||
+MakeMaker generated binaries, and that such binaries will be unable to link
|
||||
+to these libraries if they do not still reside in the build tree directories
|
||||
+(unlikely) or in the system library directories (/lib or /usr/lib), regardless
|
||||
+of any LD_LIBRARY_PATH setting. So if you specified -L../mylib -lmylib , and
|
||||
+ your 'libmylib.so' gets installed into /some_directory_other_than_usr_lib,
|
||||
+ your MakeMaker application will be unable to link to it, even if LD_LIBRARY_PATH
|
||||
+is set to include /some_directory_other_than_usr_lib, because RPATH overrides
|
||||
+LD_LIBRARY_PATH.
|
||||
+
|
||||
+So for Fedora MakeMaker builds LD_RUN_PATH is NOT generated by default for
|
||||
+every link. You can still use explicit -rpath ld options or the LD_RUN_PATH
|
||||
+environment variable during the build to generate an RPATH for the binaries.
|
||||
+
|
||||
+You can set the USE_MM_LD_RUN_PATH attribute to 1 on the MakeMaker command
|
||||
+line or in the WriteMakefile arguments to enable generation of LD_RUN_PATH
|
||||
+for every link command.
|
||||
+
|
||||
+USE_MM_LD_RUN_PATH will default to 1 (LD_RUN_PATH will be used) IF the
|
||||
+$USE_MM_LD_RUN_PATH environment variable is set during a MakeMaker run.
|
||||
+
|
||||
=item VENDORPREFIX
|
||||
|
||||
Like PERLPREFIX, but only for the vendor install locations.
|
||||
--
|
||||
2.13.6
|
||||
|
410
SPECS/perl-ExtUtils-MakeMaker.spec
Normal file
410
SPECS/perl-ExtUtils-MakeMaker.spec
Normal file
@ -0,0 +1,410 @@
|
||||
%global cpan_name ExtUtils-MakeMaker
|
||||
|
||||
Name: perl-%{cpan_name}
|
||||
Epoch: 1
|
||||
Version: 7.34
|
||||
Release: 1%{?dist}
|
||||
Summary: Create a module Makefile
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/%{cpan_name}/
|
||||
Source0: http://www.cpan.org/authors/id/B/BI/BINGOS/%{cpan_name}-%{version}.tar.gz
|
||||
# Do not set RPATH to perl shared-library modules by default. Bug #773622.
|
||||
# This is copy from `perl' package. This is a distributor extension.
|
||||
Patch0: %{cpan_name}-7.30-USE_MM_LD_RUN_PATH.patch
|
||||
# Link to libperl.so explicitly. Bug #960048.
|
||||
Patch1: %{cpan_name}-7.30-Link-to-libperl-explicitly-on-Linux.patch
|
||||
# Unbundle version modules
|
||||
Patch2: %{cpan_name}-7.04-Unbundle-version.patch
|
||||
# Unbundle Encode::Locale module
|
||||
Patch3: %{cpan_name}-7.22-Unbundle-Encode-Locale.patch
|
||||
# Provide maybe_command independently, bug #1129443
|
||||
Patch4: %{cpan_name}-7.11-Provide-ExtUtils-MM-methods-as-standalone-ExtUtils-M.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl-interpreter
|
||||
# Makefile.Pl uses ExtUtils::MakeMaker from ./lib
|
||||
# B needed only for CPAN::Meta::Requirements
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(Config)
|
||||
# CPAN::Meta::Requirements has a fallback
|
||||
BuildRequires: perl(Cwd)
|
||||
BuildRequires: perl(Encode)
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(File::Basename)
|
||||
BuildRequires: perl(File::Copy)
|
||||
BuildRequires: perl(File::Path)
|
||||
BuildRequires: perl(File::Spec) >= 0.8
|
||||
BuildRequires: perl(lib)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(vars)
|
||||
BuildRequires: perl(version)
|
||||
BuildRequires: perl(warnings)
|
||||
# If an XS module is compiled, xsubpp(1) is needed
|
||||
BuildRequires: perl-ExtUtils-ParseXS
|
||||
BuildRequires: sed
|
||||
# Tests:
|
||||
BuildRequires: perl(AutoSplit)
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(CPAN::Meta) >= 2.143240
|
||||
BuildRequires: perl(Data::Dumper)
|
||||
BuildRequires: perl(DynaLoader)
|
||||
BuildRequires: perl(ExtUtils::Install) >= 1.52
|
||||
# ExtUtils::Installed not used at tests
|
||||
BuildRequires: perl(ExtUtils::Manifest) >= 1.70
|
||||
# ExtUtils::Packlist not used at tests
|
||||
# ExtUtils::XSSymSet is not needed (VMS only)
|
||||
BuildRequires: perl(File::Find)
|
||||
BuildRequires: perl(File::Temp) >= 0.22
|
||||
BuildRequires: perl(Getopt::Long)
|
||||
# IO::File not used at tests
|
||||
# IO::Handle not used
|
||||
BuildRequires: perl(less)
|
||||
BuildRequires: perl(overload)
|
||||
BuildRequires: perl(Parse::CPAN::Meta) >= 1.4414
|
||||
BuildRequires: perl(Pod::Man)
|
||||
BuildRequires: perl(POSIX)
|
||||
BuildRequires: perl(subs)
|
||||
BuildRequires: perl(Test::Harness)
|
||||
BuildRequires: perl(Test::More)
|
||||
# threads::shared not used
|
||||
BuildRequires: perl(utf8)
|
||||
# XSLoader not used
|
||||
# Optional tests
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl(B)
|
||||
BuildRequires: perl(ExtUtils::CBuilder)
|
||||
BuildRequires: perl(PerlIO)
|
||||
# Keep YAML optional
|
||||
# Keep YAML::Tiny optional
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
Requires: perl(B)
|
||||
Recommends: perl(CPAN::Meta) >= 2.143240
|
||||
Suggests: perl(CPAN::Meta::Converter) >= 2.141170
|
||||
# CPAN::Meta::Requirements to support version ranges
|
||||
Recommends: perl(CPAN::Meta::Requirements) >= 2.130
|
||||
Requires: perl(Data::Dumper)
|
||||
Requires: perl(DynaLoader)
|
||||
# Encode is needed for producing POD with =encoding statement correctly
|
||||
Requires: perl(Encode)
|
||||
%if !%{defined perl_bootstrap}
|
||||
Recommends: perl(Encode::Locale)
|
||||
%endif
|
||||
Requires: perl(ExtUtils::Command) >= 1.19
|
||||
Requires: perl(ExtUtils::Install) >= 1.54
|
||||
Requires: perl(ExtUtils::Manifest) >= 1.70
|
||||
# ExtUtils::XSSymSet is not needed (VMS only)
|
||||
Requires: perl(File::Find)
|
||||
Requires: perl(File::Spec) >= 0.8
|
||||
Requires: perl(Getopt::Long)
|
||||
Suggests: perl(JSON::PP)
|
||||
# Optional Pod::Man is needed for generating manual pages from POD
|
||||
Requires: perl(Pod::Man)
|
||||
Requires: perl(POSIX)
|
||||
Requires: perl(Test::Harness)
|
||||
Recommends: perl(Time::HiRes)
|
||||
# Text::ParseWords is not needed (Win32 only)
|
||||
# VMS::Filespec is not needed (VMS only)
|
||||
# Win32 is not needed (Win32 only)
|
||||
# If an XS module is compiled, xsubpp(1) is needed
|
||||
Requires: perl-ExtUtils-ParseXS
|
||||
# If an XS module is built, code generated from XS will be compiled and it
|
||||
# includes Perl header files.
|
||||
# TODO: This dependency will be weaken in order to relieve building noarch
|
||||
# packages from perl-devel and gcc.
|
||||
Requires: perl-devel
|
||||
|
||||
# Do not export underspecified dependencies
|
||||
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(File::Spec\\)\s*$
|
||||
# Do not export private redefinitions
|
||||
%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(DynaLoader|ExtUtils::MakeMaker::_version\\)
|
||||
|
||||
%description
|
||||
This utility is designed to write a Makefile for an extension module from a
|
||||
Makefile.PL. It is based on the Makefile.SH model provided by Andy
|
||||
Dougherty and the perl5-porters.
|
||||
|
||||
%package -n perl-ExtUtils-Command
|
||||
Summary: Perl routines to replace common UNIX commands in Makefiles
|
||||
License: GPL+ or Artistic
|
||||
BuildArch: noarch
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
Requires: perl(Carp)
|
||||
Requires: perl(File::Copy)
|
||||
Requires: perl(File::Find)
|
||||
Requires: perl(File::Path)
|
||||
# File::Spec not used
|
||||
# VMS::Feature not used
|
||||
|
||||
%description -n perl-ExtUtils-Command
|
||||
This Perl module is used to replace common UNIX commands. In all cases the
|
||||
functions work with @ARGV rather than taking arguments. This makes them
|
||||
easier to deal with in Makefiles.
|
||||
|
||||
%package -n perl-ExtUtils-MM-Utils
|
||||
Summary: ExtUtils::MM methods without dependency on ExtUtils::MakeMaker
|
||||
License: GPL+ or Artistic
|
||||
BuildArch: noarch
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
|
||||
%description -n perl-ExtUtils-MM-Utils
|
||||
This is a collection of ExtUtils::MM subroutines that are used by many
|
||||
other modules but that do not need full-featured ExtUtils::MakeMaker. The
|
||||
issue with ExtUtils::MakeMaker is it pulls in Perl header files and that
|
||||
is an overkill for small subroutines.
|
||||
|
||||
%prep
|
||||
%setup -q -n ExtUtils-MakeMaker-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
# Remove bundled modules
|
||||
rm -rf bundled
|
||||
sed -i -e '/^bundled\// d' MANIFEST
|
||||
rm -rf t/lib/Test
|
||||
sed -i -e '/^t\/lib\/Test\// d' MANIFEST
|
||||
rm -rf lib/ExtUtils/MakeMaker/version{,.pm}
|
||||
sed -i -e '/^lib\/ExtUtils\/MakeMaker\/version[\/\.]/ d' MANIFEST
|
||||
rm -rf lib/ExtUtils/MakeMaker/Locale.pm
|
||||
sed -i -e '/^lib\/ExtUtils\/MakeMaker\/Locale\.pm/ d' MANIFEST
|
||||
|
||||
%build
|
||||
BUILDING_AS_PACKAGE=1 perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%files
|
||||
%doc Changes CONTRIBUTING README
|
||||
%{_bindir}/*
|
||||
%{perl_vendorlib}/*
|
||||
%exclude %{perl_vendorlib}/ExtUtils/Command.pm
|
||||
%exclude %dir %{perl_vendorlib}/ExtUtils/MM
|
||||
%exclude %{perl_vendorlib}/ExtUtils/MM/Utils.pm
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man3/*
|
||||
%exclude %{_mandir}/man3/ExtUtils::Command.*
|
||||
%exclude %{_mandir}/man3/ExtUtils::MM::Utils.*
|
||||
|
||||
%files -n perl-ExtUtils-Command
|
||||
%dir %{perl_vendorlib}/ExtUtils
|
||||
%{perl_vendorlib}/ExtUtils/Command.pm
|
||||
%{_mandir}/man3/ExtUtils::Command.*
|
||||
|
||||
%files -n perl-ExtUtils-MM-Utils
|
||||
%dir %{perl_vendorlib}/ExtUtils
|
||||
%dir %{perl_vendorlib}/ExtUtils/MM
|
||||
%{perl_vendorlib}/ExtUtils/MM/Utils.pm
|
||||
%{_mandir}/man3/ExtUtils::MM::Utils.*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 19 2018 Petr Pisar <ppisar@redhat.com> - 1:7.34-1
|
||||
- 7.34 bump
|
||||
|
||||
* Mon Feb 19 2018 Petr Pisar <ppisar@redhat.com> - 1:7.32-1
|
||||
- 7.32 bump
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:7.30-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Dec 18 2017 Petr Pisar <ppisar@redhat.com> - 1:7.30-3
|
||||
- Rebase patches
|
||||
- Do not recommend non-core Encode::Locale on bootstrapping
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:7.30-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Jun 13 2017 Petr Pisar <ppisar@redhat.com> - 1:7.30-1
|
||||
- 7.30 bump
|
||||
|
||||
* Sat Jun 03 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1:7.28-2
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Wed May 31 2017 Petr Pisar <ppisar@redhat.com> - 7.28-1
|
||||
- 7.28 bump
|
||||
|
||||
* Mon May 29 2017 Petr Pisar <ppisar@redhat.com> - 7.26-1
|
||||
- 7.26 bump
|
||||
- Fix META generation (CPAN RT#121913)
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.24-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Aug 25 2016 Jitka Plesnikova <jplesnik@redhat.com> - 7.24-1
|
||||
- 7.24 bump
|
||||
|
||||
* Tue Aug 09 2016 Jitka Plesnikova <jplesnik@redhat.com> - 7.22-1
|
||||
- 7.22 bump
|
||||
|
||||
* Tue May 24 2016 Petr Pisar <ppisar@redhat.com> - 7.18-1
|
||||
- 7.18 bump
|
||||
|
||||
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 7.16-2
|
||||
- Perl 5.24 rebuild
|
||||
|
||||
* Mon May 09 2016 Petr Pisar <ppisar@redhat.com> - 7.16-1
|
||||
- 7.16 bump
|
||||
|
||||
* Mon Apr 25 2016 Petr Pisar <ppisar@redhat.com> - 7.14-1
|
||||
- 7.14 bump
|
||||
|
||||
* Wed Apr 20 2016 Petr Pisar <ppisar@redhat.com> - 7.12-1
|
||||
- 7.12 bump
|
||||
|
||||
* Tue Apr 19 2016 Petr Pisar <ppisar@redhat.com> - 7.10-5
|
||||
- Own ExtUtils/MM directory by perl-ExtUtils-MM-Utils only
|
||||
- Require perl-devel by perl-ExtUtils-MakeMaker
|
||||
|
||||
* Mon Apr 18 2016 Petr Pisar <ppisar@redhat.com> - 7.10-4
|
||||
- Provide maybe_command independently (bug #1129443)
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.10-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Dec 03 2015 Petr Pisar <ppisar@redhat.com> - 7.10-2
|
||||
- Declare optional dependencies on Recommends level
|
||||
|
||||
* Fri Sep 11 2015 Petr Pisar <ppisar@redhat.com> - 7.10-1
|
||||
- 7.10 bump
|
||||
|
||||
* Wed Sep 09 2015 Petr Pisar <ppisar@redhat.com> - 7.08-1
|
||||
- 7.08 bump
|
||||
|
||||
* Tue Sep 01 2015 Jitka Plesnikova <jplesnik@redhat.com> - 7.06-2
|
||||
- Remove new line from INC (CPAN RT#106808)
|
||||
|
||||
* Tue Sep 01 2015 Petr Pisar <ppisar@redhat.com> - 7.06-1
|
||||
- 7.06 bump
|
||||
- ExtUtils::Command module is distributed by ExtUtils-MakeMaker
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.04-346
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 7.04-345
|
||||
- Increase release to favour standalone package
|
||||
|
||||
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 7.04-2
|
||||
- Perl 5.22 rebuild
|
||||
|
||||
* Fri Dec 05 2014 Petr Pisar <ppisar@redhat.com> - 7.04-1
|
||||
- 7.04 bump
|
||||
|
||||
* Tue Nov 11 2014 Petr Pisar <ppisar@redhat.com> - 7.02-1
|
||||
- 7.02 bump
|
||||
- Cope with missing Encode::Locale
|
||||
|
||||
* Wed Nov 05 2014 Petr Pisar <ppisar@redhat.com> - 7.00-2
|
||||
- Fix building with older xsubpp
|
||||
|
||||
* Mon Oct 27 2014 Petr Pisar <ppisar@redhat.com> - 7.00-1
|
||||
- 7.00 bump
|
||||
|
||||
* Fri Oct 24 2014 Petr Pisar <ppisar@redhat.com> - 6.98-311
|
||||
- Require perl-ExtUtils-ParseXS because of xsubpp
|
||||
|
||||
* Wed Sep 03 2014 Jitka Plesnikova <jplesnik@redhat.com> - 6.98-310
|
||||
- Increase release to favour standalone package
|
||||
|
||||
* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 6.98-3
|
||||
- Perl 5.20 rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.98-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri May 02 2014 Petr Pisar <ppisar@redhat.com> - 6.98-1
|
||||
- 6.98 bump
|
||||
|
||||
* Mon Apr 14 2014 Petr Pisar <ppisar@redhat.com> - 6.96-1
|
||||
- 6.96 bump
|
||||
|
||||
* Wed Mar 26 2014 Petr Pisar <ppisar@redhat.com> - 6.94-1
|
||||
- 6.94 bump
|
||||
|
||||
* Fri Mar 14 2014 Petr Pisar <ppisar@redhat.com> - 6.92-1
|
||||
- 6.92 bump
|
||||
|
||||
* Fri Feb 21 2014 Petr Pisar <ppisar@redhat.com> - 6.90-1
|
||||
- 6.90 bump
|
||||
|
||||
* Mon Feb 03 2014 Petr Pisar <ppisar@redhat.com> - 6.88-1
|
||||
- 6.88 bump
|
||||
|
||||
* Mon Jan 06 2014 Petr Pisar <ppisar@redhat.com> - 6.86-1
|
||||
- 6.86 bump
|
||||
|
||||
* Mon Dec 02 2013 Petr Pisar <ppisar@redhat.com> - 6.84-1
|
||||
- 6.84 bump
|
||||
|
||||
* Tue Nov 05 2013 Petr Pisar <ppisar@redhat.com> - 6.82-1
|
||||
- 6.82 bump
|
||||
|
||||
* Wed Oct 16 2013 Petr Pisar <ppisar@redhat.com> - 6.80-1
|
||||
- 6.80 bump
|
||||
|
||||
* Tue Sep 24 2013 Petr Pisar <ppisar@redhat.com> - 6.78-1
|
||||
- 6.78 bump
|
||||
|
||||
* Mon Sep 16 2013 Petr Pisar <ppisar@redhat.com> - 6.76-2
|
||||
- Specify all dependencies (bug #1007755)
|
||||
|
||||
* Tue Sep 10 2013 Petr Pisar <ppisar@redhat.com> - 6.76-1
|
||||
- 6.76 bump
|
||||
|
||||
* Mon Sep 02 2013 Petr Pisar <ppisar@redhat.com> - 6.74-1
|
||||
- 6.74 bump
|
||||
|
||||
* Mon Aug 05 2013 Petr Pisar <ppisar@redhat.com> - 6.72-1
|
||||
- 6.72 bump
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.68-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 6.68-4
|
||||
- Perl 5.18 rebuild
|
||||
|
||||
* Tue Jul 02 2013 Petr Pisar <ppisar@redhat.com> - 6.68-3
|
||||
- Link to libperl.so explicitly (bug #960048)
|
||||
|
||||
* Thu Jun 27 2013 Jitka Plesnikova <jplesnik@redhat.com> - 6.68-2
|
||||
- Update BRs
|
||||
|
||||
* Mon Jun 17 2013 Petr Pisar <ppisar@redhat.com> - 6.68-1
|
||||
- 6.68 bump
|
||||
|
||||
* Mon Apr 22 2013 Petr Pisar <ppisar@redhat.com> - 6.66-1
|
||||
- 6.66 bump
|
||||
|
||||
* Tue Jan 29 2013 Petr Pisar <ppisar@redhat.com> - 6.64-2
|
||||
- Run-require POD convertors to get manual pages when building other packages
|
||||
|
||||
* Mon Dec 17 2012 Petr Pisar <ppisar@redhat.com> - 6.64-1
|
||||
- 6.64 bump
|
||||
|
||||
* Tue Aug 28 2012 Petr Pisar <ppisar@redhat.com> - 6.63.02-241
|
||||
- Compute RPM version
|
||||
- Do not build-require itself, the build script runs from ./lib
|
||||
|
||||
* Mon Aug 13 2012 Marcela Mašláňová <mmaslano@redhat.com> - 6.63.02-240
|
||||
- update version to the same as in perl.srpm
|
||||
- Bump release to override sub-package from perl.spec
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.62-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Wed Jun 06 2012 Petr Pisar <ppisar@redhat.com> - 6.62-3
|
||||
- Perl 5.16 rebuild
|
||||
|
||||
* Thu Jan 12 2012 Petr Pisar <ppisar@redhat.com> - 6.62-2
|
||||
- Do not set RPATH to perl shared-library modules by default (bug #773622)
|
||||
|
||||
* Fri Nov 25 2011 Petr Pisar <ppisar@redhat.com> 6.62-1
|
||||
- Specfile autogenerated by cpanspec 1.78.
|
||||
- Remove defattr and BuildRoot from spec.
|
Loading…
Reference in New Issue
Block a user