Update to 0.06
- New upstream release 0.06 - Add optional runtime conflict warnings - Require 5.8.1, clean up a few things and add a few more tests - Use Exporter instead of Sub::Exporter - Update patch for building with Test::More < 0.88 - Drop patch for building with old ExtUtils::MakeMaker, no longer needed - Don't need to remove empty directories from the buildroot
This commit is contained in:
parent
63a0c0019c
commit
b259d0dff6
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/Dist-CheckConflicts-0.02.tar.gz
|
||||
/Dist-CheckConflicts-[0-9.]*.tar.gz
|
||||
|
@ -1,90 +0,0 @@
|
||||
diff -up Dist-CheckConflicts-0.02/t/01-basic.t.orig Dist-CheckConflicts-0.02/t/01-basic.t
|
||||
--- Dist-CheckConflicts-0.02/t/01-basic.t.orig 2011-01-02 14:20:32.000000000 +0000
|
||||
+++ Dist-CheckConflicts-0.02/t/01-basic.t 2011-01-04 14:43:47.468148878 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 6;
|
||||
use lib 't/lib/01';
|
||||
|
||||
{
|
||||
@@ -43,5 +43,3 @@ use lib 't/lib/01';
|
||||
"nested conflicts work"
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Dist-CheckConflicts-0.02/t/02-conflicts.t.orig Dist-CheckConflicts-0.02/t/02-conflicts.t
|
||||
--- Dist-CheckConflicts-0.02/t/02-conflicts.t.orig 2011-01-02 14:20:32.000000000 +0000
|
||||
+++ Dist-CheckConflicts-0.02/t/02-conflicts.t 2011-01-04 14:44:21.924129103 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 12;
|
||||
use Test::Fatal;
|
||||
use lib 't/lib/02';
|
||||
|
||||
@@ -66,5 +66,3 @@ use lib 't/lib/02';
|
||||
"correct conflict error"
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Dist-CheckConflicts-0.02/t/03-dist.t.orig Dist-CheckConflicts-0.02/t/03-dist.t
|
||||
--- Dist-CheckConflicts-0.02/t/03-dist.t.orig 2011-01-02 14:20:32.000000000 +0000
|
||||
+++ Dist-CheckConflicts-0.02/t/03-dist.t 2011-01-04 14:44:52.868009491 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 16;
|
||||
use Test::Fatal;
|
||||
use lib 't/lib/03';
|
||||
|
||||
@@ -70,5 +70,3 @@ use lib 't/lib/03';
|
||||
);
|
||||
is(Bar::Conflicts::Bad->dist, 'Bar', "correct dist");
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Dist-CheckConflicts-0.02/t/04-merge.t.orig Dist-CheckConflicts-0.02/t/04-merge.t
|
||||
--- Dist-CheckConflicts-0.02/t/04-merge.t.orig 2011-01-02 14:20:32.000000000 +0000
|
||||
+++ Dist-CheckConflicts-0.02/t/04-merge.t 2011-01-04 14:45:12.730574644 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 2;
|
||||
use lib 't/lib/04';
|
||||
|
||||
{
|
||||
@@ -17,5 +17,3 @@ use lib 't/lib/04';
|
||||
"got the right conflicts"
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
diff -up Dist-CheckConflicts-0.02/t/05-also.t.orig Dist-CheckConflicts-0.02/t/05-also.t
|
||||
--- Dist-CheckConflicts-0.02/t/05-also.t.orig 2011-01-02 14:20:32.000000000 +0000
|
||||
+++ Dist-CheckConflicts-0.02/t/05-also.t 2011-01-04 14:45:31.260101893 +0000
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 4;
|
||||
use Test::Fatal;
|
||||
use lib 't/lib/05';
|
||||
|
||||
@@ -28,5 +28,3 @@ use lib 't/lib/05';
|
||||
"unknown also entries are ignored"
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
@ -1,30 +0,0 @@
|
||||
--- Dist-CheckConflicts-0.02/Makefile.PL.orig 2011-01-02 14:20:32.000000000 +0000
|
||||
+++ Dist-CheckConflicts-0.02/Makefile.PL 2011-01-04 14:50:52.788254795 +0000
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
|
||||
|
||||
-use ExtUtils::MakeMaker 6.31;
|
||||
+use ExtUtils::MakeMaker;
|
||||
|
||||
|
||||
|
||||
@@ -16,7 +16,7 @@
|
||||
'Test::More' => '0.88'
|
||||
},
|
||||
'CONFIGURE_REQUIRES' => {
|
||||
- 'ExtUtils::MakeMaker' => '6.31'
|
||||
+ 'ExtUtils::MakeMaker' => '0'
|
||||
},
|
||||
'DISTNAME' => 'Dist-CheckConflicts',
|
||||
'EXE_FILES' => [],
|
||||
@@ -49,6 +49,9 @@
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
||||
|
||||
+delete $WriteMakefileArgs{LICENSE}
|
||||
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
|
||||
+
|
||||
WriteMakefile(%WriteMakefileArgs);
|
||||
|
||||
|
101
Dist-CheckConflicts-0.06-old-Test::More.patch
Normal file
101
Dist-CheckConflicts-0.06-old-Test::More.patch
Normal file
@ -0,0 +1,101 @@
|
||||
--- t/01-basic.t
|
||||
+++ t/01-basic.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 6;
|
||||
use lib 't/lib/01';
|
||||
|
||||
{
|
||||
@@ -43,5 +43,3 @@ use lib 't/lib/01';
|
||||
"nested conflicts work"
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/02-conflicts.t
|
||||
+++ t/02-conflicts.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 12;
|
||||
use Test::Fatal;
|
||||
use lib 't/lib/02';
|
||||
|
||||
@@ -68,5 +68,3 @@ use lib 't/lib/02';
|
||||
"correct conflict error"
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/03-dist.t
|
||||
+++ t/03-dist.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 16;
|
||||
use Test::Fatal;
|
||||
use lib 't/lib/03';
|
||||
|
||||
@@ -72,5 +72,3 @@ use lib 't/lib/03';
|
||||
);
|
||||
is(Bar::Conflicts::Bad->dist, 'Bar', "correct dist");
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/04-merge.t
|
||||
+++ t/04-merge.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 2;
|
||||
use lib 't/lib/04';
|
||||
|
||||
{
|
||||
@@ -17,5 +17,3 @@ use lib 't/lib/04';
|
||||
"got the right conflicts"
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/05-also.t
|
||||
+++ t/05-also.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 4;
|
||||
use Test::Fatal;
|
||||
use lib 't/lib/05';
|
||||
|
||||
@@ -28,5 +28,3 @@ use lib 't/lib/05';
|
||||
"unknown also entries are ignored"
|
||||
);
|
||||
}
|
||||
-
|
||||
-done_testing;
|
||||
--- t/06-runtime.t
|
||||
+++ t/06-runtime.t
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env perl
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More;
|
||||
+use Test::More tests => 9;
|
||||
use lib 't/lib/06';
|
||||
|
||||
sub use_ok_warnings {
|
||||
@@ -44,4 +44,3 @@ is(scalar(grep { ref($_) eq 'ARRAY' && @
|
||||
1,
|
||||
"only installed one \@INC hook");
|
||||
|
||||
-done_testing;
|
@ -1,26 +1,26 @@
|
||||
# We need to patch the test suite if we have an old version of Test::More
|
||||
%global old_test_more %(perl -MTest::More -e 'printf "%d\\n", $Test::More::VERSION < 0.88 ? 1 : 0;' 2>/dev/null || echo 0)
|
||||
|
||||
# We don't really need ExtUtils::MakeMaker > 6.31
|
||||
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0)
|
||||
%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
|
||||
|
||||
Name: perl-Dist-CheckConflicts
|
||||
Version: 0.02
|
||||
Release: 8%{?dist}
|
||||
Version: 0.06
|
||||
Release: 1%{?dist}
|
||||
Summary: Declare version conflicts for your dist
|
||||
Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/Dist-CheckConflicts/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Dist-CheckConflicts-%{version}.tar.gz
|
||||
Patch0: Dist-CheckConflicts-0.02-old-eumm.patch
|
||||
Patch1: Dist-CheckConflicts-0.02-old-Test::More.patch
|
||||
Patch1: Dist-CheckConflicts-0.06-old-Test::More.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
BuildRequires: perl(File::Find)
|
||||
BuildRequires: perl(File::Temp)
|
||||
BuildRequires: perl(lib)
|
||||
BuildRequires: perl(List::MoreUtils) >= 0.12
|
||||
BuildRequires: perl(Pod::Coverage::TrustPod)
|
||||
BuildRequires: perl(Sub::Exporter)
|
||||
BuildRequires: perl(Test::EOL)
|
||||
BuildRequires: perl(Test::Fatal)
|
||||
BuildRequires: perl(Test::More)
|
||||
@ -50,14 +50,9 @@ this manually.
|
||||
%prep
|
||||
%setup -q -n Dist-CheckConflicts-%{version}
|
||||
|
||||
# Don't really need ExtUtils::MakeMaker >= 6.31
|
||||
%if %{old_eumm}
|
||||
%patch0 -p1
|
||||
%endif
|
||||
|
||||
# Test suite needs patching if we have Test::More < 0.88
|
||||
%if %{old_test_more}
|
||||
%patch1 -p1
|
||||
%patch1
|
||||
%endif
|
||||
|
||||
%build
|
||||
@ -68,7 +63,6 @@ make %{?_smp_mflags}
|
||||
rm -rf %{buildroot}
|
||||
make pure_install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
|
||||
find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
|
||||
%{_fixperms} %{buildroot}
|
||||
|
||||
%check
|
||||
@ -84,6 +78,15 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man3/Dist::CheckConflicts.3pm*
|
||||
|
||||
%changelog
|
||||
* Sat Jun 22 2013 Paul Howarth <paul@city-fan.org> - 0.06-1
|
||||
- Update to 0.06
|
||||
- Add optional runtime conflict warnings
|
||||
- Require 5.8.1, clean up a few things and add a few more tests
|
||||
- Use Exporter instead of Sub::Exporter
|
||||
- Update patch for building with Test::More < 0.88
|
||||
- Drop patch for building with old ExtUtils::MakeMaker, no longer needed
|
||||
- Don't need to remove empty directories from the buildroot
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user