Initial version: 5.48.
This commit is contained in:
parent
03152a98a1
commit
8421a3a427
@ -0,0 +1 @@
|
||||
Date-Manip-5.48.tar.gz
|
38
perl-Date-Manip-5.48-datez-rhbz248500.patch
Normal file
38
perl-Date-Manip-5.48-datez-rhbz248500.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -ru Date-Manip-5.48/Manip.pm Date-Manip-5.48-new/Manip.pm
|
||||
--- Date-Manip-5.48/Manip.pm 2007-11-27 14:10:10.000000000 +0000
|
||||
+++ Date-Manip-5.48-new/Manip.pm 2008-01-03 15:58:03.000000000 +0000
|
||||
@@ -3561,6 +3561,7 @@
|
||||
$tz=$ENV{'SYS$TIMEZONE_DIFFERENTIAL'}/3600.; # e.g. '-4' for EDT
|
||||
}
|
||||
}
|
||||
+ push(@tz,$tz) if (defined $tz);
|
||||
} else {
|
||||
$tz=`date +%Z 2> /dev/null`;
|
||||
chomp($tz);
|
||||
@@ -3569,8 +3570,13 @@
|
||||
chomp($tz);
|
||||
$tz=(split(/\s+/,$tz))[4];
|
||||
}
|
||||
+ push(@tz,$tz) if (defined $tz);
|
||||
+
|
||||
+ # for international timezones
|
||||
+ $tz=`date +%z 2> /dev/null`;
|
||||
+ chomp($tz);
|
||||
+ push(@tz,$tz) if (defined $tz);
|
||||
}
|
||||
- push(@tz,$tz) if (defined $tz);
|
||||
} else {
|
||||
# We need to satisfy taint checking, but also look in all the
|
||||
# directories in @DatePath.
|
||||
@@ -3585,6 +3591,11 @@
|
||||
$tz=(split(/\s+/,$tz))[4];
|
||||
}
|
||||
push(@tz,$tz) if (defined $tz);
|
||||
+
|
||||
+ # for international timezones
|
||||
+ $tz=`date +%z 2> /dev/null`;
|
||||
+ chomp($tz);
|
||||
+ push(@tz,$tz) if (defined $tz);
|
||||
}
|
||||
}
|
||||
|
109
perl-Date-Manip.spec
Normal file
109
perl-Date-Manip.spec
Normal file
@ -0,0 +1,109 @@
|
||||
Name: perl-Date-Manip
|
||||
Version: 5.48
|
||||
Release: 1%{?dist}
|
||||
Summary: A Perl module containing a wide variety of date manipulation routines
|
||||
|
||||
Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/Date-Manip/
|
||||
Source0: http://www.cpan.org/authors/id/S/SB/SBECK/Date-Manip-%{version}.tar.gz
|
||||
Patch0: perl-Date-Manip-5.48-datez-rhbz248500.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||
|
||||
# This package was formerly known as perl-DateManip
|
||||
Provides: perl-DateManip = %{version}-%{release}
|
||||
Obsoletes: perl-DateManip < 5.48-1
|
||||
|
||||
|
||||
%description
|
||||
This is a set of routines designed to make any common date/time
|
||||
manipulation easy to do. Operations such as comparing two times,
|
||||
calculating a time a given amount of time from another, or parsing
|
||||
international times are all easily done.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n Date-Manip-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%{__perl} Makefile.PL INSTALLDIRS=vendor
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
|
||||
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
|
||||
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc README TODO HISTORY
|
||||
%{perl_vendorlib}/Date/
|
||||
%{_mandir}/man3/*.3*
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 3 2008 Ed Avis <eda@waniasset.com> - 5.48-1
|
||||
- Update to 5.48.
|
||||
- rhbz#214709 Krasnoyarsk patch now upstream.
|
||||
- Changed name to Date-Manip as now used on CPAN.
|
||||
|
||||
* Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 5.44-4
|
||||
- Apply patch to use date +%%z as possible source for timezone data
|
||||
- Fix license tag
|
||||
- Add TODO and HISTORY to %%doc list
|
||||
|
||||
* Tue Mar 20 2007 Robin Norwood <rnorwood@redhat.com> - 5.44-3
|
||||
- Fix minor issues in spec file for package review
|
||||
- Bump release
|
||||
- Resolves: rhbz#226250
|
||||
|
||||
* Fri Nov 10 2006 Robin Norwood <rnorwood@redhat.com> - 5.44-2
|
||||
- Add support for KRAT and KRAST timezones
|
||||
- Include magic dist tag in release
|
||||
- Resolves: rhbz#214709
|
||||
- Related: rhbz#100786
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 5.44-1.3
|
||||
- rebuild
|
||||
|
||||
* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 5.44-1.2
|
||||
- rebuild for new perl-5.8.8
|
||||
|
||||
* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt for new gcc
|
||||
|
||||
* Fri Sep 9 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 5.44-1
|
||||
- Update to 5.44.
|
||||
|
||||
* Mon Apr 25 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 5.42a-4
|
||||
- Bring up to date with current Fedora.Extras perl spec template. (#155913)
|
||||
|
||||
* Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 5.42a-2
|
||||
- rebuild
|
||||
|
||||
* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 5.42a-1
|
||||
- update to 5.42a
|
||||
|
||||
* Tue Aug 6 2002 Chip Turner <cturner@redhat.com>
|
||||
- automated release bump and build
|
||||
|
||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Fri Dec 7 2001 root <root@redhat.com>
|
||||
- Spec file was autogenerated.
|
Loading…
Reference in New Issue
Block a user