Patch out subfilter constants

- The xz API changed slightly for the 5.0.0 release, removing support
  for sub-block filters and bumping the library soname to liblzma.so.5.
  This update patches out the now-missing constants so that the
  package can be built with the new library.

  The issue has been raised upstream as CPAN RT#62461
This commit is contained in:
Paul Howarth 2010-10-26 18:45:07 +01:00
parent 54b7cd5211
commit 927c8a46f3
2 changed files with 39 additions and 1 deletions

View File

@ -0,0 +1,31 @@
--- Compress-Raw-Lzma-2.030/Makefile.PL.orig 2009-12-27 13:49:56.000000000 +0000
+++ Compress-Raw-Lzma-2.030/Makefile.PL 2010-10-26 15:53:26.339111604 +0100
@@ -288,28 +288,6 @@
#LZMA_BACKWARD_SIZE_MAX
-# subblock.h
-##########
-LZMA_FILTER_SUBBLOCK
-
-# enum lzma_subfilter_mode
-LZMA_SUBFILTER_NONE enum
-LZMA_SUBFILTER_SET enum
-LZMA_SUBFILTER_RUN enum
-LZMA_SUBFILTER_FINISH enum
-
-LZMA_SUBBLOCK_ALIGNMENT_MIN
-LZMA_SUBBLOCK_ALIGNMENT_MAX
-LZMA_SUBBLOCK_ALIGNMENT_DEFAULT
-
-LZMA_SUBBLOCK_DATA_SIZE_MIN
-LZMA_SUBBLOCK_DATA_SIZE_MAX
-LZMA_SUBBLOCK_DATA_SIZE_DEFAULT
-
-LZMA_SUBBLOCK_RLE_OFF
-LZMA_SUBBLOCK_RLE_MIN
-LZMA_SUBBLOCK_RLE_MAX
-
# version.h
###########
LZMA_VERSION

View File

@ -1,11 +1,12 @@
Name: perl-Compress-Raw-Lzma
Version: 2.030
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Low-level interface to lzma compression library
Group: Development/Libraries
License: GPL+ or Artistic
URL: http://search.cpan.org/dist/Compress-Raw-Lzma/
Source0: http://search.cpan.org/CPAN/authors/id/P/PM/PMQS/Compress-Raw-Lzma-%{version}.tar.gz
Patch0: Compress-Raw-Lzma-2.030-no-subfilters.patch
BuildRequires: xz, xz-devel, perl(ExtUtils::MakeMaker), perl(Test::Pod)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
@ -19,6 +20,9 @@ It is used by IO::Compress::Lzma.
%prep
%setup -q -n Compress-Raw-Lzma-%{version}
# xz 5.0.0 removes subfilter support
%patch0 -p1
%build
perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
make %{?_smp_mflags}
@ -41,6 +45,9 @@ make test
%{_mandir}/man3/Compress::Raw::Lzma.3pm*
%changelog
* Tue Oct 26 2010 Paul Howarth <paul@city-fan.org> - 2.030-2
- Patch out subfilter constants, not supported in xz 5.x (CPAN RT#62461)
* Mon Jul 26 2010 Paul Howarth <paul@city-fan.org> - 2.030-1
- Update to 2.030 (no changes)