diff --git a/.cvsignore b/.cvsignore
index e69de29..7c8c925 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -0,0 +1 @@
+Class-Singleton-1.03.tar.gz
diff --git a/perl-Class-Singleton.spec b/perl-Class-Singleton.spec
new file mode 100644
index 0000000..07f7ced
--- /dev/null
+++ b/perl-Class-Singleton.spec
@@ -0,0 +1,56 @@
+Name:           perl-Class-Singleton
+Version:        1.03
+Release:        1%{?dist}
+Summary:        Class::Singleton Perl module
+License:        Artistic
+Group:          Development/Libraries
+URL:            http://search.cpan.org/dist/Class-Singleton/
+Source0:        http://www.cpan.org/modules/by-module/Class/Class-Singleton-1.03.tar.gz
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch:      noarch
+Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+
+%description
+This is the Class::Singleton module. A Singleton describes an object
+class that can have only one instance in any system. An example of a
+Singleton might be a print spooler or system registry. This module
+implements a Singleton class from which other classes can be derived.
+By itself, the Class::Singleton module does very little other than
+manage the instantiation of a single object. In deriving a class from
+Class::Singleton, your module will inherit the Singleton instantiation
+method and can implement whatever specific functionality is required.
+
+%prep
+%setup -q -n Class-Singleton-%{version}
+
+%build
+%{__perl} Makefile.PL INSTALLDIRS=vendor
+make %{?_smp_mflags}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
+find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null \;
+
+chmod -R u+rwX,go+rX,go-w $RPM_BUILD_ROOT/*
+
+perldoc -t perlartistic > Artistic
+
+%check
+make test
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc Changes README Artistic
+%{perl_vendorlib}/*
+%{_mandir}/man3/*
+
+%changelog
+* Wed Aug 31 2005 Steven Pritchard <steve@kspei.com> 1.03-1
+- Specfile autogenerated.
diff --git a/sources b/sources
index e69de29..0344f5c 100644
--- a/sources
+++ b/sources
@@ -0,0 +1 @@
+80202a57411cb3e939fec327a87564bf  Class-Singleton-1.03.tar.gz