import perl-Carp-1.40-367.module+el8.1.0+2926+ce7246ad
This commit is contained in:
commit
c32fccb562
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/Carp-1.38.tar.gz
|
1
.perl-Carp.metadata
Normal file
1
.perl-Carp.metadata
Normal file
@ -0,0 +1 @@
|
||||
6ad4e281ea94c3065c54237b03e1740b879fb6e5 SOURCES/Carp-1.38.tar.gz
|
118
SOURCES/Carp-1.38-Upgrade-to-1.40.patch
Normal file
118
SOURCES/Carp-1.38-Upgrade-to-1.40.patch
Normal file
@ -0,0 +1,118 @@
|
||||
diff --git a/Changes b/Changes
|
||||
index b55b49f..dca6a52 100644
|
||||
--- a/Changes
|
||||
+++ b/Changes
|
||||
@@ -1,4 +1,12 @@
|
||||
|
||||
+version 1.40; 2016-03-10
|
||||
+ * Get arg_string.t to compile in perl v5.6
|
||||
+ * Add information for how to contribute to Carp.
|
||||
+
|
||||
+version 1.39; 2016-03-06
|
||||
+ * bugfix: longmess() should return the error in scalar context
|
||||
+ (CPANRT#107225)
|
||||
+
|
||||
version 1.38; 2015-11-06
|
||||
* stable release of changes since v1.36
|
||||
|
||||
diff --git a/lib/Carp.pm b/lib/Carp.pm
|
||||
index 9421c74..92f8866 100644
|
||||
--- a/lib/Carp.pm
|
||||
+++ b/lib/Carp.pm
|
||||
@@ -87,7 +87,7 @@ BEGIN {
|
||||
}
|
||||
}
|
||||
|
||||
-our $VERSION = '1.38';
|
||||
+our $VERSION = '1.40';
|
||||
$VERSION =~ tr/_//d;
|
||||
|
||||
our $MaxEvalLen = 0;
|
||||
@@ -445,7 +445,9 @@ sub long_error_loc {
|
||||
}
|
||||
|
||||
sub longmess_heavy {
|
||||
- return @_ if ref( $_[0] ); # don't break references as exceptions
|
||||
+ if ( ref( $_[0] ) ) { # don't break references as exceptions
|
||||
+ return wantarray ? @_ : $_[0];
|
||||
+ }
|
||||
my $i = long_error_loc();
|
||||
return ret_backtrace( $i, @_ );
|
||||
}
|
||||
@@ -906,6 +908,12 @@ call die() or warn(), as appropriate.
|
||||
L<Carp::Always>,
|
||||
L<Carp::Clan>
|
||||
|
||||
+=head1 CONTRIBUTING
|
||||
+
|
||||
+L<Carp> is maintained by the perl 5 porters as part of the core perl 5
|
||||
+version control repository. Please see the L<perlhack> perldoc for how to
|
||||
+submit patches and contribute to it.
|
||||
+
|
||||
=head1 AUTHOR
|
||||
|
||||
The Carp module first appeared in Larry Wall's perl 5.000 distribution.
|
||||
diff --git a/lib/Carp/Heavy.pm b/lib/Carp/Heavy.pm
|
||||
index 91a42d1..b05d758 100644
|
||||
--- a/lib/Carp/Heavy.pm
|
||||
+++ b/lib/Carp/Heavy.pm
|
||||
@@ -2,7 +2,7 @@ package Carp::Heavy;
|
||||
|
||||
use Carp ();
|
||||
|
||||
-our $VERSION = '1.38';
|
||||
+our $VERSION = '1.40';
|
||||
$VERSION =~ tr/_//d;
|
||||
|
||||
# Carp::Heavy was merged into Carp in version 1.12. Any mismatched versions
|
||||
diff --git a/t/Carp.t b/t/Carp.t
|
||||
index a18e3b4..9ecdf88 100644
|
||||
--- a/t/Carp.t
|
||||
+++ b/t/Carp.t
|
||||
@@ -3,7 +3,7 @@ no warnings "once";
|
||||
use Config;
|
||||
|
||||
use IPC::Open3 1.0103 qw(open3);
|
||||
-use Test::More tests => 65;
|
||||
+use Test::More tests => 66;
|
||||
|
||||
sub runperl {
|
||||
my(%args) = @_;
|
||||
@@ -39,6 +39,24 @@ BEGIN {
|
||||
);
|
||||
}
|
||||
|
||||
+package MyClass;
|
||||
+
|
||||
+sub new { return bless +{ field => ['value1', 'SecondVal'] }; }
|
||||
+
|
||||
+package main;
|
||||
+
|
||||
+{
|
||||
+ my $err = Carp::longmess(MyClass->new);
|
||||
+
|
||||
+ # See:
|
||||
+ # https://rt.cpan.org/Public/Bug/Display.html?id=107225
|
||||
+ is_deeply(
|
||||
+ $err->{field},
|
||||
+ ['value1', 'SecondVal',],
|
||||
+ "longmess returns sth meaningful in scalar context when passed a ref.",
|
||||
+ );
|
||||
+}
|
||||
+
|
||||
{
|
||||
local $SIG{__WARN__} = sub {
|
||||
like $_[0], qr/ok (\d+)\n at.+\b(?i:carp\.t) line \d+\.$/, 'ok 2\n';
|
||||
diff --git a/t/arg_string.t b/t/arg_string.t
|
||||
index 42b43b1..dbd2e6e 100644
|
||||
--- a/t/arg_string.t
|
||||
+++ b/t/arg_string.t
|
||||
@@ -15,7 +15,7 @@ my $e9 = sprintf "%02x", (($] ge 5.007_003)
|
||||
: ((ord("A") == 193)
|
||||
? 0x51
|
||||
: 0xE9));
|
||||
-my $chr_e9 = chr utf8::unicode_to_native(0xe9);
|
||||
+my $chr_e9 = chr eval "0x$e9";
|
||||
my $nl_as_hex = sprintf "%x", ord("\n");
|
||||
|
||||
like lm(3), qr/main::lm\(3\)/;
|
158
SPECS/perl-Carp.spec
Normal file
158
SPECS/perl-Carp.spec
Normal file
@ -0,0 +1,158 @@
|
||||
%global cpan_version 1.38
|
||||
|
||||
Name: perl-Carp
|
||||
# Keep 2-digit precision
|
||||
#Version: %%(echo '%%{cpan_version}' | sed 's/\(\...\)\(.\)/\1.\2/')
|
||||
Version: 1.40
|
||||
Release: 367%{?dist}
|
||||
Summary: Alternative warn and die for modules
|
||||
License: GPL+ or Artistic
|
||||
Group: Development/Libraries
|
||||
URL: http://search.cpan.org/dist/Carp/
|
||||
Source0: http://www.cpan.org/authors/id/R/RJ/RJBS/Carp-%{cpan_version}.tar.gz
|
||||
# Unbundled from perl 5.24.0
|
||||
Patch0: Carp-1.38-Upgrade-to-1.40.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: make
|
||||
BuildRequires: perl
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
BuildRequires: perl(warnings)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: sed
|
||||
# Run-time:
|
||||
BuildRequires: perl(Exporter)
|
||||
# Tests:
|
||||
BuildRequires: perl(B)
|
||||
BuildRequires: perl(Config)
|
||||
BuildRequires: perl(Data::Dumper)
|
||||
# IPC::Open3 >= 1.0103 in reality, but the provides is 2-digit number only
|
||||
BuildRequires: perl(IPC::Open3)
|
||||
BuildRequires: perl(overload)
|
||||
BuildRequires: perl(Test::More) >= 0.47
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
|
||||
# Do not export private DB module stub
|
||||
%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(DB\\)
|
||||
|
||||
%description
|
||||
The Carp routines are useful in your own modules because they act like
|
||||
die() or warn(), but with a message which is more likely to be useful to a
|
||||
user of your module. In the case of cluck, confess, and longmess that
|
||||
context is a summary of every call in the call-stack. For a shorter message
|
||||
you can use carp or croak which report the error as being from where your
|
||||
module was called. There is no guarantee that that is where the error was,
|
||||
but it is a good educated guess.
|
||||
|
||||
%prep
|
||||
%setup -q -n Carp-%{cpan_version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
||||
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%files
|
||||
%doc Changes README
|
||||
%{perl_vendorlib}/*
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 29 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1.40-367
|
||||
- Rebuild with enable hardening (bug #1636329)
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.40-366
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.40-365
|
||||
- Increase release to favour standalone package
|
||||
|
||||
* Wed May 11 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.40-1
|
||||
- 1.40 bump in order to dual-live with perl 5.24
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.38-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Nov 10 2015 Petr Pisar <ppisar@redhat.com> - 1.38-1
|
||||
- 1.38 bump
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.36-346
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.36-345
|
||||
- Increase release to favour standalone package
|
||||
|
||||
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.36-2
|
||||
- Perl 5.22 rebuild
|
||||
|
||||
* Fri Mar 20 2015 Petr Pisar <ppisar@redhat.com> - 1.36-1
|
||||
- 1.36 bump
|
||||
|
||||
* Mon Mar 16 2015 Petr Pisar <ppisar@redhat.com> - 1.35-1
|
||||
- 1.35 bump
|
||||
|
||||
* Wed Sep 03 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.33.01-310
|
||||
- Increase release to favour standalone package
|
||||
|
||||
* Tue Aug 26 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.33.01-3
|
||||
- Perl 5.20 rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.33.01-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri Apr 04 2014 Petr Pisar <ppisar@redhat.com> - 1.33.01-1
|
||||
- 1.3301 bump
|
||||
|
||||
* Wed Mar 26 2014 Petr Pisar <ppisar@redhat.com> - 1.33-1
|
||||
- 1.33 bump
|
||||
|
||||
* Tue Sep 10 2013 Petr Pisar <ppisar@redhat.com> - 1.32-1
|
||||
- 1.32 bump
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.26-245
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 1.26-244
|
||||
- Link minimal build-root packages against libperl.so explicitly
|
||||
|
||||
* Tue Apr 30 2013 Petr Pisar <ppisar@redhat.com> - 1.26-243
|
||||
- Increase release number to supersede perl sub-package (bug #957931)
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.26-241
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Mon Aug 13 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.26-240
|
||||
- Bump release to override sub-package from perl.spec
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.26-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu Jun 28 2012 Petr Pisar <ppisar@redhat.com> - 1.26-2
|
||||
- Perl 5.16 rebuild
|
||||
|
||||
* Tue Jun 19 2012 Petr Pisar <ppisar@redhat.com> - 1.26-1
|
||||
- 1.26 bump
|
||||
|
||||
* Wed Jun 06 2012 Petr Pisar <ppisar@redhat.com> - 1.25-2
|
||||
- Perl 5.16 rebuild
|
||||
|
||||
* Thu Mar 15 2012 Petr Pisar <ppisar@redhat.com> - 1.25-1
|
||||
- 1.25 bump
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.22-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Wed Sep 07 2011 Petr Pisar <ppisar@redhat.com> 1.22-1
|
||||
- Specfile autogenerated by cpanspec 1.78.
|
||||
- Remove BuildRoot and defattr code from spec
|
||||
- Do not export private module DB
|
Loading…
Reference in New Issue
Block a user