Import rpm: c8s
This commit is contained in:
commit
7219b581be
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/B-Lint-1.20.tar.gz
|
||||||
|
/B-Lint-1.20.tar.gz
|
68
B-Lint-1.20-Skip-a-bare-sub-test.patch
Normal file
68
B-Lint-1.20-Skip-a-bare-sub-test.patch
Normal file
@ -0,0 +1,68 @@
|
|||||||
|
From d350b6338066d2563b4abacf1eb7da56c5264b22 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||||
|
Date: Fri, 12 Jun 2015 13:27:07 +0200
|
||||||
|
Subject: [PATCH] Skip a bare-sub test
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Perl 5.22 optimization causes B::Lint not to recognize $a{b} for
|
||||||
|
bare-sub check. This patch document this deficency and skips a test
|
||||||
|
for it.
|
||||||
|
|
||||||
|
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||||
|
---
|
||||||
|
lib/B/Lint.pm | 4 ++++
|
||||||
|
t/lint.t | 11 +++++++++--
|
||||||
|
2 files changed, 13 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lib/B/Lint.pm b/lib/B/Lint.pm
|
||||||
|
index 1f5098f..7291b18 100644
|
||||||
|
--- a/lib/B/Lint.pm
|
||||||
|
+++ b/lib/B/Lint.pm
|
||||||
|
@@ -85,6 +85,10 @@ trap are:
|
||||||
|
|
||||||
|
Neither of these will do what a naive user would expect.
|
||||||
|
|
||||||
|
+Notice: Perl 5.22.0 does not report C<foo> in C<$b{foo}> as BARE token
|
||||||
|
+anymore. Therefore L<B::Lint> test is not reliable here. See
|
||||||
|
+L<CPAN RT#101115|https://rt.cpan.org/Public/Bug/Display.html?id=101115>.
|
||||||
|
+
|
||||||
|
=item B<dollar-underscore>
|
||||||
|
|
||||||
|
This option warns whenever C<$_> is used either explicitly anywhere or
|
||||||
|
diff --git a/t/lint.t b/t/lint.t
|
||||||
|
index 7317b1d..93255d9 100644
|
||||||
|
--- a/t/lint.t
|
||||||
|
+++ b/t/lint.t
|
||||||
|
@@ -14,7 +14,7 @@ BEGIN {
|
||||||
|
use strict;
|
||||||
|
use warnings;
|
||||||
|
|
||||||
|
-plan tests => 29;
|
||||||
|
+plan tests => 30;
|
||||||
|
|
||||||
|
# Runs a separate perl interpreter with the appropriate lint options
|
||||||
|
# turned on
|
||||||
|
@@ -116,10 +116,17 @@ RESULT
|
||||||
|
|
||||||
|
runlint 'bare-subs', 'sub bare(){1};$x=bare', '';
|
||||||
|
|
||||||
|
-runlint 'bare-subs', 'sub bare(){1}; $x=[bare=>0]; $x=$y{bare}', <<'RESULT';
|
||||||
|
+runlint 'bare-subs', 'sub bare(){1}; $x=[bare=>0]', <<'RESULT';
|
||||||
|
Bare sub name 'bare' interpreted as string at -e line 1
|
||||||
|
+RESULT
|
||||||
|
+
|
||||||
|
+SKIP: {
|
||||||
|
+ skip 'Perl 5.22 stopped marking $hash{bare} as BARE word, CPAN RT#101115',
|
||||||
|
+ 1, if $] >= 5.022;
|
||||||
|
+ runlint 'bare-subs', 'sub bare(){1}; $x=$y{bare}', <<'RESULT';
|
||||||
|
Bare sub name 'bare' interpreted as string at -e line 1
|
||||||
|
RESULT
|
||||||
|
+}
|
||||||
|
|
||||||
|
{
|
||||||
|
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
125
perl-B-Lint.spec
Normal file
125
perl-B-Lint.spec
Normal file
@ -0,0 +1,125 @@
|
|||||||
|
Name: perl-B-Lint
|
||||||
|
Version: 1.20
|
||||||
|
Release: 11%{?dist}
|
||||||
|
Summary: Perl lint
|
||||||
|
License: GPL+ or Artistic
|
||||||
|
Group: Development/Libraries
|
||||||
|
URL: http://search.cpan.org/dist/B-Lint/
|
||||||
|
Source0: http://www.cpan.org/authors/id/R/RJ/RJBS/B-Lint-%{version}.tar.gz
|
||||||
|
# Work around for Perl 5.22, bug #1231112, CPAN RT#101115
|
||||||
|
Patch0: B-Lint-1.20-Skip-a-bare-sub-test.patch
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: findutils
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: perl-interpreter
|
||||||
|
BuildRequires: perl-generators
|
||||||
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||||
|
BuildRequires: sed
|
||||||
|
# Run-Time:
|
||||||
|
BuildRequires: perl(B)
|
||||||
|
BuildRequires: perl(Carp)
|
||||||
|
BuildRequires: perl(constant)
|
||||||
|
%if 0%(perl -e 'print $] > 5.017')
|
||||||
|
BuildRequires: perl(deprecate)
|
||||||
|
%endif
|
||||||
|
BuildRequires: perl(if)
|
||||||
|
BuildRequires: perl(List::Util)
|
||||||
|
BuildRequires: perl(Module::Pluggable)
|
||||||
|
BuildRequires: perl(overload)
|
||||||
|
BuildRequires: perl(strict)
|
||||||
|
# Tests:
|
||||||
|
BuildRequires: perl(Config)
|
||||||
|
BuildRequires: perl(File::Spec)
|
||||||
|
BuildRequires: perl(O)
|
||||||
|
BuildRequires: perl(warnings)
|
||||||
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||||
|
Requires: perl(constant)
|
||||||
|
%if 0%(perl -e 'print $] > 5.017')
|
||||||
|
Requires: perl(deprecate)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
The B::Lint module is equivalent to an extended version of the -w option of
|
||||||
|
perl. It is named after the program lint which carries out a similar process
|
||||||
|
for C programs.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n B-Lint-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
# Install into architecture-agnostic path, CPAN RT#83049
|
||||||
|
sed -i '/PM *=>/,/}/d' Makefile.PL
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL INSTALLDIRS=vendor
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
|
||||||
|
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||||
|
|
||||||
|
%check
|
||||||
|
make test
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc Changes README
|
||||||
|
%{perl_vendorlib}/*
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.20-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.20-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.20-9
|
||||||
|
- Perl 5.26 rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.20-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.20-7
|
||||||
|
- Perl 5.24 rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.20-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.20-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 12 2015 Petr Pisar <ppisar@redhat.com> - 1.20-4
|
||||||
|
- Work around an incompatibility with Perl 5.22 (bug #1231112)
|
||||||
|
|
||||||
|
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.20-3
|
||||||
|
- Perl 5.22 rebuild
|
||||||
|
|
||||||
|
* Wed Oct 29 2014 Petr Pisar <ppisar@redhat.com> - 1.20-2
|
||||||
|
- Do not build-require version module
|
||||||
|
|
||||||
|
* Mon Oct 27 2014 Petr Pisar <ppisar@redhat.com> - 1.20-1
|
||||||
|
- 1.20 bump
|
||||||
|
|
||||||
|
* Tue Sep 30 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.18-1
|
||||||
|
- 1.18 bump
|
||||||
|
|
||||||
|
* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.17-293
|
||||||
|
- Perl 5.20 rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-292
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-291
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 15 2013 Petr Pisar <ppisar@redhat.com> - 1.17-290
|
||||||
|
- Increase release to favour standalone package
|
||||||
|
|
||||||
|
* Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 1.17-3
|
||||||
|
- Perl 5.18 rebuild
|
||||||
|
|
||||||
|
* Tue May 28 2013 Petr Pisar <ppisar@redhat.com> - 1.17-2
|
||||||
|
- Correct typo in dependencies
|
||||||
|
|
||||||
|
* Wed Jan 30 2013 Petr Pisar <ppisar@redhat.com> 1.17-1
|
||||||
|
- Specfile autogenerated by cpanspec 1.78.
|
Loading…
Reference in New Issue
Block a user