Update to 7.14
- New upstream release 7.14 - Fix a crash bug in AnyEvent::Handle with openssl 1.1.0 - AnyEvent::Handle->keepalive was documented (and defined) twice - AnyEvent::Socket::tcp_bind/tcp_server would immediately unlink a unix listening socket unless a guard is used; change this so that no clean-up will be performed unless a guard is used and document this more clearly - Make tcp_bind/tcp_server error messages more regular - Fix building on Perl without '.' in @INC - Add TCP_FASTOPEN/MSG_FASTOPEN and MSG_NOSIGNAL/MSG_MORE/MSG_DONTWAIT to constants - Update warnings to common::sense 3.74 standards
This commit is contained in:
parent
77928db500
commit
6391d3a007
@ -1,12 +0,0 @@
|
||||
diff -up AnyEvent-7.13/Makefile.PL.orig AnyEvent-7.13/Makefile.PL
|
||||
--- AnyEvent-7.13/Makefile.PL.orig 2017-05-17 14:33:30.966186261 +0200
|
||||
+++ AnyEvent-7.13/Makefile.PL 2017-05-17 14:34:13.414007081 +0200
|
||||
@@ -22,7 +22,7 @@ print <<EOF;
|
||||
|
||||
EOF
|
||||
|
||||
-do "constants.pl.PL"
|
||||
+do "./constants.pl.PL"
|
||||
or die "cannot execute constants.pl.PL: $@";
|
||||
|
||||
WriteMakefile(
|
@ -1,13 +0,0 @@
|
||||
Fix for CPAN RT#118584 from Mike McCauley (Net::SSLeay upstream)
|
||||
|
||||
--- lib/AnyEvent/Handle.pm
|
||||
+++ lib/AnyEvent/Handle.pm
|
||||
@@ -2224,7 +2224,7 @@ sub starttls {
|
||||
# Net::SSLeay::CTX_set_mode ($ssl,
|
||||
# (eval { local $SIG{__DIE__}; Net::SSLeay::MODE_ENABLE_PARTIAL_WRITE () } || 1)
|
||||
# | (eval { local $SIG{__DIE__}; Net::SSLeay::MODE_ACCEPT_MOVING_WRITE_BUFFER () } || 2));
|
||||
- Net::SSLeay::CTX_set_mode ($tls, 1|2);
|
||||
+ Net::SSLeay::set_mode ($tls, 1|2);
|
||||
|
||||
$self->{_rbio} = Net::SSLeay::BIO_new (Net::SSLeay::BIO_s_mem ());
|
||||
$self->{_wbio} = Net::SSLeay::BIO_new (Net::SSLeay::BIO_s_mem ());
|
@ -7,15 +7,13 @@
|
||||
%global have_weak_deps 0%{?fedora} > 20 || 0%{?rhel} > 7
|
||||
|
||||
Name: perl-AnyEvent
|
||||
Version: 7.13
|
||||
Release: 8%{?dist}
|
||||
Version: 7.14
|
||||
Release: 1%{?dist}
|
||||
Summary: Framework for multiple event loops
|
||||
Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/AnyEvent/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/AnyEvent-%{version}%{?subver}.tar.gz
|
||||
Patch0: AnyEvent-7.13-ssl.patch
|
||||
Patch1: AnyEvent-7.13-Fix-building-on-Perl-without-dot-in-INC.patch
|
||||
|
||||
# Build requirements
|
||||
BuildRequires: coreutils
|
||||
@ -139,12 +137,6 @@ time).
|
||||
%prep
|
||||
%setup -q -n AnyEvent-%{version}%{?subver}
|
||||
|
||||
# Fix segfault in SSL handling that manifests on OpenSSL 1.1.0 x86_64
|
||||
%patch0
|
||||
|
||||
# Fix building on Perl without '.' in @INC
|
||||
%patch1 -p1
|
||||
|
||||
|
||||
%build
|
||||
PERL_CANARY_STABILITY_NOPROMPT=1 perl Makefile.PL INSTALLDIRS=vendor
|
||||
@ -201,6 +193,19 @@ make test
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Jun 24 2017 Paul Howarth <paul@city-fan.org> - 7.14-1
|
||||
- Update to 7.14
|
||||
- Fix a crash bug in AnyEvent::Handle with openssl 1.1.0
|
||||
- AnyEvent::Handle->keepalive was documented (and defined) twice
|
||||
- AnyEvent::Socket::tcp_bind/tcp_server would immediately unlink a unix
|
||||
listening socket unless a guard is used; change this so that no clean-up
|
||||
will be performed unless a guard is used and document this more clearly
|
||||
- Make tcp_bind/tcp_server error messages more regular
|
||||
- Fix building on Perl without '.' in @INC
|
||||
- Add TCP_FASTOPEN/MSG_FASTOPEN and MSG_NOSIGNAL/MSG_MORE/MSG_DONTWAIT to
|
||||
constants
|
||||
- Update warnings to common::sense 3.74 standards
|
||||
|
||||
* Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 7.13-8
|
||||
- Perl 5.26 re-rebuild of bootstrapped packages
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user