import perl-Algorithm-Diff-1.1903-10.module+el8.3.0+6718+7f269185
This commit is contained in:
commit
aa1fd1a02b
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/Algorithm-Diff-1.1903.tar.gz
|
1
.perl-Algorithm-Diff.metadata
Normal file
1
.perl-Algorithm-Diff.metadata
Normal file
@ -0,0 +1 @@
|
||||
16b50ac7d83c6cb92d1996785e3496ba0a2cce95 SOURCES/Algorithm-Diff-1.1903.tar.gz
|
12
SOURCES/Algorithm-Diff-1.1903-provides.patch
Normal file
12
SOURCES/Algorithm-Diff-1.1903-provides.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- lib/Algorithm/DiffOld.pm
|
||||
+++ lib/Algorithm/DiffOld.pm
|
||||
@@ -2,8 +2,7 @@
|
||||
# like versions <= 0.59 used to.
|
||||
# $Revision: 1.3 $
|
||||
|
||||
-package # don't index
|
||||
- Algorithm::DiffOld;
|
||||
+package Algorithm::DiffOld;
|
||||
use strict;
|
||||
use vars qw($VERSION @EXPORT_OK @ISA @EXPORT);
|
||||
use integer; # see below in _replaceNextLargerWith() for mod to make
|
175
SPECS/perl-Algorithm-Diff.spec
Normal file
175
SPECS/perl-Algorithm-Diff.spec
Normal file
@ -0,0 +1,175 @@
|
||||
Name: perl-Algorithm-Diff
|
||||
Version: 1.1903
|
||||
Release: 10%{?dist}
|
||||
Summary: Compute `intelligent' differences between two files/lists
|
||||
License: GPL+ or Artistic
|
||||
Group: Development/Libraries
|
||||
URL: http://search.cpan.org/dist/Algorithm-Diff/
|
||||
Source0: http://www.cpan.org/authors/id/T/TY/TYEMQ/Algorithm-Diff-%{version}.tar.gz
|
||||
Patch0: Algorithm-Diff-1.1903-provides.patch
|
||||
BuildArch: noarch
|
||||
# Build:
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
# Run-time:
|
||||
BuildRequires: perl(Carp)
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(integer)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(vars)
|
||||
# Tests:
|
||||
BuildRequires: perl(Data::Dumper)
|
||||
BuildRequires: perl(lib)
|
||||
BuildRequires: perl(Test)
|
||||
# Explicit requirements:
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
Requires: perl(Carp)
|
||||
|
||||
%description
|
||||
This is a module for computing the difference between two files, two strings,
|
||||
or any other two lists of things. It uses an intelligent algorithm similar to
|
||||
(or identical to) the one used by the Unix "diff" program. It is guaranteed to
|
||||
find the *smallest possible* set of differences.
|
||||
|
||||
%prep
|
||||
%setup -q -n Algorithm-Diff-%{version}
|
||||
|
||||
# Generate provide for perl(Algorithm::DiffOld)
|
||||
%patch0
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make pure_install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
|
||||
%{_fixperms} %{buildroot}
|
||||
|
||||
# Remove example scripts we're shipping as documentation
|
||||
rm -f %{buildroot}%{perl_vendorlib}/Algorithm/*.pl
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%files
|
||||
%doc Changes README *.pl
|
||||
%{perl_vendorlib}/Algorithm/
|
||||
%{_mandir}/man3/Algorithm::Diff.3*
|
||||
%{_mandir}/man3/Algorithm::DiffOld.3*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 29 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1.1903-10
|
||||
- Rebuild with enable hardening (bug #1636329)
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1903-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1903-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.1903-7
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1903-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.1903-5
|
||||
- Perl 5.24 rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1903-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1903-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.1903-2
|
||||
- Perl 5.22 rebuild
|
||||
|
||||
* Thu Nov 27 2014 Paul Howarth <paul@city-fan.org> - 1.1903-1
|
||||
- Update to 1.1903
|
||||
- Fix documentation typos (CPAN RT#84981)
|
||||
- Add -w and -i switches to diffnew.pl (CPAN RT#69945)
|
||||
- Remove Algorithm::DiffOld from the index; the module is still distributed
|
||||
with Algorithm::Diff, but is not indexed on CPAN because this is an
|
||||
***UNAUTHORIZED*** release of Algorithm::DiffOld
|
||||
- Add patch to generate provide for perl(Algorithm::DiffOld)
|
||||
- Drop %%defattr, redundant since rpm 4.4
|
||||
- General spec tidy-up
|
||||
|
||||
* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.1902-21
|
||||
- Perl 5.20 rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1902-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1902-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Jul 18 2013 Petr Pisar <ppisar@redhat.com> - 1.1902-18
|
||||
- Perl 5.18 rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1902-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1902-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Jun 11 2012 Petr Pisar <ppisar@redhat.com> - 1.1902-15
|
||||
- Perl 5.16 rebuild
|
||||
- Specify all dependencies
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1902-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.1902-13
|
||||
- Perl mass rebuild
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1902-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Dec 14 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.1902-11
|
||||
- Rebuild to fix problems with vendorarch/lib (#661697)
|
||||
|
||||
* Thu Apr 29 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.1902-10
|
||||
- Mass rebuild with perl-5.12.0
|
||||
|
||||
* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.1902-9
|
||||
- rebuild against perl 5.10.1
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1902-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1902-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1902-6
|
||||
- Rebuild for perl 5.10 (again)
|
||||
|
||||
* Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1902-5
|
||||
- rebuild for new perl
|
||||
|
||||
* Thu Jan 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1902-4
|
||||
- fix license tag, rebuild for perl
|
||||
|
||||
* Wed Apr 18 2007 Steven Pritchard <steve@kspei.com> 1.1902-3
|
||||
- Use fixperms macro instead of our own chmod incantation.
|
||||
- BR ExtUtils::MakeMaker.
|
||||
|
||||
* Sun Sep 17 2006 Steven Pritchard <steve@kspei.com> 1.1902-2
|
||||
- Rebuild.
|
||||
|
||||
* Sat Aug 05 2006 Steven Pritchard <steve@kspei.com> 1.1902-1
|
||||
- Update to 1.1902.
|
||||
- Minor spec cleanup to match current template/cpanspec output.
|
||||
|
||||
* Mon Sep 05 2005 Steven Pritchard <steve@kspei.com> 1.1901-1
|
||||
- Updated to 1.1901.
|
||||
|
||||
* Sat Sep 03 2005 Steven Pritchard <steve@kspei.com> 1.15-2
|
||||
- Move example files to %%doc.
|
||||
|
||||
* Sat Aug 27 2005 Steven Pritchard <steve@kspei.com> 1.15-1
|
||||
- Specfile autogenerated.
|
Loading…
Reference in New Issue
Block a user