import pcsc-lite-ccid-1.4.36-1.el9

This commit is contained in:
CentOS Sources 2022-05-17 06:28:04 -04:00 committed by Stepan Oksanichenko
commit 45a4f32c33
7 changed files with 627 additions and 0 deletions

2
.gitignore vendored Normal file
View File

@ -0,0 +1,2 @@
SOURCES/ccid-1.4.36.tar.bz2
SOURCES/gpgkey-F5E11B9FFE911146F41D953D78A1B4DFE8F9C57E.gpg

2
.pcsc-lite-ccid.metadata Normal file
View File

@ -0,0 +1,2 @@
ed76f65c5c48411bf602edd87779bcbd9476720a SOURCES/ccid-1.4.36.tar.bz2
13df650b9548b4ef1b24ad11ef6b573af4d48011 SOURCES/gpgkey-F5E11B9FFE911146F41D953D78A1B4DFE8F9C57E.gpg

View File

@ -0,0 +1,133 @@
diff -up ccid-1.4.26/src/ccid.c.omnikey ccid-1.4.26/src/ccid.c
--- ccid-1.4.26/src/ccid.c.omnikey 2017-02-24 10:04:25.742132234 +0100
+++ ccid-1.4.26/src/ccid.c 2017-02-24 10:07:26.145976335 +0100
@@ -55,8 +55,16 @@ int ccid_open_hack_pre(unsigned int read
{
_ccid_descriptor *ccid_descriptor = get_ccid_descriptor(reader_index);
+ ccid_descriptor->dwNonStandardFlags = 0;
+
switch (ccid_descriptor->readerID)
{
+ case CARDMAN3121:
+ ccid_descriptor->dwNonStandardFlags = CCID_NON_STAND_OMK_3121_T1;
+ ccid_descriptor->dwFeatures &= ~CCID_CLASS_EXCHANGE_MASK;
+ ccid_descriptor->dwFeatures |= CCID_CLASS_TPDU;
+ break;
+
case MYSMARTPAD:
ccid_descriptor->dwMaxIFSD = 254;
break;
diff -up ccid-1.4.26/src/ccid.h.omnikey ccid-1.4.26/src/ccid.h
--- ccid-1.4.26/src/ccid.h.omnikey 2017-01-07 15:50:47.000000000 +0100
+++ ccid-1.4.26/src/ccid.h 2017-02-24 10:04:25.742132234 +0100
@@ -137,6 +137,7 @@ typedef struct
*/
char zlp;
#endif
+ unsigned int dwNonStandardFlags;
} _ccid_descriptor;
/* Features from dwFeatures */
@@ -153,6 +154,9 @@ typedef struct
#define CCID_CLASS_EXTENDED_APDU 0x00040000
#define CCID_CLASS_EXCHANGE_MASK 0x00070000
+/* Features from the swNonStandardFlags */
+#define CCID_NON_STAND_OMK_3121_T1 0x00000001
+
/* Features from bPINSupport */
#define CCID_CLASS_PIN_VERIFY 0x01
#define CCID_CLASS_PIN_MODIFY 0x02
diff -up ccid-1.4.26/src/commands.c.omnikey ccid-1.4.26/src/commands.c
--- ccid-1.4.26/src/commands.c.omnikey 2017-01-07 15:50:47.000000000 +0100
+++ ccid-1.4.26/src/commands.c 2017-02-24 10:11:21.297778870 +0100
@@ -1292,6 +1292,39 @@ RESPONSECODE CmdXfrBlock(unsigned int re
return return_value;
} /* CmdXfrBlock */
+static RESPONSECODE omnikey_transmit_tpdu(unsigned int reader_index,
+ _ccid_descriptor *ccid_descriptor, unsigned int tx_length,
+ const unsigned char *tx_buffer)
+{
+ unsigned char cmd[11+CMD_BUF_SIZE]; /* CCID + APDU buffer */
+ status_t ret;
+
+ cmd[0] = 0x6B; /* 3121 escape */
+ i2dw(tx_length+1, cmd+1); /* APDU length */
+ cmd[5] = ccid_descriptor->bCurrentSlotIndex; /* slot number */
+ cmd[6] = (*ccid_descriptor->pbSeq)++;
+ cmd[7] = 0;
+ cmd[8] = 0;
+ cmd[9] = 0;
+ cmd[10] = 0x1A;
+
+ /* check that the command is not too large */
+ if (tx_length > CMD_BUF_SIZE)
+ {
+ DEBUG_CRITICAL2("TX Length too big: %d", tx_length);
+ return IFD_NOT_SUPPORTED;
+ }
+
+ memcpy(cmd+11, tx_buffer, tx_length);
+
+ ret = WritePort(reader_index, 11+tx_length, cmd);
+ if (STATUS_NO_SUCH_DEVICE == ret)
+ return IFD_NO_SUCH_DEVICE;
+ if (ret != STATUS_SUCCESS)
+ return IFD_COMMUNICATION_ERROR;
+
+ return IFD_SUCCESS;
+} /* omnikey_transmit_tpdu */
/*****************************************************************************
*
@@ -1348,6 +1381,13 @@ RESPONSECODE CCID_Transmit(unsigned int
}
#endif
+ /* hack for Onmikey 3121 */
+ if ((ccid_descriptor->dwNonStandardFlags & CCID_NON_STAND_OMK_3121_T1) &&
+ (ccid_descriptor->cardProtocol == SCARD_PROTOCOL_T1)) {
+ return omnikey_transmit_tpdu(reader_index, ccid_descriptor, tx_length,
+ tx_buffer);
+ }
+
cmd[0] = 0x6F; /* XfrBlock */
i2dw(tx_length, cmd+1); /* APDU length */
cmd[5] = ccid_descriptor->bCurrentSlotIndex; /* slot number */
@@ -1373,8 +1413,9 @@ RESPONSECODE CCID_Transmit(unsigned int
RESPONSECODE CCID_Receive(unsigned int reader_index, unsigned int *rx_length,
unsigned char rx_buffer[], unsigned char *chain_parameter)
{
- unsigned char cmd[10+CMD_BUF_SIZE]; /* CCID + APDU buffer */
+ unsigned char cmd[11+CMD_BUF_SIZE]; /* CCID + APDU buffer */
unsigned int length;
+ unsigned char *rx_ptr = cmd+10;
RESPONSECODE return_value = IFD_SUCCESS;
status_t ret;
_ccid_descriptor *ccid_descriptor = get_ccid_descriptor(reader_index);
@@ -1565,6 +1606,14 @@ time_request:
}
length = dw2i(cmd, 1);
+
+ if (length &&
+ (ccid_descriptor->dwNonStandardFlags & CCID_NON_STAND_OMK_3121_T1) &&
+ (ccid_descriptor->cardProtocol == SCARD_PROTOCOL_T1)) {
+ length--;
+ rx_ptr = cmd+11;
+ }
+
if (length <= *rx_length)
*rx_length = length;
else
@@ -1581,7 +1630,7 @@ time_request:
}
else
if (length)
- memcpy(rx_buffer, cmd+10, length);
+ memcpy(rx_buffer, rx_ptr, length);
/* Extended case?
* Only valid for RDR_to_PC_DataBlock frames */

View File

@ -0,0 +1,12 @@
diff -up ./src/ccid_ifdhandler.h.readers_32 ./src/ccid_ifdhandler.h
--- ./src/ccid_ifdhandler.h.readers_32 2018-08-20 16:06:34.080905748 -0700
+++ ./src/ccid_ifdhandler.h 2018-08-20 16:07:04.638097096 -0700
@@ -47,7 +47,7 @@ extern int DriverOptions;
* The maximum number of readers is also limited in pcsc-lite (16 by default)
* see the definition of PCSCLITE_MAX_READERS_CONTEXTS in src/PCSC/pcsclite.h
*/
-#define CCID_DRIVER_MAX_READERS 16
+#define CCID_DRIVER_MAX_READERS 48
/*
* CCID driver specific functions

View File

@ -0,0 +1,94 @@
From b48e1e697010431b7f03d4ecfe917ceee95e2c64 Mon Sep 17 00:00:00 2001
From: Ludovic Rousseau <ludovic.rousseau@free.fr>
Date: Tue, 7 Sep 2021 14:06:46 +0200
Subject: [PATCH] Fix SafeNet eToken 5110 SC issue
Some SafeNet eToken 5100 (but not all) have issues when IFSD is negotiated.
For some APDU the communication stops and the token returns 0 bytes.
It is the case with the SafeNet eToken 5110 SC with
ATR: 3B D5 18 00 81 31 3A 7D 80 73 C8 21 10 30
and PC/SC name "SafeNet eToken 5100 [eToken 5110 SC]"
Another SafeNet eToken 5100 with
ATR: 3B D5 18 00 81 31 FE 7D 80 73 C8 21 10 F4
and PC/SC name "SafeNet eToken 5100 [Main Interface]"
does NOT have problems with the the IFSD negotiation.
This fixes Debian bug #993647
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=993647
---
src/ccid.c | 7 +++++++
src/ccid.h | 1 +
2 files changed, 8 insertions(+)
diff --git a/src/ccid.c b/src/ccid.c
index efef240..0d7ba54 100644
--- a/src/ccid.c
+++ b/src/ccid.c
@@ -576,6 +576,13 @@ int ccid_open_hack_post(unsigned int reader_index)
* have one */
ccid_descriptor->bPINSupport = 0;
break;
+
+ case SAFENET_ETOKEN_5100:
+ /* the old SafeNet eToken 5110 SC (firmware 0.12) does not
+ * like IFSD negotiation. So disable it. */
+ if (0x0012 == ccid_descriptor->IFD_bcdDevice)
+ ccid_descriptor->dwFeatures |= CCID_CLASS_AUTO_IFSD;
+ break;
}
/* Gemalto readers may report additional information */
diff --git a/src/ccid.h b/src/ccid.h
index b28f0c1..00ce07a 100644
--- a/src/ccid.h
+++ b/src/ccid.h
@@ -239,6 +239,7 @@ typedef struct
#define IDENTIV_uTrust3701F 0x04E65791
#define IDENTIV_uTrust4701F 0x04E65724
#define BIT4ID_MINILECTOR 0x25DD3111
+#define SAFENET_ETOKEN_5100 0x05290620
#define VENDOR_GEMALTO 0x08E6
#define GET_VENDOR(readerID) ((readerID >> 16) & 0xFFFF)
--
GitLab
From 26ad96076523472e9d0d383d014e7b1ad241fd5b Mon Sep 17 00:00:00 2001
From: Ludovic Rousseau <ludovic.rousseau@free.fr>
Date: Wed, 8 Sep 2021 11:28:48 +0200
Subject: [PATCH] Fix SafeNet eToken 5110 SC issue (firmware 0.13)
The SafeNet eToken 5110 SC with firmware 0.13 has the same problem as
the token with firmware 0.12.
We use the same oslution to fix the problem.
Thanks again to Vladimir K for the bug report.
---
src/ccid.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/src/ccid.c b/src/ccid.c
index 0d7ba54..21a2fe8 100644
--- a/src/ccid.c
+++ b/src/ccid.c
@@ -578,9 +578,10 @@ int ccid_open_hack_post(unsigned int reader_index)
break;
case SAFENET_ETOKEN_5100:
- /* the old SafeNet eToken 5110 SC (firmware 0.12) does not
- * like IFSD negotiation. So disable it. */
- if (0x0012 == ccid_descriptor->IFD_bcdDevice)
+ /* the old SafeNet eToken 5110 SC (firmware 0.12 & 0.13)
+ * does not like IFSD negotiation. So disable it. */
+ if ((0x0012 == ccid_descriptor->IFD_bcdDevice)
+ || (0x0013 == ccid_descriptor->IFD_bcdDevice))
ccid_descriptor->dwFeatures |= CCID_CLASS_AUTO_IFSD;
break;
}
--
GitLab

View File

@ -0,0 +1,16 @@
-----BEGIN PGP SIGNATURE-----
iQIzBAABCAAdFiEE9eEbn/6REUb0HZU9eKG03+j5xX4FAmEsohYACgkQeKG03+j5
xX6Afg//QeixE9OO5UXuFptk+ZFDJz3dKzd1YLQ/korWVrdC9QouHJDHdLHqUW/a
ls0aPUg2qupj2uwwidYy58EHXGtDd6BZ27Xu7d1pIJcGm8f6+obWw8RJZmzotvDI
eG+VKtpqXcj4ShCjnDu32QcMZ6XSadeuEzw+Ir8aBHazzb7xcKo1VGsYQ8i1KxPx
8YDUJ8pme43TOyCoOmrrDVlXb96g13fQ6KAyatDwmiGy2uSkXSQXMKNJ3mkEIipe
pzDt7epo3dvXTImhIuDGn+rbnSUEKFcjmlB7LSo7vV8iLfmt490b3RWxuUI0UVh9
FBCuNxUTy58yB9QS8gcqN5ljHC9877H2ACQo/i8AEB1VIP7lahLMS0+9Fn/WWMGo
gBIijeYVTCJ3VeYbnuFNBWLrGfIXQL/lmEzvs2b4DBR1UIOfe32G9xk+hKNBmRrR
Nfs/hZGlL4CMuwHsjQ/ULCh5yuryecaWlzHZyRltZUz9DMJyiWKgGQnbk3/IpvzK
ihiPlp0XRL6ZdrSZnhP8Bydk6g1eHigNzJyzVOZcACIKWKiY+5phhTfsj1L8Z8Rs
T5a6AFrOwFZFJmFAXYYv8WyXGmPVvLfZbbIes/FNJEfXSUrld7wX8qrmK6+NmkPD
hs4GOuLlVygt160edufJCl0ZIeo+9DSqUaKyuuF05u4Ay40KoYc=
=Jttr
-----END PGP SIGNATURE-----

368
SPECS/pcsc-lite-ccid.spec Normal file
View File

@ -0,0 +1,368 @@
%global dropdir %(pkg-config libpcsclite --variable usbdropdir 2>/dev/null)
%global pcsc_lite_ver 1.8.9
Name: pcsc-lite-ccid
Version: 1.4.36
Release: 1%{?dist}
Summary: Generic USB CCID smart card reader driver
License: LGPLv2+
URL: https://ccid.apdu.fr/files
Source0: https://ccid.apdu.fr/files/ccid-%{version}.tar.bz2
Source1: https://ccid.apdu.fr/files/ccid-%{version}.tar.bz2.asc
Source2: gpgkey-F5E11B9FFE911146F41D953D78A1B4DFE8F9C57E.gpg
Patch0: ccid-1.4.26-omnikey-3121.patch
Patch1: ccid-1.4.34-maxreaders.patch
Patch2: ccid-1.4.36-etoken.patch
BuildRequires: make
BuildRequires: perl-interpreter
BuildRequires: perl-Getopt-Long
BuildRequires: libusb1-devel
BuildRequires: pcsc-lite-devel >= %{pcsc_lite_ver}
BuildRequires: gnupg2 gcc
Requires(post): systemd
Requires(postun): systemd
Requires: pcsc-lite%{?_isa} >= %{pcsc_lite_ver}
Provides: pcsc-ifd-handler
# Provide upgrade path from 'ccid' package
Obsoletes: ccid < 1.4.0-3
Provides: ccid = %{version}-%{release}
# This is bundled from pcsc-lite upstream
Provides: bundled(simclist) = 1.6
%description
Generic USB CCID (Chip/Smart Card Interface Devices) driver for use with the
PC/SC Lite daemon.
%prep
gpgv2 --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
%setup -q -n ccid-%{version}
%patch0 -p1 -b .omnikey
%patch1 -p0 -b .maxreaders
%patch2 -p1 -b .etoken
%build
%configure --enable-twinserial
%make_build
%install
%make_install
cp -p src/openct/LICENSE LICENSE.openct
%post
/bin/systemctl try-restart pcscd.service >/dev/null 2>&1 || :
%postun
/bin/systemctl try-restart pcscd.service >/dev/null 2>&1 || :
%files
%doc AUTHORS ChangeLog README.md
%license COPYING LICENSE.openct
%{dropdir}/ifd-ccid.bundle/
%{dropdir}/serial/
%config(noreplace) %{_sysconfdir}/reader.conf.d/libccidtwin
%changelog
* Thu Nov 18 2021 Jakub Jelen <jjelen@redhat.com> - 1.4.36-1
- Rebase to current version from Fedora (#2017830)
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.4.34-5
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Fri Jun 25 2021 Jakub Jelen <jjelen@redhat.com> - 1.4.34-4
- Increase the maximum readers count (#1975424)
* Fri Apr 21 2021 Bob Relyea <rrelyea@redhat.com> - 1.4.34-3
- fix %{?dist} tag in Release: line (was missing the ?)
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.4.34-2
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Fri Feb 05 2021 Jakub Jelen <jjelen@redhat.com> - 1.4.34-1
- New upstream release
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.33-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.33-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Thu Jun 25 2020 Jakub Jelen <jjelen@redhat.com> - 1.4.33-1
- New upstream release (#1851217)
* Wed Apr 22 2020 Jakub Jelen <jjelen@redhat.com> - 1.4.32-1
- New upstream release (#1826675)
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.31-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Mon Aug 19 2019 Jakub Jelen <jjelen@redhat.com> - 1.4.31-1
- New upstream release (#1742657)
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.30-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.30-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Nov 20 2018 Jakub Jelen <jjelen@redhat.com> - 1.4.30-1
- New upstream release (#1651350)
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.29-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Feb 21 2018 Jakub Jelen <jjelen@redhat.com> - 1.4.29-1
- New upstream release (#1547482)
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.28-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Oct 20 2017 Jakub Jelen <jjelen@redhat.com> - 1.4.28-1
- New upstream release (#1504404)
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.27-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.27-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Mon May 22 2017 Jakub Jelen <jjelen@redhat.com> - 1.4.27-1
- New upstream release (#1453026)
* Thu Mar 02 2017 Jakub Jelen <jjelen@redhat.com> - 1.4.26-3
- Return support for OMNIKEY CardMan 3121 long writes (#1420024)
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.26-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Jan 9 2017 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.26-1
- Updated to 1.4.26
* Mon Nov 21 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.25-1
- Updated to 1.4.25
* Tue Jun 21 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.24-1
- Updated to 1.4.24
* Mon Apr 25 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.23-1
- Updated to 1.4.23 (#1328849, #1330087)
- Added gpg verification of package as part of build process
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.22-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Mon Jan 11 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.22-1
- Updated to 1.4.22
* Thu Nov 12 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.21-1
- Updated to 1.4.21
* Wed Aug 5 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.20-1
- Updated to 1.4.20
* Fri Jul 10 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.19-1
- Updated to 1.4.19 (#1241842)
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.18-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Thu Sep 18 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.18-1
- Update to 1.4.18
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.17-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Thu Jun 12 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.4.17-1
- Update to 1.4.17
* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.13-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sun Oct 20 2013 Kalev Lember <kalevlember@gmail.com> - 1.4.13-1
- Update to 1.4.13
- Tighten pcsc-lite deps with %%{?_isa}
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Wed Jun 12 2013 Kalev Lember <kalevlember@gmail.com> - 1.4.11-1
- Update to 1.4.11
* Wed Apr 17 2013 Kalev Lember <kalevlember@gmail.com> - 1.4.10-1
- Update to 1.4.10
* Thu Feb 28 2013 Kalev Lember <kalevlember@gmail.com> - 1.4.9-1
- Update to 1.4.9
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Sun Oct 07 2012 Kalev Lember <kalevlember@gmail.com> - 1.4.8-1
- Update to 1.4.8
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Tue Jun 26 2012 Kalev Lember <kalevlember@gmail.com> - 1.4.7-1
- Update to 1.4.7
* Sat Apr 07 2012 Kalev Lember <kalevlember@gmail.com> - 1.4.6-1
- Update to 1.4.6
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Fri Oct 14 2011 Kalev Lember <kalevlember@gmail.com> - 1.4.5-1
- Update to 1.4.5
- Switch to systemctl for restarting pcscd after upgrade now that it is using
native systemd unit files.
* Fri May 27 2011 Kalev Lember <kalev@smartlink.ee> - 1.4.4-1
- Update to 1.4.4
- Clean up the spec file for modern rpmbuild
* Sat Apr 02 2011 Kalev Lember <kalev@smartlink.ee> - 1.4.3-1
- Update to 1.4.3
- GPLv2+ licensed RSA_SecurID no longer gets installed, which changes
the license of the binary RPM from 'LGPLv2+ and GPLv2+' to 'LGPLv2+'.
* Tue Mar 29 2011 Kalev Lember <kalev@smartlink.ee> - 1.4.2-2
- Don't install the udev rules
* Fri Feb 25 2011 Kalev Lember <kalev@smartlink.ee> - 1.4.2-1
- Update to 1.4.2
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Mon Dec 13 2010 Kalev Lember <kalev@smartlink.ee> - 1.4.1-1
- Update to 1.4.1
* Thu Dec 09 2010 Kalev Lember <kalev@smartlink.ee> - 1.4.0-4
- Install src/openct/LICENSE file as LICENSE.openct in docs (#660600)
- Added 'and GPLv2+' to license tag to cover RSA_SecurID (#660600)
* Tue Dec 07 2010 Kalev Lember <kalev@smartlink.ee> - 1.4.0-3
- Renamed ccid package to pcsc-lite-ccid (#654377)
- Mark files under reader.conf.d as config(noreplace)
- Don't mark udev rules as config
* Tue Dec 07 2010 Kalev Lember <kalev@smartlink.ee> - 1.4.0-2
- Removed ExcludeArch: s390 s390x as these arches now have libusb1
- Updated description
* Wed Aug 04 2010 Kalev Lember <kalev@smartlink.ee> - 1.4.0-1
- Update to 1.4.0
- Build against libusb1 instead of libusb 0.1
- Install libccidtwin configuration file
- Spec file clean up
* Sun Jul 04 2010 Kalev Lember <kalev@smartlink.ee> - 1.3.13-1
- Update to 1.3.13
* Thu Nov 19 2009 Kalev Lember <kalev@smartlink.ee> - 1.3.11-1
- Updated to ccid 1.3.11
- Removed iso-8859-1 to utf-8 conversion as the files are in utf-8 now
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Tue Feb 24 2009 Bob Relyea <rrelyea@redhat.com> - 1.3.9-1
- update to ccid 1.3.9
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Tue Aug 26 2008 Bob Relyea <rrelyea@redhat.com> - 1.3.8-1
- update to ccid 1.3.8
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-4
- Autorebuild for GCC 4.3
* Mon Aug 20 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-3
- Update License description to the new Fedora standard
* Mon Apr 30 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-2
- Fix the missed use of the version macro
* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-1
- Pick up ccid 1.2.1
- use pcscd 'hotplug' feature instead of restarting the daemon
- add enable_udev
* Mon Nov 06 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-2
- Fix version macro to remove '-'
* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-1
- Pickup ccid 1.1.0
* Thu Jul 20 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-5
- require initscripts for post/postun
* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-4
- fix excludearch line
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
- rebuild
* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-3
- remove s390 from the build
* Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-2
- Move to Fedora Core, removed %%{_dist}.
* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.1-1
- 1.0.1.
* Mon Mar 6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.0-1
- 1.0.0, license changed to LGPL.
* Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-7
- Rebuild.
* Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-6
- Clean up build dependencies.
- Convert docs to UTF-8.
* Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.4.1-5
- rebuilt
* Fri Feb 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-4
- Drop Epoch: 0.
- Improve summary.
- Build with dependency tracking disabled.
* Thu Jul 1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.3
- Restart pcscd in post(un)install phase if it's available and running.
* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.2
- Provide pcsc-ifd-handler (idea from Debian).
* Sat Feb 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.1
- Update to 0.4.1.
* Fri Feb 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.0-0.fdr.1
- Update to 0.4.0.
* Wed Nov 5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.2-0.fdr.1
- Update to 0.3.2.
- Update URL.
* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.1-0.fdr.1
- Update to 0.3.1.
* Wed Sep 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.0-0.fdr.1
- Update to 0.3.0.
* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.2.0-0.fdr.1
- Update to 0.2.0.
* Tue Aug 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.1.0-0.fdr.1
- First build.