- initial c10s build - removed %{eln} macro - support packaging change of nodejs from streams to versioned packages - only `enable-booth-enable-authfile-unset` option is present - removed BuildRequires: python3-setuptools_scm - was needed for bundling dateutil - updated gating policy - added diffstat to gating fmf plan, rpmbuild failed during patching - fixed paths to bundled modules in prepare-env.sh, removed distro workaround - Bundled Python dependencies: dacite, pyagentx, pycurl, tornado Resolves: RHEL-26339 - Bundled rubygems: backports, childprocess, ethon, ffi, mustermann, nio3r, puma, rack, rack-protection, rack-test, ruby2_keywords, sinatra, tilt - Converted pcs and pcs-snmp to be architecture dependent, cockpit-ha-cluster remains noarch
42 lines
1.3 KiB
Diff
42 lines
1.3 KiB
Diff
From b27e513fb6e17016c82b551e3a966bebc7ab327c Mon Sep 17 00:00:00 2001
|
|
From: Michal Pospisil <mpospisi@redhat.com>
|
|
Date: Thu, 11 Apr 2024 11:01:19 +0200
|
|
Subject: [PATCH] fix dependency checking
|
|
|
|
Bundling pycurl was not allowed and the check was failing during builds.
|
|
The check for setuptools_scm was also removed as we no longer bundle
|
|
dateutil anywhere with pcs-0.11.
|
|
---
|
|
configure.ac | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 5d3e28cf..5881c048 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -334,13 +334,11 @@ AM_CONDITIONAL([PIP_HAS_ISOLATION], [test "x$have_isolation" = xyes])
|
|
|
|
if test "x$tests_only" != "xyes"; then
|
|
PCS_CHECK_PYMOD([setuptools])
|
|
- PCS_CHECK_PYMOD([setuptools-scm])
|
|
if test "x$local_build" = "xyes"; then
|
|
PCS_CHECK_PYMOD([wheel])
|
|
fi
|
|
PCS_CHECK_PYMOD([cryptography])
|
|
PCS_CHECK_PYMOD([lxml])
|
|
- PCS_CHECK_PYMOD([pycurl])
|
|
PCS_CHECK_PYMOD([pyparsing])
|
|
|
|
# those are kind of problematic.
|
|
@@ -348,6 +346,7 @@ if test "x$tests_only" != "xyes"; then
|
|
PCS_CHECK_PYMOD([dacite], [], [yes])
|
|
PCS_CHECK_PYMOD([tornado], [>= 6.0.0], [yes])
|
|
PCS_CHECK_PYMOD([python-dateutil], [>= 2.7.0], [yes])
|
|
+ PCS_CHECK_PYMOD([pycurl], [], [yes])
|
|
|
|
# special case, because we need to download from github
|
|
AC_PIP_MODULE([pyagentx])
|
|
--
|
|
2.44.0
|
|
|